News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Lost All Windows 7 USB capability but works in Linux

    Home Forums AskWoody support PC hardware Lost All Windows 7 USB capability but works in Linux

    Tagged: , ,

    Viewing 3 reply threads
    • Author
      Posts
      • #2141839 Reply
        anonymous
        Guest

        As Windows 7 came to its end of support period I still hadn’t made up my mind about moving to Windows 10. I decided to experiment with a Linux live disk to see if I liked it. Years ago i dual booted Windows 98 and Xandros for over a year until I got a new computer but hadn’t done so since.

        Anyways I got the last Windows 7 updates installed and cleaned up my comp a bit. I set a restore point and burned POP! OS to a USB stick and had fun playing with it. The OS works great on my computer and I have no hardware problems.

        I decided to go back into Windows and restarted the computer and removed the USB. The lights on my mouse and keyboard flashed as usual but when Windows started they wouldn’t work. I unplugged and replugged them but nothing worked. I didn’t get the usual sound when i plugged my headset or a usb.

        I turned off the computerΒ  and power and tried again and the same thing happened. I booted from the USB and things are fine.

        Years ago I had a new graphics card installed and had windows reinstalled too. They may have missed the USB drivers as there was notification in device manager. But everything worked and I rarely had problems. I did check for drivers as suggested but none could be found and the Windows install disk was no help.

        I was thinking of safe mode – if i can access it. Does any one have suggestions – especially about getting drivers. thanks,

      • #2141860 Reply
        Paul T
        AskWoody MVP

        You should not need drivers, USB is not unusual and the MS drivers are fine.

        I would fire up Device Manager and uninstall any USB devices shown. Then reboot the PC and Windows will reinstall them.

        You can also use USBDeview to view / modify your existing devices.

        cheers, Paul

        • #2141983 Reply
          anonymous
          Guest

          Thanks. I stayed in Linux for a few hours and had no problems and just rebooted back to windows. I may have left the power off a bit longer this time but other than that did nothing different from before, but things work now.

          The device manager showed the USB needed trouble shooting due to no drivers so I tried your fix and rebooted. Windows relisted the USB and my keyboard, etc, work: but the “no driver” warning is back. πŸ™ Sometimes the littlest things are annoying.

      • #2152872 Reply
        Paul T
        AskWoody MVP

        Are there any exclamation marks for the USB ports in Device Manager?

        Check the PC manufacturer’s website for later motherboard drivers.

        cheers, Paul

        • #2153341 Reply
          anonymous
          Guest

          Yes, the exclamation mark is back.
          I had the Windows USB problem happen again last night after using the live USB. I shut down POP OS! as normal, waited until the no signal pop up showed on my monitor and turned off power for a few seconds. I powered up my comp and the lights flashed on my keyboard and mouse but never came back on after Windows started.

          Luckily my monitor has a scsi cable and i can see the desktop. I waited until startup stopped processing and rebooted. I tried booting into safe mode but Windows started and the mouse and keyboard worked fine.

          I haven’t used the live USB today yet and booted straight into Windows. The keyboard and mouse work fine. I had to change my clock time though as it was on UTC for some reason.
          My computer is an OEM with Intel and Gigabyte components. I will copy some info from Speccy and post.
          -fm

          • #2153348 Reply
            anonymous
            Guest

            Motherboard
            Manufacturer Gigabyte Technology Co. Ltd.
            Model B85M-D3H (SOCKET 0)
            Version x.x
            Chipset Vendor Intel
            Chipset Model Haswell
            Chipset Revision 06
            Southbridge Vendor Intel
            Southbridge Model ID8C50
            Southbridge Revision 05
            System Temperature 28 Β°C

            BIOS
            Brand American Megatrends Inc.
            Version F9
            Date 1/24/2014

            I checked the Gigabyte site but getting the exact info is a bit byzantine. I will poke around some more.

            Thanks.

            -fm

          • #2153388 Reply
            jabeattyauditor
            AskWoody Lounger

            Luckily my monitor has a scsi cable

            I HAVE to see this…

            • #2153405 Reply
              anonymous
              Guest

              If its not audio or USB they all look the same to me. πŸ™‚ Looking at the back of my comp and checking online – I probably have a DVI monitor cable attached to my computer via a vga/dvi adapter. Anyways it works.

              1 user thanked author for this post.
              • #2153538 Reply
                MrJimPhelps
                AskWoody_MVP

                It would have to be DVI. I have NEVER seen a SCSI monitor connection in all my decades of computer support.

                Group "L" (Linux Mint)
                with Windows 8.1 running in a VM
        • #2153741 Reply
          anonymous
          Guest

          Are there any exclamation marks for the USB ports in Device Manager?

          I did some more digging and testing after using Pop! OS today. USB had failed on boot to Windows but that may have been my fault as I accidentally removed the USB instead of ejecting the cd rom I was testing. πŸ™ I had to manually quit and the machine rebooted fast so I let it complete and when Windows stopped processing I shut it down and left the power off for a while. USB was fine when I booted up later.

          I noticed that my clock time was wrong since reboot (it showed UTC instead of my time zone) and checked online. I found a forum post that stated Ubuntu (on which Pop! OS is based) uses UTC time and a known issue is incorrect time when dual booting back to windows. The post said it had something to do with the motherboard.

          In another forum a person said the USB shouldn’t effect Windows because it holds everything in RAM. This might explain why USB works when I power down for a bit but the clock is still wrong. The drivers would refresh/reload at start up but the clock is set via a schedule.

          I still don’t know why the USB shuts down. After checking I realized that the exclamation mark was a red herring and probably unrelated to this issue. It refers to and unknown device – possibly something I used years ago and got rid of. The registry though is still recording it. The actual USB ports – Generic USB Hub, etc – are okay and show Microsoft drivers. I would need an adapter for my old mouse to see what Device Manager says when the problem occurs.

          -fm

      • #2178228 Reply
        firemind
        AskWoody Lounger

        This was one of my posts. I have been using Linux Mint as sole OS for almost a week now and have had the odd USB problem.

        I did some research and the problem may relate to my Corsair keyboard and mouse. There are references to problems in Ubuntu and Linux Mint and people suggested updating the firmware in the devices. I may look into that when i get tired of reconnecting the usb when the problem occurs. First of all I want to use my spare mouse to check the terminal to see what error messages show up.

    Viewing 3 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Lost All Windows 7 USB capability but works in Linux

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.