• Lost Connectivity for Printer

    Author
    Topic
    #2525731

    I’ve got a myriad of devices that connect to the internet, including Printers.  With a recent re-install and new router I’m got myself in a heap of trouble.

    I got a new router so that I could place some of my devices on a guest account for security.  Now I’m thinking that some things, like printers have to be on the “main” account or they won’t work.  Is this correct thinking?

    The second part of my question is do you have to select:  “Private or Public” network profile for a printer to work?

    Mike

    Viewing 4 reply threads
    Author
    Replies
    • #2525741

      Wanted to add that the router is a TP-Link Archer AX55.  The guest account is isolated from the main(private) account.  There are two options in the guest account but I don’t see that either would solve the problem.  Checking either would make things less secure.

      TP-Linkfrominterface

      Attachments:
    • #2525748

      As the guest network is isolated from your main network you will not be able to see devices on the guest network, including your printer.
      There isn’t an easy / cheap way to use a printer and not allow it to have access to the internet.

      do you have to select:  “Private or Public” network profile

      Where are you seeing this option?

      If the printer has this setting you need to know what it dis/allows under each setting.
      If it’s on your PC you should have the network set to private if you want to connect other devices. If not, public is fine.

      cheers, Paul

      2 users thanked author for this post.
      • #2525753

        The private or public profile comes up when you are first installing Windows and setting up the network. Or, you can also see it by clicking on the network icon.

        Thanks for the information Paul.  I guess it seems odd to me that you can’t isolate a printer in a simple way without a lot of technical. Considering the hundreds of thousands of printers out there, they seem like good access points for internet threat actors.

         

        Mike

        • #2525754

          Normally printers aren’t exposed to outside IP addresses.  If you enable web based printing then they are, but I don’t do that.

          Guest network is best for Alexa’s and Internet of things.

          Computers and printers are on the internal network.

           

          Susan Bradley Patch Lady

          1 user thanked author for this post.
          • #2525845

            Thanks Susan for fixing that image. I think that’s an odd feature of the forum software.

            The printer is a BW laser (Canon MF445dw).  I think it’s pretty connected, but not sure (specs below in link, scroll to Security).  If I’m overly concerned, I could use a Ethernet cable, but that’s a hassle with a Laptop.

            Thanks all for the help.

            Canon specifications:

            SECURITY SPECIFICATIONS
            AUTHENTICATION Standard: Department ID Authentication
            DATA Standard: Verify System at Startup
            NETWORK Standard: IP/MAC Address Filtering, IPSEC, TLS Encrypted Communication, SNMP V3.0, IEEE 802.1X, IPv6, SMTP Authentication, POP Authentication before SMTP
            DOCUMENT Secure Print, High Compression PDF, Searchable PDF
            WI-FI AUTHENTICATION METHODS Wi-Fi Infrastructure Mode:
            WEP 64/128 bit, WPA-PSK (TKIP/AES), WPA2-PSK (AES)
            Wi-Fi Access Point: WPA2-PSK (AES)

    • #2525936

      You did assign the printer a STATIC IP address (vs letting the router give it one via DHCP), right?

      2 users thanked author for this post.
      • #2525977

        owburp:  No I did not.  Not sure what your thinking here.  I’m using a T-Mobile Gateway (dumbed down router + modem).  The gateway has WiFi, which I turned off using a script hack.  Then I hooked a new router to the gateway and turned off the router’s DHCP server and setup a guest account for my IoT stuff.  The problem was that I put the printer on the guest account.  Moving the printer to the Main/Private account solved the issue completely.

        Are you thinking of another way ?

        BTW:  You can’t do much with the T-Mobile gateway other than band split and naming.  No access to any other features or setup.

        Mike

    • #2526028

      The difference between a static IP address and one that is assigned to the printer by DHCP is that the static address will not change (unless you specifically make the change) whereas there’s no guarantee that the DHCP address will not be assigned by the router to a different device later on. Some routers will allow you to specify that whatever DHCP address a device was assigned will be reserved for that device and so will function similar to a static address. Bottom line, if your printer has an IP address that changes, your computer won’t be able to find it.

      Rereading your post a little more closely, it seems like you are using the T-Mobile router’s DHCP server and you turned off the one in your own router. That seems kind of backwards to me, but maybe the T-Mobile won’t allow you to turn the DHCP off. If it isn’t possible to switch that around then another solution would be to connect your printer to your router via Ethernet; that should allow stable access to it.

      Moving the printer to the Main account might be working now but I don’t think there’s any guarantee it will continue to work if DHCP is involved.

      1 user thanked author for this post.
      • #2526033

        Nice understandable description of the static IP owburp.  I’ve always wondered about that.  I came across turning off one of the DHCP servers by scouring the net with others hooking up this same combination (T-Mobile Gateway + Separate Router).  Some said “double” DHCP could cause problems, but may work in some cases.

        Anyway, you can do anything with the T-Mobile Gateway, so it’s going to do the DHCP no matter what.  The manufacturer (SageMCom) made it that way.

        Actually, things worked fine with double DHCP and even the printers worked just fine.  But I decided to turn it off in the separate router anyway.  In fact the printers have worked for over a year just with the Gateway and it’s DHCP.

        The only time I had an issue was putting the printers on the guest account and that was why the devices could not see each other.  There’s no easy way around that……..as least for me and my knowledge.

        Thanks for your explanation.

        Mike

         

        • #2526065

          Hold on a sec. Was it your intent to put the printer on the guest network and then access it from computers on the main network??? Those are meant to be two “separate” networks — it’s the whole point of having a guest network so never the twain shall meet.

        • #2526312

          Over the years, each time I came across a network printer that lost access, it was due to an IP address assigned via DHCP. In this particular case, I broke a major rule of troubleshooting by trying to fix a problem before fully understanding what that problem was; I tried to help and wasted everyone’s time.

          I apologize. It won’t happen again.

          1 user thanked author for this post.
          • #2526353

            Everything is okay.  Sometimes it just takes a little bit more chatter to figure things out here on AskWoody.com

            I learned some new stuff anyway.

            Mike

    • #2526035

      but I don’t think there’s any guarantee it will continue to work if DHCP is involved

      It is just not true that using the router assigned address (via DHCP) is likely to cause printer problems. The printer advertises its presence, as do other devices and Windows sees these devices because they are all on the same network – as evidenced by Mike’s ability to print after moving the printer to the main network.

      BTW, my printers are always DHCP and I never have printing issues – except with HP printers that go to sleep and never wake up unless you power cycle them.  🙂

      cheers, Paul

      1 user thanked author for this post.
      • #2526067

        The reason why your DHCP printers “work” is probably because they don’t get powered down and never disconnect from the network so DHCP never has to reassign an IP address. The HP printers go to sleep and thus give up their IP address, so when they wake up the DHCP server looks for an available IP address to assign; it might be the same as before or maybe different.

        Or at least that’s how I figure it…….

        1 user thanked author for this post.
        • #2526442

          Nope, the IP assigned after a reboot is the same one used previously. It’s an HP thing…

          cheers, Paul

    Viewing 4 reply threads
    Reply To: Lost Connectivity for Printer

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: