News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Macrium Reflect exposes yet another problem MS still can’t solve!

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 Macrium Reflect exposes yet another problem MS still can’t solve!

    Viewing 1 reply thread
    • Author
      Posts
      • #2362542
        RetiredGeek
        AskWoody MVP

        Hey Y’all,

        As many of you may know by now I love to tinker. Of course, this often gets me into trouble, curse your Registry! Well I was at it again last evening playing around trying to uninstall IE 11 based on other posts here. Naturally, before starting I imaged my C: drive to my H: Misc drive (the machine has 3 physical SSDs (1 NVME & 2 SATA).

        After doing the uninstall and seeing problems I first tried to just reinstall IE 11 but that didn’t solve the problem. So Boot using my Rescue Media. Well guess what the H: drive wasn’t listed. It showed up in the backup list but not the Restore list? I tried a different Rescue disk then one with a different Reflect version and finally a newly created one using only Reflect’s defaults. All to no avail.

        So off to Macrium’s Support Page to file a ticket (nice to hold lifetime licenses). Enter the problem and license number and wait for a reply. When I woke up this morning I had an email from Macrium requesting more information. Unfortunately I had to spend 3.5 hours in the dentist’s chair so I didn’t get back to it until this evening.

        What they wanted was screen shots of both the Backup & Restore screens. Of course when working in WinPE that means using the cell phone to snap pictures. To get all the partitions of the boot drive in the frame I had to fiddle with the pane sizes on the screen then it hit me like a ton of bricks. Although the H: Misc drive showed on the Backup screen it did NOT show a drive letter only the label!
        Reflect-Problem-with-Drive-Letters
        Now I remembered back a few years when SSDs were new that even installed internally Windows would often see them as Removeable and thus not assign permanent drive letters. So off to Google to do a little searching and I came up with a solution a simple Registry Entry.

        C:WINDOWSsystem32>reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device" /f /v TreatAsInternalPort /t REG_MULTI_SZ /d 0
        The operation completed successfully.
        

        However, this did not solve the problem, so on the next step.
        Next I used Disk Management to do the following:

        1. Change Drive (Partition) Letter to NONE.
        2. Reboot
        3. Change Drive (Partition) Letter to H.
        4. Reboot
        5. Reboot using Rescue Media
        6. Problem Solved!

        In case you should run up against this problem I hope this helps. 😎

        May the Forces of good computing be with you!

        RG

        PowerShell & VBA Rule!
        Computer Specs

        Attachments:
        3 users thanked author for this post.
      • #2363232
        krism
        AskWoody Plus

        Yes, difference in the way “default” sets it vs how assigning a letter does it. Good catch. Good idea to always actually assign a letter to something new!

        Group W (windows, current)
        - ThinkPad T570-20HA, i7-7600U, 2.8GHz, UEFI/GPT, Win10 21H1 Pro x64, 16GB, Sammy 256GB M.2 NVMe PM961. -

    Viewing 1 reply thread

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: Macrium Reflect exposes yet another problem MS still can’t solve!

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.