• Macrium user error:selected volume guid?

    Home » Forums » AskWoody support » Backup » Backup software – Macrium Reflect » Macrium user error:selected volume guid?


    Using Macrium Reflect 8 free. Win 10 22H2, old Dell. Uefi, GPT.

    Got a new 2TB WD Passport for backups. Thought I’d make a new rescue thumb drive as well.
    Went through settings to create first backup on new drive, to add ‘verify’ etc. Accidentally did 2 major untoward changes late at night:
    1. Selected ‘Guid’ vs ‘Windows drive destination’ in M/R backup menu (thinking I’d avoid issues with drive letters that occurred last year with my orig. old M/R WD b/up drive.)
    2. New Rescue usb: chose RE, YET when I checked driver areas, said “available to copy from host” and I clicked on it? Result: it auto turned it into ‘PE’ and copied “drivers from host” wim something?? I was accidently online at the time of creation (usually never am).

    Results: even offline, M/R needs ‘new’ rescue usb in before I plug in new WD in order to see that drive and do a backup.

    Worse, both my other (older) M/R WD passport and it’s own rescue RE usb are no longer recognized. I have tried the old rescue usb with the new and old WD’s to no avail. Older drive ‘existing backups xml’s’ show up with red X’s, no access to actual files on that E:/ drive. Have tried everything. Works only with new WD drive & new PE rescue usb?

    I can bios boot to new WD as long as the new ‘PE’ rescue usb is in, and it sees only my latest backup (older E:/ xml definition files show, but red X.)
    Done in prep as about to do a Win 10 repair install to deal with other unrelated issues. Wondering what to do after Win 10 repair install to sort this M/R scenario out i.e.
    -can I change from GUID to Windows destination?
    -Will I regain access to old WD b/ups if nec.? Will I lose access to the new drive b/ups made via ‘new’ GUID if I made a destination change back to windows drive letters?
    -Make new RE (nonPE) rescue usb? Would it gain access to both?

    I believe something has changed with all my .xml files impacting all. And both old/new rescue usb’s. Anyone have input? Searched online for answers for days. Feeling very stupid.

    As I understand it, WinRE works on all with bare min drivers. Thus if AFTER the repair install using a .wimRE iso, will I NO longer have access to PE rescue/bup to restore from?

    If I’m doing an Win 10 over the top repair install tonight, will I be able to restore from at least this PE/GUID selection error drive if repair went south?? (I ask that as I tried to dism b/up drivers in prep, but Dell ones were slipstreamed in shop 2 yrs ago so aren’t showing up, so I’ll be reliant on ability to restore from this PE/Macrium mess! Ty

    • This topic was modified 3 months, 3 weeks ago by Deo.
    Viewing 13 reply threads
    • #2564854


      In your search for information, did you look on the Macrium website (macrium.com), under the heading Support, item Knowledgebase, which will take you to its extensive documentation. It may take you some time and reading, but it’s likely you will find your answers there.

      Hope this helps and good luck.

    • #2564861

      TY Phil!  The first place I went was Macrium site (and all their forums). I would NOT  have posted here at AW had I not come up empty on 10 hrs of searching the globe for an answer re: how the changes impacted my old drive/rescue usb, and what access to either would occur if I tried to revert. I’m on’free’ so can’t post there.

    • #2564897

      2. New Rescue usb: chose RE, YET when I checked driver areas, said “available to copy from host” and I clicked on it? Result: it auto turned it into ‘PE’ and copied “drivers from host” wim something??

      That’s normal.

      WinRE is the Recovery Environment (i.e. all the special tools you see if you boot into Recover Mode.)

      WinPE is the Preinstallation Environment (what you see when you run setup.exe from an install ISO.)

      WinRE actually runs using WinPE so it can access your existing Windows installation in an “offline” mode allowing it to change things that would normally be in-use and unavailable to be modified.

      The Macrium rescue disk, like most other recovery S/W, uses WinPE for exactly the same reason, that allows it to access/modify your system while the existing Windows installation isn’t being used.

      FYI, the other option rescue disks use is Linux but, since it can’t run “Windows” programs, it’ll only be able to access your drives and won’t include the various Microsoft tools available in WinPE to repair defective Windows installations.

        Yeah, I know it’s possible to use Wine to run Windows programs on Linux, but creating a Linux rescue disk that included the WinRE tools and could actually run them would be way beyond the ability of normal users!

      As for your GUID vs Drive letter issue…

      That’s stored as part info describing each particular backup so the S/W knows “where it came from” and “where it goes” when you select the restore option.

      And yes, if a backup was made using a GUID and you change the option back to Drive letter, the S/W will no longer “see” the backups made using the GUID, or vice versa for backups made using Drive letters (BTDT although it was with Paragon not Macrium!)

      In mine case, Paragon has an option to “add an archive” to its list of available backups (regardless of whether it was created using GUID or Drive letters) by simply browsing to the archive file’s location.

      Maybe Macrium has a similar option that would allow you to switch back to Drive letters and add the GUID backup to it’s list of available backups?

      BTW, using the GUID is more restrictive than using Drive letters because, when doing a restore, only one drive will have the same “unique” GUID used creating the backup but any drive could have the “same” Drive letter used creating it.

      1 user thanked author for this post.
    • #2569019

      Any Macrium 8 free experts out here? What are my options so as not to cause damage (wear and tear) to this new 2TB WD usb hardrive?

      To revert from GUID/PE (have always used Windows drive destinations & RE rescue prior to this error) back to drive ltrs and WinRE?

      Does this mean I should delete backups made under GUID stg (as I won’t have access to them after), then change GUID stgs to ‘Windows drive destinations’? Then create new rescue thumb drive choosing RE and hope PE settings and added drivers revert? Hopefully I’ll gain access to last yrs older WD usb passport and figure out how to repurpose that now b/up full drive to be cleanly used as M/R backup drive in future? How to do that?(As of GUID error, I have no access to older 1TB wd passport drive as it was set to ‘drive letters’.) Or throw away?

      Both WD are formatted to NFTS, Desktop old Dell, is UEFI/GPT with secure boot on. Appreciate input. Ty

      • #2569022

        And Yes, I have searched Macrium forums ad nausem, and one entry asked a slightly related question-no reply to them. Can’t post as I’m on M/R free. Nothing in knowledge base on reverting. TY.

    • #2569038

      not to cause damage

      It’s a hard disk, you can’t damage it by using it.

      You should always have access to backups made by MR. To test this try mounting the backup file by right clicking on it in Explorer.

      Why can’t you see the old MR backups? Are they visible in Explorer?

      What is the “GUID error”? A screenshot may be helpful.

      cheers, Paul

      • #2570932

        Will post below on wear tear on older full b/up drives after immediate concerns are addressed.

        No, GUID drive is not viewable via Explorer. Old Passport is no longer viewable via explorer. Visible b/up folders from Old WD but clicking on any of them the forces M/R pop up “Select…and associate drive letter in explorer’ (shows X:??). Will post pics when on PC, as couldn’t even ‘screenshot’ from within bios boot now-same pop up ‘associate drive letter..’ Thus have to take ipad pic and convert via PC to .png for AW to accept.

        Just happened (esp with old drive) after June Windows updates.

        At this point, after checking both old/new WD Passports with their respective rescue drives via bios, I doubt I’ll be able to restore from any backup. Same popups for both “choose drive letter”…only as of today. Only thing that has changed is June updates applied yesterday.

    • #2569139


      When using Reflect the boot USB doesn’t have to be changed except for software upgrades and it may not be necessary even there.

      What changes when you select GUID or Drive letter location for your Destination Drive is the BDF (Backup Definition File).

      If you want to continue to use GUID you’ll need to create a different BDF for each drive you use. Make sure to name them appropriately!

      If you want to use Drive Letters you’ll want to use a product like USBDLM, it’s free and works very well. For more information on this topic you can download my Backup for Non-Techies file from my OneDrive shared folder. You don’t have to use the software included but the PDF included in the zip may prove useful.

      May the Forces of good computing be with you!


      PowerShell & VBA Rule!
      Computer Specs

      1 user thanked author for this post.
      • #2570935

        Pls see my orig post. Sorry I’m not fluent in brief tech-eze! Am using Free, thus can’t post there.

        Selecting GUID did create it’s own .xml (BDF), however it impacted ALL .xml’s; even from old b/drives. It also changed ALL old rescue USB’s to PE from their normal (independent RE) format.  Will expand in next post below (if time permits before July updates peak their head).

        There is an obscure note at the bottom of the advanced stg screen under ‘drive destination’ which states: Note: Changing this option affects new backup definitions. To apply to an existing backup definition the definition must be edited to re-save the XML file”. There are no forum posts explaining this, other than knowing “code”, which I don’t.

        I’ll further post my question: does that mean wipe/reformat existing ‘M/R only’  new WD Passport, and how to revert rescue USB’s to RE from PE.

        For others, caution: don’t use GUID for your ‘drive destination’ stgs in MR.

        • #2570955

          To see what is / may be on the GUID drive, fire up MiniTool Partition Wizard. It will show you all the partitions and should allow you to assign drive letters to the partitions.

          It also changed ALL old rescue usb’s to PE

          How can it affect things that already exist? If you created it using RE it will still be RE.

          cheers, Paul

          • #2576632

            It says “RE” at top in BIOS, but it loads as green ‘PE’ first. It’s a very different screen then I’ve ever seen before. It will also not allow me to take screenshots in BIOS, nor do anything else.

      • #2576661

        Thank you, yet shouldn’t M/R at default work w/out having to assign drive letters? I’ll be back if this not the case! TY:)

    • #2576633

      My needs are simple. I wish to ‘undo’ the error of this GUID mess, and revert back to a ‘normal’ RE rescue thumb drive, reverting from GUID to destination drive discovery “use assigned drive letter to locate.” My drive letter has never had to be ‘assigned’, it has always defaulted to E:/.

      Pic 1 (more to follow): Here is location where the accident was made:


    • #2576640

      2. (more to come) When I boot into BIOS, it ‘shows’ RE at the top, yet takes a long time to load, is green, and the new rescue ‘PE’ loads drivers first.

      Prior to GUID, I was able to simply select a backup. Now it forces me to choose a ‘drive letter’ (which I haven’t as all “options/boxes” are obscure.) Also note, M/R in BIOS will not allow me to take a screen shot, thus this is screen shot is a jpeg from my phone camera (AW wouldn’t accept jpeg’s from my ipad.)


      Next up: more pics as requested

    • #2576642

      3. I am no longer able to to use File Explorer to view files as before. Even though it shows backups, it refuses to allow me to go any further.


      (on to more pics…)

    • #2576646

      4. When I use my OLD WD passport with it’s OWN rescue thumb drive, it displays all old backups, yet when I click on any back backup there (not shown), I get the same results as in pic 2 above. Never needed to select ‘drive letter’ before with it and the same when in file explorer, now it shows I need to select a drive letter?? THUS it has indeed impacted older drives/rescue media and viewing capability. Again no screen shot avail when in M/R rescue BIOS (see above, will take phone pic & convert again for AW, but same occurs as above.)

      This all began when I selected GUID on the new ext HDD/new rescue thumb, but it’s impacted my old drive & its rescue thumb drive too.

      Old drive/old rescue:


      Separate xml’s (definition files) for both old and new:


      Summary next…

    • #2576659

      (Lost a nice concise summary whilst editing above! Start again)

      I believe I am posting this in the right forum, and there are many Macrium guru’s here on AW. Has anyone dealt with these issues before? I am on FREE version, so I can’t post in the M/R forum. Have, ad nauseam during time off, searched the web and M/R forums.

      Nothing about reverting destination from GUID back to windows destination/letter assignment. (M/R KB itself says “you will need to edit .xml file” but no instructions.) Will I lose access to  GUID backups?

      I want to get back to RE rescue, clean backup drive, and start again using windows destination vs GUID. Does M/R embed files at root? Do I have to ‘reformat’ this new NFTS drive to start again? If so, will it not wear/tear a perfectly good drive? Ditch both the old rescue thumb drives?

      Will I lose access to GUID backups? Not that recovery would even be possible given the above; no access to backups?

      I can’t restore IF I don’t “assign” a drive letter after the GUID mistake (and even then, unclear if successful as per older M/R 2021 forum post.) Something shows up as ‘X’ drive letter in BIOS?

      Wouldn’t know what I’m restoring and to where as check boxes, as shown in pics above, don’t indicate what to restore? How to tell? Loss of viewing files with file explorer is troubling too. I don’t wish to ‘assign’ drive letters as I rotate. It’s always worked flawless as E until now. Bottom line: the PC is scanned and clean with the only error being my M/R GUID selection. How to cleanly begin again on this new WD HDD? Have used M/R for years with none of these issues.

      And yup, it’s impacting the OLD HDD/Rescue thumb drive. Unable to take screen shots from BIOS with M/R – is this new with Windows?? I’m about to do the July updates without a solid backup. Any M/R astute peeps, many thx for timely wise help here? Otherwise I’ll update without a back up, yikes!

    • #2576667

      1. What you call “BIOS” seems to be Macrium booted from a USB. This is not BIOS, it’s Windows RE (Rescue Environment) which then auto loads Macrium. You can’t take screen shots because there’s nowhere to save them in RE.

      2. Your screenshot shows C: as the 3rd volume (you can expand the column to see more detail). Selecting the check box next to the 3rd volume will mount the image and allow you to browse / copy files.

      3. Your list of backup images looks standard to me. If you viewed them in Explorer, you would be able to mount them, per 3 above. If you want to restore an image, you would select it as normal.

      I can’t see any issues there that mean you can’t view / restore your backups.

      When I want to check my backups, I do it from within Windows by firing up MR or mounting from Explorer. I can’t see why you would not be able to do the same.

      I would take a standard image backup from within Windows (I do this all the time) and then install the Windows updates.

      cheers, Paul

      1 user thanked author for this post.
      • #2577318

        1. In lieu of quotes, as my iPad won’t do partial quotes? And Ask Woody ‘Edit” won’t allow me to view thread/ go back to “replying to quote” to try again! Nor will site allow view thread in separate tab original post while logged in.
        It is when I am booting M/R recovery thumb and backup drive using Dell BIOS F12.

        I have my backup drive in with rescue thumb while booting in BIOS; has always allowed me to save screen shots prior to GUID?

        2. It did not allow me to mount or view anything.

        It would not allow me to view in Explorer – see my post with screen shot above. I was always able to prior to GUID destination. Will not mount via Explorer? see screen shot above.

        3. Please advise how as, shown in my screen shots, it was not possible.


        Since Paul’S reply: Still with GUID selected, I created a new RE (not PE) rescue drive and it created a new .xml file. Then it was back to ‘normal’ when viewing in recovery boot (via BIOS) and gave me a drop-down menu to attach a letter (i.e. G:/) to be able to browse windows native files (i.e. not libre office docx) Note: closing and reopening then offered an “H:/” (L/H side of the screen “Detach Images” showed up & finally allowed me to do so for BOTH G:/ & H:/ vs the above screen shots.

        Neither option was available when booting from the PE drive.

        * New RE rescue still shows ‘PE’ at bottom? Assume it has ‘copied drivers from host’ Will post pic when have a chance.

        Even with the new rescue thumb drive, The “Restore” button in the top menu did nothing. The only “Restore” option was from above “backups list” allowed a list (i.e. “drag and drop” or “copy partitions”, again different from before. In an emergency, what do you pick/do?) In February, this was not the case. Have things changed, even though the ‘Free’ version no longer gets updates? PS, very different from Susan’s knowledge base article; I assume she was working within an actual operating windows system vs with a failed unit and doing it via recovery/BIOS restore.

        Knowing what to do to restore would be timely, as I updated July’s Win 10 22H2 and have an issue with Edge now not opening in my local USER acct; yet fine in local ADMIN acct.

    • #2577325

      Please stop calling it “BIOS”. You have booted into Windows from a USB.
      You do this when a restore is required because no programs are running from the hard disk that may prevent you overwriting the data.

      You should only boot from USB when you intend to restore Windows / partition the whole disk. Any other restore can be done by firing up Macrium / backup program of choice from within normally booted Windows and browsing your backup files or mounting one in Explorer.

      Restoring from a USB booted into Windows depends on what sort of backup you made.
      Your screenshot in #2576642 above indicates you are making image backups. These are either restored as a full partition / disk by selecting the required partition in the restore window, or mounting the image in normal Windows Explorer, browsing to a file, and copying it.

      cheers, Paul

    • #2577479

      Sorry Paul, meant “testing” Rescue via boot works as test mentioned many times to do on AW.  And no, I can’t “mount” via Win explorer although I was able to pre-GUID.  Perhaps I didn’t “unmount” weeks ago? Can’t recall.

      Seems I have truly messed things up with:

      Settings (thx Paul, what happens if I change?) etc. Esp with “backing up” via selecting “Image selected disks” vs “Create an image of the partitions”.  I assumed from the M/R forum that all partitions would not copy with the “create” option when the system is UEFI/GPT so I made the GUID change.

      It appears no AW M/R gurus have made my “GUID” error?

      Let’s start from scratch so I can close this topic:

      – I wish to revert back to drive letter destinations.  Has anyone here toggled destinations in Advanced Settings from GUID back to windows drive letters?  What would you do?

      – Any problems if I reset all M/R Settings to default?  Should I delete existing backups prior to doing that?

      – Worst case: does anyone recommend wipe/reformat of the new WD 2TB backup drive to NFTS, delete all .xml files, and start fresh?

      – Does anyone recommend uninstall/reinstall M/R, if even possible now that the “free version” is no longer available?  Would that reset the registry settings, even though I haven’t touched them, and maybe get me back to baseline to start over?  Seems a bit drastic and I’m not sure if resetting to defaults in M/R will work to clean this up.  I wrote down the “free” license ID, would that work?

      – Last question, answer or not please: The old WD backup drive is only used for M/R and is full.  What to do?  Delete the backups in order to reuse it or, if M/R at root, wipe/reformat to NFTS for future use?  If recommended, please explain how?

      Thanks AW community! Open to any suggestions, just looking for simple explanations/advice.

      PS: Can you defrag an ext HDD via Windows?  Is it recommended?

      PPS: Edge via Local User acct began to work again today, 2 days after July CU updates.

    Viewing 13 reply threads
    Reply To: Macrium user error:selected volume guid?

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: