News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Malfunction with Ubuntu graphics-drivers PPA nVidia driver update v455.45

    Posted on Ascaris Comment on the AskWoody Lounge

    Home Forums AskWoody support Non-Windows operating systems Linux – all distros Malfunction with Ubuntu graphics-drivers PPA nVidia driver update v455.45

    Tagged: ,

    Viewing 2 reply threads
    • Author
      Posts
      • #2314474
        Ascaris
        AskWoody_MVP

        If you’re using the Ubuntu graphics-drivers PPA to get the latest and greatest nVidia proprietary drivers, be advised that there might be a problem with their release of the 455.45 driver, for 20.04 (Focal), at least.

        I downloaded that driver today on my G3, and the next time I rebooted, the nVidia card was not working. The G3 uses nVidia Prime, so it booted into the desktop on the Intel integrated GPU, but when I tried to start a game that uses the nVidia card, it crashed. I tried to start glmark2 (a small graphics benchmark that is nice enough to tell me what renderer it is using) on the nVidia, and it gave an error message.

        I checked all of the usual stuff, and it all seemed in order. I then removed the nVidia driver (I used the command line, but if you remove the ‘nvidia-driver-455’ package in Synaptic, it will have the same effect) and downloaded the one directly from nVidia, which comes in a cross-platform .run installer format that isn’t as easy to use as the .deb format that’s used by the PPA, and it worked perfectly well.

        The driver, in other words, is fine; it’s apparently something with the way the Ubuntu devs (the graphics-drivers PPA is maintained by Ubuntu itself) packaged it. Just a heads-up… it may or may not work for you. If not, you can roll back to the previous version (455.38) or install the .run from nVidia as I did. Note that if you do use the .run, it will not show the driver in Synaptic, so if you want to uninstall it, you would use the .run file for that again, but with the –uninstall switch. It’s generally easier to use the .deb packaged versions, but you have the option in case that isn’t working (or if the newest one isn’t available in .deb yet and you simply do not wish to wait).

        Group "L" (KDE Neon Linux 5.20.5 User Edition)

      • #2315126
        Ascaris
        AskWoody_MVP

        I just tried the same update on my desktop PC, which uses only the nVidia card, unlike the laptop that uses Intel and nVidia, and it’s working fine.

        Group "L" (KDE Neon Linux 5.20.5 User Edition)

      • #2318421
        firemind
        AskWoody Lounger

        I heard that people had problems with the 455 driver and haven’t upgraded my Mint desktop PC from 450 yet. i have the odd boot issue but that may be related to something else.

    Viewing 2 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Malfunction with Ubuntu graphics-drivers PPA nVidia driver update v455.45

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.

?
This website collects data via Google Analytics. Click here to opt in. Click here to opt out.
×