News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Microsoft Edge acting goofy

    Viewing 3 reply threads
    • Author
      Posts
      • #2372839
        bkinnie1
        AskWoody Plus

        I have a Dell Inspiration PC that uses Windows 10 with the latest updated Microsoft Edge browser installed. About six months ago during one of the updates the browser started acting goofy.

        Every time I try to click on a link I get a text box popping up that has several choices: Back, Forward, etc. It is very annoying. I have looked all over to see if there is some way to turn this off.

        I also have an HP Laptop, it has the same version of Windows with the same updates and it doesn’t do what the PC is doing.

        Any ideas?

      • #2372844
        b
        AskWoody MVP

        That’s the normal menu for a right-click on the page background, which makes it look more like a mouse issue.

        Doesn’t the same thing happen in Google Chrome (which I see on your taskbar)?

        Windows 10 Pro version 21H2 build 19044.1149 + Microsoft 365 (group ASAP)

      • #2374594
        bkinnie1
        AskWoody Plus

        The same thing happens to me in Chrome. I tried some troubleshooting. I tried to create a local account, not using a microsoft account. I get the same issue.

        When I try a reset , keeping my files the process does not complete it gives me a message saying there is something wrong.

        I’ve also went to settings, apps and modify the app by repair. I have done this several times with no resolution. The problem stops for a few minutes then starts again.

        • #2374599
          b
          AskWoody MVP

          Try a different mouse.

          It sounds much more like a hardware issue than Windows or browsers.

          Windows 10 Pro version 21H2 build 19044.1149 + Microsoft 365 (group ASAP)

      • #2375757
        bkinnie1
        AskWoody Plus

        I want to thank everyone for their help. I did further troubleshooting by taking my wireless mouse and pluging it in after removing the mouse that came with the computer. The issue went away, problem solved.

        I bought another wireless mouse and no more problems.

        Thanks again.

        1 user thanked author for this post.
        b
    Viewing 3 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: Microsoft Edge acting goofy

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.