News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Microsoft Store – internet connection

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 Microsoft Store – internet connection

    Topic Resolution: Resolved
    Viewing 23 reply threads
    • Author
      Posts
      • #2223259 Reply
        gwilki
        AskWoody Plus

        I am running windows 10 1909, but the issue was the same with 1809.

        When I go to the Microsoft store for a windows app, I get a message saying that I am not connected to the internet. The error code is 0x800704cf. I am on a wired connection to the internet and it is good.

        I have read about several fixes and done them all. Here they are:

        checked to ensure that no proxy is enabled

        ran the store troubleshooter

        reset the store app – 6 times

        reset the store cache folder

        re-registered the store app using powershell

        I am not using a VPN

        ran network troubleshooter – no issues

        In the hours that I’ve spent trying to fix this, I’ve done other things that I’ve forgotten.

        Can anyone here please help? This is ridiculous!

      • #2223379 Reply
        Lars220
        AskWoody Lounger

        I have read about several fixes and done them all. Here they are:

        Here is another link to review that has some steps to try that may help you,  your list does not seem to include a couple of steps listed, but maybe you already tried these:

        Step 5. Reset TCP/IP Protocol & WINSOCK Catalog
        Step 6. Refresh IP Address and Reset DNS Address settings

        Look over this link for ideas:

        https://www.wintips.org/fix-microsoft-store-error-0x800704cf-it-doesnt-look-like-youre-connected-to-the-internet/

      • #2223389 Reply
        gwilki
        AskWoody Plus

        Thanks for this, Lars. I did every step and I still cannot connect with the MS store.

        In trying all this, I found that I cannot log into my MS account, either.

        I can open my home page and surf normally otherwise.

        I can log into my account from two desktops on the same home network. I can also get into the MS store from those desktop PCs.

        The pc causing the problem is a Lenovo X220 laptop.

      • #2223508 Reply
        gwilki
        AskWoody Plus

        Just an update; this morning, I tried a safe boot with network. It did not solve my issue.

        1 user thanked author for this post.
      • #2223574 Reply
        b
        AskWoody Plus

        Check date and time zone?

        Windows Store Error 0x800704CF

        1 user thanked author for this post.
      • #2223586 Reply
        gwilki
        AskWoody Plus

        Tks, b. I’ve done that, too.

        I apologize to the group here for not listing everything that I’ve tried. I’ve done so many “fixes” that I’ve lost track.

        Today, I followed one piece of advice and turned off the windows firewall and virus protection. No joy.  I turned off TPM on the laptop. No joy.

        This is crazy to me, as I have no problem on any of the other pcs on my home network. I’ve compared their security settings one line at a time with this laptop and they are exactly the same.

        I believe it’s time to give up on this one.

        1 user thanked author for this post.
        b
      • #2223920 Reply
        EP
        AskWoody_MVP

        I’m afraid the last option would be to re-install Win10 by doing an in-place upgrade on that Lenovo X220 laptop

      • #2223922 Reply
        gwilki
        AskWoody Plus

        Thanks, EP. Since microsoft.live.com and the microsoft store are the only sites that I have found that I cannot get into, I believe that I’ll just live with it. I figure that the chances of something going wrong with an upgrade are high and that I  could be worse off than I am.

        • #2223953 Reply
          Rick Corbett
          AskWoody_MVP

          Probably 5 stupid questions but…

          1. Have you flushed the DNS cache (ipconfig /flushdns) twice? (Our network guys at work *always* advised me run the command twice… and on one occasion – to my amazement – it did the trick. I had thought they were joking.)

          2. Have you then tried a Ping to microsoft.live.com to see if it resolves to an IP address?

          Windows’ default behaviour is to query the local DNS cache first before trying an external DNS server… so a corrupt cache could cause what you are experiencing.

          I stumbled across the info that Microsoft have released an update to its published Public IP address block range today (7th April). More details can be found here (and a .CSV is available for download… but doesn’t show domains, only IP address blocks).

          From the link (my emphasis):

          This file contains MSFT Public IP Address blocks. Updates will only occur when the list changes so please check the Data Published date.

          (Note: I couldn’t find any mention of the Data Published date either in the worksheet or in the document’s properties.)

          I don’t think there’s much point trying a Ping to microsoft.store.com. I tried and the result was a redirection to a third-party CDN (Content Delivery Network) handling Store activities on Microsoft’s behalf. However, if flushing the cache resolves the microsoft.live.com issue then it should also resolve the Store issue.

          3. Have you checked the device’s HOSTS file (in C:\Windows\System32\Drivers\etc\hosts) for a microsoft.live.com and/or microsoft.store.com redirection? It’s a long shot… and the only thing I can think of which would add this would be malware.

          4. Another long shot… is the device’s DNS settings set manually using a different DNS provider to the other devices?

          5. As it’s a laptop, I assume it has wireless? If so, have you tried connecting wirelessly? I ask because I found a similar issue (see post dated April 16, 2019) via a Google search and noted that it only occurred when using an ethernet connection, not wireless.

          Hope this helps…

      • #2224022 Reply
        gwilki
        AskWoody Plus

        Rick:

        1. I flushed the cache 3 times.
        2. I pinged microsoft.live.com and it timed out 4 times. Just to compare, I pinged ebay.com and got 4 returns in milli seconds.|
        3. I looked at the hosts file in that location and all it said was that it was a sample hosts file. There was nothing in it but a couple of examples – neither of them related to Microsoft.
        4. I am allowing the device to set the DNS servers. On the advice of another member here, I tried setting them manually to Google’s servers. It did not fix the problem.
        5. I have tried both wireless and ethernet connections. Both have the issue. Both also fail the ping test.

        Thank you very much for taking the time to help me out. I used to think that I could find a solution to pretty much any issue my pcs threw at me. I know better now.  🙂

      • #2224039 Reply
        Alex5723
        AskWoody Plus

        I have tried both wireless and ethernet connections. Both have the issue

        Can you connect to Microsoft store/Live using your PC and smartphone tethering ?

        Have you checked your router’s settings? logs ?

        • This reply was modified 7 months, 4 weeks ago by Alex5723.
      • #2224111 Reply
        gwilki
        AskWoody Plus

        Alex: Instead of tethering to my smart phone, I was out this evening and sat in my car in a McDonald’s parking lot. I connected to their free wifi and was able to surf to several sites. But I still could not connect to microsoft.live.com or outlook.live.com.

        So, I think it’s safe to say that the issue is not with my home router or network. It is something hidden away in the laptop.

      • #2231455 Reply
        Rick Corbett
        AskWoody_MVP

        So, I think it’s safe to say that the issue is not with my home router or network. It is something hidden away in the laptop.

        If you have a spare 2GB USB stick, you can double-check by booting from a Linux Live USB stick and using the built-in browser.

        Have a look at How-To Geek‘s excellent How to Create a Bootable Linux USB Flash Drive, the Easy Way tutorial.

        (I used Linux Mint Cinnamon and downloaded v18 x64 because – at 1.6GB – the ISO file is 300MB smaller than the latest v19.3.)

        Hope this helps…

      • #2231874 Reply
        joep517
        AskWoody MVP

        I realize you are on a home network but is this a home or work PC?

        Is it running Windows 10 Home or Pro or ??

        --Joe

      • #2231982 Reply
        gwilki
        AskWoody Plus

        Rick: Well, it works in Linux. I did as you instructed, booted to the linux usb, did not install linux, but ran firefox browser from the usb stick. I could access outlook.live.com and microsoft.live.com.

        So, I guess that means that something in my windows installation is the bad actor, but what?

        Thanks for getting me this far.

      • #2231983 Reply
        gwilki
        AskWoody Plus

        Joe: I’m running windows 10 home 1909.

      • #2232025 Reply
        Rick Corbett
        AskWoody_MVP

        I guess that means that something in my windows installation is the bad actor, but what?

        On the plus side, you’ve confirmed the issue is solely to do with the Windows install on the laptop. On the minus side, you’ve had the issue since 1809 so it’s going to be next to impossible to backtrack/fix after all that has been tried. (I suspect you may have installed 1909 [or let 1909 install] in the hope that it would fix the issue.)

        Looking back through your posts I can’t see any mention of any antimalware scans (e.g. Malwarebytes Free, Eset‘s free Online Scanner, etc.). This, I suggest, is your next step.

        If nothing (e.g.  a redirector) is detected and fixed then IMO you would appear to have three options:

        1. Live with it.
        2. In-place repair.
        3. Clean install.

        In an earlier post, @ep suggested you “re-install Win10 by doing an in-place upgrade”. You replied “I believe that I’ll just live with it. I figure that the chances of something going wrong with an upgrade are high and that I could be worse off than I am.”.

        That’s fair enough but I think the word ‘upgrade’ may have been misleading in this context. You are already on 1909… so you won’t be ‘upgrading’ anything… merely *repairing* what’s already there. (Plus, you’ll be using something like Macrium Reflect Free to take an image backup beforehand, won’t you? 🙂 )

        Have a read of this excellent TenForum’s How to Do a Repair Install of Windows 10 with an In-place Upgrade tutorial. IMO it will give you all the information you need to make a decision.

        Hope this helps…

         

        3 users thanked author for this post.
      • #2232051 Reply
        Alex5723
        AskWoody Plus

        gwilki wrote:
        So, I think it’s safe to say that the issue is not with my home router or network. It is something hidden away in the laptop.

        After your latest post I think that the problem may lay with your Microsoft Account.
        Have you tried logging from another PC/Tablet/smartphone ?

      • #2232082 Reply
        gwilki
        AskWoody Plus

        Alex: Yes, I can log into my microsoft account from all the other pcs on my home network.

      • #2232083 Reply
        gwilki
        AskWoody Plus

        Rick: Thanks for our advice.

        I routinely run Malwarebytes on all my pcs. It has not found anything on this laptop, thankfully.

        I do use the free version of MacriumReflect, and have up to date backups of the laptop and an emergency repair boot usb stick for it. (It does not have a DVD drive.)

        I’ve opened the link to the repair instructions, but not yet read it through. I will, though. Since I have an up to date backup, I suppose it can’t do any harm and I’m pretty much out of options, it seems.

      • #2232155 Reply
        Lars220
        AskWoody Lounger

        Just a thought I have not noticed mentioned before, have you tried to repair Windows 10 using DISM, and the SFC Utility from an Administrator Command Prompt? As a reminder, you can right click the Start button and find a Command Prompt (Admin) shortcut link, and be online / connected to internet when running the Command Prompt commands found at the below link. I would save time and skip CheckHealth, ScanHealth, and just use RestoreHealh, be patient and let run, then run sfc /scannow. Review article for more information:

        How To Repair Windows 10 Using DISM and SFC Utility
        Last updated Mar 9, 2020
        Dism /Online /Cleanup-Image /RestoreHealth
        sfc /scannow
        Open command prompt as administrator

        https://windows101tricks.com/repair-windows-10-using-dism-sfc-utility/

      • #2233220 Reply
        gwilki
        AskWoody Plus

        Tks again, Lars. I ran the dism/online and it seemed to fix something, judging from the response. Then I ran sfc /scannow. It found nothing.

        The problem is still there. It would seem that the only solution will be the in place repair that Rick recommended.

        1 user thanked author for this post.
        • #2261373 Reply
          ChuckWW
          AskWoody Plus

          I  got onto this thread just now via the new newsletter, and I am having exactly the same problems as you. I mean exactly! I’ve also done most of the things you’ve done to try and repair it. As a last resort, I tried the in-place reinstall two days ago, which I’ve done a couple of times in the past to fix other problems I could not resolve. I’m sorry to say absolutely nothing changed with being unable to connect to the Microsoft Store and the Microsoft sites (plus bing.com for me) you’re having the problem with. Phooey!

      • #2261440 Reply
        gwilki
        AskWoody Plus

        Clearly, I can relate, ChuckWW. I just gave up. I can access the MS sites from my other PCs, so the only inconvenience to me is not being able to download and install apps on my laptop. So far, I’ve been able to find apps on other sites that do what I am looking for, so I haven’t needed the ones on the MS store. It is still frustrating,  though. Since I can access the store using Linux on my laptop, and I cannot access the store from my laptop on any network, it’s clear to me that there is some combination of windows 10 and my Lenovo laptop that cannot play nice together. Maybe at some point, there will be a windows 10 monthly update that fixes this as a side effect of what the update is really intended to do.

        Good luck.

        • #2261462 Reply
          ChuckWW
          AskWoody Plus

          I’m in the process of tracking down the cause, running through firewall and diagnostic logs plus searching through the registry. I think I have a lead, but I’m not going to get too excited about it yet. But it may pan out!

      • #2261469 Reply
        ChuckWW
        AskWoody Plus

        I fixed it on my PC! I ran network diagnostics and while it couldn’t fix anything, the log gave me a starting point. For me, the culprit was one of the telemetry blocking programs I’d forgotten I even had – WPD. I reset everything to the Windows defaults, and I didn’t even have to reboot for those Microsoft addresses and the Store to work. The other thing I thought might be causing problems was another I use, O&O SutUp10, but setting it back to the factory settings didn’t fix the problem. See if you have WPD.exe on your PC. It’s a stand alone executable. And if you don’t, your network diagnostics log should point us to what settings are blocking those Microsoft connections.

        The pertinent diagnostic log info:

        Issues found
        Your computer appears to be correctly configured, but the device or resource (bing.com) is not responding. Contact your network administrator or Internet service provider (ISP) Completed

        Security or firewall settings might be blocking the connection

        InformationalDiagnostics Information (Network Security)
        Details about network security diagnosis:

        Settings that might be blocking the connection:
        Provider name: WPD_Provider
        Provider description: WPD_Provider
        Filter name: WPD MS Third party IP Block V36

        2 users thanked author for this post.
      • #2261513 Reply
        gwilki
        AskWoody Plus

        Well, ChuckWW, if I had a prize to offer, you would win it! I explored C:\ and found a folder for wpd, opened it and found the wpd executable. I opened that. I didn’t see anyway to set it to its defaults,so I just disabled it. As you said would happen, I was immediately able to connect to outlook.live.com.

        Within about a minute, I got a warning from windows defender saying my firewall was turned off. I went into security and turned it on. All was still well.

        I don’t have a clue as to how wpd got on the laptop. No one uses it but me and I know I did not consciously install it.

        It appears that, once it is there it takes over for windows firewall. Disabling wpd does not turn the firewall back on.

        Thank you very much ChuckWW.

        • #2261522 Reply
          ChuckWW
          AskWoody Plus

          Well, hallelujah! I so happy that worked for you.

          Like you, I don’t use the store much, but I do have a few apps I like. A big part of it was simply knowing that something wasn’t working like it should, and that kind of thing bugs me to no end.  Another function that accursed WPD blocked was the radar on the Weather app. There are a million ways to get weather information, but that app is actually quite handy.

          • #2261524 Reply
            PKCano
            Da Boss

            It’s probably Bing Weather (Microsoft). That’s why it’s blocked.

            • #2261531 Reply
              ChuckWW
              AskWoody Plus

              Yep, anything Bing-y was getting blocked.

               

    Viewing 23 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Microsoft Store – internet connection

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.