News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Mint Upgrade Now Offered In System Reports

    Posted on firemind Comment on the AskWoody Lounge

    Home Forums AskWoody support Non-Windows operating systems Linux – all distros Mint Upgrade Now Offered In System Reports

    Viewing 4 reply threads
    • Author
      Posts
      • #2279522 Reply
        firemind
        AskWoody Lounger

        I installed an update for mintreports from the Update Manager and now have an option to upgrade to Linux Mint 20. The link appears in Administration>System Reports and it also places a notification icon on the panel.

        I am backing up files and may upgrade tonight. I will let you all know if it is different than the command line experience everyone has referred too.

        upgradenotice

        Attachments:
        4 users thanked author for this post.
      • #2279582 Reply
        Microfix
        AskWoody MVP

        Might be an idea to have a read at this Thread before doing anything, it may or may not affect your system.
        Better to be safe than sorry.

        | Win8.1 Pro x64 | Linux Hybrids x86/x64 | Win7 Pro x86/x64 Offline |
        1 user thanked author for this post.
        • #2279864 Reply
          firemind
          AskWoody Lounger

          Thanks, I use Timeshift and updated before upgrading. Ulyanna installed and so far no problems.

          1 user thanked author for this post.
      • #2279736 Reply
        Ascaris
        AskWoody_MVP

        I would guess it’s a launcher for the same upgrade script as in the command line.  Would  be interested to know how it went. The people that were a little nervous about the process would be interested to know this too.

        The funny thing is, I did see that while I was in the process of upgrading Mint, but I had already started on the command line, so it didn’t register.

        Group "L" (KDE Neon User Edition 5.19.4).

        2 users thanked author for this post.
        • #2279866 Reply
          firemind
          AskWoody Lounger

          It was a bit of a let down but it worked. i had hoped it was a GUI overlay of the terminal info like the Update Manager but it was just a link to the Linux Mint blog. 🙂 I had to copy/paste the code from the browser to the terminal.

          1 user thanked author for this post.
      • #2279768 Reply
        DrBonzo
        AskWoody Plus

        This sounds like the kind of thing I saw when I was running Ubuntu 16.04 LTS. After updating some software through the update manager, I was presented with a pop-up screen that said the software on the computer was up to date, but that an upgrade to 18.04 LTS was now available. Click OK to upgrade, or click cancel, or click remind me later. After a few weeks I clicked OK and 20 minutes later was the proud parent of 18.04 LTS. All of my old settings, data, and files were carried over (even the printer); the only thing I needed to do was enter a website for getting Opera updates.

        • #2279868 Reply
          firemind
          AskWoody Lounger

          It took a long time to upgrade but once done I just had to tweak a few settings.

      • #2279890 Reply
        firemind
        AskWoody Lounger

        I have mentioned this in replies but here is a bit more info.

        I prepared to upgrade by checking for software updates, running Bleachbit to clean out junk, running clamtk (i tend to before updates) and setting a restore point with Timeshift. I also turned off my screensaver and monitor sleep mode for the update.

        I then clicked on the notice shown in the screen shot and……..ended up on the Linux Mint blog page telling people how to update using the terminal. Sigh. I am not afraid of the terminal but a more user friendly approach would have been nice.

        I decided to follow the upgrade instructions exactly and follow recommendations. The only PPAs and repositories effected in my case were Wine and Lutris and Mint backed up the links so no problem there. I downgraded and removed them.

        I did the mint-upgrade check and it looked fine so I started the upgrade. The downloads when well but contact with the download site failed around when around 99% done. I run the command again and the download finished.

        I then copied and pasted the final upgrade command and let Mint handle reboots when cron/etc were turned on and off. The upgrade went well but took a long time – over an hour. My system was up to date and my Internet is fine so I am not sure what the issue was – but I expected it to take time.

        There was no progress bar or other indicator of progress except for moving text. Reading the text periodically gave me some indication of progress and finally i was told to reboot.

        Of course my desktop looked the same but System Reports confirmed I was using Ulyanna and the 5.40 kernel. i checked some files/programs and most were the same. I did go to the Lutris site and reinstalled via terminal. I didn’t have to touch Wine so my one MMO was unchanged.

        There may be some issues i haven’t found yet but so far it looks good.

        A clean install would have been much faster – based on my experience with 19.3 – but then I would have had to reset my email, reinstall Wine, and my MMO game and other games. After the reboot I had to copy three lines into the terminal and Lutris was back to normal and that was all.

        For those nervous about using the terminal I can relate. Watching incomprehensible text flow by doesn’t help when there is no real progress bar and copy/paste isn’t as easy as clicking next. But the system works and if you go watch tv or do something else it won’t be long before you see reboot notice.

         

         

        1 user thanked author for this post.
    Viewing 4 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Mint Upgrade Now Offered In System Reports

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.