News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Mouse Freezes When I Attach an External Drive to My MS Surface Book

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » Mouse Freezes When I Attach an External Drive to My MS Surface Book

    Author
    Topic
    #350789

    I have a new MS Surface Book with Windows 10 Pro version 1803.

    It has a persistent problem. With one exception (a more than 10-year old 2 GB pen drive), when I attach any of my USB drives it freezes the mouse, and I have to use the touch pad (which I dislike using). I’ve tried this with 5 or 6 drives, and in most cases the mouse freezes and stays frozen until I disconnect the drive. In other cases the mouse works intermittently, but only hesitantly. I’ve tried three different wireless mice (all Logitech, two of which use the same software, although they’re different models), with the same result in all three cases.

    Two friends thought that my problem may have resulted from the “fact” that the Surface is “notorious” for having “under-powered” USB ports, and that it could be solved by my using a powered USB hub. I ordered a powered hub, which arrived today, and it doesn’t help.

    I had one other problem, which may or may not be related: the button configuration for the mouse wouldn’t stay fixed. That is, I’d change it to left handed, but after a re-start it reverted to right-handed. By Googling, I found that others had had the same problem, and that one person solved it by first changing the configuration, then detaching the USB connection, then rebooting and then reattaching the USB connection. Don’t know why that would work, but it did, in both his case and mine. But again, I’ve no idea whether that’s at all related to my freezing issue.

    Can anyone give me advice on how to troubleshoot the freezing issue?

    Thanks.

    Viewing 6 reply threads
    Author
    Replies
    • #350791

      Has Microsoft (or Intel) released any new drivers for their USB subsystem?

      • #351031

        I’ll check that out later today.

        Thanks for the suggestion.

    • #350877

      Detach the mouse before you attach a drive, then attach a drive, then reattach the mouse.
      Any change?

      Have you changed the ports into which you put the mouse dongle?

      Are they USB 3.1 ports? If it’s possible to reconfigure them to 3.0, it’s worth a shot.

      Lugh.
      ~
      Alienware Aurora R6; Win10 Home x64 1803; Office 365 x32
      i7-7700; GeForce GTX 1060; 16GB DDR4 2400; 1TB SSD, 256GB SSD, 4TB HD

      • #350999

        Ha! Life is good!

        I think it worked. At least the mouse worked when I tried it just now. Over the next few days, I’ll be finding out whether it’s permanent and works when I deal with moving files around, etc.

        Thanks very much for the suggestion.

      • #351032

        Turns out that it’s not a perfect solution.

        When I put the computer into hibernation and then back out again, the mouse is frozen until I disconnect the USB drive and mouse, then reconnect the drive, then reconnect the mouse.

        But if in the fullness of time I otherwise don’t have to deal with freezing, that’s a relatively minor matter.

        Later today I’ll be checking for updated drivers to see if that affects things.

        Thanks again for your help.

    • #351149

      Thanks very much for the suggestion.

      Thanks again for your help.

      You’re welcome Bob, glad you’re mostly sorted 🙂

      There’s a good chance new drivers will fix the rest of it.

      Lugh.
      ~
      Alienware Aurora R6; Win10 Home x64 1803; Office 365 x32
      i7-7700; GeForce GTX 1060; 16GB DDR4 2400; 1TB SSD, 256GB SSD, 4TB HD

      • #351251

        It turns out that things are more complicated. The device manager reports that all of my drivers are up to date. But beyond that, it turns out that the solution of disconnecting and reconnecting the mouse worked only for the external drive that I tried this morning. I’ve now tried it with two other external drives (both very new), and they both freeze the mouse, which stays frozen even after I disconnect and reconnect it.

        Further, the drive for which the process seemed to work this morning now doesn’t freeze the mouse at all, even if I disconnect the drive, leave the mouse connected, and then reconnect the drive. Which is rather curious, to say the least. That drive is a rather older one, but still a USB 3. Other older drives have also frozen the mouse, but I have not yet tested what effect disconnecting and reconnecting the mouse has on them.

        But in short, the problem hasn’t been even partially solved after all, except in the case of that one drive. So if any other solutions suggest themselves, I’d appreciate hearing about them.

        Thanks.

        • #355175

          if any other solutions suggest themselves, I’d appreciate hearing about them

          Please summarize what the folks at TenForums have looked at or suggested, so we don’t end up wasting our time duplicating effort.

          Lugh.
          ~
          Alienware Aurora R6; Win10 Home x64 1803; Office 365 x32
          i7-7700; GeForce GTX 1060; 16GB DDR4 2400; 1TB SSD, 256GB SSD, 4TB HD

          • #363746

            There was a single response. It was, in full “Already answered at AskWoody.”

            I replied that the solution here was only partial (since I’d still have to disconnect and reconnect the mouse every time I rebooted or changed external drives), and that, in any case, it had turned out that the suggested solution worked with only one particular drive, which had started not to freeze the mouse at all, even if I didn’t go though the dance of disconnecting and reconnecting the mouse. (BTW, since then, that drive has gone back to causing the freeze, with the disconnect/reconnect solution not working for it at all).

            There have been no other responses at the other forum. I assume that the single reply I did get, by implying that I already had a complete solution, is driving other potential responses away.

            • #364732

              If you’ve already posted a similar question on a different site, please link to it so we can avoid reinventing the wheel.
              User Account & General Rules

              Windows 10 Pro version 21H2 build 19044.1319 + Microsoft 365 (group ASAP)

            • #380684

              I’m new to the forums, and when I first read the user account and general rules, I either missed the thing about cross-pointing or simply forgot it. My apologies.

              My intent was, when/if I got advice from one forum that didn’t appear in the second forum, I’d mention it myself on the second forum. But now that the rule’s been brought to my attention, I’ll of course comply with it.

              2 users thanked author for this post.
              Elly, b
    • #351221

      Windows 10 Pro version 21H2 build 19044.1319 + Microsoft 365 (group ASAP)

      1 user thanked author for this post.
    • #369639

      There have been no other responses at the other forum. I assume that the single reply I did get, by implying that I already had a complete solution, is driving other potential responses away.

      Cross-posting issues aside, I would guess that few of us have had the opportunity of even using, let alone owning, a Surface Book… let alone a new one. 🙂

      I certainly haven’t… so I had to look up the specs. It look like the Surface Book 2 uses 2 x USB 3.1 ports (and a USB Type-C port). I’m assuming you’re using a Logitech Unified Bluetooth Transceiver with your mouses. I’m also assuming that ‘something’ happens to either Bluetooth or to USB connectivity when you connect a drive. (Unlikely to affect both and more likely it’s USB.)

      I don’t have an answer for you… just a question. If you download/run (using Run as administrator) Nir Sofer’s USBDeview, what – if anything – does it show happening to the mouse/unified transceiver when you plug one of the drives in?

      • #381721

        I’m not sure what a unified transceiver is. Looking through the Logitech site, it seems to come up in connection with USB receivers that can be used with multiple devices (e.g., a mouse and keyboard). If that’s what it refers to, I’m not using one; or, at least, if it is one, it’s not how it was packaged as sold.

        I’m experiencing the freezing problem with two different mice, each of which was purchased separately from any other device. I started with the one I purchased specifically for the laptop: a Logitech M310 (specs shown here < https://www.logitech.com/en-us/product/wireless-mouse-m310 >, where they refer to the receiver as a nano-receiver with 2.4 GHZ wireless connectivity).

        Because of the continued freezing problem, I’ve also tried using a much older mouse that I have for my slowly dying Win 7 desktop. That mouse might be (probably is) more than 10 years old, a Logitech MX Revolution, which utilizes a receiver which is about an inch long. It’s depicted here: < https://support.logitech.com/en_us/article/9338?product=a0qi00000069usMAAQ >.

        Both mice utilize the same SetPoint software, and both experience the freezing problem I’ve described.

        I downloaded USBDeview and ran it as administrator. It doesn’t identify either mouse as a Logitech, but I determined which lines of information concerned the mouse by disconnecting and then reconnecting it. In both cases, disconnecting the receiver removed the green highlighting for three separate lines of data related to a USB receiver, and the entry in the “Connected” column entry changed from “Yes” to “No.” Reconnecting the receiver changed it all back.

        So when I then connected an external drive that caused the mouse to freeze, I checked all three lines. I did that for two different external drives. Nothing changed in any of the lines of data. In all three cases, the entry in the column for “Disabled” said “No”, regardless of whether an external drive was connected with corresponding freezing of the mouse.

        Right clicking on a line and selecting properties produces a box that presents the same data in more compact form. Given the fact that connecting a drive that made the mouse freeze didn’t change any of the entries, I doubt it helps, but for what it’s worth, I took a screen capture of that information for one of the three lines of data for each mouse. Copies of those two screen captures are attached.

        Hoping that this sheds some light.

        Thanks for your help.

        M310

        MX-Rev

    • #383097

      Your first post mentions 3 Logitech mice but your last post only identifies 2 Logitech mice – an M310 (with nano transceiver) and an older MX Revolution (with standard transceiver). Both connect via wireless (not Bluetooth – my mistake). You don’t use a unifying transceiver (which is just a transceiver that can connect up to 6 wireless Logitech peripherals).

      Do you have any Logitech software installed? (The screenshots suggest not.)

      If not then the Logitech website mentions 2 products which may help:

      1. SetPoint for customising mouse buttons (you mentioned in your first post that swapping mouse buttons didn’t ‘stick’) which is available for download (or from here for direct download of the latest version for Windows 10 x64)

      2. Logitech Connection Utility for reconnecting non-unifying mice. The MX Revolution is mentioned specifically and is available for download (or from here for direct download).

      Hope this helps…

      • #408075

        I do have three mice. I left out the third from my recent post because after I initially discovered that all three mice froze, I did all comparison testing with only the two that I mentioned last time, the M310 and the MX Revolution. I figured that testing with two mice with different receivers was enough to determine whether any results I got were unique to one single mouse.

        The third mouse is a Logitech M510. Although each mouse uses a different receiver, all three utilize the same SetPoint software, which I installed shortly after I first purchased the computer. (Logitech also provides “Options” software for the M510, but not for the M310. I successfully installed it as well, but when I tried to set it up, I got a message that no device for which the software was designed was attached to the computer.)

        I did uninstall and reinstall the SetPoint software, to see if it made any difference. It didn’t.

        I also tried the connection utility you suggested. But each time (I tried several times), it produced a message that it was unable to pair the device with the receiver.

        (A question, because I’m not understanding something. The utility says its purpose is to re-establish the connection between the receiver and the device, and I assume that the message about failing to “pair” means that there was a failure to “connect.” But since the mouse doesn’t work unless the receiver has been plugged in, isn’t there in fact a connection after it’s plugged in? I’m not trying to parse words; I’m just trying to understand what’s going on.)

        Your comment that the USBDeview data indicated that I didn’t have any Logitech software installed reminded me of something that I hadn’t thought about since I originally installed it. I discovered only today that it affects only two of the mice (it doesn’t affect the M510), so I suspect it’s not relevant to the freezing problem, which affects all three mice, but I mention it for what it’s worth. I also attach a screen shot of some USBDeview data for the M510, and wonder whether they too fail to show any Logitech software installed. I can’t tell myself.

        But the thing I had forgotten… After I first installed the SetPoint software, I went into the Logitech settings in order to change the M310 mouse from right handed to left handed, but couldn’t find where to do it. I didn’t think much about it at the time, because I knew I could simply go into the Windows 10 mouse settings and make the change there, which is what I did. Once I did that I forgot about the Logitech settings.

        But now, in light of your comment, I dug further. It turns out that quite a number of Logitech customers have reported an issue with this (Logitech support posted a message on it for Windows XP, Vista and 7, though not for 10; and one blog has over 60 comments on the subject). Specifically, the Settings box is supposed to have three tabs, “My Mouse,” “My Keyboard,” and “Tools.” But when my M310 or MX Revolution is attached to this particular computer, the Settings box has only the “Tools” tab. A screen shot is attached. Also attached is a screen shot for the M510 Settings box, which does have all three tabs, which I wasn’t aware of before, because I hadn’t been using the M510 with this computer, and had connected it only briefly, just to confirm that it too froze when an external drive was attached.

        Since the freezing problem persists with all three mice, I’m not going to narrate the things I tried today in an effort to fix the tabs problem. If you think it’s relevant, because the tabs problem and the freezing problem might be aspects of some over-arching issue, I can post back on that subject. For now, suffice it to say that nothing I’ve tried has helped with the tabs issue.

        Does any of this (or anything else) suggest any further steps I might take in an effort to fix the freezing issue?

        Thanks.

    • #410478

      First a caveat – I’ve never used any version of a Surface Book but I am aware of issues with them not playing nicely with peripherals, including their own docking stations. I don’t use wireless peripherals, especially not Logitech, but I am also aware of issues with these too.

      With this out of the way, I note that you appear to have had most success with the Logitech M510. I don’t think it’s a coincidence that – going by the Device Description, Driver InfSection and Description fields in each screenshot – the M510 is the *only* mouse that appears to be identified correctly and to be using a Logitech driver (shown in the Driver InfPath field). Whether or not it’s the *right* driver can only be checked by examining the contents of the oem119.inf file used.

      If you look at the  corresponding field for the other 2 mice you can see that one uses MS’ built-in generic usb.inf file whilst the other uses MS’ built-in generic input.inf file.

      If you look at the files in Notepad (they’re stored in the C:\Windows\INF folder) you will see that usb.inf has no mention of Logitech whilst input.inf does not include either the MX Revolution or M310 in any of the 33 Logitech entries.

      Digging deeper (by using the Vendor/Product IDs in the Instance ID field and checking them on the PCI Lookup database),  the MX Revolution appears to be identified correctly but the M310 is mis-identified as using a Unifying transceiver… which it doesn’t, according to the Logitech website. However, the M510 *does* use a Unifying transceiver.

      I have no idea why USBDeview indicates no Logitech drivers installed/loaded for the other 2 mice when your first post mentions no driver issues showing in Device Manager.

      Overall, it appears that Win 10 has a vague idea that the MX Revolution and M310 are wireless mice but no idea what their capabilities are.

      In the absence of any input from anyone else here I think you have 2 choices, both involving more specialist assistance rather than the generic help on offer here:

      1. Follow the advice (and link) in this Surface Book 2 – Cursor freezes and mouse stops working randomly post and download the Surface Diagnostic Toolkit.

      2. Use the Logitech Support forum. (It already has posts like M510 mouse is not working or frequently stops working.) Whilst you have to create an account, Logitech Support staff are the only ones (IMO) who will be able to tell you whether Unifying and non-Unifying transceivers can co-exist happily on a Win 10 device.

      This isn’t a cop-out (well, it is in a way…), it’s just you’re using:

      • A laptop with known hardware issues (Google surface book 2 problem – about 360 million results).
      • Logitech mice with known issues (Google logitech mouse problem – over 10 million results), hence why I gave up using them years ago.

      Just be aware that Microsoft is more than likely to blame Logitech and vice versa. It’s also likely that you may be asked to reset your Surface Book 2 from scratch and start again with just the most recent mouse/transceiver.

      Hope this helps…

      • #424650

        I’ll follow your advice.

        Thanks very much for taking all the time to help me with this.

    Viewing 6 reply threads
    Reply To: Mouse Freezes When I Attach an External Drive to My MS Surface Book

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.