News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Moving from Windows 7 to Windows 10

    Posted on wilson123 Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 Moving from Windows 7 to Windows 10

    This topic contains 0 replies, has 1 voice, and was last updated by  wilson123 1 week, 3 days ago.

    • Author
      Posts
    • #1997755 Reply

      wilson123
      AskWoody Plus

      In preparation for the January 2020 end of support for Windows 7, I purchased a new pc with Windows 10 installed.

      As I make my new PC do the same useful things that my (6 year) old PC can do, I’ve made the following observations:

      My old PC:

      Dell Model XPS 8700
      Windows 7 64 bit Professional
      Microsoft Office 2010 Professional (32 bit)

      My new PC:

      Dell Model XPS 8930
      Windows 10 64 bit upgraded to Professional
      Microsoft Office 365 (64 bit)

      I configured the new PC similarly to the old PC, including installing programs, creating the same partitions on the HDD, and copying files, folders, databases, etc.

      Among the things that I’ve found useful in the past are the Microsoft Word Templates that I’ve created and I copied them from the old PC as well.

      On the new PC, I found that Microsoft Word documents, Excel spreadsheets, and Access databases seem to work as before, with the exception of the Word templates. These templates create documents using data copied from Access databases using a DAO interface.

      When I try to run the macro in these templates, I get the error message:

      “Run-time error ‘-2147221164(80040154)’: Class not registered

      Following the advice on Microsoft.com, I ran the Office 365 repair routines; the first one, which took just a few minute did not correct the problem. The second one, which took several hours and included an uninstall and a reinstall of Office 365 (64 bit), also did not correct the problem.

      I, then, tried un-registering and re-registering dao360.dll which facilitates the database connection. This, also did not correct the problem.

      I found the dll (dao360.dll) required for DAO in the programs(x86) directory, suggesting that it is a 32 bit dll. I suspected that this was the basis of the problem.

      Installing the 64 bit dll and configuring the registry seemed a bit too ambitious; a simpler solution was to uninstall the 64 bit Office 365 and install the 32 bit version.

      This solved the problem.

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Moving from Windows 7 to Windows 10

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.