• MS Edge takes over pdfs

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » MS Edge takes over pdfs

    Author
    Topic
    #2383710

    The changing of default programs automatically by Win 10 has become a huge annoyance, particularly making Edge the default pdf program (a real joke), and Photo the default image program instead of ACDSee. The many internet solutions I have read (I’ve tried several) don’t work, or at least don’t stick — Edge always becomes the default for pdfs. I have Win 10, 21H1, build 19043.1165. Does anybody have a “real” fix for this problem? I’m not a dedicated techie, but I can dig into the Registry if I have detailed instructions.

    Viewing 29 reply threads
    Author
    Replies
    • #2383711

      That’s a real pain and many have complained about Edge hijacking pdf file association.

      There are two ways to fix this.

      The easiest is a new setting in Edge (need to be sure your version of Edge is the current version).

      • Open Edge
      • Click the ellipse (…) icon at the top right and select Settings to display the Settings page.
      • On the Settings page click the three line icon next to Settings to display the Settings menu.
      • Select Cookies and site permissions
      • Scroll down the page and click PDF Documents
      • Turn on Always download PDF files and exit Settings.
      • Return to default apps settings and choose the program you want to open pdfs.

      Many have reported that this sticks after updates, but I haven’t had an update since I changed this setting.

      The second method does involve a registry hack that prevents Edge from opening pdf or other file types.  Try the above first and if that setting holds.  Let me know it it doesn’t and I’ll post the registry hack.

       

      HTH, Dana:))

      HTH, Dana:))

    • #2383744

      Another ‘solution’ would be to use a different browser…

      BATcher

      Plethora means a lot to me.

    • #2383756

      I find the easiest way to change what opens a file by default is to either select the file (PDF in my example below) in the folder where it is located and use the Properties icon in the QAT (Quick Access Toolbar) or press the Alt + Enter keys, or r/click a file > Properties.
      Once the Properties box is on view, click the Change tab and then select your preferred viewer/editor to open the file.
      If your preferred program isn’t showing, you will need to scroll down and select More apps and Look for another app on this PC to navigate to what you are looking for.
      You can do the same for your images that open in the wrong program viewer/editor.

      You say you have tried several methods – it’s often wise to say what methods you have tried so any ‘helper’ isn’t repeating what you have already done.

    • #2383779

      First, since I’m relatively new to “lounging” (although I have participated in minor ways in other Forums), thanks to Moonshine for your advice on proper questioning; certainly makes sense.

      Second, DrCard, I have followed your advice, will see if it sticks, and report back.

      Third, AskWoody website (and precursors): Every Windows computer sold should have AskWoody be the first thing that pops-up at startup! Since my days of the Apple IIe, through several Macintosh versions, and subsequent entry into the maze that is Windows computing, the PC has pretty much ceased to be “personal,” and has become the CC — Communal Computer. Long gone are the days when system settings and program preferences resided at one location. Thanks to AskWoody Loungers for being part of my “Communal Computer.”

      • #2383822

        Since my days of the Apple IIe, through several Macintosh versions, and subsequent entry into the maze that is Windows computing, the PC has pretty much ceased to be “personal,” and has become the CC — Communal Computer. Long gone are the days when system settings and program preferences resided at one location.

        Welcome to a fellow Apple devotee who eventually entered the “convoluted” world of Microsoft Windows!

        I started out with an Apple+ and still “occasionally” used an Apple IIGS all the way up til 2014.

        I got sucked into the Microsoft world back in ’92 while serving in the USAF where I had to use Windows for Workgroups 3.11 with the NCSA Mosiac browser.

        Finally took the plunge and purchased a Windows PC back in ’97 (Gateway laptop) and haven’t looked back since.

        BTW…

        Prior to Windows 10 you could “manually” edit the file association entries in the registry to fix your problem but, starting with Windows 10, Microsoft locked them down by using a “self-generated” hash key that, if changed, forces the file associations to revert back to Microsoft’s preferred defaults.

        There is a work around that allows you to set your own personal file associations just as before, but it requires 3rd party S/W (Set User FTA) that can create a “valid” hash key for the changes so they stick.

        You also have to reapply the changes after every Windows update as the updates will reset them back to Microsoft’s preferred programs (I have mine set to auto-run Set User FTA at every bootup.)

    • #2383809

      Sorry, DrCard, your suggestion did not work. MS Edge still took over as PDF default. The setting you refer to in the Edge settings says this: “If Microsoft Edge is  your default PDF reader, PDF files will open automatically without downloading.” Changing that in the settings simply causes the PDF files to download no matter what browser you’re in. Firefox popped up the save dialog instead of opening. AND, changing that setting in Edge didn’t keep Edge from taking over default position for PDFs.

      Here’s what else doesn’t keep Edge from hijacking PDFs: Uninstalling Edge (it pops back up); Changing the default PDF app from Edge to something else, no matter how you do it; disabling Edge in Task Manager.

      It seems clear that Microsoft has no intention of allowing anything but Edge to be the default PDF viewer. The only solution seems to be for folks like Susan and other credible individuals known to the bandits at Microsoft to continue raising a stink. Then, maybe…just maybe…Win 11 won’t do that. I’m offering my seaside property in Arizona to anyone who believes that!

    • #2383810

      It seems clear that Microsoft has no intention of allowing anything but Edge to be the default PDF viewer.

      Updates never changed any setting on my pc including defaults apps.

      • #2383817

        It’s not updates that are the problem. I can change the default PDF viewer from Edge to Adobe Acrobat Reader, and within the same day, it’s changed back to Edge. I’ve never detected a pattern, but then I’ve never checked the defaults every 15 minutes all day long either. Maybe Microsoft has something against Adobe because of their buggy Flash Reader!

    • #2383821

      Try:
      Settings App\Apps\Default Apps
      Scroll down and click on “Choose default apps by file type.”
      Scroll down to .pdf on the left.
      Click on the Edge icon to the right.
      Choose another app, like Firefox, Adobe Reader, or ACDSee (may be under “more options”).

      • #2429030

        This worked for me. TWICE! I did it a couple of months ago, but this evening I uploaded a pdf to Google Translate, and BOOM–all my pdfs went back to Edge. I had to go back and find your solution–which is really simple. Anyway, thanks!

      • #2524018

        Thanks, I just tried this.  We’ll see if it works.  I keep wondering also why CCleaner shows a bunch of Edge stuff cleaned up, which did not happen before (I only use Firefox.)

        If any of you experienced people can point me in the right direction on another problem (Windows 10); after the latest update, once again, I’m asked to put in the password to use the computer.  I have saved articles before, since it happens once in a while, not every update.  I need to find a place this is discussed.  Thanks a million!

    • #2383825

      “Does anybody have a “real” fix for this problem? I’m not a dedicated techie, but I can dig into the Registry if I have detailed instructions.”

      That may be the simplest way to go. Just figure out what regedits need to be done to assign defaults, then create a merge registry key (or keys).

      Running a registry file at Logon

      How to Create Task to Run App or Script at Logon in Windows 10

      Once you do that, you can either do a manual registry merge, or have it merge during the computer startup. As always, do a WHOLE registry backup before you do any registry edits!

      FYI, I have not encountered this issue (defaulting pdfs to Edge) with the Edge Linux beta.

       

    • #2383840

      Sorry to hear that did not keep your pdfs from being taken over by Edge.  On my system the pdfs are staying associated with the app I want, Chrome.

      This Registry hack will remove the file association for pdfs from Edge, thus preventing Edge from hijacking pdf file association; which will leave the pdf file association to the app you have selected as default for this file type.  Not sure of your Registry knowledge so I’ll explain the steps in detail.  With every Registry edit goes the “warning” that messing with the registry can cause problems.  This means if at any point the instructions or steps don’t match what you see in your Registry, then stop and change nothing….you are in the wrong place in the Registry or the instructions you are following are not for your Registry (i.e. the Registries for Home and Pro differ quite a bit).  If this happens, stop and find out before proceeding.

      Synopsis:

      You will look into the Registry for your version of Edge to learn the name given to the registry key for Edge to have file association for pdfs.  This long name is different for different versions.  Using that name you will find that registry file association key and rename it.  Since that key (now with a different name) cannot be assessed using the key name (different) in the Edge settings, Edge can no longer make file associations to pdfs.

       

      Registry Edit to Remove Edge’s PDF File Association

      • Open the Registry Editor (Win Key + R – type in regedit and press Enter. OK the UAC box.
      • First, back up the Registry. File> Export.  Name the file RegBkupDate&Time (Name the file as a Reg Back up with the date and time the file was made) and save the file.  Registry backups really don’t take very long.
      • To go to a key in the left Navigation pane of the Editor window look at the key’s name (which is its location in the Registry). Click the > the left of the first branch listed in the name such as the > to the left of HKEY CURRENT USER.  This expands the branch and displays other branches to be selected.  Look for the second branch in the name (in the below case, SOFTWARE) and click the > to expand that branch.  Proceed through each branch in the name to reach the key indicated.
      • Go to this key:

      HKEY_CURRENT_USER\SOFTWARE\Classes\LocalSettings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages

      • Expand > Packages. There will be a long list of keys.  Scroll down to MicrosoftEdge_ XXXXX (Replace the X’s with numbers that are different for different versions.).  Mine is Microsoft.MicrosoftEdge_44.19041.1023.0_neutral__8wekyb3d8bbwe.  The key is that there are two other keys with names very similar (Microsoft.MicrosoftEdge.Stable).  You know you have the right key because you can expand it to show more branches.
      • Expand the above key. Click to expand the MicrosoftEdge  Click to expand Capabilities.  Click to highlight File Association.
      • With File Association highlighted, look in the right pane at individual keys. Under the Name column find .pdf and copy the long name in the data column for the .pdf.  For my version it is AppXd4nrz8ff68srnhf9t5a8sbjyar1cr723.
      • Now go HKEY_CURRENT_USER\SOFTWARE\Classes with the Classes branch expanded. Scroll down the branches under Classes and find the branch that exactly matches that listed for Edge above.  It must match exactly to have the correct one.
      • Once you find the correct Class branch, right click the branch name and select rename. Place the cursor at the end of the highlighted name and click to keep the original name.  Add an underscore (_) to the end of the original name and press the Enter key.  The name differs only by the added underscore, which you can remove if you want to undo this hack.
      • Close the Registry and you should be good to go. Be sure to assign a default app for PDFs now that Edge can’t do it any longer.

       

      HTH, Dana:))

      HTH, Dana:))

      • #2383958

        It appears that the entire registry key does not display with the rest of the text.  That first Registry key is

        HKEY_CURRENT_USER\

        SOFTWARE\

        Classes\

        Local Settings\

        Software\

        Microsoft\

        Windows\

        Current Version\

        AppModel\

        Repository\

        Packages\

         

        This registry edit will hold thru Edge updates and keep Edge from taking over PDFs.

        HTH, Dana:))

        HTH, Dana:))

      • #2384067

        Thanks for the detailed info. I will make an attempt at this solution. One question, though.

        Saving a copy of the registry is, obviously, quite easy. But, in the event that the registry is corrupted by my fumbling, how does one go about restoring it from the copy?

      • #2384078

        I’m into the registry but have a roadblock. There are two microsoft.microsoftEdge keys in my registry (see screenshot). I suspect the first one is a holdover from my previous attempts to uninstall Edge, but I don’t know. The second matches exactly your version in your computer. Advice?

        • #2384149

          Look at the FileAssociations  for each of the versions.  The name in the Data column is the name of a specific file association key listed in the Classes branch.

          If the names in the Data column (name of the file association key) is the same in both versions of Edge, then proceed with finding that key in the Classes branch and renaming it.  If the names in the Data field are different, then find in Classes branch and rename each key listed.  I suspect the key names are the same.

          Let those following this know what happens.   Let me know if you need further help.

           

          HTH, Dana:))

          HTH, Dana:))

    • #2383933

      As I once set the different application for opening PDFs, it remains as I set that, until another iteration of Edge is installed by updates on my PC.
      Ive seen that many times, but it never comes back until another update appears, unfortunatelly I cant tell how is it with 21H1, maybe its just bug in that build.

      I would definatelly stick to the @moonshine ‘s solution

      Dell Latitude 3420, Intel Core i7 @ 2.8 GHz, 16GB RAM, W10 22H2 Enterprise

      HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

      PRUSA i3 MK3S+

    • #2383943

      As I once set the different application for opening PDFs, it remains as I set that, until another iteration of Edge is installed by updates on my PC.

      The problem is, unless you’ve disabled automatic updates for Edge, “incremental” updates get installed at least weekly (more often if a major security problem is found) which resets the file associations.

      1 user thanked author for this post.
      • #2383949

        Thanks for the conribution.
        So the temporary solution for @PlantMan can be “disable automatic updates for Edge”?
        Is that “Receive updates for other Microsoft products” under the Windows update options?

        I know that there is also switch for enabling updates in Microsoft store (via three dots menu).

        Unfortunatelly I dont know which version we are talking about right now. Its not specified in the topic.

        Dell Latitude 3420, Intel Core i7 @ 2.8 GHz, 16GB RAM, W10 22H2 Enterprise

        HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

        PRUSA i3 MK3S+

        • #2383959

          He said it’s not being caused by updates, but Edge updates are not via Windows Update or Microsoft Store.

          1 user thanked author for this post.
    • #2384033

      Thanks for everybody’s interest in finding a solution to this problem. Unfortunately, as I have searched many times for a solution on the internet, and now in AskWoody, and not found one that works, I can only assume that the problem is the 500 pound Canary in the room, Microsoft, who will only change the situation when it suits them or when enough heavy hitters hit hard enough. You folks might as well move on to another subject, as this one seems to have hit a dead end. Thanks.

    • #2384058

      Auto updates for Edge can be disabled as follows.

      Disable the “Microsoft Edge Update Service (edgeupdate)” service by entering SC config edgeupdate start=disabled at an elevated command prompt

      Open Task Scheduler and disable/delete the following 2 tasks.

      • MicrosoftEdgeUpdateTaskMachineCore
      • MicrosoftEdgeUpdateTaskMachineUA

      Notes: you can then manually update Edge whenever you choose by going to “Help and feedback > About Microsoft Edge” and it won’t reset your file association settings.

      If you update to a new major version of Windows (i.e. 20H2 -> 21H1), the above Edge items will get reset back to their default settings.

      1 user thanked author for this post.
    • #2384068

      As I once set the different application for opening PDFs, it remains as I set that, until another iteration of Edge is installed by updates on my PC.
      Ive seen that many times, but it never comes back until another update appears, unfortunatelly I cant tell how is it with 21H1, maybe its just bug in that build.

      I would definatelly stick to the @moonshine ‘s solution

      I update Edge manually (after receiving Microsoft’s update mail).
      My default PDF app (portable Sumatra PDF) has stayed as default.

    • #2384178

      This Registry hack will remove the file association for pdfs from Edge, thus preventing Edge from hijacking pdf file association; which will leave the pdf file association to the app you have selected as default for this file type.

      I have followed DrCard’s instructions and hacked my registry. Very clear and easy to follow (thanks). I’ll report my success or lack thereof tomorrow.

    • #2384181

      There are versions of Edge for Linux and macOS. This discussion seems to provide some excellent reasons for never installing Edge on a Mac or a Linux PC. Even without knowing this, why would any Mac or Linux user want to do that? I still have not figured out that one.

      Ex-Windows user (Win. 98, XP, 7); since mid-2017 using also macOS. Presently on Monterey 12.15 & sometimes running also Linux (Mint).

      MacBook Pro circa mid-2015, 15" display, with 16GB 1600 GHz DDR3 RAM, 1 TB SSD, a Haswell architecture Intel CPU with 4 Cores and 8 Threads model i7-4870HQ @ 2.50GHz.
      Intel Iris Pro GPU with Built-in Bus, VRAM 1.5 GB, Display 2880 x 1800 Retina, 24-Bit color.
      macOS Monterey; browsers: Waterfox "Current", Vivaldi and (now and then) Chrome; security apps. Intego AV

    • #2384271

      Well, bad news this morning: DrCard’s registry hack did not fix the problem of MS Edge edging out anything else as PDF default program. I looked in the registry and everything is as I left it yesterday according to DrCard’s instructions. I set, yesterday, Adobe Acrobat Reader DC as my default PDF program. I shut down my computer overnight, and this morning MS Edge was the default. Perhaps there’s something unique about my setup. I suppose I could try simply not shutting the computer off (Dell XPS 8930); not sure I want to do that, though.

      Most of the time, it’s easy enough to open a pdf with my preferred program using “open with,” but that’s not available in all situations.

    • #2384275

      Try change the default PDF handler from within Adobe Acrobat Reader DC.
      Open AAR DC and go to the Menubar > Edit > Preferences > General > Scroll down to the bottom.
      Check ‘Tell me if Acrobat is not my default application’, then Select as default PDF handler > OK > Follow the prompts.
      This method is the same as I showed you earlier up the thread, but it is initiated from within AAR DC this time.

      • #2384281

        I’m pretty sure I’ve also done that before without a positive result, but for the sake of trying everything, I’ll do that. However, if hacking the registry won’t fix it, it seems highly unlikely that manually changing the default anywhere will. Thanks.

    • #2384297

      Hi PlantMan,

      There is something strange with your set up.  Most likely the dual Registry keys.  That hack works for me and a few others I gave it to.  Have not given up.

      Have you tried any other app besides Adobe to be the default app?  I’ve seen adobe cause a lot of problems in the past.  If no, then try another app like Chrome.

      While investigating this I discover what may be the real problem behind this… the plain .pdf file association is not registered with the kernel even if in Windows Default Apps it shows the .pdf and the default app.  To prove this:

      Open an elevated Command Prompt and enter assoc|more to see all file associations.  Keep hitting the Enter key to go down the alphabetical list and find .pdf.   Don’t see it?

      You can add the .pdf file association to the app you want here.  Find the PATH to the .exe file of the app you want to use for pdfs.  Example: “C:\Program Files (x86)\Google\Chrome\Application\chrome.exe” for installed Chrome.  Note that the entire PATH is in quote marks.

      At the command prompt enter:

      assoc .pdf=”C:\Program Files (x86)\Google\Chrome\Application\chrome.exe”

      Replace the PATH above with the PATH to the App  you want.

      This will register the .pdf and associate to the app you want.  This may make the other things you did work.

      If this doesn’t hold, then I’ll show you how to make that assoc command run every time you start your PC and thus rebooting will get the association you want back.

       

      HTH, Dana:))

      HTH, Dana:))

      2 users thanked author for this post.
      • #2384312

        Open an elevated Command Prompt and enter assoc|more to see all file associations. Keep hitting the Enter key to go down the alphabetical list and find .pdf.

        I followed these instructions and found this:

        .pdf=Acrobat.Document.11

        .pdfxml=Acrobat.pdfxml

        .pdx=AcrobatPDXFileType

        On my computer, I have Adobe Acrobat 11, Adobe Acrobat Reader, and Flexipdf. I use Firefox as my browser. AcrobatXI is my preferred program. I have, in the past, set each of these pdf programs as default and every time they have been changed to Edge. This is the “new” Edge I’m talking about.

        When this problem began, I began to think that, Acrobat 11 might not hold the default because it’s so old (I detest Adobe’s subscriptions and will not sign up). Even so, I still tried it without success. However, with the registry hack in-place, and the fact that Acrobat 11 is listed as the default, I’ve set it as default to see if it sticks.

        15 minutes later: the default has been set back to Edge!

        1 user thanked author for this post.
        • #2384334

          15 minutes later: the default has been set back to Edge!

          Microsoft doesn’t update that often.  Something else is doing this: a security app, a running script, a policy editor, etc.

          The hack I gave you works for me and others, but none I know that uses this hack uses Adobe.  Not sure if Adobe is part of the problem as it does have settings to make it the default app.  I still think testing a different pdf viewer and see if it holds as default with the prior settings.

          I assume the assoc|more output was while Adobe was entered as default app.  What does the assoc|more show for .pdf when Edge takes over?

          If the Assoc for the pdfs you posted are correct when Adobe is default, you use them to create a .bat file that can change the file association to Adobe by running the .bat file.  Let me know if you want help writing the bat file.

           

          HTH, Dana:))

          HTH, Dana:))

          • #2384340

            Good question DrCard about the assoc|more hack. I’m not positive what was default at the time, but I know it wasn’t Adobe Acrobat 11. Probably Adobe Reader.

            I have used the assoc|more hack to make FlexiPDF the default pdf program. I have restarted a couple of times and it seems to be holding. I’ll report tomorrow. If that holds, I may try the same hack with the full path of Adobe Acrobat 11, since I accidentally deleted that program and reinstalled recently. Got tricked by Adobe (long story).

            We’ll see whether I need the .bat file. Thanks for the offer.

    • #2384428

       since I accidentally deleted that program and reinstalled recently.

      That may explain all.  If the pointer to the app for a file association is not where the pointer indicates, Windows will select another app to use to open the file and make that app the default (like Windows own Open with and Edge is the first choice).  Adobe installations go deep like anti-virus software and if not cleaned properly before reinstalling you get duplicate pointers and one points to where the app is not there, making Windows choose Edge instead.

      Yes, enter the PATH to the Adobe Acrobat 11 . exe file in the assoc command.  With the other hacks in place, it should stay with Adobe.  Be sure to do the same assoc with the other pdf type files you displayed in your setup.  All those different type pdf files need to be associated with your Adobe Acrobat 11 exe file.

      HTH, Dana:))

      HTH, Dana:))

      • #2384435

        I have used the assoc|more hack to make FlexiPDF the default pdf program. I have restarted a couple of times and it seems to be holding.

        Well, it’s Wednesday morning and another day of computing controlled completely by Microsoft! The FlexiPDF fix did not hold; Edge is again in control of pdfs. I see no reason to try the Adobe Acrobat 11 fix, but I might as well have my preferred PDF program sitting there being ignored.

      • #2384454

        Since my last post, I discovered that I had entered the path information incorrectly into Command prompt. I left out the word “Application” (see image). I have since made the correction, this time with Adobe Acrobat 11. I’ll see what happens.

        Oops, sorry, that’s wrong. “Application” is not in the Adobe pathway. Since I can’t delete this post, just disregard it.

    • #2384462

      Hi PlantMan,

      Here is a little tip about copying the PATH correctly:

      Go to the .exe file’s location in File Explorer and hold the pointer over the .exe file to highlight it (don’t click it just hold the pointer over the file name until it highlights).   On the Home tab above click Copy path.  The PATH is now properly and correctly copied including adding the needed quote marks.  In the command where the PATH goes, press Ctrl + V to paste the PATH into the command.

       

      HTH, Dana:))

      HTH, Dana:))

      • #2384465

        Here is a little tip about copying the PATH correctly:

        Like I said previously, computers ain’t as simple as they used to be!

        Great tip, thanks. When I do that, I find I had the wrong path; the boldface part is what I missed: “C:\Program Files (x86)\Adobe\Acrobat 11.0\Acrobat\Acrobat.exe”

        Back to the computer to enter the correct path. Results pending.

      • #2384484

        Drcard, let’s take a different approach in solving the problem with Edge overtaking the default for pdfs. Can you give me a foolproof solution for hacking out Edge from doing anything on my computer? I don’t like it, I don’t want to use it as my browser (I use Firefox), and it’s causing me untold angst daily. The internet is full of non-working solutions for this; do you have one that works?

    • #2384606

      Fire up Process Monitor – Windows Sysinternals | Microsoft Docs.
      Set the filter to capture the registry setting that is being changed.
      Change the setting manually and then let it run for a while.

      cheers, Paul

      1 user thanked author for this post.
    • #2384621

      As I pointed out in my post #2383822

      Starting with Windows 10, Microsoft locked down the registry entries that control file associations by using a “self-generated” hash key. If you “manually” change the registry setting for .pdf files, you’ll get the following notification message within a few minutes of changing the entry .

      The only way to properly reset a file association in the Windows 10 registry is to use a 3rd party program like Set User FTA that can create a “valid” hash key for the change you want to make so Windows won’t detect the change and overwrite it.

      I’ve been successfully using Set User FTA for over a year to prevent Windows from taking control of my file associations (i.e. pdf, html, jpg, avi, txt, etc., etc.) and keeping my own personal preferences intact.

      1 user thanked author for this post.
      • #2384622

        Not sure what versions that applies to, because that is not the case in my situation.  I have been editing my Windows 10 manually for a very long time and all my edits remain.  I have never seen that notification from Windows.  Not sure if Plantman got that message even when his Windows change the association back to pdf.  That message and action looks more like a Group Policy or Script ran at start up.   Also Edge has not taken over my pdfs.

        My Windows is Home 21H1 Build 19043.1165 and manual edits to the Registry do work and stay on this setup.

        What version and build shows that message?

        Dana:))

        HTH, Dana:))

        • #2384625

          Home and PRO versions do not offer same options in Windows Security. Pro versions can do such things as PlantMan posted. Its some sort of security monitoring.

          Dell Latitude 3420, Intel Core i7 @ 2.8 GHz, 16GB RAM, W10 22H2 Enterprise

          HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

          PRUSA i3 MK3S+

    • #2384658

      If you “manually” change the registry setting for .pdf files, you’ll get the following notification message within a few minutes of changing the entry .

      I have never received a message of any sort when the default PDF program is changed to Edge, nor did I receive any messages when I applied Drcard’s registry hack or any of the other hacks I used.

      My Windows 10 Home version is 21H1 build 19043.1165. Perhaps in my strange case, it would be worthwhile to try the Set User FTA program. Any reason not to??

    • #2384824

      My OS is Win10 Pro 21H1 build 19043.1110 (didn’t installed the Aug KB5005033 update yet.) As for the issue with “manually” changing file associations in the registry…

      Contrary to what most think, the primary registry locations Windows uses to control what program opens what file extension is not in HKEY_CLASSES_ROOT but HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FileExts

      At that location you’ll see a list of all of Windows “default” file extensions, as well as any extension where you ever selected a “non-standard” program to open it, with up to 3 different subkeys per extension depending on the choices you made regarding that particular extension (the Windows “default” extensions will contain all 3 subkeys):

      • OpenWithList = you right-clicked an extension and selected one of the programs listed in the “Open with” option.
      • OpenWithProgids = you right-clicked an extension, selected “Choose another app“, checked the “Always use this app to open…” box, and selected one of the programs listed.
      • UserChoice = You opened Setting > Apps > Default > Choose default apps by file type and selected one of the listed programs for that file extension.

      If it exists, the UserChoice subkey will have 2 entries:

        Hash (with a meaningless string as its value)

        ProgId (with a value indicating which program is the default for that extension)

        Hash

      • Note: if it exists for a particular extension, the ProgId value shown under UserChoice in this section of the registry completely overrides all other registry settings as far as controlling what program opens which extension.

      In previous versions of Windows, there was no Hash entry and you could “manually” change the ProgId value to whatever you wanted with no problems. Windows 10 added a file association protection mechanism (that Hash value) to prevent direct changes to the UserChoice area of the registry.

      Here’s how it works…

      If an application or user changes an existing ProgId in a UserChoice registry key (to change the file association for a particular extension) without also setting a new “valid” Hash value, Windows 10 will detect the Hash value is no longer valid and trigger a reset back to the Windows default file associations and you’ll get that popup notification.

      The change back to Windows default file associations includes the pesky Edge taking over PDF’s and HTML’s problem.

      • Note: Windows default file associations include a lot more file types that just PDF’s and HTML’s.

      The Set User FTA program I referred to allows you to set you own personal program ⇒ file extension associations, including programs that are not listed in any of the standard Windows program selection drop-downs, while also creating a new “valid” Hash value for the changes so they don’t trigger the new file association protection mechanism.

      As I stated before, I’ve been using it on my PC for over a year and currently have 203 personal file associations it sets to prevent Windows from grabbing control of them.

      When I first started using SetUserFTA, I found I always had to go back and run it again after every Windows/Edge update. I fixed that by creating a batch file that runs during every boot up/restart to keep the file associations I want and not what Microsoft “thinks” they should be.

      BTW…

      The reason some of the suggested registry fixes for this issue don’t work is because Microsoft removed a lot of those registry entries in Win10 1809 or newer so they’re now simple ignored.

      1 user thanked author for this post.
      • #2384930

        I downloaded SetUserFTA, unzipped it, and attempted to start the program. It would not start. Apparently it’s only for Pro versions of Win 10; I have the Home version. Am I correct?

        • #2385000

          I can’t see any requirement for Windows Pro.
          What message do you get when you run it?

          cheers, Paul

        • #2385016

          By itself, SetUserFTA.exe doesn’t actually do anything.

          You either have to run it from a cmd prompt with command line parameters to set a specific file association (i.e. “SetUserFTA.exe extension progid“) where the parms would be something like .pdf AcroExch.Document.

          Or run it as “SetUserFTA.exe configfile” where “configfile” is a simple text file that lists each file association you want to make on a separate line in the following format extension, progid.

          You can use “SetUserFTA.exe get > CurrentFileAssociations.txt” to create a text file that lists all your current file associations and simple edit the appropriate lines for the extensions you want to change and use the result as your configfile.

          I initially used the get option to create a list of all the file associations on my PC and then extracted & modified the lines for the specific extensions I wanted to set to my own personal file association preferences and saved it as MyFileAssoc.txt.

          Then I created a single line batch file

          @SetUserFTA.exe MyFileAssoc.txt

          that runs on every boot/restart to prevent Windows from changing those preferences.

          BTW, the version.txt file that comes with the program explains all the above or you can visit the author’s blog at http://kolbi.cz/blog/?p=346

          1 user thanked author for this post.
          • #2385031

            BTW, the version.txt file that comes with the program explains all the above or you can visit the author’s blog at http://kolbi.cz/blog/?p=346

            I read the blog before I downloaded SetUserFTA. I now realize that we are into the realm of my ignorance. I can follow clear, simple, relatively jargon-free instructions and modify the registry, but the blog uses terms with which I am not familiar, and which would require too much explanation for simple instructions.

            I have a simple method for opening pdfs with Adobe Acrobat 11 from within File Explorer, and can kluge-together solutions for opening pdfs from other locations, such as emails.

            It sounds like that, with SetUserFTA, the problem is solved for those who know how. Thanks to everybody for attacking the problem. For Average Joe Me, I’ll deal with my Microsoft anger-management issues and move on.

            PlantMan

      • #2384941

        Thank you for that info.  It changes a lot I used to think I knew.  I did some testing on my Home version which has the same keys you refer to.   This is what I found:

        This User choice key does control the default app for that file extension.

        Changing the default app in the Default App settings changes this key and changes the hash value.

        Changing the file association with the assoc command has no effect on this key of the file’s association.  That’s a big change as I used that command for a long time.

        Since I have not had Edge take over as default for my PDFs, I assume the setting in Edge to download pdfs prevents Edge from taking over as default for pdfs.  Time will tell.

        Thanks, I learned a lot form you.

        Dana:))

        HTH, Dana:))

        • #2385019

          Yeah, there are a lot of things that use to work in older versions of Windows that, even though the programs/options for them still exist, just don’t work any more!

          My own PC’s have so many different tweaks applied to Windows to force it to work the way I want instead of what Microsoft wants that it usually takes me a few days to reapply them all when a new major version is released.

          Been into PC’s since way back (first one was a Healthkit H8 I built back in 1977) and have been very disappointed at the direction major OS’s have recently taken to try and “force” everyone onto a completely locked down OS.

          I understand they’re trying to protect “unaware” users from being hacked, but give me a break. They should make allowances for those of us who really do understand what we’re doing and provide us with a way to “unlock” the ability to customize our OS the way we want!

          Heck, I’d even be willing to accept a “if you unlock this OS, we can’t be held responsible for the consequences” clause in the license terms of such a product.

          1 user thanked author for this post.
    • #2385342

      Eureka! I think I may have accidentally stumbled upon the solution to my problem of MS Edge taking over the PDF default! Here’s what happened.

      Adobe Acrobat Updater kept popping up on startup and at other times. An internet search provided the solution, which seems to have worked. https://www.wintips.org/how-to-disable-automatic-update-in-adobe-reader-dc/

      While working through the steps of the Adobe Acrobat Updater solution, I noticed a possible solution to the Edge/PDF problem — disabling the MS <span style=”text-decoration: underline;”>Edge updater</span>. Here’s what I did:

      1-Search for and open the Task Scheduler app.

      2-In the Panel on the left side of Task Scheduler, click <u>once</u> on the “Task Scheduler Library” folder.

      3-In the Panel at the horizontal center of the screen, expand the “<u>Name</u>” column until the task names are all visible.

      4-There are two tasks that relate to Edge (the names mean nothing to me personally):

      MicrosoftEdgeUpdateTaskMachineCore

      MicrosoftEdgeUpdateTaskMachineUA

      5-Left click on each of the names and select “Disable”. I have no idea whether it’s necessary to disable both, but as far as I’m concerned, anything with the Edge name is my enemy and needs to be stopped!

      6-Close the Task Scheduler and restart the computer.

      I have not had MS Edge take over the PDF default since implementing this solution. However, I imagine I will have to do this again after Susan says it’s time to accept Windows updates. That’s not an issue for me, though, since it takes less than a minute to implement the solution which, hopefully lasts until the next update.

      Apparently, the reason the PDF default on my machine was being reset to Edge so frequently is explained by a comment in the “Triggers” column of the second Task listed above, indicating when to implement the task: “At 7:59 PM every day – After triggered, repeat every 1 hour for a duration of 1 day.

      Also, in searching through the Task Scheduler information, it appears to my unpracticed eye that there are multiple opportunities to turn off annoying Microsoft tasks. But that’s another story.

      I implemented this fix yesterday early evening and this morning it still holds.

      • #2385371

        However, I imagine I will have to do this again after Susan says it’s time to accept Windows updates.

        Edge updates are not via Windows Update though, so do you have any alternative plan to ever update Edge in the future?

    • #2385372

      Well, joy morphs into sorrow quickly in the Windows fixing world! My Task Scheduler fix didn’t work after all. Edge is back as the PDF default handler.

      To investigate, in the Task Scheduler Library, I clicked on each of the MicrosoftEdgeUpdate items shown in my previous post, and then clicked on the Trigger tab for each task and found that it is still shown as enabled, even though in the Library listing it still shows as Disabled. Clearly, for this task, Microsoft has given us a “dummy button” to play with.

      I have a question for someone who knows more about the Task Scheduler than I do. There is an option to Delete the Task Scheduler items for Edge. Is that something I can try without screwing up something else? I never intend to use Edge and would uninstall it if that would work, which it doesn’t.

      • #2385374

        You can uninstall Edge. See #2372696. Instructions are about halfway down the post.
        If you do this, please pay attention to the “Note of Caution,” because if done wrong it can cause problems with the Windows Update you do.

        • #2385456

          Removing Chromium Edge
          + Locate the Chromium Edge setup.exe file and note the Edge version number. C:\Program Files (x86)\Microsoft\Edge\Application\<current version of Edge>\Installer
          + Open an Admin Command Prompt and copy/paste this command to the default C:\Windows\System32 prompt. Substitute your current version of Edge for “89.0.774.68.”

          I have a question about this portion of your post #2372696

          After entering the info into the Admin Command Prompt, is the next step to hit “enter?” Sounds dumb, I know, but I have stated previously that I only enter the guts of Windows with detailed instructions.

           

      • #2385497

        You missed a step for properly disabling Edge updates.

        In addition to disabling those 2 scheduled tasks, you must also disable the “Microsoft Edge Update Service (edgeupdate)” by entering SC config edgeupdate start=disabled at an elevated command prompt.

        Once you add the extra step, Edge will no longer automatically update itself.

        You will still be able to manually update it whenever you choose by going to “Help and feedback > About Microsoft Edge” and it won’t reset your file association settings.

    • #2385425

      Edge is back as the PDF default handler.

      After uninstalling Edge you should block re-installation.
      You can still use Microsoft’s Blocker Toolkit

      The problems you have with switching default apps indicate some fundamental problems with your installed Windows 10.
      I would suggest running Windows 10 repair / clean install.

    • #2399937

      Chrome just did this same thing seemingly the day I updated to 10 21h1

    • #2510159

      If anyone is still having this problem of Microsoft Edge hijaking your default PDF reader in Windows 10 (Not sure about other operating systems?), then I may have a solution for you that has been working for me.

      Simply open Task Manager\Services and disable Microsoft Edge from starting up when Windows boots. So far my PDF reader stays the same every time I boot up windows, and doesn’t change in between viewing PDFs.

      Hope this helps

    Viewing 29 reply threads
    Reply To: MS Edge takes over pdfs

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: