News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • MS Word Document Broken Links

    Posted on Casey H Comment on the AskWoody Lounge
    Viewing 15 reply threads
    • Author
      Posts
      • #2223324 Reply
        Casey H
        AskWoody Plus

        Greetings All –

        I have a MS Word document that I’ve had for a few years now.  It contains numerous Biblical Chapter & Verse links to an online Bible source.  Recently (first noticed it a few days ago), clicking on any of the links gives the message, “This operation has been canceled due to restrictions in effect on the computer.  Please contact your system administrator.”

        This problem only occurs on my laptop which has Office 2010.  My main PC has Office 2016, and there the links work perfectly. Both computers have the latest version of WIN 10 1909.

        I have tried pasting the content into a new document and saving it to a new location.  The document is kept on both PCs, and my laptop syncs the document with Google Drive.  If I save the problem file to pdf, the links work fine.  The problem seems confined only to Word 2010 on my laptop. There are a few online hints that point to Outlook as the culprit.  I use Outlook on my main PC as an email handler but not on my laptop. Other hints pointing to deleting certain registry entries or returning certain Group Policy settings to not configured were investigated, but turned out to be non relevant.  I have also added my file storage area as a “Trusted Location” in the Trust Center.  I suspect I may have accidentally altered one of my security settings but have no clue as to which.  I also thought that perhaps the February Windows and Office updates might have hosed something, but I installed the March updates this morning, and the problem persists.

        Any help would be appreciated.  Thanks

        Casey H.

      • #2223341 Reply
        b
        AskWoody Plus

        I don’t think it’s connected with Outlook, other than that the same error appears when clicking links in Outlook for some people just as yours fail in Word.

        The most likely explanation is that some sequence of events (such as uninstalling Google Chrome) has left you without a default browser being set correctly.

        So check at Settings, Apps & features, Default apps, Web browser and click to select your normal web browser.

        If that doesn’t work, let us know which browser is normally used on that laptop.

      • #2223491 Reply
        Casey H
        AskWoody Plus

        Thanks for the input.  I have not uninstalled any browser.  Until about a month ago the only browser I had was Edge.  Then something happened (can’t remember what), and I installed Firefox, which I made my default browser. I don’t know if my problem came about before or after adding Firefox.  In response to your reply, I clicked on “Reset to the Microsoft recommended defaults.”  I then tested the document again, and the problem remains.

      • #2223535 Reply
        Vincenzo
        AskWoody Lounger

        I would suggest doing a repair on Office, done from Control Panel    Add/Remove

      • #2223547 Reply
        Casey H
        AskWoody Plus

        That was a good idea–unfortunately no dice. The repair tool ran successfully, but the problem remains.  I also ran the system file checker which came up empty.  Looks like definitely a problem with Office as I get the same message with other Word files as well as Excel.  I’m hesitant to reinstall Office as the last time I did that, I had a struggle with the number of detected installations.  This is the only computer with said installation, but it has been on other machines in the past, never on more than what is allowed.  I’m also hesitant to uninstall Firefox as it always takes a lot of time to reconfigure No Script.

        • #2223554 Reply
          b
          AskWoody Plus

          In response to your reply, I clicked on “Reset to the Microsoft recommended defaults.”; I then tested the document again, and the problem remains.

          Open Command Prompt as Administrator and enter each of the following commands separately:

          REG ADD HKEY_CURRENT_USER\Software\Classes\.htm /ve /d htmlfile /f
          REG ADD HKEY_CURRENT_USER\Software\Classes\.html /ve /d htmlfile /f
          REG ADD HKEY_CURRENT_USER\Software\Classes\.shtml /ve /d htmlfile /f
          REG ADD HKEY_CURRENT_USER\Software\Classes\.xht /ve /d htmlfile /f
          REG ADD HKEY_CURRENT_USER\Software\Classes\.xhtml /ve /d htmlfile /f

          1 user thanked author for this post.
      • #2223569 Reply
        Vincenzo
        AskWoody Lounger

        Perhaps you could narrow it down to whether it is Word or your browser, by changing the default browser to a different browser.

      • #2223747 Reply
        MrJimPhelps
        AskWoody_MVP

        Type EDIT GROUP POLICY, and drill down through the group policy settings on both computers. I believe you will find a difference between the two computers which is blocking you on the old computer. (Unfortunately I am unable to do this myself right now to try to find the setting you need to look for.)

        The tip-off that there is a Group Policy setting causing this is your error message: “This operation has been canceled due to restrictions in effect on the computer. Please contact your system administrator.”

        If that doesn’t fix things, then perhaps there is a setting in your online Bible software. If you log into that site (with a username and password), then there may be a setting you can adjust. If not, then you might need to call their tech support dept for assistance.

        Group "L" (Linux Mint)
        with Windows 8.1 running in a VM
      • #2233259 Reply
        Casey H
        AskWoody Plus

        I’ve changed browsers–no luck.  The Bible site is just that.  There’s no account, username, or password.  I went into the Group Policy Editor and changed all settings to not configured and rebooted.  Problem still exists.  I also thought it might be something with the synch to Google Drive, so I took the file directly from my desktop’s storage, copied to a flash drive, and put it on my laptop.  Still no workie.  I haven’t tried those registry keys yet.  Kind of busy right now, but I’ll try that next week.  Thanks for all the input.

        Casey H.

      • #2233263 Reply
        Alex5723
        AskWoody Plus

        I have a MS Word document that I’ve had for a few years now.  It contains numerous Biblical Chapter & Verse links to an online Bible source.  Recently (first noticed it a few days ago), clicking on any of the links gives the message, “This operation has been canceled due to restrictions in effect on the computer.  Please contact your system administrator.”

        Please check this solution :

        https://www.slipstick.com/problems/this-operation-has-been-cancelled-due-to-restrictions/

      • #2240689 Reply
        Casey H
        AskWoody Plus

        Got around to installing the recommended registry entries, all of which said were successfully installed.  It still doesn’t work.  The only thing I haven’t done yet is turn on Internet Explorer and fiddle with its recommendations.  I have never used IE on this computer.  I turned it off the day windows was installed and used Edge exclusively until I installed Firefox a month or so ago. To this point I have never uninstalled any browsers and have alternately selected Edge & Firefox as defaults in trying to figure this out.  I really don’t know when this problem started as I rarely work with Office documents on this computer, and they are the only ones that are affected.  I can save the troublesome file as a pdf, and the links work perfectly.  What’s left to try?

        Casey H.

      • #2240699 Reply
        Vincenzo
        AskWoody Lounger

        I can save the troublesome file as a pdf, and the links work perfectly. What’s left to try?

        I would uninstall/reinstall Office.

      • #2240703 Reply
        Alex5723
        AskWoody Plus

        The only thing I haven’t done yet is turn on Internet Explorer

        IE is part of Windows OS not to be turned off. Turn IE on again even if you don’t use it.

      • #2240742 Reply
        b
        AskWoody Plus

        Got around to installing the recommended registry entries, all of which said were successfully installed.  It still doesn’t work.

        Did you restart Windows after adding the registry entries?

        You need to restart Windows for the change to take effect.
        https://www.slipstick.com/problems/this-operation-has-been-cancelled-due-to-restrictions/

      • #2241147 Reply
        Casey H
        AskWoody Plus

        I’ll be darned.  I turned IE 11 back on in Control Panel’s “Turn Windows Features On or Off” and the links are now working.  This seems very strange.  I have IE turned off on my main computer as well, and said links are not affected on it.  Both have WIN 10 Pro, 1909 with March updates.

        In regard to not supposed to shut IE off, I was under the impression that either Fred, Woody, or Susan had recommended this because of IE being so full of security holes, and that even if not used, an unpatched IE made the computer vulnerable.

        At any rate, I guess the problem is solved.  Thanks to all who weighed in.  It’s greatly appreciated as always.

        Casey H.

        1 user thanked author for this post.
      • #2263109 Reply
        anonymous
        Guest

        Here is an alternative solution to enabling or turning on unsafe IE11.  It’s so simple that I’m surprised no one else posted it, unless I missed it.  Select the link w/ the right mouse button & choose “Copy shortcut”.  In your browser, put your cursor in the address bar, press the right mouse button & choose Paste.

        1 user thanked author for this post.
      • #2269354 Reply
        Casey H
        AskWoody Plus

        Indeed that works quite nicely.  A great solution if the fundamental issue had never been resolved,  Now that everything is normal, I’m just a mouse click away.

        Casey H.

    Viewing 15 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: MS Word Document Broken Links

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.