News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • My computer won’t go into sleep.

    Posted on Lil88reb Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 My computer won’t go into sleep.

    Topic Resolution: Not Resolved
    • This topic has 31 replies, 7 voices, and was last updated 1 week ago.
    Viewing 27 reply threads
    • Author
      Posts
      • #2232919 Reply
        Lil88reb
        AskWoody Plus

        I have checked the Power & Sleep in Settings. They are what they have always been. I opened the case about 2 weeks ago and blew the motherboard and fans off. After that I noticed the computer was not going into sleep. If I click Start/Power and then Sleep, the computer goes to sleep just fine.

        Anybody ever run into this before????

      • #2233129 Reply
        anonymous
        Guest

        Please run winver or open Settings > System and click on About to tell us which specific version are you using at this time. The Version and OS build numbers are important to know.

      • #2233148 Reply
        Pluto
        AskWoody Plus

        If you run powercfg -requests from an elevated command window, it should give you a clue as to what is preventing the system from sleeping.

        • #2264838 Reply
          WSstarvinmarvin
          AskWoody Lounger

          I used both command line and Windows Powershell to run the command powercfg -requests . Each one provided the same result. May we assume the result “none” (in each category shown below in my screenshot) means that the “usual suspects” listed are not preventing the machine from entering Sleep mode?

          Windows-10-Powerconfig-requests

          Attachments:
      • #2233279 Reply
        Lil88reb
        AskWoody Plus

        Windows 10 Pro

        Version 1909

        OS build  18363.657

        • #2241297 Reply
          anonymous
          Guest

          Okay there are no sleep issues listed as being repaired for this Windows 10 build. Powercfg -a will list all available sleep modes, the long supported Standby (S3) and a few other essential types should be present.

          This may not be your issue but Microsoft has fixed a few bugs relate to sleep; If you are using Microsoft Defender Advanced Threat Protection Auto Incident response, it was listed as causing prevention of sleep in a newer build. The repair for this bug is inside one of the C/D week variety updates.

      • #2233282 Reply
        Lil88reb
        AskWoody Plus

        If you run powercfg -requests from an elevated command window, it should give you a clue as to what is preventing the system from sleeping.

        Ran powercfg -requests and it indicated a Mini Tool program. Uninstalled same, but still will not go to sleep.

      • #2233566 Reply
        Pluto
        AskWoody Plus

        >Uninstalled same

        OK – what does powercfg -requests now say? Anything other than none, none, none indicates that something is ‘holding the door open’.

      • #2233575 Reply
        Lil88reb
        AskWoody Plus

        All 6 replies are “None”

      • #2233581 Reply
        Pluto
        AskWoody Plus

        Then, in all likelihood, there’s a setting somewhere that isn’t right. Check everything again; sometimes these things change themselves by magic! Likewise, check again that the system really does go to sleep when so commanded from the desktop.

        See if this can be made to put the machine to sleep.

        If powercfg -requests is negative and the system really is capable of sleep, there isn’t a lot left.

        I think that’s all I can offer to help.

      • #2252558 Reply
        Lil88reb
        AskWoody Plus

        I’m not sure the hard drives aren’t shutting down, I think the fans are not going to sleep because that is what I hear running all the time. I don’t see hard disk activity going on by the light on the front.

      • #2252651 Reply
        Lil88reb
        AskWoody Plus

        I went a few days without replying because sleep just started working. I got about 6 days of normal, then it went back to not going to sleep. I didn’t touch or change a thing during that working time. Still goes to sleep from the desktop and stays asleep until I wake it with the mouse. Windows Home Server won’t even wake it for it’s nightly backup.

        • #2252721 Reply
          anonymous
          Guest

          Did you notice any odd warnings or errors in Event Viewer?

      • #2258151 Reply
        Lil88reb
        AskWoody Plus

        For some reason, sleep seems to be working right now. Thanks for everybody’s input.

      • #2261784 Reply
        Lil88reb
        AskWoody Plus

        This is annoying. I have 3 desktops close to 9 yrs. old and they all went to sleep until a couple of months ago. Sleep works as it should for several days and then I have to put it to sleep with the power button in the start menu. I got tired of fighting this problem, so I cloned the SSD  to another new SSD and put it into one of the other identical computers. Now that computer has the same problem. I don’t know if this is a problem that started with a Microsoft Update or not. Microsoft tech. tried to solve the problem remotely originally and it worked for about a day. Both computers are ASUS M4A88-TD3’s and now have the same problem.

        I have disabled all wake timers, but it’s not something that is waking the computers, they just don’t go to sleep in the first place. If I put the the computers to sleep with the power/sleep button, they stay asleep until wake them with the mouse.

        Again, this computer had the same sleep settings for years and worked fine until a couple of months ago.

        Any further suggestions?

        • #2262190 Reply
          Paul T
          AskWoody MVP

          If the sleep button works then it is a configuration problem, maybe.

          Do you move the mouse after selecting sleep? Try turning off wake with mouse – I only ever use the power button to wake a machine.

          cheers, Paul

      • #2263524 Reply
        Lil88reb
        AskWoody Plus

        Just to clarify, these computers won’t go to sleep after the 30 minute set time. All wake timers are off. I have turned off both the mouse and keyboard, so they are not keeping the computers from going to sleep at the 30 minute time. If I put the computers to sleep with the power/sleep button, they stay asleep until I move the mouse. So this is a problem of not going to sleep at the scheduled time. If I put it to sleep, it stays asleep for days at a time.

        And again, Microsoft worked on the problem remotely for almost an hour and still couldn’t fix it.

      • #2263528 Reply
        Paul T
        AskWoody MVP

        It’s as if the “put me to sleep” process is preventing the computer sleeping because it is running.

        Have you reset all power configurations and then tried again from scratch?

        cheers, Paul

      • #2263573 Reply
        Lil88reb
        Guest

        Thanks for the thought, but the computer is always running before the set time to go to sleep, so …

        It had been reset to different times many times and Microsoft did a custom setting that did not work either

      • #2263579 Reply
        Lil88reb
        AskWoody Plus

        Thanks for the thought, but the computer is always running until it reaches the set time to go to sleep.

        The configuration has been checked and/or changed many times. Microsoft also did a custom setting that did not work either. I realize some of the Microsoft techs just read and act from a script and are not experts. My brother was a Microsoft System Engineer but is no longer with us, so I am on my own. Microsoft techs used to call him when they reached their wits end. I wish I could do that now.

      • #2263802 Reply
        anonymous
        Guest

        You may try these commands:

        1. powercfg /LASTWAKE
        2. powercfg /SLEEPSTUDY
        3. powercfg /ENERY

        Also you may try replacing your mouse. Some mouse are too sensitive so continuously scans and this prevents sleep.

        You may want to take a look at this thread:
        https://superuser.com/questions/532993/why-wont-my-computer-go-to-sleep-automatically

         

      • #2264177 Reply
        Wayne Mineard
        AskWoody Plus

        A similar thing happened to me. After blowing out the machine, when I try to put it to sleep manually or let the computer through settings, it shuts down instead. Windows 10 Home Ver. 1903, Build  18362.778.

      • #2264565 Reply
        Paul T
        AskWoody MVP

        After blowing out the machine

        Meaning?

        What changed between sleeping and not sleeping? Did you install Windows updates etc?

        cheers, Paul

      • #2264673 Reply
        Wayne Mineard
        AskWoody Plus

        Blowing out meaning I opened it and used canned air to clean the inside, fans, etc. Previously, I could put it to sleep by using the Start>Power>Sleep option. Now (after cleaning) when I do that it shuts down instead of going into sleep mode. Funny thing is that I can put it in sleep mode by pushing the power button down. I just changed that in Settings.

      • #2264711 Reply
        genej101
        AskWoody Plus

        I may know what is wrong. If you have an HP machine. I did NOT install the May updates yet, but this started happening to me this week. I’d put the machine to sleep and it’d wake right back up. I found an article online that explained what might be happening. I found the issue. I have an elevated command prompt on my desktop (some thing Fred Langa suggested years ago, maybe from the old Langlist). The article is here: https://homecentez.com/how-to-fix-windows-wont-stay-asleep/

        I ran the powercfg /lastwake command and found that it what woke it was Realtek PCIe GBE Family Controller. I followed the suggestions to disable it and the problem disappeared. What I’m annoyed about now is that I ran powercfg /devicequery wake_armed, found the device was gone (there could be other issues according to the article but mine was immediate), so the problem is solved, but the article suggests finding a new drive. I have an extended warranty on this machine, HP isn’t providing live chat, so you have to call them, I’ve been on hold for nearly four hours (horrible music). What I want to know is if it is okay to leave it disabled (not allowed to wake the machine) or not. I can’t get to HP to find out. Anyone here have an idea? You CAN stop the machine from waking, or find out what is waking it through this article. But fixing it is the question now. Thanks for any ideas and I hope the article helps with figuring out what is waking your machine. After all this time, DOS commands still do more than anything in terms of diagnosis. Win10 is supposed to be a new operating system, but it is still a shell over DOS. Geez.

      • #2264842 Reply
        WSstarvinmarvin
        AskWoody Lounger

        In case anyone missed it, when you run powercfg -requests the desired result is “none” as shown in the screenshot below. In this case I used Windows Powershell (Administrator) which gives the same result as command line:

        Windows-10-Powerconfig-requests

        Attachments:
      • #2274327 Reply
        Lil88reb
        AskWoody Plus

        This problem started on my computer with a Samsung SSD, although it had been going to sleep at the set time. My second computer had a regular hard drive and I decided to switch to an SSD. I cloned this new Samsung SSD from the first computer and installed in the second computer. This new SSD wound up doing the same thing as the SSD in my first computer, would not go to sleep without going to power/sleep.

        I began to think it had something to do with the Samsung SSD’s, so I put the original hard drive back in and sleep worked fine. I moved this hard drive into the first computer that had the original SSD. This computer went to sleep at the set time. That kind of led me to believe that there was something not right with the Samsung SSD’s.

        Went back to using the Samsung SSD’s in both machines. At this point, both computers periodically go to sleep at their set times, but 80% of the time I have to PUT them to sleep.

        There have been some suggestions that maybe the mouse get moved or is too sensitive. Again, it’s not something waking the computer. When it either goes to sleep or I put it to sleep, it stays asleep until I wake it. It will stay asleep for days and only wakes when I start it.

        • #2275057 Reply
          anonymous
          Guest
          1. Have you seen in the Advanced power settings for the current power plan if the hard drive is set to sleep?
          2. Years ago there were reports of problems with the Samsung Magician program, are you using any Samsung management software?
          • #2275068 Reply
            anonymous
            Guest

            Forgot to add the citation links for the first question, and the second.

      • #2274877 Reply
        anonymous
        Guest

        Is there a firmware update available for your SSD?

      • #2275012 Reply
        Lil88reb
        AskWoody Plus

        Firmware is up to date.

        • #2275048 Reply
          anonymous
          Guest

          OK, just checking. We have a Samsung 840 EVO from several years ago. It’s installed in a Lenovo Ideapad Y500 laptop running Windows 8.1. There were a couple of reported problems with the 840 EVO from some users. Putting Windows in Hibernate mode caused some computers to not wake up, and an extended power off  period (of weeks or months) sometimes resulted in data loss on the drive. Out of caution, we installed an update (a firmware update i think), and we’ve never experienced any problems.

      • #2275011 Reply
        misty914
        AskWoody Lounger

        No firmware update. It’s up to date.

      • #2275081 Reply
        genej101
        AskWoody Plus

        I’ve the same issue. Solved it by disabling a driver – details above. I can get my machine to stay asleep now. But for it to go to sleep requires me putting it to sleep. There are several other things I’d like to do that too but this pc isn’t one of them. :^)

      • #2275838 Reply
        Lil88reb
        AskWoody Plus

        Thanks, but you didn”t have the same problem. As stated many times above, my computers wont go to sleep. I have to put it to sleep and it never wakes up until I wake it up.

    Viewing 27 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: My computer won’t go into sleep.

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.