News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • My data drive is not accessible!

    Home Forums AskWoody support Non-Windows operating systems Linux – all distros My data drive is not accessible!

    Viewing 2 reply threads
    • Author
      Posts
      • #2370926
        MrJimPhelps
        AskWoody MVP

        I am running Linux Mint 20.1 xfce, and I tried to save something to my data drive (a 4TB hard drive), but it didn’t show in the list of drives!

        I suspected Timeshift was the culprit, because I set it to back up to the data drive (and I also read that in another post somewhere!). So I went into Timeshift, and under Schedules I unchecked all scheduled backups. I then rebooted. Lo and behold, my data drive was back!

        Since this is the only time this has ever happened (even though Timeshift has been doing backups for a couple of weeks now), my guess is that it was doing a backup when I tried to access my data drive, and somehow it co-opted the data drive during the time it was doing a backup.

        I can’t find any way to tell Timeshift to do its backups only at certain times of the day (e.g. at 3 in the morning, when I am asleep), nor am I certain that that will even fix the problem; so for now I will leave Timeshift off.

        Group "L" (Linux Mint)
        with Windows 8.1 running in a VM
      • #2370942
        DrBonzo
        AskWoody Plus

        On Mint 19.2 Cinnamon I have Timeshift set for Daily, Keep 5. I’ve found that if I want Timeshift to make backups at 2:00 am, all I have to do is create a manual Timeshift backup at 2:00am and from then on it will do it’s daily backup at 2:00 am.

        There is a way to schedule using something called cron (I think), but I don’t know how to do it.

        1 user thanked author for this post.
      • #2371516
        Ascaris
        AskWoody MVP

        I am running Linux Mint 20.1 xfce, and I tried to save something to my data drive (a 4TB hard drive), but it didn’t show in the list of drives!

        Was the volume (or volumes) on the drive mounted at that point?

        The ‘disks’ utility will show all of the drives that are detected on the system even if they are not mounted. Its full name is the Gnome Disk Utility, but it’s just called ‘disks’ in the UI.

        I suspect a reboot would have helped even if you did not change the Timeshift setting. It got unmounted somehow, I think… perhaps an accidental click on an unmount button somewhere?

         

         

        Group "L" (KDE Neon Linux 5.22.3 User Edition)

    Viewing 2 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: My data drive is not accessible!

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.