Woody Leonhard's no-bull news, tips and help for Windows, Office and more… Please disable your ad blocker – our (polite!) ads help keep AskWoody going!
Home icon Home icon Home icon Email icon RSS icon
  • My experience trying to upgrade and update Win 10 in a VM

    Posted on Ascaris Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 10 My experience trying to upgrade and update Win 10 in a VM

    This topic contains 9 replies, has 5 voices, and was last updated by  Ascaris 4 months ago.

    • Author
      Posts
    • #202952 Reply

      Ascaris
      AskWoody MVP

      I decided to test the Windows 10 upgrade thing a couple of weeks ago.  I’d heard (well, read) some people saying that the free upgrade, which extended well beyond the official one-year period in practice, had finally ended, and that upgrades were no longer automatically activating.  Others reported it still worked.

      I decided to test it on one of my VMs on my Core 2 Duo laptop, running Windows 7 as a guest (Linux Mint 18.3 host).  The Windows 7 guest is activated, so if the free upgrade works, it should show 10 activated too.

      I grabbed my old .ISO (the same one I used to perform the initial upgrade when I tested 10 in 2015, which means it’s for 10240/1507) and upgraded it (on a clone of my 7 VM; I am not giving up 7!).  It upgraded without any problems, and it shows that it is activated in 10.

      So far, so good.  So what? (Great album!)

      It immediately installed a few updates for 1507, then began downloading the update to 1803.  It failed the first time, as I did not have enough room in the VM’s virtual hard drive.  I tried plugging in my external HDD and pointing Windows Update at it, and it seemed to be working, but it didn’t (the details of why are fuzzy).

      I increased the size in the VM for 10, and let it try again.  It began to install the upgrade, but then something happened on the reboot and it reverted to 10240 again.  I hit the check for updates button to try again, and this time it downloaded and rebooted into the “This will take a while, don’t turn off your computer” screen.  It froze at 7%… no flashing of the virtual HDD light, no sign of activity, the little spinner thing onscreen frozen, the CPU usage pegged at 100%, with the laptop fan whirring noticeably.  After a few hours of waiting, I reset the VM.

      It rebooted, then went to “reverting to your previous version of Windows.”  And then it froze once again.  After a long wait to make sure it was really frozen, I reset it.

      It rebooted, and went to a black screen.  Same deal… no HD activity, CPU pegged, no signs of actually doing anything forever.  Reset it again, after dutifully waiting in case it was really doing something.

      The next time it said “reverting to your previous version” again, and this time it did actually revert to my previous version.

      Windows 10 did eventually come back up, still at 10240.  I checked for updates again, and it found the upgrade to 1803 again, so I let it try again.  The second try went about like the first… froze at 7%, then froze again, then again, and then it gave up and reverted to 10240 again.

      Now it says that it’s up to date when I check for updates, in 10240.  It installs the frequent updates for Defender, and that’s it.  It does not find the 1803 update anymore.

      Now, I know there are ways I can force the issue with updating (using the media creation tool to make an .ISO, then upgrading in place), but one of the points of this exercise was to see how the experience looks to a regular user, and it’s not good.  It’s telling me that a version of Windows 10 that gets no more security updates is “up to date,” which it most certainly is not.  It already tried the 1803 update and concluded it’s not gonna work, I guess, but it’s not smart enough to try to update to a 16xx or 17xx first and to go from there to 1803.  Given that you can’t get ISOs of those versions officially anymore, I would guess that MS considers them to not exist, so it’s update all the way or nothing.

      It’s still claiming 10240 is up to date, even today, after this month’s patches are out.  It downloaded and installed the MSRT and the Defender update, and that’s it.

      Group L (Linux): KDE Neon User Edition 5.14.3 (based on Ubuntu 18.04) + Windows 7 in Virtualbox VM

      1 user thanked author for this post.
    • #202953 Reply

      PKCano
      AskWoody MVP

      Did you try using wushowhide and hiding 1803 and see if it will offer you 1703 or 1709? I’d try the closest version first instead of going for the long run.

      Hope you backed up the original VM so you can continue to start from scratch?

      • #202971 Reply

        Ascaris
        AskWoody MVP

        PKCano,

        I tried using wushowhide, but it reports that there are no updates available to hide or that are hidden.  It simply seems to be pretending that 1803 doesn’t exist!

        I do have the original Windows 7 VM image and a copy from when the Win 10 upgrade had just completed.  I’m going to try hiding 1803 and see if it offers one of the older ones.  Still, I would like to know what a regular person is supposed to do in this situation if the virtual installation was an actual bare-metal one, and where the person is not especially technically oriented. MS is telling me that it’s all up to date; I know better, but would a regular person guess that when it said that, it really meant it was a couple of years behind in updates?

        Group L (Linux): KDE Neon User Edition 5.14.3 (based on Ubuntu 18.04) + Windows 7 in Virtualbox VM

        1 user thanked author for this post.
        • #203002 Reply

          PKCano
          AskWoody MVP

          MS is telling me that it’s all up to date; I know better, but would a regular person guess that when it said that, it really meant it was a couple of years behind in updates?

          Well, 1607 is up to date – it is out of support and there are not more patches. You have the latest, therefore up to date. Also, so not a couple of years behind in patches, b/c later versions are not patches for 1607, but a completely different version.

          Try starting with the base 1607 – it was offered 1803 (that failed). This time, try hiding 1803 with wushowhide before it tries installing and see if it offers the earlier versions.

          • #203007 Reply

            Ascaris
            AskWoody MVP

            1507 is the base, not 1607.  I’m attempting your idea of hiding 1803 and seeing what it does now.

            I know where you’re coming from with the idea that “your system is up to date” referring to 10240, but most people don’t have any idea what 10240 is, or 1507 in the other nomenclature style.  They just know it’s Windows 10, and “up to date” should mean just that.  If that interpretation was really what MS intended, it would not have tried to upgrade three or four times before it came to the conclusion that it was up to date, and the entire thing wouldn’t force upgrades either if it really was a separate product.  MS is playing loosey goosey with the usual definitions, considering each build of 10 a separate product when it benefits them, but not when it suits them better to consider it one unified product (“the last version of Windows ever”).

            Personally, I already know 10240 is outdated.  I’m more concerned for regular, reasonable people and what they would be led to believe about their state of security when they read “Your PC is up to date.”  MS tells people to upgrade to 10 to get the best in security, in part because Windows 10 is always up to date, and here I have a PC (as far as MS is concerned, it’s a PC) running Windows 10 that would have continued to be updated for security for another 1.5 years if I had left it on 7, but with Windows 10, has been out of security support for over a year now, which they are not likely to understand.  10’s not unsupported, right?  And besides, it says it’s up to date!

            To me, it seems like the same kind of sophistry that they used with the GWX adware back when 10240 was new.  Maybe it’s just more Windows 10 dysfunction, but after all the things they’ve done since the beginning of the 10 era, I can’t help but notice that it bears a remarkable resemblance to what came before.

            Group L (Linux): KDE Neon User Edition 5.14.3 (based on Ubuntu 18.04) + Windows 7 in Virtualbox VM

            1 user thanked author for this post.
            • #203009 Reply

              PKCano
              AskWoody MVP

              In this charade MS is playing, the player has to guess many times what the mime is acting out before the real answer can be gleaned.

              The problem is, MS keeps changing the answer, so the mime changes the act, and it becomes almost impossible for the player to guess the meaning.

              1 user thanked author for this post.
    • #202954 Reply

      BobbyB
      AskWoody Lounger

      @ascaris caught this a few years back, I know it pertains to Win8->8.1 and might not be the case now with Win10 or VM’s running in Virtual Box, Paralell’s etc.
      https://social.technet.microsoft.com/Forums/windows/en-US/b9ca72ab-cdc3-4ae8-be6f-1ce9cb18ffb6/upgrading-windows-8-to-81-native-vhd-boot?forum=w8itproinstall
      I use “Native Boot” VHD’s +VHDX’s extensively a whole lot easier and safer than partitioning, although creating a partition is painless enough I suppose these days. May be they fixed it with Win10?

    • #202956 Reply

      SkipH
      AskWoody Lounger

      Ascaris wrote: “Given that you can’t get ISOs of those versions officially anymore…”

      Please see a post at #182885 for info on a utility that links to ISO images directly from Microsoft servers.

      The current version of the utility is 6.10. I just ran it and checked for a few ‘older’ versions of Win10x64, and there seems to be possible links to all previous versions.

      This utility has been discussed before on AskWoody, and I have personally used it to get some ‘back’ versions, or to download an ISO of the most current version (at the time it was ‘new’), skipped the MS media creation app, as it seems to fail more than it works, won’t even download the most ‘current’ version most of the time, at least for me.

    • #202970 Reply

      ViperJohn
      AskWoody Lounger

      Given that you can’t get ISOs of those versions officially anymore.

      After MS stopped using Digital River for ISO hosting and download I have used the “Windows ISO Downloader” MANY times to get virgin Win7 and Win10 (all versions are available) ISO files from MS TechBench.  It beats the heck out of MS’s clunky Media Creation Tool by light years!!!

      https://heidoc.net/joomla/technology-science/microsoft/67-microsoft-windows-and-office-iso-download-tool

       

    • #203417 Reply

      Ascaris
      AskWoody MVP

      As PKCano suggested, I tried using wushowhide to hide the update to 1803 in my VM.  With it hidden, it reports “Your PC is up-to-date.”  It doesn’t offer updates to any other build that might ease the transition from 10240 (1507).  I tried searching for updates a few times, and letting Windows sit there for a few hours in case it needed more time, but it never found any more updates except more definition updates for Defender.

      I went to the MS site in that VM, and that page had a banner at the top (detecting the useragent, no doubt– this was in Firefox) pointing me to the upgrade assistant download to help get to 1803.  I downloaded it and tried it, and it did recognize 1803 as available.  I had it start the upgrade, but it didn’t quite work.  It downloaded and did the “installing” bit from Windows, but it didn’t do anything after that.  When I rebooted manually, it just came up in 10240 as if nothing had changed.

      I ran the upgrade assistant once more, and it repeated the whole thing.  This time, it told me it wanted to reboot at some point in the future.  I told it to go ahead and do it now, and it booted to the “Working on updates” screen.  As it had several times before, it froze at 7%.  After a long wait, I reset it, and on the next boot, it’s just a black screen.  It’s following the same path as before– the update assistant didn’t make things work any better at all.

      Group L (Linux): KDE Neon User Edition 5.14.3 (based on Ubuntu 18.04) + Windows 7 in Virtualbox VM

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: My experience trying to upgrade and update Win 10 in a VM

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.

    Your information:


    Comments are closed.