• Network permissions


    Once upon a time my Win 7 and Win 10 systems happily talked to each other over my home network. Around Win 10 1809 or a it later, Win 7 could no longer access files on the Win 10 system. Now Win 10 has gone to 20h2 and neither system can access the others files etec.

    Both see the other as they are included in the Network folder, but any attempt to access a file results in a message about not having permissions. Sharing and security permissions have been set to full control on both machines. Network discovery etc is on, no passwords are required on either machine.

    I’m lost on this problem, and terribly frustrated as it seems things have gone from tolerable to bad to helpless as Win 10 has “evolved”!

    Help would be appreciated!


    Viewing 7 reply threads
    • #2343278

      Easiest way?

      As a test, re-enable the SMB v1 network protocol on your Windows 10 devices and reboot them. (SMB v1 was removed since Windows 10 1709.)

      1. *Right*-click on Start.

      2. Select Windows PowerShell (Admin) from the context menu.

      3. When the PowerShell console window opens, copy/paste the following command then press the Return/Enter key:

      Enable-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol" -All

      4. Reboot.

      If your devices can now ‘see’ each other again then you need to balance functionality against the (IMO, very small) risk of continuing to use an insecure network protocol on your own internal local network.

      Hope this helps…

      • #2343398

        G’day Rick,

        Done that. The win 7 machine has only an SNMP, and the Win SNMP provider is ticked.

        The result: No change other than the win 10 machine no longer shows itself in the network folder, whereas the win 7 shows both.

        On the win 7 when I try to access the win 10 I get a message saying I do not have permissions to access it. When I try to access the win 7 machine from the win 10 the message is simply “can’t access, there might be a problem with the network”, and the diagnostic test finds nothing.

        When I set the security & sharing permissions there were a plethora of options, e.g. “Everyone”, “Network”, and these differ on the two machines. All have been given full access for both sharing and security.

        Best wishes, Peter
        Mod edit: Name of poster attached, not logged in

    • #2343488

      @Peter… you may not be logged in.
      when you get to Paul T’s link (above), scroll up to #2313600
      and follow the link there. Some people have found a solution
      there, in my case, I found a deep rabbit hole.
      Good luck

      • #2344203

        I think I’m stuck in PFC’s rabbit hole! I followed #2313600 and this link (I can’t recall where I found it) https://www.winhelponline.com/blog/how-to-share-files-and-printers-in-windows-10-homegroup-alternative/ and have got nowhere!  To summarise,

        • both the Win 7 and Win 10 machines do show both machines in the Network folder under My PC,
        • both have network discovery turned on do not require passwords
        • both have the various Function discovery etc services active (automatic), and the Win 10 machine has all SMB features turned on
        • on both machines the shared folder’s security and sharing permissions for “Everyone” and “Network” are “full control”
        • when I click on the Win 10 icon from Win 7 I’m told I do not have permission to access it,
        • when I click on the Win 7 icon from the Win 10 machine I get a similar message but am also told my organisation’s security policies (presumably mine!) block unauthorised guest access.

        What next?

        Regards, Peter


    • #2343483

      Hi Paul,

      Passover protected sharing is “off” on both machines. Also, network discovery is “on” on both machines.

      Mod edit: Name of poster attached, not logged in

    • #2343502

      Hi Paul,

      Passover protected sharing is “off” on both machines. Also, network discovery is “on” on both machines.

      Mod edit: Name of poster attached, not logged in

      it was the other things at #2313600 I was pointing to.

    • #2343508
    • #2344264

      What next?

      as a workaround, I’ve turned on Remote Desktop Connection.
      for remote printing, I’ve installed PrinterShare app (thanks Alex)

      If/when I can see the Computer name in File Explorer (Network), I right click on it,
      select Remote Connection … and ignore a certificate warning I get.

      The functionality that’s broken is not critical to me.
      Paul T referred to it as The Credential Manager “Thing” and
      according to conclusions in the Microsoft Community, it’s
      something MS needs to fix.

      Good luck with your endeavors

      • This reply was modified 2 years, 7 months ago by PFC.
    • #2344272

      Not sure how much access you want but if you right click on a folder and pick Share in the context menu, a wizard to do what you want pops up.  The proper access in Network and Sharing Center have to set, too.

      I can see all my network computers (home network) but can’t access anything except the shared folders.  Permission has to be done from the target computer.  You can map a network drive from a client in a similar fashion but again, permission to access the drive has to first be given by the target after share folders are set up in the target.  You’ll enter something like this from the client:


      where Target is the name of the target machine and SHAREtarget is the name of the folder you shared with clients.

      Pretty sure you know this but Remote Desktop is definitely not a great way access files; it’s used to take over the target for various reasons.

      Simple networking in Windows is not complicated but the instructions are vague and switches are here and there.  Win 10 put up some roadblocks Win 7 didn’t have and seems to have become more “secure” as Win 10 has evolved.  Credentials should automatically be created.  Work on the target first.

      Yup, used to be easy.

    • #2345223

      The saga is still ongoing!

      I have tried the suggestion in #2344272. In fact, I’d been using this as a way around earlier inability to access non-local files via the Network folder. Doesn’t work any more: the Win 10 machine says my organization’s security policies  block unauthorized guest access (when it tries to access the Win 7 machine). I switched Guest account on the Win 7 machine – still no access. Permissions and sharingwere all granted on the Win 7 (target) machine to “Everyone”.

      It sounds so simple, but it’s proving quite obtuse, in part because I now believe I’m not understanding the error message Win 10 gives me.

      My big concern  is that I can no longer sync the two machines, e.g. using FreeFileSync.

    Viewing 7 reply threads
    Reply To: Network permissions

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: