News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Network printing crashes various apps

    Posted on 7Natives Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 10 Windows 10 version 1909 – November 2019 Update Network printing crashes various apps

    This topic contains 1 reply, has 2 voices, and was last updated by  anonymous 3 weeks, 6 days ago.

    • Author
      Posts
    • #2086415 Reply

      7Natives
      AskWoody Lounger

      Newbie here.

      Windows 10 users are only able to print to a network-attached printer using some applications. Firefox, Chrome, Notepad(!), and Print Test Page all crash, taking the host app with them. I suspect other mainstream MS apps will do the same.

      On the upside, printing to the printer from a PDF works fine. Same devices, same printer, same network, no changes. This is our current workaround, print to a PDF, then print the PDF to the printer for actual hard copy.

      There are also some apps that print OK, e.g., Mozilla Thunderbird, MS Edge (this is not the newest version just being rolled out now), Internet Explorer 11.x, and Quickbooks.

      I saw a lot about this issue under Win 10-v1903, but found nothing under Windows 10-v1909. I am in the process of upgrading our Windows 7 devices to Windows 10, v1909. I have one left to go but am holding off for now. I only have a few users on this network.

      From reading here and other places about the ‘net, it appears my best option at this time might be to roll back to the legacy print driver that worked under Windows 7, as Windows 10 accepts that as a “legacy” item. I haven’t tried that yet.

      PRINTER

      the printer is hardwired to the LAN; it’s a Canon MF8350Cdn.

      USER 1

      New HP laptop delivered with Windows 10 Pro OEM, connected to the LAN by WiF.

      USER 2

      Dell Optiplex 9020M hardwired

      ENVIRONMENT

      Windows 10 Pro v 1909
      UPDATES:
      KB4532938
      KB4528760

      PRINTER DRIVER
      v4 (Win 8-10)
      dated 06/21/2006 installed 01/14/2020
      10.0.18362.1 | Microsoft
      Canon MF8300B Series UFRII LT
      Shows Network Device = <false>

      ISSUE
      Network printing fails on some apps:
      Firefox crashes | print queue empty
      Chrome crashes | print queue empty
      Notepad crashes | print queue empty
      Printer > Print Test Page crashes | print queue empty
      _____________________________________
      Edge works
      Thunderbird works
      IE 11.x works
      QB works
      Primo PDF works

      WORKAROUND
      In failing apps, print to PDF then print from PDF to Canon.

      Has anyone else been seeing this, regardless of printer and if so, does anyone know of any fixes?

      Thanks,
      7

      Moderator Note: Removed HTML from post. Please view posts in TEXT tab if you copy and paste, and remove unnecessary HTML. Thank You.

    • #2087453 Reply

      anonymous

      You may have to go to a different section of Canon’s site for your country, but there is a driver dated October 2016.

      This newer driver could have the fix for the application crashing bug mentioned under the Optional Driver(s) banner: Service Pack for MF8050Cn/MF8350Cdn Printer Driver (32-bit & 64-bit)

      Also, Microsoft hardware drivers are a last resort.

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Network printing crashes various apps

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.