News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Network share stopped working

    Author
    Topic
    #2376937

    Hi,

    I have a Win 10 Enterprise PC which has a network share used to scan files to this PC. This share worked for many months.

    This past week the share just stopped working. Nothing can access this PC by its netbios name, not the scanner, not remote desktop either. Both still work by IP address (\\192.168.1.x\share), but not by PC name. No changes were made to the share or its permissions.

    What did change is that a build and an update came in.

    The PC is now at Win 10 Enterprise Version 2004 (OS Build 19041.1083) with 2021-07 Cumulative Update for Windows 10 Version 2004 for x64-based Systems (KB5004945) applied. Bam, the share stops working same day (I wish I could see the time of the update, but it only gives the date. Close enough).

    I did some troubleshooting and got it to work, but it breaks on reboot, which leads me to believe it’s a service that’s not getting started when it should.

    Is this a known issue with Enterprise and this build and update? I have Pro 2004 PC’s in the same office that still work.

    Does anyone know what the problem might be? Could someone recommend a good site with step by step instructions for troubleshooting network issues like this?

    Thanks in advance.

    Viewing 2 reply threads
    Author
    Replies
    • #2376941

      Are the other unaffected Windows 10 Enterprise machines also on build 19041.1083  or are they still on build 19041.1052?

      The preview release that brought the build number up to 19041.1081 is included in the release for KB5004945 which brought your machine in question up to build number 19041.1083.

      That preview release had several updates for various networking issues, per its description found at the following Microsoft page: https://support.microsoft.com/en-us/topic/june-21-2021-kb5003690-os-builds-19041-1081-19042-1081-and-19043-1081-preview-11a7581f-2a01-47d5-ba12-431709ee2248.

      Scrolling through the detailed listing of “Improvements and fixes” for version 2004 will reveal the several networking-related items that were tinkered with. Could the machine in question have in place a work-around for one of these networking-related fixes that then broke the netbios-type connection? In other words, could there have been a work-around in place that, coupled with one of the fixes listed, proceeded to break the netbios-type connection from the specific computer in question to the networked peripheral?

      Just a thought.

      • #2376955

        I’m not seeing anything specific to networking in the document.

        Could someone recommend a good site with step by step instructions for troubleshooting network issues like this?

    • #2376950

      This is the only Enterprise PC in the network, all the others are Pro and continue to work… so it’s something specific to Enterprise and this update that broke it.

      • #2376954

        This is the only Enterprise PC in the network, all the others are Pro and continue to work…

        Ok, but are their build numbers the same, 19041.1083?

        • #2376960

          I’m waiting on someone to come on shift and turn the PC’s on… or maybe I’ll just go to that site tomorrow…..

        • #2377170

          So anther pc that works is Windows Pro Version 2004 (OS Build 19041.1083).

          I ran sfc /scannow and dism /online /cleanup-image /restorehealth

          sfc reports that Windows Resource Protection found corrupt files and successfully repaired them. dism didn’t complain.

          It seems to be working now. I’m going to leave the IP address link up on the scanner for awhile, but I’ll ask the staff to try the PC name link first (got an IP reservation in the router for the time being).

          As if that isn’t enough, the PC, a Dell Optiplex, froze and started blinking 2 – 3. That’s bad memory, processor, or motherboard. Gee, wish they could be a little more specific.

          Ran Dell Command Update. Whole bunch of drivers needed updating, must have missed this one in my last check.

          Running full diagnostics at the moment. Maybe the PC hosed the update? Could be….

          Just goes to show ya, it’s always something……..

          Thanks to all…

          • #2377350

            After all of the updates have installed and you’ve hopefully been able to successfully reboot, please let us know if the scanner is communicating with the PC in question.

            If the updates you’ve hopefully been able to install don’t do the trick, one idea that had surfaced (but I don’t know what happened to it) was from Susan Bradley. She had suggested you try the scanner vendor’s site to see if there might be a firmware update for it, or perhaps a newer driver available for it that helps it deal with the latest updates for Windows 10 ver. 2004 from Microsoft.

            I’m with you now, though, I do believe there’s something amiss with the individual machine, not necessarily anything else. However, a firmware update for the scanner might help fix the snafu between the Enterprise machine and the scanner. It might help the scanner deal with tighter security that now exists on the Enterprise machine that didn’t exist before.

            BTW, thank you very much for double checking the build numbers of the two Pro machines, because it allows ruling out a difference in builds as a possible culprit.

    • #2376956

      Function Discovery Provider Host – can you see if setting that service to enabled helps?

      Susan Bradley Patch Lady

      • #2376958

        I was actually looking at that yesterday.

        There’s a detailed analysis of those services that I stumbled across here:
        https://3piecesoftware.com/IT_Issues_Network_Computers_Missing.php

        Why would Microsoft screw around with this, it was working since day 1, and now an update comes in and bam it stops working!

        And the other thing is, if you change the startup type of system services, the next time you do sfc /scannow, they get reset back to the default… now that’s a gotcha.

    Viewing 2 reply threads
    Reply To: Network share stopped working

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.