News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Networked Windows 10 computers cannot see each other.

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 Networked Windows 10 computers cannot see each other.

    Viewing 7 reply threads
    • Author
      Posts
      • #2380570
        anonymous
        Guest

        I have a desktop computer (Bert) and a laptop (Ernie).  They both use Windows 10 Pro with all the updates.  I want the ability to freely transfer files between them like I used to be able to do.  They are connected through a switch which also connects to a half-dozen network hard drives.  Each computer can see all the hard drives–they just can’t see each other.

        I have literally spent hours on the internet, jumping through all kinds of hoops and changing all kinds of settings, even re-installing Windows 10 on the laptop.  Whatever I do they steadfastly refuse to acknowledge the other’s existence with the exception that Ernie can see Bert as a media device but cannot read any of the media on it.

        I have been fighting with this on and off for weeks and I’m getting so frustrated.  It used to work!

      • #2380612
        doriel
        AskWoody Lounger

        hello and wellcome! I suggest you do this:
        1) Put both computers into same Workgroup (This PC -> Properities -> Put same Workgroup name on both computers). This will join them together.
        2) Create shared folders, or you can share whole partition too
        (Rightclick the folder/partition you want to share, go to tab “Sharing” and check the box “Share this folder”)

        After this is done, you should see the shared folders on your network.
        Lets start with this, then we can move on. This initial setup should help you, then you can decide, if you want just read or read and write from shared folders. But one step at a time.

        Let us know, if it went OK. Here is Youtube Video to help enable the function.

        workgroup

        sharing

        Dell Latitude E6530, Intel Core i5 @ 2.6 GHz, 4GB RAM, W10 20H2 Enterprise

        HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

        PRUSA i3 MK3S+

        • This reply was modified 2 months ago by doriel. Reason: pictures added
        • This reply was modified 2 months ago by doriel.
      • #2380626
        PFC
        AskWoody Plus

        They both use Windows 10 Pro with all the updates.

        what version and OS Build are Bert and Ernie running?

        • #2380655
          anonymous
          Guest

          Thank you for your input.  All that you suggested has been done.  And undone.  And done again!  As I said, this used to work well.  I’m hardly an expert but nor am I new at this.  My various computers on my own network have been sharing stuff for years.  I guess it’s one of the more recent Windows updates that has wrecked it.

        • #2380656
          anonymous
          Guest

          Well, I just kicked myself.  I could have sworn they were both using Windows 10 Pro but laptop Ernie is Windows 10 Home.  Not sure if this would make a difference.  As I said, this used to work!

           

          Bert:     Windows 10 Pro      21H1 19043.1110

          Ernie:   Windows 10 Home 21H1 19043.1110

          • #2380661
            PFC
            AskWoody Plus

            I know what you’re going through. It hasn’t worked for me since ver 1909.

      • #2380681
        alejr
        AskWoody Lounger

        My uncle’s in-home network has a Windows 10 Pro PC and 3 Windows 10 Home PCs and they can all see/share files between them. Here’s his network settings.

        Note: the following needs to be done for each PC and you’ll need to restart them for the changes to take effect.

        Open the Services control panel (services.msc) and ensure the status for these services are as follows

        • DHCP Client is running and set for Automatic
        • DNS Client is running and set for Automatic (Trigger Start)
        • Function Discovery Provider Host is running and set for Manual
        • Function Discovery Resource Publication is running and set for Manual (Trigger Start)
        • SSDP Discovery is running and set for Manual
        • UPnP Device Host is set for Manual (it may or may not be running)

        Open Settings > Network & Internet and verify the Network status shown at the top of the right-hand panel shows it’s a Private network.

        • If it’s not, click the Properties button and change the Network Profile to Private

        Scroll down and select Network and Sharing Center in the right-hand panel and then select Change advanced sharing settings in the left-hand panel of the window that pops up.

        Expand the Private (current profile) item and set the following:

        • Select Turn on network discovery and check the Turn on automatic setup of network connected devices box.
        • Select Turn on File and printer sharing

        Expand the All networks item and set the following

        • Select Turn off password protected sharing

        Note, if you do want to use password sharing, you’ll need to set up user accounts on each PC for the other PC so they can login to each other.

        Good luck!

        • #2380693
          RetiredGeek
          AskWoody MVP

          Alejr,

          There is no such setting for:
          Function Discovery Resource Publication is running and set for Manual (Trigger Start)

          Services-Settings

          Just set it to: Automatic (Delayed Start) and things work fine.

          Note: the computers will still NOT show up in File Explorer, unless you enable SMBv1, until you search for them on the Address bar, e.g. \\ComputerName\ShareName once this is done they will show up under network.

          I’ve been fighting this for what seems like eons. I’ve just learned to live with File Explorer the way it is.

          HTH 😎

          May the Forces of good computing be with you!

          RG

          PowerShell & VBA Rule!
          Computer Specs

          • #2380705
            alejr
            AskWoody Lounger

            You’re right, there’s no option for Manual (Trigger Start) in the properties dropdown for any service.

            But when this particular service is set for Manual, it actually displays a Startup Type of Manual (Trigger Start) in the main services window.

            Services-1

            So a startup type of Manual doesn’t always really mean Manual.

            Strange?!?!

             

        • #2380699
          anonymous
          Guest

          Thank you.  I will go over all these settings on both computers although, scanning them, the steps all look familiar.  After all, I’ve been fighting this for weeks.

          I did dust off an old computer, did a fresh install of Windows 10 Pro, then did all the updates.  Both Bert and Ernie can see “CookieMonster”.  They still can’t see each other, nor can CookieMonster see them.

          Thanks again!  It might be a couple of days before I can get back here to report.

      • #2380713
        Al Taylor
        AskWoody Plus

        I have a desktop computer (Bert) and a laptop (Ernie).  They both use Windows 10 Pro with all the updates.  I want the ability to freely transfer files between them like I used to be able to do.  They are connected through a switch which also connects to a half-dozen network hard drives.  Each computer can see all the hard drives–they just can’t see each other. I have literally spent hours on the internet, jumping through all kinds of hoops and changing all kinds of settings, even re-installing Windows 10 on the laptop.  Whatever I do they steadfastly refuse to acknowledge the other’s existence with the exception that Ernie can see Bert as a media device but cannot read any of the media on it. I have been fighting with this on and off for weeks and I’m getting so frustrated.  It used to work!

        Are you by any chance running one or both machines without a logon password (i.e. “blank” password)?  If so, I will post a procedure that has solved this issue for me.

        • #2380959
          anonymous
          Guest

          All 3 machines have identical user and password login.

      • #2380756
        Alex5723
        AskWoody Plus

        Set a fix IP address for the PCs and add to quick access.

        • #2380925
          Paul T
          AskWoody MVP

          Fixed IP is not required for any computer unless it’s a server.

          Once the PC is viewable on the network you can add a folder to Quick Access (drag n drop) as Alex suggests.

          cheers, Paul

      • #2380777
        PFC
        AskWoody Plus

        Note: the computers will still NOT show up in File Explorer, unless you enable SMBv1,

        what are the implications of doing this? Does it increase security risks?

        The following is copied from a 2017 How To Geek.

        SMBv1 is an old version of the Server Message Block protocol Windows uses for file sharing on a local network. It’s been replaced by SMBv2 and SMBv3. You can leave versions 2 and 3 enabled—they’re secure.

        The older SMBv1 protocol is only enabled because there are some older applications that haven’t been updated to use SMBv2 or SMBv3. Microsoft maintains a list of applications that still require SMBv1 here.

        If you’re not using any of these applications—and you probably aren’t—you should disable SMBv1 on your Windows PC to help protect it from any future attacks on the vulnerable SMBv1 protocol. Even Microsoft recommends disabling this protocol unless you need it.

      • #2380958
        anonymous
        Guest

        OK!  I’ve gone over all the steps listed by Alejr and, as I suspected, they had already been done.  I’ve also, as suggested somewhere on “the net”, tried re-naming both computers.  It hasn’t made any difference.

        To repeat:  I fired up an old computer (CookieMonster), did a clean install of Windows 10 Pro and installed all the updates.  It is otherwise virginal.  It can see both Bert and Ernie on the network and they can both see it.  They still can’t see each other.

        Thanks to all those who are helping!!

    Viewing 7 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: Networked Windows 10 computers cannot see each other.

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.