News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • new to Win-10–USB hubs won't work

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 new to Win-10–USB hubs won't work

    This topic contains 2 replies, has 2 voices, and was last updated by  DougJ 3 days, 15 hours ago.

    • Author
      Posts
    • #2013041 Reply

      DougJ
      AskWoody Plus

      I have retired my Win-7 machine and replaced it with a Win-10 machine I had built for me.  The OS and program files are on a NVME, my photography data are on an second NVME, all other data are on an onboard a SSD drive.  The mother board is a Gigabyte B360 HD3 ATX LGA 1151; the CPU is an Intel Core i7-8700 3.2 GHz 6-core processor; 32 Gig of Corsair Vengeance RAM.

      This all works well except for a USB 3 and a USB 2 hub plugged into two of four USB ports off the motherboard–the ports themselves are working since if I plug a device into any one of the four, the device works.  When I plug a hub into a port, device manager reports an ” address not set” error.  In device manager, I’ve turned off power management for the hubs; I’ve reinstalled device drivers, and followed other suggestions available through a Google search, done power off reboots galore, all without success.

      In a much earlier thread, I read that update 1703 seems to have unleashed the USB malfunction issue.  However, unless I’ve missed it, I didn’t see what either a successful workaround or a MS resolution is.  My initial install is 1903 of Win-10 now updated to 1909, still no external hubs working.

      I’d welcome any and all advice as to what I might try–even if I’ve tried it before.

      Thanks in advance,

      Doug

    • #2013044 Reply

      GoneToPlaid
      AskWoody Plus

      Are these external hubs powered hubs? If so, are they being powered via a power supply instead of being powered by the motherboard?

      • #2013550 Reply

        DougJ
        AskWoody Plus

        I replied to your post yesterday, GTP, but I don’t see it here.  I don’t post here very often so I must have erred in some way.  Sorry ‘about that.

        Both external hubs are powered hubs.

        Both external hubs are powered by their own external power brick.

        Thanks for your response and questions.

        Ciao,

        Doug

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: new to Win-10–USB hubs won't work

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.