• new Win10 install can’t see smb drives

    Home » Forums » Networking – routers, firewalls, network configuration » new Win10 install can’t see smb drives


    I have four SMB file systems on my LAN.   I cannot “see” any of them in ib new laptop [win10/home].   If I go to “network” it shows all the different drives, but in the pane at the top it sees none of them [so I can’t mount them as a network drive].  It’s odd: my win10/pro has no problem nor does my wife’s ancient XP system [to be replaced with the new laptop when I finish getting it set up 🙂 ].   Is there some setting deep inside win10 that controls whether it will “notice” SMB systems on the network or something like that?

    There are no programs installed on the new laptop: only thing that’s happened is that it has two local accounts [one admin, one ordinary] .

    Viewing 24 reply threads
    • #2268594

      Have you re-enabled SMB1 on your existing W10 machine?
      What operating system / box is the SMB using?

      cheers, Paul

    • #2268740

      Actually I didn’t have to — I found my way to “Programs and Features” and checked the SMB setting and all the SMB1.0 boxes were checked.

      As for OS, the only one I know is the Ready=NAS that is running SMB/CIFS and that’s running Linux under the covers but I have no idea about the other three   All four show up on my system and on my old laptop [XP]..  *not*one* shows on the new systems.  They all show up as network devices (other devices and storage in the Network list from Explorer], but none can be found via their \\ID path [in the “computer” section of network devices.

      The only thing I can mention is that I have *only* local accounts on the system — when I started it up I [intentionally!] had wifi disabled and so went the “i have no internet connection” path to make the base [administrator] account be a non-MS account.  Then I created a local/unprivileged account.  Could not having an MS account on the system somehow be preventing it from seeing SMB drives?  I know the Internet stuff works .

    • #2268840

      This is bizarre — I was curious about what the new system knew about the various NASs on my LAN to see if I could get a hint as to what the problem might be… *and*they*were*all*there* in the “computer” section, just like they should be.  I then had no  trouble mounting my main NAS and now all is well.

      I only did one thing: last time I started the laptop I checked the SMB setting and just for the **** of it clicked it off and then back on.  Then I shut it down and a little later I fired it back up [as I mentioned above] and sudden it was all OK.  My *only* guess was that perhaps the smb1.0 setting wasn’t “on” even though it showed as being checked and I , somehow, mananged to *really* get it checked.  win10 continues to mystify me 🙂

      1 user thanked author for this post.
    • #2268939


      I am still having the same problem of not “seeing” the SMB drive from my X64 Windows 10 even after rebooting and switching on/off SMB1.
      The SMB server works perfectly from a 32bit Windows 10 May update, and from a tablet.

      Any guess how to resolve?

      • #2270045

        It seems you have to be lucky (have the ducks lined up correctly) for SMB drives to show. You can always map manually, so adding a shortcut is the easiest.

        cheers, Paul

    • #2270042

      I am having problems with attaching to my NAS box as well, the mapped drives still show up in explorer but when I click on them it says that the password is wrong, I can see the NAS box under network but if I click on it, again it wants password which it says is wrong. I know it is the right username / password. I can connect / disconnect from my Android phone.

      I have tried turning SMB on / off but still the same.

      • #2270046

        That’s not an SMB problem, it’s a credential issue.

        I suggest you start a new thread so we don’t clutter this one.

        cheers, Paul

        • #2270048

          OK thanks will do, if you want to remove it feel free

          • This reply was modified 3 years, 6 months ago by WScwjs.
          • #2275023


            Eventually, I found the answer. SMB1 is disabled at two places. First in the “group profile” second in the actual registry. Of course one needs to allow first SMB1.

            This is all done to prevent unauthorised access to old type of  SMB servers.

            Best regards,

    • #2275032


      Eventually, I found the answer. SMB1 is disabled at two places. First in the “group profile” second in the actual registry. Of course one needs to allow first SMB1.

      This is all done to prevent unauthorised access to old type of  SMB servers.

      Best regards,

      Hi Istvan,

      Any chance of telling us where to look ?


    • #2275085

      Any chance of telling us where to look ?

      To save messing about in the registry, use the following PowerShell one-liner:

      1. *Right*-click on the Start button.

      2. Select Windows PowerShell (Admin).

      3. Wait for the PowerShell console to open then copy/paste the following command into it and press the Return/Enter key:

      Enable-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol" -All

      (This will install the SMB1 parent protocol plus its ‘client’ and ‘server’ derivatives. Note: This can take several minutes.)

      4. Reboot.

      Note that – by default – if you don’t then use the newly installed SMB1 protocol then it will be automatically removed after 15 days.

      Hope this helps…

      2 users thanked author for this post.
    • #2275089

      As a follow-on, if you have AutoHotkey installed then you can copy/paste the following as an AHK file and it will do it all for you, taking care of the elevation automatically. It’s just a wrapper for the PowerShell command.

      ; Prompt to 'Run as Admin', i.e. show UAC dialog
      If Not A_IsAdmin
      Run *RunAs "%A_ScriptFullPath%" ; Requires v1.0.92.01+
      psScript =
      Enable-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol" -All
      ; Use this call if you don't want to see PowerShell output
      RunWait PowerShell.exe -Command %psScript%,, hide
      MsgBox Now reboot for the change to take effect.

      Hope this helps…

    • #2275224

      Any chance of telling us where to look ?

      To save messing about in the registry, use the following PowerShell one-liner:

      1. *Right*-click on the Start button.

      2. Select Windows PowerShell (Admin).

      3. Wait for the PowerShell console to open then copy/paste the following command into it and press the Return/Enter key:

      Enable-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol" -All

      (This will install the SMB1 parent protocol plus its ‘client’ and ‘server’ derivatives. Note: This can take several minutes.)

      4. Reboot.

      Note that – by default – if you don’t then use the newly installed SMB1 protocol then it will be automatically removed after 15 days.

      Hope this helps…

      Thank you, but it does not work on mine, the only way I can see my mapped drives after reboot is with this,

      net use x: /d
      net use x: \\nas\p2p

      Which I run in a batch flie


      • #2275231

        Your problem is not SMB1 related because you can map and use drives.

        To make your map permanent, run the commands once manually, but add “/persistent:yes” to the second command.

        cheers, Paul

    • #2275535

      We have been seeing the same issue on domain joined computers trying to access mapped drives on Windows Server 2000 and Server 2003.

      Explorer hangs when trying to access the mapped drives to locations on Server 2000 and 2003.
      Navigating to the shared folders, while they are mapped, is not possible via unc path or cname.
      Navigating to the shared folders is only available after the drives have been forcibly removed via cmd line with the net use * /delete command is used and the computer restarted.


      switching off /on SMB1 in Windows Features
      disabled antivirus/firewall
      made domain user Local Admin
      Ran the PowerShell cmd (elevated): Enable-WindowsOptionalFeature -Online -FeatureName “SMB1Protocol” -All.

      Pinging each Server is not an issue, mapped drives or not.
      FYI – mapped drives to Server 2008 r2 work as expected.

      We have added shortcuts to the folders on the User’s Desktop as a temp workaround.

    • #2275558

      Thank you for your help.

      Followed the links, which had nearly the same information.

      Already enabled the listed network sharing options, with the exception of:

      > Turn off password protected sharing.this is not showing as an option under Advanced Sharing settings -> All Networks

      The only services listed , that were not already set to Automatic (they now are):

      Peer Name Resolution Protocol (PNRPSvc)

      Peer Networking Grouping (P2PSvc)

      Peer Networking Identity Manager (P2PIMSvc)

      Have restarted the system and still encounter the same issues accessing the mapped drives.


      • #2275563

        Password protected sharing is in Control Panel\Network & Sharing Center advanced sharing link on the upper lift. In the third section down.

    • #2275589

      Windows 10 Pro shows just empty space in the upper left for this location:

      Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings


    • #2280131

      Win10 build update 2004 added smb1 bugs
      Win10 PC’s on 1909 & below were working perfectly with mapped smb1 shares off old PC’s
      When auto upgraded to 2004 , these smb1 shares stopped working (several Win10 PC’s)
      A rollback to the previous 10 version/build fixed the issue .
      There is no fix if you have build version 2004 & have the smb1 issues , unless you rollback Win10 . Even though smb1 was enabled , it didnt work (for long) on 2004

    • #2289791

      yea its a Windows update issue.  I have only had problems connecting to mapped NAS drives after the update.  It never been an issue before.  I played around with it for a few days trying to get it to work.

      Here is what i did:

      go to services.msc and set all to Automatic Startup
      DCHP Client
      Homegroup Listener
      Homegroup Provider
      Net.Tcp Port Sharing Service
      Network Connections
      Network List Service
      Network Location Awareness
      TCP/IP NetBIOS Helper
      Computer Browser (Browser)
      Function Discovery Provider Host (FDPHost)
      Function Discovery Resource Publication (FDResPub)
      UPnP Device Host (UPnPHost)
      Peer Name Resolution Protocol (PNRPSvc)
      Peer Networking Grouping (P2PSvc)
      Peer Networking Identity Manager (P2PIMSvc)

      Then went to explorer, computer, map network drive and select drive letter but used IP address to connect to the NAS drive instead of the default shared names that come up in the browse box.

      Its been working fine for a few days now so far

      • #2289813

        After doing the above steps and it working for a few days

        i finally rebooted to test it one last time and it broke connection.

        So go to regedit and search for all your mapped drive Ex. \\drive name or IP

        and delete all the entries it finds, mine found only a couple then reboot.  The map drive will work again like it should, but apparently if you reboot it loses it connection again.

        So go back to regedit and
        Then add the following after remapping your drive or else it will fail to connect after a reboot or shutdown.
        [HKEY_CURRENT_USER\Network\X or Y or Z whatever you named it]

        then add dword name “ProviderFlags”=dword:00000001

        I have rebooted numberous times and its still working and wanted to help anyone else out there because this update has been a headache with mapping drives.  I will update if any issues pop up again.


        • #2293546

          Had an issue with a smb1 mapped drive which i couldnt access after rebooting, this solved it:

          “then add dword name “ProviderFlags”=dword:00000001”

          Thanks for posting your advice

          I hope everybody who has the same problem, can find your answer.

          Srry for the broken english.

          Have a good day !

    • #2293715


      Great thank you adding dword name “ProviderFlags”=dword:00000001”  works perfectly.


      Stay Safe

      • This reply was modified 3 years, 3 months ago by WScwjs. Reason: correct spelling
    • #2294801

      Another way in a domain – edit logon script as follows

      net use Y: /delete
      net use Y: \\example\example /persistent:no

      Important: /persistent:no

    • #2305199

      Before attempting esoteric “fixes” for your NAS not showing in File Explorer (FE) in Win 10 check to see if your malware program is blocking the visibility of the NAS. I discovered by painstaking trial-and -error that on my old VAIO after installing a clean from scratch build (2004 latest as at 17/10/2020) of WIN10Pro x64 my Synology NAS was picked up immediately by the OS in its base standard configuration and a list of its Shared folders cascaded nicely down the left column under “Networks”. Then I installed the current version of “Malwarebytes” ( which I have endorsed/used for many years and found that it immediately made my NAS disappear from FE Networks along with its folders. Oddly, having pinned the Synology to my “Quick Access” list the folders could still be accessed through QA but not under Networks. Go figure. I discovered that only by disabling Malwarebytes (right-click System Tray icon and select “Quit/Exit”) and rebooting/logging out of my account did this allow the NAS to re-appear as before with its list of Folders. This was repeatable ad nauseam.

      I filed a Support Ticket with Malwarebytes and await their response.

      • #2309053

        MalwareBytes – BOOM… that is the correct answer!!

        They have just pushed an update today, November 1, 2020 which fixes this “unable to browse network computers” problem. Love MB, but their QC testing before general public release is utterly abysmal. At least 4 times in as many years, they have been the culprit when iOS backup to iTunes stops working… just far enough apart that you forget why everything stopped working the last time.

        • #2309466

          Thank you very much.

          I was 3 days into an investigation of why my NAS drives were becoming unavailable shortly after a reboot when I found your post (why I didn’t think to look here first I cannot explain…).

          In my case, not only were they disappearing in FE, they were unavailable to applications such as Veeam backup (which has a nas drive as a target).  It was that backup failing that alerted me to a problem.

          As soon as I forced an MB update, all was well!  So thanks again – you saved me a lot more pain!

    • #2313600

      Here is a very comprehensive article with a number of suggested fixes :


    • #2313617

      I have a QNAP NAS and the firmware allows the setting of the lower and upper SMB levels. If I set the lower level anything above 1, the NAS no longer appears in Windows Explorer. SMB 1 is said to be a security weakness but I just have to leave it at 1.

    • #2326502

      Once again, hats off to AskWoody.

      I just upgraded my Win 10 Pro 64-bit from 1909 to 2004.  My PC is local account and I do NOT have a password to reboot and log on to my User Account on my PC.  It’s in my bedroom.

      In 1909, my new HP OfficeJet Pro 9015 all-in-one printer-scanner-faxer would NOT “Scan to Network Folder” when I had no password on my PC (where the network folder is) unless I enabled ONLY SMB1 on the printer and enabled SMB1 on the PC.  Then it worked.

      After upgrading to 2004, the above setup stopped working (again), even after I re-enabled all the SMB1 checkboxes in the 2004 features box.  Didn’t know what to do until I found this thread and also checked Turn off password protected sharing.  The upgrade to 2004 had turned it back on, so I just turned it off, and VOILA, my HP 9015 can again Scan to Network Folder.

      This is why I am a (very modest) contributor to AskWoody, and you should be too.

      Thanks again, all here.  Cheers!

    • #2343325

      This only occurs after a shutdown/reboot. Drives mount normally after ‘restart’. I run a simple script to delete and re-map mine:

      @echo off

      for %%i in ( N O P Q R S T U ) do net use %%i: /delete

      for %%i in ( N O P Q ) do echo “net use %%i: \\Nas1\%%i /persistent:yes” & net use %%i: \\Nas1\%%i /persistent:yes

      for %%i in ( R S T U ) do echo “net use %%i: \\Nas2\%%i /persistent:yes” & net use %%i: \\Nas2\%%i /persistent:yes


      This could be cleaned up, I was in a hurry and lazy.

    • #2352778

      None of this worked for me on Win 10 20H2. On the smb server side I had to comment out from smb4.conf this line:

      smb ports = 139
    • #2366512

      I am coming back for a second time on this issue. I had this issue when I upgraded my Dell 7510 laptop to Windows 10 2004. I have one NAS drive from Thecus that is older and only supports SMB 1.5. After trying many things, I finally solved this by mapping a folder on the NAS drive and setting the ProviderFlags Dword 1 in the registry under the mapped drive letter. That has worked fine on that computer for several months.

      I recently switched to a new Dell 7550 laptop that came with Windows 10 20H2 installed. I had the same problem initially, that I had to reenter the password every time I tried to access the NAS. I have tried enabling the SMB 1.0 services, enabling NetBIOS over TCP/IP, allowing NLTM authentication, making a whole host of Windows services start automatically, and a few other things, including the ProviderFlags in the registry. Now, when my computer boots, the mapped drive shows that it did not connect. When I select it, I get strange error messages like the specified device name no longer exists or I have no permission to access. I am not even give the option to enter credentials. However, if I reboot the computer, the drive connects this time every time using the stored credentials. It then works fine until I shut down over night and reboot the next day. I suspect that, on initial boot, the drive tries to connect. For some reason, the Thecus recognizes the connection, but Windows does not. When I try to access later to establish the connection, the Thecus does not respond because this computer is already using that Thecus account. I understand one cannot have more than one connection to the same NAS from the same computer at the same time. Why it happens only at initial boot I cannot tell unless it has something to do with timing (the Thecus probably responds a bit slower since it has not been accessed in a long time).

      I have tried everything I could find on this thread and elsewhere, with no success. The last thing I tried was mapping the drive using its IP address instead of its network name. Same problem. Any advice is appreciated. Thanks.

    • #2367200

      I found the answer to my problem on Windows 10 20H2.  I had forgotten that Windows defaults to a Fastboot mode on startup, so my new computer came with that set.   I turned off Fastboot.  Then I remapped my NAS drive, and set the registry hack ProviderFlags again.  Now the drive connects at startup just like it does on my older Windows 10 2004 laptop.  I suspect that the Fastboot might explain other issues that people may be having on initial startup that are corrected by a reboot.

      I had talked to Dell Prosupport about this.  They found a Microsoft support document saying Microsoft is trying to get rid of SMB 1 support.  That document suggested that the registry hack worked only on 2004 and was purposely invalidated for 20H2 and later versions.  So this problem may come up again in the future, but for now doing a normal boot on startup and making the suggested workarounds including the registry hack seems to still work on 20H2.

      • #2367218

        SMBv1 lets ransomware run rampant and ergo why they want to shut it down.  Clean installed Win10 machines disable SMB v1.  Existing machines that feature upgrade from (I believe it’s 1909 to 2004 but it may be a version prior to 2004, say 1903 to 1909?) will look to see if you are still using SMBv1 and if not detected in 15 days of the feature release upgrade process it will disable SMBv1 and then you have to manually turn it back on.  The better way is to see of your NAS has a setting to force it to SMB v2 so you don’t have to keep lowering the security .  SMBv1 is really old and bottom line easy pickin’s for ransomware misuse.

        Susan Bradley Patch Lady/Prudent patcher

        • #2367219

          Sorry scrolled up and saw it only supports SMB 1.5.  I’d reach out to Thecus and see if there’s any hope of an upgrade? Otherwise and I know this is hard to hear, but plan on an upgrade at some point in time as older SMB versions are ultimately not safe.

          Susan Bradley Patch Lady/Prudent patcher

    • #2367229

      I have actually purchased a new Synology NAS that is my main device now.  However, the Thecus is still fast, so I use it as a second backup media.  Unfortunately, Thecus has not updated the firmware in my N7700PRO for many years.   They have newer versions out, but they use different software.  That was one strong reason for purchasing the Synology, as they seem to design their  systems so that all can run the latest software, perhaps with some features disabled.    I will put a message on the Thecus forum, but officially Thecus has no updates.

      • #2367240

        @marklang I faced the same issue with an old Buffalo Link Station a few years back. Found an outside forum not associated with Buffalo that had instructions on editing the firmware to allow smb2 as default. Putty in, made a few edits and it has been working fine ever since. Just a thought.

        Never Say Never

        • #2367243

          Thanks.  I am not sure I would be comfortable doing that if I could find the instructions.  I found a Thecus forum on SNB Forums and posted a message.  I will see if anyone responds.

    Viewing 24 reply threads
    Reply To: new Win10 install can’t see smb drives

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: