News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • new Win10 install can’t see smb drives

    Posted on berniec Comment on the AskWoody Lounge

    Home Forums Networking – routers, firewalls, network configuration new Win10 install can’t see smb drives

    Viewing 17 reply threads
    • Author
      Posts
      • #2268499 Reply
        berniec
        AskWoody Plus

        I have four SMB file systems on my LAN.   I cannot “see” any of them in ib new laptop [win10/home].   If I go to “network” it shows all the different drives, but in the pane at the top it sees none of them [so I can’t mount them as a network drive].  It’s odd: my win10/pro has no problem nor does my wife’s ancient XP system [to be replaced with the new laptop when I finish getting it set up 🙂 ].   Is there some setting deep inside win10 that controls whether it will “notice” SMB systems on the network or something like that?

        There are no programs installed on the new laptop: only thing that’s happened is that it has two local accounts [one admin, one ordinary] .

      • #2268594 Reply
        Paul T
        AskWoody MVP

        Have you re-enabled SMB1 on your existing W10 machine?
        What operating system / box is the SMB using?

        cheers, Paul

      • #2268740 Reply
        berniec
        AskWoody Plus

        Actually I didn’t have to — I found my way to “Programs and Features” and checked the SMB setting and all the SMB1.0 boxes were checked.

        As for OS, the only one I know is the Ready=NAS that is running SMB/CIFS and that’s running Linux under the covers but I have no idea about the other three   All four show up on my system and on my old laptop [XP]..  *not*one* shows on the new systems.  They all show up as network devices (other devices and storage in the Network list from Explorer], but none can be found via their \\ID path [in the “computer” section of network devices.

        The only thing I can mention is that I have *only* local accounts on the system — when I started it up I [intentionally!] had wifi disabled and so went the “i have no internet connection” path to make the base [administrator] account be a non-MS account.  Then I created a local/unprivileged account.  Could not having an MS account on the system somehow be preventing it from seeing SMB drives?  I know the Internet stuff works .

      • #2268840 Reply
        berniec
        AskWoody Plus

        This is bizarre — I was curious about what the new system knew about the various NASs on my LAN to see if I could get a hint as to what the problem might be… *and*they*were*all*there* in the “computer” section, just like they should be.  I then had no  trouble mounting my main NAS and now all is well.

        I only did one thing: last time I started the laptop I checked the SMB setting and just for the **** of it clicked it off and then back on.  Then I shut it down and a little later I fired it back up [as I mentioned above] and sudden it was all OK.  My *only* guess was that perhaps the smb1.0 setting wasn’t “on” even though it showed as being checked and I , somehow, mananged to *really* get it checked.  win10 continues to mystify me 🙂

        1 user thanked author for this post.
      • #2268939 Reply
        anonymous
        Guest

        Hi,

        I am still having the same problem of not “seeing” the SMB drive from my X64 Windows 10 even after rebooting and switching on/off SMB1.
        The SMB server works perfectly from a 32bit Windows 10 May update, and from a tablet.

        Any guess how to resolve?

        • #2270045 Reply
          Paul T
          AskWoody MVP

          It seems you have to be lucky (have the ducks lined up correctly) for SMB drives to show. You can always map manually, so adding a shortcut is the easiest.

          cheers, Paul

      • #2270042 Reply
        WScwjs
        AskWoody Lounger

        I am having problems with attaching to my NAS box as well, the mapped drives still show up in explorer but when I click on them it says that the password is wrong, I can see the NAS box under network but if I click on it, again it wants password which it says is wrong. I know it is the right username / password. I can connect / disconnect from my Android phone.

        I have tried turning SMB on / off but still the same.

        • #2270046 Reply
          Paul T
          AskWoody MVP

          That’s not an SMB problem, it’s a credential issue.

          I suggest you start a new thread so we don’t clutter this one.

          cheers, Paul

          • #2270048 Reply
            WScwjs
            AskWoody Lounger

            OK thanks will do, if you want to remove it feel free

            • This reply was modified 4 months, 3 weeks ago by WScwjs.
            • #2275023 Reply
              anonymous
              Guest

              Hi,

              Eventually, I found the answer. SMB1 is disabled at two places. First in the “group profile” second in the actual registry. Of course one needs to allow first SMB1.

              This is all done to prevent unauthorised access to old type of  SMB servers.

              Best regards,
              Istvan

      • #2275032 Reply
        WScwjs
        AskWoody Lounger

        Hi,

        Eventually, I found the answer. SMB1 is disabled at two places. First in the “group profile” second in the actual registry. Of course one needs to allow first SMB1.

        This is all done to prevent unauthorised access to old type of  SMB servers.

        Best regards,
        Istvan

        Hi Istvan,

        Any chance of telling us where to look ?

        Clive

      • #2275085 Reply
        Rick Corbett
        AskWoody_MVP

        Any chance of telling us where to look ?

        To save messing about in the registry, use the following PowerShell one-liner:

        1. *Right*-click on the Start button.

        2. Select Windows PowerShell (Admin).

        3. Wait for the PowerShell console to open then copy/paste the following command into it and press the Return/Enter key:

        Enable-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol" -All

        (This will install the SMB1 parent protocol plus its ‘client’ and ‘server’ derivatives. Note: This can take several minutes.)

        4. Reboot.

        Note that – by default – if you don’t then use the newly installed SMB1 protocol then it will be automatically removed after 15 days.

        Hope this helps…

        2 users thanked author for this post.
      • #2275089 Reply
        Rick Corbett
        AskWoody_MVP

        As a follow-on, if you have AutoHotkey installed then you can copy/paste the following as an AHK file and it will do it all for you, taking care of the elevation automatically. It’s just a wrapper for the PowerShell command.

        ; Prompt to 'Run as Admin', i.e. show UAC dialog
        If Not A_IsAdmin
        {
        Run *RunAs "%A_ScriptFullPath%" ; Requires v1.0.92.01+
        ExitApp
        }
        
        psScript =
        (
        Enable-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol" -All
        )
        
        ; Use this call if you don't want to see PowerShell output
        RunWait PowerShell.exe -Command %psScript%,, hide
        
        MsgBox Now reboot for the change to take effect.

        Hope this helps…

      • #2275224 Reply
        WScwjs
        AskWoody Lounger

        Any chance of telling us where to look ?

        To save messing about in the registry, use the following PowerShell one-liner:

        1. *Right*-click on the Start button.

        2. Select Windows PowerShell (Admin).

        3. Wait for the PowerShell console to open then copy/paste the following command into it and press the Return/Enter key:

        Enable-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol" -All

        (This will install the SMB1 parent protocol plus its ‘client’ and ‘server’ derivatives. Note: This can take several minutes.)

        4. Reboot.

        Note that – by default – if you don’t then use the newly installed SMB1 protocol then it will be automatically removed after 15 days.

        Hope this helps…

        Thank you, but it does not work on mine, the only way I can see my mapped drives after reboot is with this,

        net use x: /d
        net use x: \\nas\p2p

        Which I run in a batch flie

        Clive

        • #2275231 Reply
          Paul T
          AskWoody MVP

          Your problem is not SMB1 related because you can map and use drives.

          To make your map permanent, run the commands once manually, but add “/persistent:yes” to the second command.

          cheers, Paul

      • #2275535 Reply
        anonymous
        Guest

        We have been seeing the same issue on domain joined computers trying to access mapped drives on Windows Server 2000 and Server 2003.

        Explorer hangs when trying to access the mapped drives to locations on Server 2000 and 2003.
        Navigating to the shared folders, while they are mapped, is not possible via unc path or cname.
        Navigating to the shared folders is only available after the drives have been forcibly removed via cmd line with the net use * /delete command is used and the computer restarted.

        Tried:

        switching off /on SMB1 in Windows Features
        disabled antivirus/firewall
        made domain user Local Admin
        Ran the PowerShell cmd (elevated): Enable-WindowsOptionalFeature -Online -FeatureName “SMB1Protocol” -All.

        Pinging each Server is not an issue, mapped drives or not.
        FYI – mapped drives to Server 2008 r2 work as expected.

        We have added shortcuts to the folders on the User’s Desktop as a temp workaround.

      • #2275558 Reply
        anonymous
        Guest

        Thank you for your help.

        Followed the links, which had nearly the same information.

        Already enabled the listed network sharing options, with the exception of:

        > Turn off password protected sharing.this is not showing as an option under Advanced Sharing settings -> All Networks

        The only services listed , that were not already set to Automatic (they now are):

        Peer Name Resolution Protocol (PNRPSvc)

        Peer Networking Grouping (P2PSvc)

        Peer Networking Identity Manager (P2PIMSvc)

        Have restarted the system and still encounter the same issues accessing the mapped drives.

         

        • #2275563 Reply
          PKCano
          Da Boss

          Password protected sharing is in Control Panel\Network & Sharing Center advanced sharing link on the upper lift. In the third section down.

      • #2275589 Reply
        anonymous
        Guest

        Windows 10 Pro shows just empty space in the upper left for this location:

        Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings

         

        • #2275592 Reply
          PKCano
          Da Boss

          Screen-Shot-2020-06-26-at-6.09.32-PM

          Attachments:
          • #2275602 Reply
            anonymous
            Guest

            I cannot post a screen shot, but our options end at File sharing connections, there is nothing below to scroll to.

            • #2275605 Reply
              PKCano
              Da Boss

              Most probably that setting for password protected sharing is controlled from elsewhere. The domain server?

              • #2275658 Reply
                Paul T
                AskWoody MVP

                I don’t think you can disable that on a domain.

                cheers, Paul

      • #2280131 Reply
        anonymous
        Guest

        Win10 build update 2004 added smb1 bugs
        Win10 PC’s on 1909 & below were working perfectly with mapped smb1 shares off old PC’s
        When auto upgraded to 2004 , these smb1 shares stopped working (several Win10 PC’s)
        A rollback to the previous 10 version/build fixed the issue .
        There is no fix if you have build version 2004 & have the smb1 issues , unless you rollback Win10 . Even though smb1 was enabled , it didnt work (for long) on 2004

      • #2289791 Reply
        anonymous
        Guest

        yea its a Windows update issue.  I have only had problems connecting to mapped NAS drives after the update.  It never been an issue before.  I played around with it for a few days trying to get it to work.

        Here is what i did:

        go to services.msc and set all to Automatic Startup
        DCHP Client
        Homegroup Listener
        Homegroup Provider
        Net.Tcp Port Sharing Service
        Network Connections
        Network List Service
        Network Location Awareness
        TCP/IP NetBIOS Helper
        Computer Browser (Browser)
        Function Discovery Provider Host (FDPHost)
        Function Discovery Resource Publication (FDResPub)
        UPnP Device Host (UPnPHost)
        Peer Name Resolution Protocol (PNRPSvc)
        Peer Networking Grouping (P2PSvc)
        Peer Networking Identity Manager (P2PIMSvc)

        Then went to explorer, computer, map network drive and select drive letter but used IP address to connect to the NAS drive instead of the default shared names that come up in the browse box.

        Its been working fine for a few days now so far

        • #2289813 Reply
          anonymous
          Guest

          After doing the above steps and it working for a few days

          i finally rebooted to test it one last time and it broke connection.

          So go to regedit and search for all your mapped drive Ex. \\drive name or IP

          and delete all the entries it finds, mine found only a couple then reboot.  The map drive will work again like it should, but apparently if you reboot it loses it connection again.

          So go back to regedit and
          Then add the following after remapping your drive or else it will fail to connect after a reboot or shutdown.
          [HKEY_CURRENT_USER\Network\X or Y or Z whatever you named it]

          then add dword name “ProviderFlags”=dword:00000001

          I have rebooted numberous times and its still working and wanted to help anyone else out there because this update has been a headache with mapping drives.  I will update if any issues pop up again.

           

          • #2293546 Reply
            anonymous
            Guest

            Had an issue with a smb1 mapped drive which i couldnt access after rebooting, this solved it:

            “then add dword name “ProviderFlags”=dword:00000001”

            Thanks for posting your advice

            I hope everybody who has the same problem, can find your answer.

            Srry for the broken english.

            Have a good day !

      • #2293715 Reply
        WScwjs
        AskWoody Lounger

        Hi,

        Great thank you adding dword name “ProviderFlags”=dword:00000001”  works perfectly.

         

        Stay Safe

        • This reply was modified 1 month, 3 weeks ago by WScwjs. Reason: correct spelling
      • #2294801 Reply
        anonymous
        Guest

        Another way in a domain – edit logon script as follows

        net use Y: /delete
        net use Y: \\example\example /persistent:no

        Important: /persistent:no

      • #2305199 Reply
        anonymous
        Guest

        Before attempting esoteric “fixes” for your NAS not showing in File Explorer (FE) in Win 10 check to see if your malware program is blocking the visibility of the NAS. I discovered by painstaking trial-and -error that on my old VAIO after installing a clean from scratch build (2004 latest as at 17/10/2020) of WIN10Pro x64 my Synology NAS was picked up immediately by the OS in its base standard configuration and a list of its Shared folders cascaded nicely down the left column under “Networks”. Then I installed the current version of “Malwarebytes” (4.2.1.89) which I have endorsed/used for many years and found that it immediately made my NAS disappear from FE Networks along with its folders. Oddly, having pinned the Synology to my “Quick Access” list the folders could still be accessed through QA but not under Networks. Go figure. I discovered that only by disabling Malwarebytes (right-click System Tray icon and select “Quit/Exit”) and rebooting/logging out of my account did this allow the NAS to re-appear as before with its list of Folders. This was repeatable ad nauseam.

        I filed a Support Ticket with Malwarebytes and await their response.

    Viewing 17 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: new Win10 install can’t see smb drives

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.