News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Ongoing bugs in Win10 Fall Creators Update

    Home Forums AskWoody blog Ongoing bugs in Win10 Fall Creators Update

    This topic contains 33 replies, has 11 voices, and was last updated by  anonymous 1 year, 6 months ago.

    • Author
      Posts
    • #155206 Reply

      woody
      Da Boss

      I’m putting together an article for Computerworld, and I’d appreciate your input. Win10 FCU, version 1709, was released on October 17. Since that time
      [See the full post at: Ongoing bugs in Win10 Fall Creators Update]

    • #155211 Reply

      WildBill
      AskWoody Plus

      So sad, & as I’ve said, avoiding upgrading to Windows 10 like the plague. Or at least until 2023… sorry for the mild profanity, but “Windows as a service” sucks slimey cyber-rocks!

      Windows 8.1, 64-bit, now in Group B!
      Wild Bill Rides Again...

    • #155213 Reply

      Noel Carboni
      AskWoody_MVP

      Happy New Year to all!

      I also think it’s lunacy to push two new versions of Win10 out every year

      Hear hear.

      Remember only a few short years ago when voices of reason said “Wait to install any new Windows version until after the first service pack is released“?

      A Service Pack typically took, what, 18 months to develop?

      Does anyone feel that Windows is today less complex than it was when it took Microsoft a year and a half to stabilize it without adding new features, and with a professional testing force on staff? Or that somehow engineers have just found a magical way to do higher quality work in one-third the time?

      This is one of those “What did you think was going to happen?” moments, isn’t it? 🙂

      On the technical front, for what it’s worth with my tweaking (which shuns most everything new and focuses on legacy Win32 desktop operation) I’ve been able to stabilize Win 10 v1709 pretty well. I don’t see it crash or run into many bugs to do the kinds of software development and business management work I typically do. It seems pretty clear Microsoft must not be allowing much change to the core OS functionality, so as not to destabilize it. However, the processes and resources used are increasing alarmingly to accomplish pretty much the same things as before.

      The only specific bug I have seen is one where I have to update by downloading the Windows 10 Cumulative updates from the catalog. It refuses to see them available when I enable the communications pathways then initiate a check for updates from within Settings.

      -Noel

      4 users thanked author for this post.
    • #155214 Reply

      PKCano
      Da Boss

      Woody is asking for specific bug(s) here.
      General discontent with and bashing of Windows 10 “just because” is OFF TOPIC and will be dealt with as such.

      1 user thanked author for this post.
      • #155228 Reply

        WildBill
        AskWoody Plus

        Sorry, pk_cano. I succumbed to temptation… keeping quiet on this thread.

        Windows 8.1, 64-bit, now in Group B!
        Wild Bill Rides Again...

        • #155244 Reply

          Cybertooth
          AskWoody Lounger

          @wildbill, when it comes to Windows 10, it’s very difficult to avoid falling into that “general discontent” mode, so I understand how it happened to you.

          Happy New Year!

           

          1 user thanked author for this post.
    • #155224 Reply

      anonymous

      This would be a good point for @ch100 to chime in, as I’m sure that he’s seen a few bugs in the day-to-day dealings with Windows 10 that may not have been mentioned here.

      2 users thanked author for this post.
    • #155235 Reply

      b
      AskWoody Plus

      Win10 FCU, version 1709, was released on October 17. Since that time, we’ve seen lots and lots (and lots and lots) of bugs. Some of them have been in 1709 since the get-go. Some were introduced by bad patches. Some of them have only become apparent in the past week or so.

      I’ve been following most of the bugs in my Computerworld articles, listed here.

      You’re so keen to pin problems on 1709 you’ve even included issues from two and a half years ago:

      MortazaAnsari, also on the MS Answers forum, says:
      I recently upgraded my computer from Windows 7 Home to Windows 10 Home using the free upgrade. The upgrade was successful but i wanted to clean install so i used the built-in recovery. … EVERYTIME i start my computer it automatically boots to Windows 10 and thats where it loads for about 7 seconds and then an error comes up stating that there is an INACCESSIBLE_BOOT_DEVICE.

      Mortaza reports that reaching into the PC, unplugging the hard drive, booting from a USB restore image solved the problem – but others on that thread haven’t been so lucky
      https://www.computerworld.com/article/3243325/microsoft-windows/win10-fcu-december-patch-kb-4054517-fails-big-time.html

      MortazaAnsari asked on August 4, 2015

      No connection with 1709 or KB4054517 in the entire thread.

      Even the last post three months ago was one week before 1709 was released, never mind patched.

      Knuckle dragger Cannon fodder Chump Daft glutton Idiot Crazy/Ignorant Toxic drinker Blockhead Unwashed mass Seeker/Sucker "Ancient/Obsolete" (Group ASAP) Win10 v.1903

      1 user thanked author for this post.
      • #155262 Reply

        woody
        Da Boss

        You’re absolutely right. Scratch that one off the list. Thanks!

      • #155277 Reply

        anonymous

        @ b

        Yes, that one report is incorrect. But what about the other 5 correct reports about the buggy KB 4054517 for Win 10 FCU/1709.?
        Please present your defense of M$-Win 10 FCU/1709’s bugginess.

        Edit for content.
        Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum

        • #155325 Reply

          b
          AskWoody Plus

          @ b

          Yes, that one report is incorrect. But what about the other 5 correct reports about the buggy KB 4054517 for Win 10 FCU/1709.?
          Please present your defense of M$-Win 10 FCU/1709’s bugginess.

          There are only two known issues with KB4054517, both of which have had workarounds documented by Microsoft for two weeks. The first only applies in quite obscure circumstances (Reset this PC used within a couple of weeks before this update). The second was only a false “update failed” for some users when it had actually succeeded, which was easily verified by alternative methods.

          There are no widespread bugs in 1709 and a few have already been fixed. I and others have not experienced any issues with 1709 or KB4054517 either at home or at work. Woody is making a mountain out of a molehill as usual.

          Knuckle dragger Cannon fodder Chump Daft glutton Idiot Crazy/Ignorant Toxic drinker Blockhead Unwashed mass Seeker/Sucker "Ancient/Obsolete" (Group ASAP) Win10 v.1903

          • #155343 Reply

            woody
            Da Boss

            Much depends upon what you mean by “widespread.”

            I just found out that UPS Worldship and Sage/Peachtree will crash following an upgrade to 1709.

            2 users thanked author for this post.
            • #155811 Reply

              b
              AskWoody Plus

              I just found out that UPS Worldship and Sage/Peachtree will crash following an upgrade to 1709.

              Workarounds for both provided weeks ago (not by Microsoft).

              Knuckle dragger Cannon fodder Chump Daft glutton Idiot Crazy/Ignorant Toxic drinker Blockhead Unwashed mass Seeker/Sucker "Ancient/Obsolete" (Group ASAP) Win10 v.1903

          • #155382 Reply

            anonymous

            @ b

            There are no widespread bugs in 1709

            .
            The point is that the buggy Win10 FCU December cumulative patch KB 4054517 has affected many users, especially Win 10 Home users who are forced-fed updates and upgrades , as evidenced by many such threads at answersdotmicrosoftdotcom just after December Patch Tuesday.

            In this case, it’s the “quality” of the bug, not quantity of bugs.
            https://www.computerworld.com/article/3243100/microsoft-windows/microsoft-confirms-stalled-downloads-bogus-errors-in-win10-fcu-update-kb-4054517.html

            • #155816 Reply

              b
              AskWoody Plus

              In this case, it’s the “quality” of the bug, not quantity of bugs.

              It is about quantity when Woody says, “… lots and lots (and lots and lots) of bugs” and then refers to only a few obscure issues which have had easy workarounds available for weeks.

              Knuckle dragger Cannon fodder Chump Daft glutton Idiot Crazy/Ignorant Toxic drinker Blockhead Unwashed mass Seeker/Sucker "Ancient/Obsolete" (Group ASAP) Win10 v.1903

    • #155240 Reply

      anonymous

      Every major update hoses the home group in unpredictable ways. one time, completely killed it, another the network remained open and available but homegroup insisted there were no other WIN10 pc’s connected, latest homegroup is OK on one PC while the latest upgraded PC has no homegroup but network connectivity remains fully functional.

      One update refused to complete installing at the reboot. I had to manually update again to complete the process.

      Otherwise, once completed, my systems are all ok and stable.

      • #155255 Reply

        woody
        Da Boss

        That’s probably why home groups are getting the axe in 1803

        1 user thanked author for this post.
        • #155433 Reply

          Ascaris
          AskWoody_MVP

          That’s one way of dealing with a problem, I guess.  It’s the same solution that Verizon took with my mom’s DSL service (back when Verizon was her local telephone company).  Her service used to get bogged down and slow to dialup-like speeds during peak hours, and the service on- and off-peak was becoming increasingly unreliable.  Requests for repair from the company revealed that the DSL infrastructure in her area was so old that parts were no longer available; they tried to send her a replacement modem (although I am 99% sure that hers was fine), but it didn’t work.  The type of DSL she had required an obsolete modem that had been out of production for ages; they ended up telling her to buy one on eBay.  The equipment needed to provide that type of DSL on the company’s end was no better.

          Eventually, the company simply told my mom that she was no longer a DSL customer of theirs; they were simply going to mark her address as a DSL-ineligible one (very common in her rural area) and call it a day.  Rather than committing to fixing the problem for what had been a patient customer, they decided it was easier to not even bother trying to fix what was broken.

          I never used Homegroups myself, but I know that some people out there did.  To have MS take away yet another feature that some people find useful is bad enough, but if they’re doing it to avoid the annoyance of fixing bugs they introduced in the process of adding bunches of features no one asked for so they could have something to write in the “what’s new with Windows” blog… well, that’s just crazy.

          Group "L" (KDE Neon User Edition 5.16.4).

          3 users thanked author for this post.
        • #155479 Reply

          anonymous

          For those people like me that needed a new machine with Windows 10 version 1511, home group worked as expected like many other functions. Like the Windows 10 API functionality degradation mentioned by another anonymous, Home group was broken because of Microsoft’s actions.

          Reading examples of frustration encountered by yourself and others whom have resorted to using Dropbox for local network file sharing is tacit confirmation of my claim.

          1 user thanked author for this post.
    • #155257 Reply

      BobbyB
      AskWoody Lounger

      Well strangely, really no system crippling BSOD’s to report or major “oooops” from Win10 1709. Just a couple, one potential security risk given the light of recent events.

      1. .Net 3.5 wont install with either the enabling in “Programs, add and remove Windows features” or the “standalone” download from M$ on a clean install, did @Noel hit this problem? as we are both devotee’s of the clean install. This necessitates the following:

      Dism /online /enable-feature /featurename:NetFX3 /All /Source:D:\sources\sxs /LimitAccess

      Where D:\ is the install medium

      This has affected 2 clean install machines here but scant detail out there as yet after some “Googling”.

      2. Slightly more worrying given the current security advice and the fact that Win10 1709 actively disables “SMB1/CIFS File Sharing Support” it seems that to get Network Explorer to reliably display all machines in a “Workgroup” that this has to be re-enabled to get other machines to show up in, admittedly a mixed “Workgroup” Win’s 7, 8.1 & 10 x64 & x86, not tested on a Domain as of yet here, although at work no such problem seems to manifest in the other versions 1703 & 1607 all x64’s, yet.

      Appart from that no major “niggles” but then again those “updaters” may skip the those problems as presumably they evade these issues from the previous Vers. although here, a combination of 2 new HDD’s and a fervent belief in clean install’s. Has probably thrown up these issues.

       

      Happy New Year Woody and all  🙂

      1 user thanked author for this post.
      • #155399 Reply

        Noel Carboni
        AskWoody_MVP

        1. .Net 3.5 wont install with either the enabling in “Programs, add and remove Windows features” or the “standalone” download from M$ on a clean install, did @Noel hit this problem?

        It’s been a while now since I installed v1709 afresh and my memory for details isn’t what it used to be (I’ve slept since then) but I do see that I managed to get the .NET Framework 3.5 installed – and I don’t recall doing it with DISM. It’s possible I downloaded a .msu file directly from the Microsoft site/catalog I suppose. I do that with Windows Updates regularly anyway and having done so wouldn’t stand out in my memory.

        ScreenGrab_W10VM_2018_01_02_053858

        2. Slightly more worrying given the current security advice and the fact that Win10 1709 actively disables “SMB1/CIFS File Sharing Support” it seems that to get Network Explorer to reliably display all machines in a “Workgroup”…

        Regarding your second point, I have had both computer browsing and SMB1 disabled on all systems for quite a long time, and I DO see a VERY intermittent problem with getting Win 7 shares to show up… I have as of yet been unable to pinpoint why. Almost all of the time accessing files via Windows Networking on another LAN machine works fine as usual by using its UNC share name e.g.,

        \\SVN\C
        

        …but every few weeks just out of the blue it will just fail. It acts like the machine is just not there, but a PING works and and an RDP connection to it will connect just fine. I can wait a minute and try again and voila, it works again. Or if I try using the workgroup name as a domain name e.g.,

        \\SVN.carboni.lan\C
        

        …it works. It’s the strangest thing. It feels like it’s in Explorer, TBH. But it’s not limited to v1709 or even to Windows 10. I’ve seen it happen once or twice from my supremely stable Windows 8.1 workstation as well. Thing is, it’s SO infrequent (having happened once every few months) and it goes away on its own so quickly that I haven’t been able to begin to diagnose it. No errors are logged anywhere.

        A funny thing about intermittency… It feels like it’s slowly increasing with the latest Win 10 versions.

        I have my Win 10 v1709 test VM set to auto-logon via netplwiz. Just booting it up this morning to check my .NET installation and get the screen grab above, I saw winlogon crash during the logon attempt. It left me with a black screen. After a moment I was able to get the logon screen by clicking the mouse, then I logged-on successfully. Now I have an ugly red mark in the Reliability monitor… I’ll take some responsibility for this one, because I am re-theming Windows 10. But I HAVE to do that because the lifeless, flat UI Microsoft provides is so unusable (not to mention buttugly) as to make me lose the will to test Win 10 entirely otherwise. It didn’t crash like this before v1709; I’ve had it automatically logging on forever.

        AnotherWin10Bug

        -Noel

        Attachments:
        5 users thanked author for this post.
        • #157197 Reply

          BobbyB
          AskWoody Lounger

          Thx for your input @Noel as ever greatly appreciated and quite Knowledgble, finally got round the issue by setting the following to “automatic” from manual (default): (run ->services.msc)

          · DNS Client
          · Function Discovery Provider Host
          · Function Discovery Resource Publication
          · Peer Networking Grouping
          · HomeGroup Provider
          · HomeGroup Listener
          · SSDP Discovery
          · UPnP Device Host
          re-enabling NetBios from Default:netbios-enable

          and unfortunately enabling SMB/CIFS1.0 (grrrrr despite the risks)

          A quick delve to add the Win10 briefly to a Home Group (just the main Win10 Machine, not the rest) then removed, and every thing woks a treat first time, every time, every reboot.net-view

          Now i’ll have to change all the Machine ID’s after publishing this lol 😉

          Should we really have to do this for simple networking in, the alleged pinnacle, of Windows 10 flagship OS lol? Never a dull moment it seems thank goodness I don’t get these problems at work .

          Attachments:
    • #155280 Reply

      anonymous

      Machine that will not update due to issues with NVMe & SATA drive installations, keeps trying to update after every failure. My 1511 machine has pulled down approximately 500GB of failed updates, since 1607 was pushed. My main connection is data unlimited by only ADSL so it nearly stop any other traffic while it downloads again.
      Was a bit of a shock when doing some remote support work while visiting my father in-law via tethering to my phone.
      Solution from manufacture and MS clean install on feature updates!

    • #155299 Reply

      anonymous

      I have Windows 10 Home version 1709 build 16299.125 running on a Dell xps8700 4th gen corei7 desktop pc. I think this is the most current build with every update available. However, I just use it for home and personal computing: no gaming or exotic software applications added. I do use GnuCash and Microsoft Money Deluxe Sunset Edition and Microsoft Works 7, which are some pretty old application programs.  So far the one and only problem that I’ve had was one time, about two weeks ago, I turned the pc on and booted it up with the resource monitor running in one corner of the display on boot-up and never touched a thing, not the mouse or keyboard or anything after pressing the pc’s power button to boot it up. I got distracted by something on the TV.  When I came back to the computer about an hour later, the desktop had frozen. Even the clock in the lower right corner on the task bar had stopped; and all the graphs on the resource monitor had stopped. Both the mouse and the keyboard acted as though they were unplugged from their usb ports (they weren’t, I checked). The caps lock light wouldn’t even come on when pressing caps lock on the keyboard. The dvd tray would open and close, and plugging a usb thumb drive into an open usb port seemed to result in the usb thumb drive having power, since its red activity light blinked on and off. But nothing happened on the display (which was solidly connected to the pc, I checked). Nothing I did had any effect as far as getting the computer to respond. I finally had to force it to power off by pressing and holding the power button until it powered off. After rebooting, I never could figure out why this happened. The event viewer revealed nothing other than the computer was rebooted without being cleanly shut down first. And the reliability monitor said the same thing. No indication anywhere that anything was ever wrong, other than me having to force the computer to shut down so that I could reboot. It hasn’t done this again since.

       

      1 user thanked author for this post.
    • #155318 Reply

      anonymous

      Windows Update had apparently selected me as a candidate guinea pig for v1709, even though I had checked using wushowhide and had my WiFi connection set as metered. How vile, thank goodness I hit the power button and disabled the Windows Update service ASAP! It’s quiet and seemingly behaved now… but how the heck am I supposed to get security patches now? I don’t want 1709, why can’t Microsoft understand that?!

      2 users thanked author for this post.
      • #155321 Reply

        PKCano
        Da Boss

        Here is some information that may help you:

        Woody’s ComputerWorld article on turning off Auto updates
        https://www.computerworld.com/article/3241241/microsoft-windows/its-time-make-sure-windows-auto-update-is-turned-off.html

        Woody’s ComputerWorld article on blocking Win10 forced updates
        https://www.computerworld.com/article/3138088/microsoft-windows/woodys-win10tip-block-forced-win10-updates.html

        1 user thanked author for this post.
      • #155345 Reply

        woody
        Da Boss

        Have you tried the nostrums PKCano mentioned?

        • #155692 Reply

          anonymous

          I have my WiFi connection set as metered now, but last time I ran Windows Update it still attempted to download the feature upgrade. The only solution I can think of right now is the one I’ve used all along: disable the Windows Update service. Nuclear option, and I enable it very cautiously *only* to update Windows Store apps (Contrary to what people say, the updates there are at least a heck of a lot smoother than any other update scheme from Richmond). I know I’m going to have to update eventually, but not to a half-baked OS; once 1709 seems stable I’ll throw my hat in and get it updated.
          The main reason why I’m so terrified of installing any Windows 10 feature upgrade is that they break this game I have installed on my computer, to the point the uninstallers don’t even work, so I have to manually uninstall and reinstall the whole game. I’ve done it once, and while I happily managed to get it to work, it was not a pleasant experience at all. This time, I’ll try to uninstall the game before upgrading, and then reinstalling, so I don’t have to delete the game’s registry keys manually. But, as Microsoft seems very happy on taking away from me, I want to have control over WHEN I upgrade so that I can set aside time to do all of this uninstalling, updating, nail-biting, and reinstalling.

    • #155429 Reply

      anonymous

      Hello and happy new year!

       

      There is a problem with latest version of windows 10 (1709) with 8100 officejet pro if your printer is in network mode (via rj-45). It takes 8 seconds to print, but before the last update of windows 10 (1709) this problem didn’t exist. HP and Microsoft know this problem, but they aren’t doing nothing to solve this problem!

      Here are the links:

      https://h30434.www3.hp.com/t5/Inkjet-Printing/My-OfficeJet-Pro-8100-is-slow-to-initiate-a-print-job-after/td-p/6390422

      https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/slow-printing-on-windows-10-after-fall-creators/da51b440-e36f-41d5-9450-dc1dfd0fff02

      Thanks!

    • #155477 Reply

      anonymous

      The Update committed the Cardinal Sin! It changed all my customized windows background colors.

      Believe it or not, this is one reason I have never gone to a Mac.

      It used to be easy to change appearances in Windows. Now, it’s a registry hack.

      And, I was hoping it would get rid of the Ribbon in all my Office apps and return them to a sensible menu …. (that was just magical thinking).

    • #155558 Reply

      AlexEiffel
      AskWoody_MVP

      I went to my parents last night for the holidays. My father said his old HP 1018 printer stopped working. Fearing the worst, I asked if he noticed Windows making a big update. He had no idea.

      I went downstair to look at the computer and it had finally updated its 1607 version to 1709, skipping 1703. That’s the first of those home versions I set up that got upgraded. The bug was really weird. You could send something to the printer and it would not even seem to reach the queue. Nothing would get sent, like it would be thrown in the void. The printer’s status would switch to online in Windows when turned on so it looked like it worked, but apparently no document could reach it!

      To fix this, I just deleted the printer and restarted Windows, then it found it and reinstalled it without even telling me anything and everything worked. Easy for me to find and fix, but not for someone who can’t even figure out Windows “feature updated”. How could he not see all these new ad tiles all over the place and the new contacts icon on the far right? He doesn’t seem to use the start menu, he just clicks on the shortcuts I put in the taskbar to start his apps, just like in the old days of Win XP. And, he doesn’t care that much about the way his computer looks, he doesn’t notice these things. He just uses Windows to start his apps.

      Some could say it is not a new bug of 1709 since I have seen it many times during previous feature upgrades. A PC gets feature upgraded, then printers stop working. You download the same old printer driver from 2013 on the manufacturer’s web site, reinstall it, and voilà, you have a printer working again. I just wouldn’t like to be a normal user having to deal with this by myself with no outside help.

      I still wonder how Microsoft think they magically made upgrade installs better than clean installs for 10 when they never seemed to get it right in any other non constantly changing Windows version. And I wonder if when going from 1607 to 1709 skipping a version, did they convert everything right or they ran on the assumption that everyone is going to upgrade to all versions never skipping one, concerting and cleaning properly only for the previous version? What if I updated that offline PC on 1511 to 1709? That’s a lot of conversions to support, but they are, obviously, out of support after 18 months so I guess that kind of answer the question and one should never rely on this for those. But from 1607 to 1709, skipping only one version and upgrading from a supported version to another? Do the forced beta testers know, or they are like my father for the most part and don’t even notice that their OS got a full install? “At Microsoft, we thought we could save money and do a better job by replacing professional testers by a much higher quantity of free beta testers who don’t notice a full upgrade of their OS”.

      How come I have seen this bug many times with different brands of printers on a few stations for different version of Win 10 and it is still happening? Not all the PCs I manage did that. But maybe 5%? It doesn’t seem to me like it should still happen if the QC is working.

      1 user thanked author for this post.
      • #155737 Reply

        teuhasn
        AskWoody Lounger

        I’m running the latest version of 1709 (Pro, though) on two PCs for almost two weeks now with no issues. One of these PCs is also connected to an HP 1018! My 1018 hasn’t had any problems with 1709 or Win 10, but I’ve consistently used wushowhide to block Microsoft’s monthly attempt to update the driver for the 1018. That extra step can be too complicated for many users. It was much easier to teach someone how to block a hardware driver update in Win 7. As you noted, the 1018 driver HP put out in 2013 runs fine in the latest version of 1709.

    • #155582 Reply

      anonymous

      There’s an easily reproducible bug in the SysListView32 API in 1709. Using an affected application such as 7-Zip, open an archive which contains enough files to require scrolling. Now attempt to highlight some files with the mouse – it will instead scroll to the end of the list.

      https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/syslistview32-mouse-selecting-bug-after-windows-10/9e217971-2be2-47ce-af76-dbc255acd8d1?auth=1

      2 users thanked author for this post.
    • #169597 Reply

      anonymous

      in windows 10 build 1709 workgroup w/o a server – able to ping and see other computer in file explorer but unable to connect to it, map drive, access it…    I’m just glad I’m not the only one plagued with this. leaning to installing windows server to share / host quickbooks in multi user mode but concerned problems will continue to pop up – maybe less so – it’s only with shares – everything else printing, Internet works fine. tried many solutions nothing – then it works – then it doesn’t….. thank you microsoft

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Ongoing bugs in Win10 Fall Creators Update

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.