• Outlook 2016 strips links from Windows Secrets newsletters

    Home » Forums » AskWoody support » Productivity software by function » MS Outlook and email programs » Outlook 2016 strips links from Windows Secrets newsletters

    Author
    Topic
    #506318

    Beginning about a week ago, Windows Secrets newsletters have arrived in Outlook without active hyperlinks. I’m referring to the links following the title of each thread in the newsletter. Oddly enough, the “unsubscribe” link at the end of each newsletter is still active, however. Another oddity: after the first two days of linkless newsletters, on the third day the links were restored. But the next day the newsletters were back to being linkless. Is anyone else having this problem? Has there been a change in the newsletter formatting, or is there a setting in Outlook that is causing this. This is not a problem with any other emails, only Windows Secrets.

    Fafner

    Viewing 16 reply threads
    Author
    Replies
    • #1571455

      Beginning about a week ago, Windows Secrets newsletters have arrived in Outlook without active hyperlinks. I’m referring to the links following the title of each thread in the newsletter. Oddly enough, the “unsubscribe” link at the end of each newsletter is still active, however. Another oddity: after the first two days of linkless newsletters, on the third day the links were restored. But the next day the newsletters were back to being linkless. Is anyone else having this problem? Has there been a change in the newsletter formatting, or is there a setting in Outlook that is causing this. This is not a problem with any other emails, only Windows Secrets.

      Fafner

      I’m having the exact same problem with Outlook 2010.

    • #1571565

      Check whether Windows/IE’s SmartScreen is playing a part in this?

    • #1571567

      Do you have an email contact for Windows Secrets?

      --Joe

      • #1571592

        I’ve recently had the same issues with Outlook 2010.
        Messages which contained hyperlinks wouldn’t respond (open default browser to show content) when clicked.
        I use Firefox as my default browser, but made IE11 default to get a comparison.
        After doing this, hyperlinks, when clicked, then would show a ‘How do you want to open this?’ dialog box.

        Opting to use Firefox (or any other browser) the link(s) would open to view the content in the chosen browser as I would have expected.
        Any further clicking of the same link in the message, or a link in any other message continually generated the same ‘How do you want to open this?’ box.
        Making Firefox default again still generated the above dialog box after clicking links.

        What cured the issue for me was to go to this page: You are prompted to specify Internet Explorer when you click a link in Outlook 2010 or Outlook 2007https://support.microsoft.com/en-gb/kb/3094186 – and using the ‘Easy Fix’ download.

        Links would open immediately in Internet Explorer 11, but after changing the default browser back to my preferred Firefox, links always open in Firefox now as I want.

        Perhaps a recent update has caused this problem for some users of Outlook when certain scenarios are present on their system.
        Note: the Easy Fix creates a Restore Point during the fix process.

        • #1571705

          I have read the above replies and they don’t seem to apply to my case. Bypassing Smart Screen or any other fix relating to a browser doesn’t apply, because it’s not a browser issue. If I open the email in my ISP’s web site, the links are good, but when the messages are downloaded to Outlook, the links are no longer there. The text of the links is there, but it is no longer a hyperlink. It’s plain text in black, not a hyperlink in blue. It doesn’t seem to be an Outlook setting issue, though, because if I open older messages that I have saved, the links in those messages are active. It’s just in Windows Secrets messages received within the last week or so that the problem exists. And, as I said, the final “unsubscribe” link at the end of the page is still active in the new messages.

          The fix posted by Moonshine, above, isn’t applicable either. That message refers to “links that wouldn’t respond.” I don’t have links that don’t respond. I just don’t have links at all.

          To answer another question, yes, I have an email contact for Windows Secrets in Outlook.

          Fafner

    • #1571712

      With W10, at least, SmartScreen isn’t ‘just’ for browsers according to the MS spiel built into W10 when you work through the privacy etc. options. Also, different UAC settings might change the way messages from SS are displayed.

      In W7 it was just for browsers, sure.

      If you’re using W8 > 10, the best way to check whether it’s interfering or not is to completely disable it and reboot to test.

      Log into your webmail and check the original email content as well, the problem might be triggered closer to source.

      • #1571757

        I’m running Windows 8.1. I tried disabling SmartScreen, rebooted, and it made no difference. Didn’t help.

        I did try logging into web mail. When I do so, the links are there and they work. It’s when they are downloaded into Outlook that the links are stripped out.

        Fafner

    • #1571758

      It could be the Outlook Junk/phishing filter, though the following Article states that all links would be disabled but with the message open in the reading pane, there would be an option in the InfoBar to Enable links and other functionality (not recommended): Turn on or off links in email messages (Applies To: Outlook 2016 , Outlook 2013)

    • #1571867

      Not a fix, just a workaround, but do you see a link to “Click to see the newsletter online” at the start of the email? If so, do that and read in your browser, where all links should work. If that doesn’t work, enter windowssecrets.com/newsletter/ into your browser, from where you can select the one you want to read.

      • #1571948

        I read the message about the Outlook junk/phishing filter that satrow posted, as well as the link in his message, and it doesn’t seem to apply to my case. Except for the fact that the links are stripped (the link text appears, but they are not formatted as links (not blue) and not clickable), the messages appear to open normally, and there is no InfoBar.

        As for workarounds, there are lots of them. Currently, I am copying the link text and copying it into my browser. It’s not that I can’t get into Windows Secrets posts. I’m just trying to figure out why there are no links (except the unsubscribe link at the end, which is live) in the messages. As I said, this is not an issue with any other emails, only with Windows Secrets. So that seems to indicate that something in the formatting of the Windows Secrets newsletters has changed. Again, as I said earlier, saved Windows Secrets newsletters from more than a week ago have all the links intact. It’s just the recent newsletters that have this problem.

        Fafner

    • #1572377

      That’s bizarre. Do the links in the WS newsletters from more than a week ago still work? I have checked the links in my recent WS newsletters (most recent being 2016-07-28), and all the links (blue text) work for me. That suggests that the problem is not in the emails themselves, but in your PC. But if something has changed in your PC, then those older links should also not work any more either. Have you changed something in your default browser? Have you tried a different browser? If you have an alternate browser, make it the default and see what happens. If you can copy the link text and paste it into your browser, and that works, it suggests a problem in the interface between Outlook and your browser, but that still doesn’t explain why the older WS newsletters work and the current ones don’t.

      Have any other WS readers had this problem?

      • #1572664

        That’s bizarre. Do the links in the WS newsletters from more than a week ago still work? I have checked the links in my recent WS newsletters (most recent being 2016-07-28), and all the links (blue text) work for me. That suggests that the problem is not in the emails themselves, but in your PC. But if something has changed in your PC, then those older links should also not work any more either. Have you changed something in your default browser? Have you tried a different browser? If you have an alternate browser, make it the default and see what happens. If you can copy the link text and paste it into your browser, and that works, it suggests a problem in the interface between Outlook and your browser, but that still doesn’t explain why the older WS newsletters work and the current ones don’t.

        Have any other WS readers had this problem?

        I wasn’t the original poster on this problem, someone with a different version of Outlook was. Older emails have links that are working properly. If I copy and paste a non-working link into a browser, it works.

        • #1572710

          Yes, as I said, links in older messages still work.

          Here’s another clue that will maybe mean someone to somebody. My Windows Secrets subscription is via a Yahoo email address. Again, to repeat what I wrote before, when I open yahoo mail in my browser, the links are all there in the messages, but when I download the messages into Outlook 2016, the links are gone (but the text of the links is still there). This morning I tried an experiment. Using Outlook, I forwarded one of the linkless newsletters to two other of my email addresses. One is a POP/SMTP account, like yahoo is, and the other is an Exchange account. When I downloaded the messages into Outlook using these other accounts, all the links were restored!

          I also tried simply copying a linkless message into a folder in one of those other accounts, but simply copying the message did not restore the links.

          Any ideas? Why would Outlook strip the links from a Yahoo message but not from the same message received via another account? Again, let me repeat, the “unsubscribe” link at the end of the messages is still there, but all the others are stripped.

          Fafner

    • #1572815

      Perhaps you have the Windows Secrets contact set to receive email as text only.

      --Joe

      • #1572845

        No, I don’t have the Windows Secrets contact set to receive email as text only. As I wrote in earlier posts, the unsubscribe link at the end of each post still works. Also, as I wrote earlier, when this behavior started, I got linkless posts for two days, then one day of posts with links, then back to the linkless posts again. During that time, I didn’t change any settings.

        Fafner

    • #1572847

      Fafner

      Out of interest, whilst viewing the newsletter in its own window, if you selected all the content (Ctrl + A) and then opted to Edit the message via Actions in the ‘Move’ group, then clicked the ‘Format Text’ tab and opted for ‘HTML’ and then saved the edits (Ctrl + S).
      When the message window is closed, then reopened, do the links now become active and stay active?

      My images are from Outlook 2010 so will look a little different to your version.

    • #1572923

      Moonshine, this was an intriguing suggestion, and it worked! The original email was formatted as plain text, and changing it to HTML restored the links. So where is the setting that causes Lounge emails to be received as plain text? I have the Lounge as one of my contacts, but I can’t find any setting that would affect how the emails are received. Could someone steer me in the right direction?

      Fafner

    • #1572968

      See if E-mail Properties for contact addresses in Outlook 2013 and Outlook 2016 helps with determining the contact settings.

      --Joe

    • #1573085

      I couldn’t find anything in that resource that helped. Is there something there that refers to formatting of received emails. I couldn’t find it.

      Fafner

      • #1573319

        Well, I have partially solved the problem, but it raises another question. I was looking at my Windows Secrets Lounge entry in my contacts, trying to find something in its properties that would cause messages to download as plain text rather than HTML. Unable to find anything, I deleted the contact entirely. This morning, Lounge posts all appeared in Outlook with links restored. Although the problem has been more or less solved, I would still love to know why creating a contact causes messages to download as plain text.

        Fafner

    • #1576873

      I am revisiting this question because the problem has returned. To recap, emails from Windows Secrets Lounge arrive as plain text, with the result that all the links in the text are inactive (they’re just the text of the url and are not clickable). This problem went away when I deleted Windows Secrets Lounge from my contacts. The problem returned yesterday. But here’s another piece of strange behavior that may provide a clue: If I forward the messages to myself at the same email address, they arrive as HTML. So, somewhere there must be a setting that causes messages from Windows Secrets Lounge, and ONLY messages from Windows Secrets Lounge, to arrive as plain text. I have spent hours trying to find where that setting may be, but I have not found it. Can someone please help?

      Fafner

      • #1578187

        Beginning about a week ago, Windows Secrets newsletters have arrived in Outlook without active hyperlinks.

        I am revisiting this question because the problem has returned. To recap, emails from Windows Secrets Lounge arrive as plain text, with the result that all the links in the text are inactive

        Newsletters, notifications or both (as they come from different addresses)?

    • #1578170

      Just a thought, but you don’t say (I think?) what anti-virus program you are using. Some AV programs have email scanners included, and if they see something in the HTML code that they don’t like, they may convert a message to plain text. There could be something in the WS Newsletters which is setting this off, and the recent recurrence could be due to an updated definition. If your AV has such a scanner, try turning it off. The links to unsubscribe etc. at the end of a Newsletter would still work, because they are email addresses and not URLs.

    • #1578290

      To respond to the two above posts: I am using Windows defender. I looked at the settings and didn’t find any place it its settings that might do what you suggest. Also, that doesn’t sound like it could be the problem. If I forward the email to myself at the same email address, it arrives as HTML, with the links restored. If there were something in the HTML code that the AV program is causing to turn the message into plain text, wouldn’t it still be there when forwarded? It’s only when the email arrives from Windows Secrets Lounge that the message is turned into plain text.

      In reply to the second post above, I’m referring to the daily emails from Windows Secrets Lounge, giving summaries and links to all the posts in the previous 24 hours. I’m not sure what the distinction is between newsletters and notifications. I’m not referring to the weekly (or so) newsletters from Windows Secrets. Those arrive as HTML, or at least they did until something inactivated my subscription (I’m informed that it’s been reactivated, but there hasn’t been a newsletter since then).

      Thanks to both of you for your replies, but the problem still continues.

      Fafner

    • #1578940

      I have the same issue.

      The problem appears to be restricted to the new post notifications in subscribed threads from Windows Secrets Lounge. Links appear as plain text. In all my Outlook 2016 email, Windows Secrets Lounge new post notifications are the only emails whose links are affected. Windows Secrets Newsletter links all appear as links, not plain text. Links in all my other emails from various sources appear as links.

      I went back chronologically, and the last new post notification email that appeared normal (links are actual links instead of plain text) was 8/31/2016. Everything after that date has url’s for new post alerts as plain text, not hyperlinks. Interestingly enough, if the quoted post contains a hyperlink, it shows as a hyperlink, not as plain text.

      I can find no settings in my Lounge Profile that have any relationship to how emails from Windows Secrets Lounge are formatted, only which types of notifications I wish to receive (PM, new posts, etc.). I have no Outlook Rules that convert hyperlinks to plain text.

      Interesting puzzle.

      Always create a fresh drive image before making system changes/Windows updates; you may need to start over!
      We were all once "Average Users". We all have our own reasons for doing the things that we do with our systems, we don't need anyone's approval, and we don't all have to do the same things.

      • This reply was modified 4 years, 2 months ago by bbearren.
      • #1580764

        I just thought I’d add a final note to this thread. Two days ago, Lounge newsletters once again started appearing in Outlook as html, with links attached. As far as I can tell, this was the result of no actions on my part. I didn’t change anything about my Outlook or Office installation.

        Fafner

        • #1580765

          I just thought I’d add a final note to this thread. Two days ago, Lounge newsletters once again started appearing in Outlook as html, with links attached. As far as I can tell, this was the result of no actions on my part. I didn’t change anything about my Outlook or Office installation.

          Fafner

          Similar here. The only emails I had problems with were notification emails of new posts in threads in The Lounge. The links were there, just not active. Yesterday they started working again. I’ve done nothing.

          Always create a fresh drive image before making system changes/Windows updates; you may need to start over!
          We were all once "Average Users". We all have our own reasons for doing the things that we do with our systems, we don't need anyone's approval, and we don't all have to do the same things.

          • This reply was modified 4 years, 4 months ago by bbearren.
    • #1581263

      As this has affected more than one user, it would seem that the messages were actually being sent in plain text format, or possibly in Rich Text format? I don’t know much about RTF, or whether such a message would have active links, but in my Outlook settings there is an option “When sending messages in Rich Text format to internet recipients…..”, where the options are “Convert to HTML format”, “Convert to Plain Text format”, and “Send using Outlook Rich Text format”. It is possible that this option was set incorrectly at the sending end, but has recently been fixed.

      • #1581374

        On the 8th of October I reported that messages from the Lounge had started coming in as HTML, so the problem seemed to have been fixed (not at my end, because I had made no changes). Well, yesterday and today the messages once again reverted to plain text. I changed nothing here. In fact, I’ve been away from the computer for a couple of days. But now I have, on the same screen and in the same Outlook folder, messages from yesterday and today in plain text and messages from several days prior to that in HTML.

        Fafner

    Viewing 16 reply threads
    Reply To: Outlook 2016 strips links from Windows Secrets newsletters

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: