News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Password save in Win 10 2004

    Posted on marklang Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 10 Windows 10 version 2004 – May 2020 Update Password save in Win 10 2004

    Topic Resolution: Resolved
    Viewing 9 reply threads
    • Author
      Posts
      • #2311919
        marklang
        AskWoody Plus

        I have been having a very specific problem with saved passwords (credentials) in my recently upgraded Windows 10 2004.   I know that Susan Bradley mentioned that many people are having problems that may related to third party software (HP).  In my case, Windows no longer remembers the password for one of three NAS drives I have on my local network.  The device with the problem is made by Thecus.  I also have two Syn0logy NAS drives on the local network, and neither of them is having a problem.   I have not noticed any other issues.  Only when I try to access the Thecus device, I get an error that the password is invalid and asks me to enter one.  I enter it, and mark to save in credentials.   It will then work until I next boot up, when the error comes back.

        I have tried running sfc /scannow.  It found an error with a .NET file that was fixed, and gave a warning about some windows system files having multiple owners.  But it did not fix the problem.   I also created a local computer account, and logged into it.   Then I logged back into my online Windows account.  Again, no benefit.

        Are there any other suggestions?  I know it seems to be a bug in 2004, but I am hoping there might be a workaround until Microsoft fixes it.  Thanks.

      • #2311982
        Paul T
        AskWoody MVP

        That seems like a corrupt Windows credential store.
        This post has possible fixes.

        cheers, Paul

        • #2311988
          Alex5723
          AskWoody Plus

          @Paul T

          WOT has flagged the URL to Windows report..

          Attachments:
          • #2315292
            Kirsty
            Manager

            This should overcome that problem:

             
            Windows 10 2004: ‘Credentials Manager’ broken [Workaround]
            By @gborn | Aug 13, 2020

            Workaround could help
            Then I came across this article and the post from Latest, which describes the issue of the credential management in Windows 10 May 2020 Update (version 2004) not storing passwords. The automatic login to websites and services like Outlook, Adobe Creative Cloud, OneDrive, in Google Chrome, Microsoft Edge or in VPN networks fails afterwards.

            In general, a workaround is described as removing the Microsoft account from the settings page and then creating a local user account. After a restart, the local user account can be changed to a Microsoft account. Then the login should work and the login data will be saved. Anyone affected?

             
            Read the full article here

            • #2315330
              marklang
              AskWoody Plus

              As I noted, this work around did not work for me.  Thanks.

      • #2311999
        Paul T
        AskWoody MVP

        The advice is still relevant.

        OK on VirusTotal.

        “You gave this site a bad report” implies it was you who flagged that site. What does the full report say?

        cheers, Paul

      • #2312001
        Alex5723
        AskWoody Plus

        “You gave this site a bad report” implies it was you who flagged that site.

        No, it wasn’t me. Never visited the site.

        It says on the front “Potentially unwanted programs”

        Attachments:
      • #2312078
        b
        AskWoody Plus

        I have been having a very specific problem with saved passwords (credentials) in my recently upgraded Windows 10 2004.

        Are there any other suggestions? I know it seems to be a bug in 2004, but I am hoping there might be a workaround until Microsoft fixes it. Thanks.

        Use the PowerShell command to search for any scheduled tasks which use the “S4U” (service for user) LogonType, as advised by the following Microsoft Community answer and Microsoft Support article:

        Systemwide password amnesia (v2004 build 19041.173)

        Outlook and other apps won’t remember password after Windows Updates

        If any are found, disable those tasks (or change them to “Do not Store password” or “Run only when user is logged on”) as explained in that answer and linked source.

      • #2312108
        marklang
        AskWoody Plus

        Thanks for the advice.  I followed the suggested leads.  I changed the permissions on the Microsoft>Vault file.  I made the Credentials service start on automatic.  I searched for S4U tasks, but found none.   (The problem is with an NAS on the network.)  Right after that, when I tried to access my Thecus drive I got the following message

        Permissions

        This was worse.  I could not access the drive at all.  I rebooted the computer, and I seem to be back to where I was — with the same problem.  I tried deleting the device in Windows Credentials and re-establishing it.  This time I also set up an entry for the IP address of the device.  I will have to see what happens.

         

        Attachments:
        1 user thanked author for this post.
        b
      • #2312155
        PaulK
        AskWoody Lounger

        Does the password on the Thecus have (about) the same format as the other passwords: length, upper/lower case, special characters, etc.?
        Hypothesis: The password-storing routine is losing its mind over some quirky syntax test.
        Test: Temporarily change the Thecus password to be the same as that on one of the ‘OK’ units.

      • #2312477
        marklang
        AskWoody Plus

        Thanks for the suggestion, PaulK.   Since this is my local network, the password for the Thecus device is the same as the one for my main Synology NAS.  And it is fairly simple.   So the problem must not relate to the password form.   It seems like some kind of Windows link or memory related to the Thecus must have been corrupted  when I made the upgrade to Windows 10 2004.   I tried deleting the entry in Windows Credential Manager, and then creating a new one.  That did not fix it.  I am not sure where else to look.  My login account for the Thecus is valid, as it still works when I don’t get the permission error and I manually enter the password.   I am not sure what else would make Windows think it is inaccessible.

        Yesterday, I had the problem with permissions again that I noted earlier.  I got the message that the Thecus is not accessible and I might not have permission to access.   I have all my NAS drives mapped to Windows.  However, at that time, I noticed that the mapping for the Thecus did not show in file explorer.   This morning when I booted up, the mapping was back, and I did not get the permission error when I accessed it.  Nevertheless, I still have to enter my password.

        I can live with having to enter the password for a while.  However, when I get that permission error I cannot access the device in any way.   Does anyone have any idea what might be causing that, or what I can do trace the problem or repair or work around?  Thanks.

         

      • #2315290
        marklang
        AskWoody Plus

        Just an update.  I have now tried every workaround I have seen suggested.  I have tried logging into a local account on my computer, rebooting, then switching back to an online account.  I tried the recommendations to make Credentials Manager run in automatic mode, and to enable permissions in the associated folder.  (This seemed to cause permission access problems for a while, but that seems to have gone away.)  I tried deleting the Thecus device entry in Credentials Manager, and setting up a new one.  I tried running sfc /scannow.   I even tried creating a new registry Dword(32) key named ProtectionPolicy at HKEY_LOCAL_MACHINE\Software\Microsoft\Cryptography\Protect\Providers\df9d8cd0-1501-11d1-8c7a-00c04fc297eb and setting it to 1, which is supposed to fix some problems with saving of credentials.   None of these things helped with my issue.

        Interestingly, my issue is still very narrow.  While most people having troubles with Win 10 2004 credentials seem to lose passwords all over the place, I only have a problem with my NAS device made by Thecus.  My other NAS devices made by Synology work fine.  My OneDrive password works fine.   In fact, once I set the password for the Thecus, it does seem to be retained as long as I am logged into the computer (although this may just be that the login to the Thecus is remembered).    However, the first time I try to access the Thecus after a new boot I have to re-enter the password.

        Perhaps this is just one example of the error in Win 10 2004 and I will just have to wait for Microsoft to fix it.  Any other ideas are welcome.  Thanks.

      • #2318063
        marklang
        AskWoody Plus

        I am not sure why I cannot find the post here now, but I did receive a suggestion that seems to have worked.  Apparently, this is an issue with the version of smb network protocol.   I was instructed to run Powershell as administrator with the command Get-SmbConnection.  That gave me a list of all my currently active NAS devices and what version of smb they were using.  It turns out that the Thecus is using smb 1.5.

        I was then instructed to run RegEdit, navigate to key HKEY_CURRENT_USER/Network.  I found the letter for the Thecus drive mapping, and I added a DWORD(32-bit) key named ProviderFlags and gave it a value of 1.  The next time I booted up the computer, I had to enter the Thecus password.  However, after that it seems to remember the credentials.

        The main reason I have the new Synology NAS is because I was running out of storage and needed to add more disks.  However, the Thecus N7700PRO has not had any firmware updates in many years.   Thecus now has a newer version of the product, and apparently any new software is not compatible – so they are not updating the old systems.  That is why it is stuck on smb 1.5, and I have no options of which I am aware to change that.  I discovered that Synology apparently uses an architecture where all of their devices can run the latest version of their software.   So I elected to purchase a large, fast Synology NAS for my increased needs.  My new Synology NAS is running smb 2.0.2.   I also gets firmware updates regularly.

        Interestingly, I also have an even older small Synology 2-drive NAS that was my first NAS but I really don’t use any more.   It was running the latest Synology firmware.  However, it was set to use smb 1 probably as a legacy.  For some reason, while I did have trouble with this NAS automatically connecting at bootup, I was not having the credentials problem with this one — even though it showed using smb 1.5, also.  It must be something in how the Thecus implements smb.   I was able to reconfigure the old Synology to run smb 2.0.2 like the new one.  (I had to unmap and remap the drive, and change the firmware configuration.)

        I am not exactly sure what that registry key did, but it seems to be a workaround for my problem.   Thanks again to everyone for the assistance.

    Viewing 9 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Password save in Win 10 2004

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.

?
This website collects data via Google Analytics. Click here to opt in. Click here to opt out.
×