News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Power Options question

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 Power Options question

    This topic contains 13 replies, has 7 voices, and was last updated by  RetiredGeek 2 weeks, 4 days ago.

    • Author
      Posts
    • #1984389 Reply

      BobStr
      AskWoody Plus

      I have Win 10 Version 1809, which I’m running on a laptop. Power Options seems to work differently on my laptop than on my old desktop with Win 7, and I’m wondering whether I’m doing something wrong, or whether it’s by design that the laptop acts differently (and if so — just my curiosity — whether that’s a function of Win 10 or of the hardware).

      I have a program (eXtreme Gammon, AKA “XG”) which, among other things, analyzes backgammon positions. Depending on the settings, any particular analysis can take a very short to a very long time. On my Win 7 desktop, the computer doesn’t go to sleep while the XG analysis is running. If, say, I have Power Options set to put the computer to sleep after 5 minutes of inactivity, the computer waits for XG to complete its analysis, waits another 5 minutes, and only then goes to sleep. On my laptop, however, the computer goes to sleep regardless of whether XG is running an analysis. I therefore always have to remember to change the Power Options setting (sometimes to “Never”) to accommodate my estimate of how long a series of analyses are going to run; otherwise, the computer goes to sleep in the middle of it all.

      Any thoughts on why that is and whether I can do anything to change it?

      Thanks.

      1 user thanked author for this post.
    • #1985815 Reply

      Bluetrix
      AskWoody MVP

      @BobStr,

      I have talked to a few people about this issue in Windows10. I’ve had this same question on the back burner for some time. The consensus is: you can’t delay the selected sleep time so a program can complete running before sleep-mode does it’s thing – sleep. My question is and was, why couldn’t I use the [/requestsoverride] command to do this. Because it’s not in the Power Request override parameters for a particular process, service, or driver. Besides, that’s not something the everyday user is comfortable doing. So the bottom line now is, “It’s the nature of the beast.”

      I really hate being told I can’t do something with my OS.

      I did find a program that may help you at:

      Windowsreport.com

      That web page shows (9) Apps that can prevent windows from going into sleep/hibernate mode. I looked for a simple one of those (9) and decided to test: Caffeinated

      It was designed to run on Windows7. I downloaded and tested it on my laptop, running Windows10 Home this weekend. I tested several time options. Options range from 5 minutes to 5 hours to indefinitely. It worked as advertised. I admit, I didn’t try the “indefinitely” or “5 hour” settings.

      nosleep

      You do not have to alter your current power settings. Your power settings resume after “Caffeinated” completes it’s countdown. If you have a 15 minute sleep setting and enable 1 hour on “Caffeinated”, sleep mode kicks in after 1 hour and 15 minutes.

      It’s simple to use, it’s portable and has a tiny footprint. If you download and install the program on your system, a coffee cup icon will appear in the hidden section next to the clock tray.  You can Pin it to the Start Menu, or drag it to your tool bar. One click turns it on/off, the default setting is “indefinitely.”  Have a look-see at those (9), use one … or not. I’ll keep the one I downloaded, I know it works 🙂
      HTH

      Windows10 Home 1809 | Mint19 on VM

      Attachments:
      2 users thanked author for this post.
    • #1985830 Reply

      PKCano
      Da Boss

      I have been using that on my Mac for years. I works really well. When I’m working I set it to indefinitely. That way I can go eat lunch and the machine doesn’t sleep or screensave. But one click changes from a full cup of coffee to to an empty cup, and it’s off so sleep and screensaver can take over.

      Screen-Shot-2019-10-20-at-8.17.18-PM

      Screen-Shot-2019-10-20-at-8.17.58-PM

      Attachments:
      1 user thanked author for this post.
    • #1986990 Reply

      NightOwl
      AskWoody Plus

      @ PKCano

      I have been using that on my Mac for years.

      Your *using that* implies that you are using the *same program* (i.e. Caffeinated as mentioned above by @ Bluetrix), but it appears that technically those two programs are not the *same*.

      It appears that *Caffeine* (by Lightheadsw–from your *about* screenshot information, but now is currently developed by IntelliScape Computer Solutions ) was developed first for the Mac, and then Desmond Brand lifted the User Interface (UI) from *Caffeine*, and then ported his program to run on Windows back around Sept. 19, 2011, and he called it *Caffeinated*.

      Desmond Brand states on this webpage that his program requires *.Net 3.5* to run, and has only been tested on Win7: http://desmondbrand.com/caffeinated/

      But, this LifeHacker website says it works under Win10 without any problems: https://lifehacker.com/prevent-your-windows-pc-from-sleeping-with-caffeinated-1832271248

      So, the two programs *look the same*, but are obviously designed for two different OS’s.

      And, just to make it more confusing–someone else (Zhorn Software: https://www.zhornsoftware.co.uk/caffeine/index.html ) has developed a Windows based program that performs the same function as the Mac software, and has called their program *Caffeine* as well. I did not find a screen shot of the Zhorn Caffeine program–so don’t know how it appears when running.

      But, your *about* screenshot states a copy write dated as beginning in 2006. The Zhorn website’s earliest version date listed is 2008. So, I have to say the original Mac version was first based on the available info.

      NightOwl

      No question is stupid ... but, possibly the answers are 😉 !

    • #1987062 Reply

      Bluetrix
      AskWoody MVP

      Desmond Brand states on this webpage that his program requires *.Net 3.5* to run, and has only been tested on Win7: http://desmondbrand.com/caffeinated/%5B/quote%5D

      Had you read Desmond’s Blog as I did, you might see it a bit differently. Besides, I have yet to see PK attest to something they didn’t know a little something about. 🙂

      The two programs are basically the same, one is for MacOS.

      I use an excellent if simple program called Caffeine on OS X. Its only purpose is to temporarily prevent your computer from automatically sleeping, or displaying the screensaver. A similar program called Insomnia is available for Windows, but I dislike its UI.

      So, I built Caffeinated. It’s a port of Caffeine that runs on Windows. The UI is straight-up lifted from Caffeine, and the entire program is pretty much just a usable wrapper around the SetThreadExecutionState function from the Windows API.

       

      Windows10 Home 1809 | Mint19 on VM

    • #1987078 Reply

      NightOwl
      AskWoody Plus

      @ BobStr

      Any thoughts on why that is and whether I can do anything to change it?

      Well, I think you have stated *the obvious* already–Win7 is different from Win10, and a laptop is not the same as a desktop computer. To expect those differences to have the same outcome on the Power Options–could happen–but I’m not surprised that it’s not happening!

      I have a desktop and a laptop with the same OS on it, and even the very beginning of using the OS on each is *different*–the log in screen on the laptop has the dialog box opened and ready to type in the password. The desktop requires that I mouse click on the screen to open the dialog box before I can start typing the password.

      And slightly different issue, but similar in the actions–I have a screen saver set, and it almost always is triggered to switch into the screen saver if I spend too much time just scrolling and reading a long webpage. I have to be clicking on things for the system to register that there is *activity* occurring. But, ever so often, if some other program is working in the background, that activity is being registered and prevents the screen saver from kicking in. I have no idea what the exact *activity* is going on that’s somehow *different*.

      But, to your question:

      … whether I can do anything to change it?

      The above link by @ BlueTrix plus the *Caffienated* program he references are basically *timers* that will prevent the Power Options from kicking in for a designated time. Sure, they’re easy to click to set, but you might as well just open up the Power Options dialog, and set the time out timers there.

      But, I stumbled upon a *solution* that may very well *mimic* how your Win7 OS was waiting until your eXtreme Gammon (AKA “XG”) has finished doing it’s calculations. I found it here: https://www.itechtics.com/tools-prevent-windows-10-sleeping/

      It’s in the one Comment at the bottom of the page:

      Flo
      May 22, 2019 @ 8:12 PM

      Have you heard of econap? That’s a good tool to prevent the standby while your pc is doing something

      Click here: Econap

      There’s multiple triggers that you could set to detect when there is activity occurring that you want to have continue until the calculations are done, and you can set the sensitivity of the triggers so they properly detect when activity is occurring. When the activity level decreases below the appropriate threshold, then the Sleep function is allowed to kick in.

      So, this program is not an internal setting for Win10, but a third party program that you run as an add on.

      NightOwl

      No question is stupid ... but, possibly the answers are 😉 !

      1 user thanked author for this post.
      • #1987173 Reply

        BobStr
        AskWoody Plus

        I supposed it’s obvious to someone to knows more than I do, but the reason I wouldn’t have expected Power Options to work differently in this manner for Win 10 on a laptop is that, at least based on my earlier experience, it seemed plain that the PO setting is designed to not activate if something that it perceives as an “activity” is going on, with the sleep setting kicking in only after that “activity” has ceased. On my Win 7 machine, for example, virus scans are not treated as activities that stall the action of PO, whereas XG analyzing BG  positions is so treated. It’s not clear to me why something that PO treats as an “activity” on a Win 7 desktop isn’t treated as one on a Win 10 laptop.

        I suppose that any program can be expected to operate a little differently on a Win 10 laptop than on a Win 7 desktop, but I’d expect most programs (e.g., a word processing program, a browser, etc.) to behave essentially the same way on both systems. That that’s obviously not the case with Power Options is the reason for the first half of my question: why is it different on the different systems?

        But that’s really just my idle curiosity. The more important part of my question was whether I could do anything about it, and it seems that your suggestion of Econap may well do the trick. I need to spend more time reading what that website has to say and then perhaps try using the program.

        I appreciate your advice. Other solutions that have come to my attention so far seem to merely provide alternatives to the PO settings themselves, which don’t really work for me (unless I use the “never” setting) for two reasons. First, the minor issue, is that I simply prefer not to have to reset something every time I want to have a BG analysis running while I’m away from the computer. Second, and the more significant issue, is that if I set XG to analyze several positions in sequence, I have no idea how long the entire process is going to last, because XG gives me an estimated completion time only one position at a time (and, moreover, it takes XG a minute or longer to get enough of a grip on any particular position in order to tell me how long it expects the analysis of that position to last).

        But that’s probably more than I needed to say. My bottom line is: thanks for your help, and for the suggestions that the others here provided.

        1 user thanked author for this post.
    • #1987238 Reply

      NightOwl
      AskWoody Plus

      @ BobStr

      … why is it different on the different systems?

      Different hardware–different software–different programing!?

      Does the eXtreme Gammon program exit after it’s done doing its analysis? Or does it just stop doing the analysis activity, and sit there waiting for input?

      I think the Econap program can probably handle either case, but the setup is probably different–if it exits, then probably monitoring the program process would work, if the program stays open, then probably have to monitor system activity level changes would be needed, and you might have to invoke the Econap program at the time you set up the eXtreme Gammon program and want to walk away from your computer for the evening.

      NightOwl

      No question is stupid ... but, possibly the answers are 😉 !

    • #1988038 Reply

      wavy
      AskWoody Plus

      and i will throw another into the mix. mousejiggler
      does just that to keep windows awake. https://archive.codeplex.com/?p=mousejiggler

      🍻

      Just because you don't know where you are going doesn't mean any road will get you there.
    • #1988261 Reply

      Bluetrix
      AskWoody MVP

      Back in 1992, the Energy Star initiative was created by USA’s EPA. Computers and monitors were the first products to be labeled under this system. That seemed a bit off to me considering things like refrigerators, electric water heaters and such, far outpaced energy waste than a computer. Apples and oranges.

      The introduction of Windows XP in 2001 included sleep mode, which addressed this issue by reducing power consumption when a computer was not in use, by user enabled power options. This didn’t stop some programs (AV’s) from overriding power settings. Those AV programs could, and did prevent a computer from entering sleep mode. Users avoided enabling power settings – because they could. We are more ecologically minded today.

      The AV sleep issue was addressed in Windows 7.  Windows 10 took it a step further. Microsoft isn’t likely to change the direction in the way this works. It’s one size fits all.

      I’ve read blogs other than AskWoody, that had complaints that a non-security program could prevent sleep mode while running unattended, where a security program such as an AV didn’t prevent sleep mode.

      One pointed their finger at the developers of AV’s, claiming that developers know how to implement a simple workaround in their products yet fail to do so. I get the impression developers are on the same bandwagon as Microsoft and don’t want to be one to go against Microsoft’s standards.

      The answer to this problem is an universal echo. Either set your power option to “never” when needed, or use a third party program like suggestions in this topic refer to.

      As I mentioned in my first reply, “It’s the nature of the beast.”
      I know that’s not very helpful, but it is accurate.
      Good luck.   🙂

      Windows10 Home 1809 | Mint19 on VM

    • #1988642 Reply

      BobStr
      AskWoody Plus

      XG doesn’t exit after the analyses have completed. It just sits there with the last position analyzed open.

      Hoping that Econap will work. Won’t be that big of a deal if it doesn’t, since I’m sticking with the Win 7 desktop for most analysis (because it’s so much faster). But it would be nice for when I’m at a tournament on the road, and I want to analyze a series of positions over night, if Econap would do the trick on the laptop. Worst comes to worst, and it doesn’t work, in those limited number of cases I can always set PO to “never”.

      Thanks again for your suggestion.

       

       

    • #1990216 Reply

      Paul T
      AskWoody MVP

      If you can work out when the analysis finishes on screen then you could write an AutoHotKey script to move the mouse until the end of the analysis. Maybe it’s something as simple as XG using almost no CPU.

      cheers, Paul

    • #1991167 Reply

      RetiredGeek
      AskWoody MVP

      Bob,

      Here’s a little PowerShell program I genned up to hopefully solve your problem.

      The program will accept a process name, power profile, and number of seconds  as parameters. After some initial checking it will enable the specified power profile and then check when that process goes to zero cpu usage at the interval specified in the seconds parameter. When zero cpu is reached for the process the power profile in use when the program was started will be reinstated.

      Please read the comment based help for details. Once the program is on your drive you can get the comment based help by either opening the program in a text editor like notepad or from inside PowerShell enter the following command in the console window.

      Get-Help [d:path]Set-NoSleep.ps1 -full

      Set-NoSleep
      HTH 😎

      May the Forces of good computing be with you!

      RG

      PowerShell & VBA Rule!
      Computer Specs

      Attachments:
      1 user thanked author for this post.

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Power Options question

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.