News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Problem setting default browser

    Posted on pnshldn Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 10 Windows 10 version 1903 – May 2019 Update Problem setting default browser

    This topic contains 10 replies, has 7 voices, and was last updated by  Microfix 1 month ago.

    • Author
      Posts
    • #1911378 Reply

      pnshldn
      AskWoody Plus

      Running W10 V1903 Home on an older Dell Vostro 220 as a 32 bit system. My problem existed with V1803 as well. Defined accounts are Admin, Me, Lynne, Visitor and Guest. Only Admin account has Admin priviledge. FF is the default browser for Admin, but I’m unable to set it as the default for my account or Visitor. Haven’t tried the others but I expect the same. Only options are the MS browsers. I placed a shortcut on my task bar so that I can use FF, but browser links always go to Edge. How can I install FF to all accounts so that I can choose it as the default for each account?

    • #1911466 Reply

      b
      AskWoody Plus

      Install as Administrator?

      How to install Firefox for ALL users

      Knuckle dragger Cannon fodder Chump Daft glutton Idiot Crazy/Ignorant Toxic drinker Blockhead Unwashed mass Seeker/Sucker "Ancient/Obsolete" (Group ASAP) Win10 v.1903

    • #1911481 Reply

      Bob99
      AskWoody Plus

      Instead of going through Control Panel or the Settings panel within Win10, try setting it as the default from within a running instance of Firefox.

      Go ahead and launch Firefox with your regular user account. Now that it’s up and running, click the “hamburger” icon on the far right side of the browser’s window, to the right of the URL/address bar. Select the item labeled “Options” with the gear-looking symbol next to it. You should now click the selection on the left side of the screen labeled “General” with the gear-looking symbol next to it. However, that tab/screen should open by default whenever you go into the Options menu.

      On the “General” settings screen the first choice at the top is “Startup”. Under that choice are two sets of settings, one for restoring the last session, the other for making sure Firefox is the default browser (“Always check if Firefox is your default browser”). Click the box to make Firefox the default browser, and you should be all set.

      Make sure to repeat these few steps with all of the other accounts that you want to have FF as the default browser.

      Let us know if this doesn’t work. @microfix is one of the MVP’s here and is quite good at solving issues with Firefox, so he may be able to help if this suggestion doesn’t work.

      1 user thanked author for this post.
      • #1913222 Reply

        pnshldn
        AskWoody Plus

        FF is not able to set the default to FF. I end up in the Settings Default Apps page with Browser highlighted on Microsoft Edge. Other choices are IE or something from MS Store. I don’t believe this is a FF issue but something about W10 and non privileged accounts. My version of FF is 68.0.2 which I believe is latest. I tried reinstalling FF from Admin  account but that did not work. I’ll try temporarily adding Admin privilege to user account to see if that works.

        • #1913228 Reply

          b
          AskWoody Plus

          But did you try right-clicking the Firefox installer and selecting Run as administrator (as advised in the Mozilla link in the first reply at #1911466)?

          Knuckle dragger Cannon fodder Chump Daft glutton Idiot Crazy/Ignorant Toxic drinker Blockhead Unwashed mass Seeker/Sucker "Ancient/Obsolete" (Group ASAP) Win10 v.1903

          • #1913233 Reply

            pnshldn
            AskWoody Plus

            Yes, I did right click and Run as Administrator. No joy!

    • #1911657 Reply

      which FFversion?  Newer you should be Ok.  But older, pre-v56+/-, you may have issues (esp. if you also installed a FF fork like WF or Palemoon).

      *Edit: and of course check your Target.  Taskbar Icon, Properties, Target should be going to Cprogramfiles\mozilla firefox\firefox.exe (default location, I think -but I use a Portable)

    • #1911946 Reply

      anonymous

      Goofy things like this are why I always set every account as admin until I finish installing, customizing and optimizing things. After that I go back and change the account to limited user.

      1 user thanked author for this post.
      • #1911996 Reply

        MrJimPhelps
        AskWoody_MVP

        Goofy things like this are why I always set every account as admin until I finish installing, customizing and optimizing things. After that I go back and change the account to limited user.

        Doing the above is an excellent way of making sure that everything is set up the way you want it to be.

        Group "L" (Linux Mint)
        with Windows 8.1 running in a VM
        • #1913235 Reply

          pnshldn
          AskWoody Plus

          I gave Admin privilege to my user account, signed out, restarted, signed in and verified Admin privilege. Ran downloaded and reinstalled FF. Got the “not your default …”, clicked “make it my default, and ENDED UP WITH EXACTLY THE SAME PROBLEM: NO FF AS A CHOICE FOR DEFAULT BROWSER. Yet the newly reinstalled FF put a shortcut on my desktop that works, but I still can’t set FF to be the default. What the h…. is going on?

    • #1913250 Reply

      Microfix
      Da Boss

      In an Admin account, do the following steps in this link:

      https://support.mozilla.org/en-US/kb/how-change-your-default-browser-windows-10

      It may also be attributed to MS Edge preload on startup: try disabling this (if you don’t use edge) then do the first link again.

      https://www.howtogeek.com/397718/how-to-prevent-microsoft-edge-from-preloading-on-windows-10/

       

      ********** Win7 x64/x86 | Win8.1 x64 | Linux Hybrids x64 **********

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Problem setting default browser

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.