• Problem with downloading behavior in Firefox 98.0

    Home » Forums » AskWoody support » Questions: Browsers and desktop software » Other browsers » Problem with downloading behavior in Firefox 98.0


    Firefox 98.0 has changed its behavior for downloading files.  But,I have gone to FF Settings and changed how it handles downloaded files, as you see below.

    Consequently, when I download a pdf, jpg, and docx file, I get the FF dialogue box that I want to get, i.e., I have a choice of saving it or opening it.

    But, I do not see ‘Microsoft Excel Document’ in the FF Application list. So, when I download an Excel file, the last folder that I had had open shows up in File Explorer, presuming that I want to save the downloaded Excel file there. But, I don’t want that. I want to get the same kind of dialog box that I get for downloading pdf, jpg, and docx files.

    How can I accomplish that? I do not see any way to add applications to the Application list and to set the Action to ‘Always Ask.’ But, there must be some way to do that. I want to get a dialog box for.xlsx files and for .cvs files so that I can have the option of opening them on the spot just like the dialog boxes for .pdf, jpg, and docx files offer me that option. I don’t want to save them; I just want to open them.

    1 user thanked author for this post.
    Viewing 6 reply threads
    • #2430340
      2 users thanked author for this post.
      • #2430407

        I find nothing here that provides information on how to add an application to the FF 98.0 Applications List. (None of the links provide any information either.)

        I have FF 98.0 on two laptops, a Dell 5482 and a Dell 7569. The Dell 5482 FF 98.0 Applications list shows Excel cvs files, but the 7569 does not. The Dell 7569 FF 98.0 Applications list shows JPEG Image files but the 5482 does not.

        So, I need to add Excel .cvs files to the 7569 FF Applications list, I need to add JPEG Image files to the 5482 FF Applications list, and I need to add Excel .xlsx files to both the 5482 and 7569 FF Applications List.

        I am thinking that there is a command in about:config to add these, but I have no idea what the command looks like or where to go in about:config to add them. I’ve tried the FF Help feature, but there is nothing that I can find either.


        • #2430419

          OK, I’ve finally figured it out!!

          On the 5482, JPEG Image was not listed in the FF Applications list. So, I sent to my e-mail a .jpg file. Then, I went to my e-mail, clicked on the attachment, and downloaded it to the Downloads folder. A dialog box popped up listing the file I had just downloaded. I right-clicked on the file and selected “Always Open Similar Files”.

          Then, I went to the 5482 FF Applications list and JPEG Image was now listed. So, that’s how I added it to the Applications list. Then, in the Action column, I right-clicked and changed the Action to ‘Always Ask’.

          After changing the Action to ‘Always Ask’, now I get the dialog box that asks me what I want to do with a jpg file.

          What a complicated process!!!

          5 users thanked author for this post.
          • #2430447

            Whew!  What a complicated mess !  It always makes me wonder why Messilla thinks we want to have to Fix their screwed up “Updates” every month !

            The download process was JUST FINE as it was . . . give it a rest for rice cakes !

            Edit:  I Always want to save whatever I’m downloading so I can run a quick Malware Scan on it before I run it.  In my opinion this is just plain stupid.

            Being 20 something in the 70's was much more fun than being 70 something in the 20's.
            • This reply was modified 1 year, 6 months ago by Charlie.
            • #2430466

              Yes, I wonder why Firefox decided to change the download defaults and in the process change everything a user had previously set.

            • #2430897

              Google has programmed Chrome to do this download behavior, so Mozilla copied it?

              I could understand if it actually mostly prevented the horrible consequence of any bleary eyed user opening poisonous malware laced files and/or lessened a habit of blindly clicking through dialogs.

              But unless it exists on Bugzilla or a Mozilla blog there may not be a public explanation for these changes.

              (Best of luck next week for everybody everywhere subjected to Daylight Savings Time!)

              1 user thanked author for this post.
    • #2432141

      Something crazy is going on here. I just discovered that during the past week (i.e., since the FF update to version 98), 43 .pdf files from online accounts had been downloaded to the Downloads folder, even though
      a. I have set the Action for ALL file types, including .pdf documents is to ‘Always ask’
      b. And when asked, I always elect to ‘open file’, not to save it.

      But, evidently, the file is saved anyway — in the Downloads folder.

      Before version 98, FF put these “to-be-viewed” files in a systems temp folder. And my A/V software (McAfee) cleans out temp files (if the box is checked for that) on a user-defined schedule. None of these cleaned out temp files gets sent to the Recycle Bin.

      Now, I have to go to the Download folder myself and manually clean them out and then manually delete them from the Recycle Bin.

      I fail to see why FF changed its download behavior. Was this supposed to be some kind of improvement? It doesn’t seem like an improvement to me. Or have I overlooked something here that would keep these ‘to-be-viewed’ files from being saved?

      2 users thanked author for this post.
    • #2432318

      The reason that happens is, in order to open a file, first it must be saved somewhere on your PC. This is true for every browser and always has been.

      The difference is, in older versions of FF, the default download location was “C:\Windows\Temp” (or whatever folder a user set as their Windows temp folder.) In FF 98 they reset the value to “%USERPROFILE%\Downloads“.

      To restore the default download location to what it was in older versions.

        Enter about:config in the URL box

        Enter download in the search box.

        Change the value of browser.download.dir back to “C:\Windows\Temp

      BTW, it “seems” the only reason FF forced this change on everyone was simply to match what Chrome based browsers are using.

      2 users thanked author for this post.
      • #2432328

        • Change the value of browser.download.dir back to “C:\Windows\Temp”

        That sounds like the perfect solution, but there is no browser.download.dir

        There IS a browser.download.useDownloadDir, but there is no option to change it to the name of a directory. It is false, probably because in ‘Settings’, under the ‘Download’ heading, I have it set to ‘Always ask you where to save files’.

        And if it’s important to know this, under the the ‘Applications’ heading, the ‘Action’ for all of the content types is ‘Always ask’. And, as I’ve indicated, if I choose to open the file, it goes to the Download directory, because it has to go somewhere in order to open it (as you’ve said).

        Is there another preference that will put the file-to-open in “C:\Windows\Temp” ?

    • #2432348

      Ok, here’s some options you can try.

      1- “Manually” add the browser.download.dir option.

      To manually add an option, enter the full option name in the search box, select its type (in this case string), click the add button, and set it’s value to “C:\Windows\Temp

      Restart FF, open a file using a link, then check where it was downloaded to.

      If that doesn’t work…

      2- Change Always ask where to Save files to Save file to and change the default location from “Downloads” to “C:\Windows\Temp

      Restart FF and change it back to Always ask where to Save files and verify the default location listed for Save file to doesn’t revert back to “Downloads

      If that doesn’t work…

      3- Change the browser.download.improvements_to_download_panel option to false (true = “new” download behavior, false = “old” download behavior)

      Note: this last option may be removed in the future versions of FF.

      1 user thanked author for this post.
    • #2432359

      Hi WCHS:

      I agree with you.  I really don’t like this new file download behaviour in FF v98.

      See the 08-Mar-2022 tip in the AskVG.com article Restore Classic Download Confirmation Prompt in Mozilla Firefox that describes how to change the advanced setting browser.download.improvements_to_download_panel to FALSE (i.e., as suggested in option 3 of alejr’s post # 2432348).


      I changed this advanced setting to FALSE in about:config today and downloaded a few PDFs and so far this seems to have stopped files from being automatically saved in my Downloads folder. Note that I always have Tools | Options | General | Files and Applications | Downloads set to “Always ask you where to save files“.

      The Firefox section of AskVG.com at https://www.askvg.com/category/mozilla-firefox/ has lots of other tips for customizing Firefox and it’s usually the first site I visit whenever Mozilla makes a change to Firefox that I don’t like.
      Dell Inspiron 15 5584 * 64-bit Win 10 Pro v21H2 build 19044.1586 * Firefox v98.0.1 * Microsoft Defender v4.18.2202.4-1.1.19000.8 * Malwarebytes Premium v4.5.6.180-1.0.1634

      2 users thanked author for this post.
      • #2432419

        Hi Imacri,
        I started with @alejr’s #1 and unfortunately, I ‘Refreshed’ FF instead of ‘Restarting’ and so lost all of my customized settings. I have spent the last two hours putting them all back!! Obviously, the manual addition of browser.download.dir was lost in the ‘refresh’ and your note appeared before I considered adding it again.

        Yes, changing browser.download.improvements_to_download_panel to false worked. And because of the | Files and Applications | Download setting, I can choose to ‘open’ .docx, .jpg, .pdf, .cvs, .xlsx files.

        When they are opened, they are now saved to who-knows-where. I no longer find them in the Downloads folder and I don’t find them in C:\Windows\Temp either.

        I wonder where they go.

        1 user thanked author for this post.
        • #2432469

          This worked for me.  Things are back to normal (pre-98) at least until next month.

          Being 20 something in the 70's was much more fun than being 70 something in the 20's.
    • #2450064

      According to Martin Brinkmann’s 31-May-2022 ghacks.net article Firefox 101 Stable: Security Fixes and Classic Download Behavior Restored, the Firefox v101 update scheduled for release today is restoring the “classic” download prompt.

      I’m still waiting for the FF v101 update to be offered to my machine, but according to that ghacks.net article users who go to to Settings | General | Files and Applications | Applications will see a new option called “What Should Firefox Do With Other Files?” that can be changed  from “Save Files” (the default) to “Ask Whether to Open or Save Files“.  The official release notes for FF v101 haven’t been posted yet at https://www.mozilla.org/en-US/firefox/releases/ but according to Martin Brinkmann this change to the download prompt isn’t even mentioned there.

      Note that I applied the workaround mentioned in post # 2432359 and already see the following option in my Firefox settings so I’m not really sure if the changes in FF v101 will actually improve my download experience.


      Kudos to ALF60 for posting a link to that ghacks.net article <here> in the Norton Tech Outpost.
      Dell Inspiron 5584 * 64-bit Win 10 Pro v21H2 build 19044.1706 * Firefox v100.0.2 * Microsoft Defender v4.18.2203.5-1.1.19200.5 * Malwarebytes Premium v4.5.9.198-1.0.1689 * Macrium Reflect Free v8.0.6758

      1 user thanked author for this post.
    • #2450079

      This is from FF 101
      The default was “Save Files”


    Viewing 6 reply threads
    Reply To: Problem with downloading behavior in Firefox 98.0

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: