• Prompt to Save Templates


    Whenever I close a changed document, I am prompted to save the template that it is based on. For example, I create a new letter based on the letterhead.dot template, and when I save/close it, I also get a box asking whether I want to save letterhead.dot.

    Apart from being very annoying, if I make changes in a particular letter, I don’t want them saved in the master template.

    Is there a way to turn this off? I turned off the “Prompt to save normal.dot” but it had no effect. I’m running W2K with SP1 on a Windows 2000 system.


    Viewing 2 reply threads
    • #508538


      Here’s a possible cause: if you’re using the built-in Letter Wizard to create your new letters, you will likely get a prompt to save the global template, due to a design feature of the Letter Wizard.

      The Letter Wizard prompts you for various entries and then places these in your letter. It then makes these entries available for future use (right click with the cursor on any of the entries in the letter). It does this by saving your entries as Autotexts, and inserting the entries using AutoTextList fields (Alt+F9 to see the field codes).

      A bit of testing indicates that these autotext entries are being saved automatically to Normal.dot. So every time you create a unique entry, you will get the prompt. It is kind of annoying – perhaps the Letter Wizard could have been designed to store the data a different way.

      In any case, never turn off the “Prompt to Save Normal Template” setting – leaving this on is an important defense against viruses (yeah, and then MS designs its wizards to trigger this prompt, without explanation!).

      Well, that’s one plausible explanation for the prompt you’re getting. If you’re not using one of the built-in wizards, then back to the drawing board (although it is possible that a custom-designed template could be doing something similar).

      Hope this helps,

      • #508539

        Unfortunately, I’m not (and have never used) the Letter Wizard. I don’t think it’s anything in the template, since I get the prompt with documents created with *all* templates (except, interestingly enough, normal.dot!)

        Any other suggestions? Please?


        • #508543

          Tough one. Are all these templates ones that came with Word, or were they built by you or someone else?

          Another question: do you have any other global templates or add-ins running? (Look at Tools>Templates and Add-Ins.)

    • #508542

      See, it’s too bad the old posts are history ‘cuz this question has been answered several times. A quick search would have found this one. But, since it appears no archive is forthcoming, it’s my pleasure to offer this solution:

      put activedocument.attachedtemplate.saved = true

      at the end of your initialize event (or autoexit or a more appropriate place as per your discernment). I’m not sure what causes Word to do this, but this solution works.

      • #508544

        Thanks, Kevin – good idea.

        The place to put this would be in a Document_Close procedure, in the attached template’s own This Document module.

      • #508545

        Be very careful of anything that does a AUTO SAVE to the Global settings. You may not like what has beeen changed in your Normal.dot template. I have even seen some of the macros and scripts over written by these autosaves.

        DaveA I am so far behind, I think I am First
        Genealogy....confusing the dead and annoying the living

        • #508562


          I’d agree with you if the attached template being autosaved was Normal.dot – that would be dangerous and effectively would be the same as turning off the prompt to save Normal.dot.

          In this case though, dealing with attached templates other than Normal.dot, it seems a safe enough workaround, no?


          • #508570

            Could this make changes to the attached template, if so will the changes ALWAYS be wanted to be saved? If NOT then it is just like the autosave of the normal template, you would end up with some thing that you do NOT want in your template.

            DaveA I am so far behind, I think I am First
            Genealogy....confusing the dead and annoying the living

            • #508586

              Hi Gary & Dave:
              I don’t think this will cause a prompt to save a template. You can’t set both Automatically update & Add to Template for a style. You can only set the former.

              Format/Style/Modify/Automatically update means that your document style will change whenever you manually format a paragraph. That should not cause a change in a template.

              Format/Style/Modify/Add to template won’t stay checked. It’s a way to copy a document style to a template. That will cause a prompt to save the template, but only the one time you use it.

              Like Dave, I tend to stay away from “automatic” changes. It’s only useful when you are developing new styles & are experimenting. Rather than have to add manual formatting, click in the dialog box & press , each time you make a change (& then tell Word you don’t want to reapply the style), you only have to apply manual formatting. It then updates all the paragraphs that have that style. After it’s served it’s usefullness, I think it’s best to turn it back off.

              Anyhow, I think the original poster (I can’t see who it was because there’s no split screen should look to see if there’s an add-in or macro that’s causing the changes.

              Hope this helps.

    • #508547

      One reason could be that you are using templates originally created in Word 97 in Word 2000. If you have not yet said Yes to save them, you should do so. The next time you use them you should not be asked again. Another reason is that you are using a template with styles and that style is set (under Format-Styles-Modify) to “Add to template” and “Automatically update”. In other words, if you’ve got style Heading 1, for instance, and have now used it in the new document (based on the template), and then decided you didn’t want it bolded, so you unbolded it. This causes it to automatically update, and the template wants to save the style too. Hope this makes sense. (And hope my signature works–I hate when it doesn’t and this is my first post on the new board.)

    Viewing 2 reply threads
    Reply To: Prompt to Save Templates

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: