• PS-Remoting GotchYa!

    Author
    Topic
    #2259336

    Hey Y’all,

    I ran into an interesting problem with PS-Remoting the other day. It took a while but I isolated the problem via much googling and have 2 fixes. What’s really interesting is that it affects one of my Win10 desktops but not the other?

    Known behavior of WinRM, a key component in PS-Remoting, is that it will not hookup if ANY network on the machine is marked Public! Well I don’t use Public networks and both my ethernet and Wi-Fi networks were marked Private as they should be. Couldn’t quite figure this out where was WinRM finding a Public network?

    Set-WSManQuickConfig : WinRM firewall exception will not work since one of the network 
    connection types on this machine is set to Public. Change the network connection type to either 
    Domain or Private and try again. 
    
    At line:116 char:17
    +                 Set-WSManQuickConfig -force
    +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Set-WSManQuickConfig], InvalidOperationExcept 
       ion
        + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManQuickConfigCommand
    

    As usual windows error messages to the rescue, fat chance!

    So it turns out that it is Hyper-V that is setting up the network adapter causing the problem.
    NetworkAdapters
    Of course you can delete this adapter but next reboot it will reappear! If you disable it just creates a new one.

    Soulution 1: Uninstall Hyper-V in Control Panel -> Programs & Features -> Turn Windows features on or off. This works but what if you want to user Hyper-V?

    Solution 2: Use Group Policy to set Unidentified Networks to Private (yes a network Windows creates is Unidentified to Windows!).

    gpedit.msc > Computer Configuration > Windows Settings > Security Settings > Network List Manager Policies > Unidentified Networks > Location type: Private. This solves the problem and allows you to keep Hyper-V running if necessary.

    Of course if you’re running W10 Home you don’t have gpedit.msc.
    Well you can always resort to the registry. Note: I haven’t tried this one yet, will get to it on my wife’s machine as soon as she leaves the house (lol).

    Navigate to:
    HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlClass{4D36E972-E325-11CE-BFC1-08002BE10318}
    You will find enumerated keys like 0000, 0001, 0002 and so on.
    Expand them one by one and look for DriverDesc REG_SZ value data.
    In the same registry key where you found the name of the nic to exclude (DriverDesc value), create another new DWORD Value, name it *NdisDeviceType (it Case Sensitive!!). Double click on this value and in “Value Data” field put 1 as Decimal data.
    Registry-vEthernet
    HTH 😎

    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!
    Computer Specs

    Viewing 0 reply threads
    Author
    Replies
    • #2553223

      I’ve been hunting for a fix for this issue ALL DAY and this article fixed it.  Many, many thanks!!!

       

    Viewing 0 reply threads
    Reply To: PS-Remoting GotchYa!

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: