News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Resurrection Remix on the Moto G7 Play is a winner

    Posted on Ascaris Comment on the AskWoody Lounge

    Home Forums AskWoody support Non-Windows operating systems Android Resurrection Remix on the Moto G7 Play is a winner

    • This topic has 0 replies, 1 voice, and was last updated 1 week ago.
    Viewing 1 reply thread
    • Author
      Posts
      • #2334212
        Ascaris
        AskWoody_MVP

        Not long ago, I broke my steadfast moratorium on smartphones and bought a Motorola G7 Play. You may have read much of this before in another post.

        Unfortunately, with LineageOS, there was an annoying bug that made its signal strength meter on the status bar for cellular data to display incorrectly. When it should have shown the signal at full strength, it showed the icon for no signal. If the signal got a little bit worse, it would show the icon for full strength.

        I verified that the actual signal strength being reported by the phone’s radio was good. If the signal was -100 dBm or stronger, it would show no signal. If it was -101 dBm down to about -108 dBm, it would show full.

        Even though I know what the empty signal icon meant, it drove me crazy.

        That prompted me to consider other AOSP variants. Many don’t have a version for the Moto G7 Play, but some that do included Resurrection Remix, a downstream derivative (fork) of LineageOS. I downloaded the file, tried to flash it, and… no good.

        I learned that the LineageOS recovery ROM (a very basic thing compared to TWRP, short for Team Win Recovery Project, that is usually recommended) rejects anything except official Lineage releases.

        I would have installed TWRP, but I could never get it to work, as far as I knew. The Lineage recovery worked fine to install Lineage, but that was all it was meant, or able, to do.

        I found out that TWRP actually had been working, but I didn’t realize it.

        When TWRP booted before, I got the splash screen, but it never progressed beyond that. I kept waiting, but nothing happened. Had I just tried to swipe it away like it was a lock screen picture, it would have revealed the main menu. Doh!

        Using that info, I was able to boot into TWRP from the fastboot menu (bootloader), then from there install TWRP onto the phone. I was then able to install Resurrection Remix (RR) with no further ado. I rooted it with Magisk also.

        When I booted RR for the first time, I waited, holding my breath to see if the cell data icon would show its ugly hollow self like LineageOS had and… it didn’t. The bug was not carried over into RR! Just what I had hoped for

        RR has many more things you can tweak and modify compared to LineageOS. I like that kind of stuff!

        One of the features about RR I like is that it has the built-in ability to spoof the signature of a given app. You have to turn the feature on first, and then give the app you want spoofed permission to do so. As far as I know, it only works with system apps, so even if a malicious user app tried to use the spoofing ability to its advantage, and was able to get the user to enable spoofing in general and spoofing for that app, it would not work, since it would be a user app.

        The purpose of signature spoofing is to enable Micro-G to work. You can make this work in LineageOS too, by first installing Xposed, which I found in the form of EdXposed and Riru, and then Micro-G from the Magisk (root) app, and finally, the backends for various mapping bits, to replace the functions of Google Maps. There are step by step guides available if this sounds like too much.

        With RR, though, I just had to turn on spoofing, install Micro-G from Magisk, give spoofing privileges to the fake Play Store app bit of Micro-G, install the backends, and it worked.

        I had all kinds of apps that don’t work without Play services working before with edXposed/Riru/Micro-G, but it seems that more things work now than did before. I’ve got a bunch of things that would not work without Play services, but they all work now, and my phone is completely Google app free. One of them that was meant to map the location of one of their stores in Google Maps was able to correctly map the location using maps from OpenStreetMaps, I believe. The app thinks it is talking to Play services, which in turn pulls in Google Maps, but it was all Micro-G.

        As before, I use Aurora to download and install apps from Google’s Play repository, and I can do that without attaching a Google account. The Google account gives the phone a persistent ID, just the thing Google wants. It also assigns a random advertising ID, which you can  change to another random one whenever you want, but it would not surprise me a bit if in Google’s vast caches of user data, all of the data associated with the old advertising ID was just moved to the new one at the same time it was changed. It’s better to not have an account linked, which normally would have a pretty big negative impact on the usability of the device, but it works pretty nicely now! And if I do want to use Google Maps or other Google services, I can always load them in the browser (Opera is the only one installed on the system… Chrome has never been here. Opera is the only one I know about that properly does text reflow on zoom, a must-have feature for me).

        RR came with a rather bare-bones configuration, with a lot of the AOSP bits that were in LineageOS not present. That’s not really a problem, as it is easy to find replacements.

        I like RR a lot so far. It’s a little odd how I have the language set to EN-US and it still uses British spellings throughout all of the RR menus (the ones directly from Lineage are correctly localized), but that’s a trifling concern. I have not had any weird behaviors or crashes that I can attribute to the OS… I did have a few instances of weirdness, but force closing some recently installed apps fixed it for one (it had said it was for an older version of Android and that it could behave incorrectly), and I am not sure about the other.

         

        Group "L" (KDE Neon Linux 5.20.5 User Edition)

      • #2334785
        anonymous
        Guest

        ? says:

        nice write-up, thanks Ascaris! i looked into lineage, but no package for moto e6. i would love to bump all the googliness off and run clean.

    Viewing 1 reply thread

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Resurrection Remix on the Moto G7 Play is a winner

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.

?
This website collects data via Google Analytics. Click here to opt in. Click here to opt out.
×