• Return Full Context Menus to File Explorer

    Home » Forums » AskWoody support » Windows » Windows 11 » Windows 11 version 22H2 » Return Full Context Menus to File Explorer


    Hey Y’all,

    After reading Susan’s email this morning (plus only) I tried out the registry entry to get the full context menus in file explorer back. Worked like a charm and I’m using Tiny11!

    For those of you who are loathed to mess in the Registry Editor I’ve attached a .Reg file that you can double click and merge into your registry. No muss No fuss.

    Download from here

    Moderator Susan note:  Made the edits to fix the typo. This time I exported from my working PC!

    May the Forces of good computing be with you!


    PowerShell & VBA Rule!
    Computer Specs

    3 users thanked author for this post.
    Viewing 8 reply threads
    • #2589794

      I was planning to build a KB page and do just that.  Mind if I link your reg key? Actually it’s in the alert which can be read by anyone.

      Susan Bradley Patch Lady/Prudent patcher

    • #2589841

      Susan, be my guest.

      May the Forces of good computing be with you!


      PowerShell & VBA Rule!
      Computer Specs

    • #2590013

      The .Reg file was appreciated, but did not work for me.  I logged into my Administrator account to run the file and restarted the laptop.  The condensed context menus still appear.

      This is on a year old 16″ HP Spectre x360, running Win 11 Pro, Version 22H2, OS build 22621.2134.  I have not installed updates this month yet as I was focused on this issue after Susan’s email yesterday.

      By the way, great hat Retired Geek.  Looks similar to my Tilley.


      • #2590046

        They should work. Are you using any other file explorer customization tool?

        Susan Bradley Patch Lady/Prudent patcher

      • #2590052

        Did you run it on the user account you are logged into? Sounds like you probably added it to your “Administrator account”

        Never Say Never

      • #2590164

        I had the same problem so went net-hunting. The follow worked for me:

        (save the section between the asterisks as a .reg file, run and restart).


        Windows Registry Editor Version 5.00




        It seems the RetiredGeeks .reg works for some but some need to specifically enter a blank, despite that being the default value🤔

        Group A (but Telemetry disabled Tasks and Registry)
        1) Dell Inspiron with Win 11 64 Home permanently in dock due to "sorry spares no longer made".
        2) Dell Inspiron with Win 11 64 Home (substantial discount with Pro version available only at full price)

    • #2590058

      The .Reg file was run under both the Administrator account and my normal local account.  The condensed context menu continues to show in both accounts.

      I am not aware of any other file explorer customization tool having been run on this computer.  Would such a tool show up anywhere besides Add/Remove Programs?

      Generally I try to run without many add-ons, including portable files.  Since I don’t use the Taskbar much I have it parked to the left in lieu of center.  I’m a long time keyboard shortcut person.  But I agree with Susan about the frustration and extra steps the condensed context menus pose.

      Thank you to everyone for their comments/questions.

      • #2590076

        There is a typo in your .Reg file the CLSID key should end with 50c905bae2a2 and not 50c905ba32a2  (change the 3 to an e).  I ran the original .REG file and like @tbkid found it didn’t work. I renamed the key in the registry editor then restarted the PC and now it works.

    • #2590092

      If the 3 is to be changed to an e, as pointed out by Gromitd90, that is only incorrect in Susan’s posting on Tuesday.  RetiredGeek’s .Reg file had ’50c905ba32a2′.

      The condensed context menu is still an issue for me.

    • #2590095

      This has worked for me

      Windows Registry Editor Version 5.00

      Never Say Never

    • #2590107

      Perhaps I misspoke.  In rereading the posts it appears Gromitd90 was referring to RetiredGeek’s reg file when he said there was an inaccuracy in the key’s label.   Thus Susan’s post was apparently the correct labeling.

      Nonetheless, since this morning I have tried it with both spellings.  And still it does not work.  This leads me to believe it is something with some configuration in my laptop, which is what most of you probably already assumed.

      Again, everyone’s help has been appreciated!

      • #2590112

        Did you download my revised link?

        HKEY_CURRENT_USER\Software\Classes\CLSID\{86ca1aa0-34aa-4e8b-a509-50c905bae2a2} should be the working one as that’s what I have here at the office.

        Susan Bradley Patch Lady/Prudent patcher

        • #2590121

          Very Interesting…

          Context Menu:

          Registry Entry:

          Well, all I can say is it works for me.

          UPDATE: I tried it with the 86ca1aa0-34aa-4e8b-a509-50c905bae2a2 and that worked also, go figure!

          UPDATE & APOLOGY!:
          Well I kept on figuring and finally remembered, hard at my age, that I had StartAllBack installed. Thus the fact that the wrong registry key worked because it wasn’t being used!



          May the Forces of good computing be with you!


          PowerShell & VBA Rule!
          Computer Specs

    • #2590174

      Susan wrote: “Made the edits to fix the typo”, but a new typo’ has now appeared in the .reg file at the “Download from here” link above.

      In the 1st line the Registery key correctly ends “e2a2}”, but in the 2nd line it ends “ea2}”, so the now missing ‘2’ character three places from the end of the key name in the 2nd line needs restoring.

      BTW: Often when making Registry changes these do not work immediately, but it is necessary to restart the PC before they work. I don’t know if that is needed in this case, but have people who found it did not work for them tried restarting their PCs? Just a thought.

    • #2590230

      Though I had restarted the computer after making changes to the registry each time yesterday I realize I never fully shut it down.  Over night it was shut down and upon restarting the computer this morning there is now a full context menu when right clicking.

      The .reg file I last ran used key names ending in ’50c905bae2a2′ and set a blank (@=””) after each of the key entries.  It worked and I’m not messing with it anymore.

      Everyone’s efforts in looking at this is really appreciated.  And Susan, thank you for making this community possible.


    Viewing 8 reply threads
    Reply To: Return Full Context Menus to File Explorer

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: