• Sata and Non-Sata SSD in a PC isn’t good it seems…Help!

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » Sata and Non-Sata SSD in a PC isn’t good it seems…Help!

    • This topic has 13 replies, 5 voices, and was last updated 5 months ago by rdleib.
    Author
    Topic
    #2555752

    I have a PC running Win10, it has two Samsung SSDs, a 2 TB data SSD and a 500gb boot SSD. I managed to completely mess up something in the BIOS, resulting in the 2 TB SSD using or formatted for SATA, and evidently the boot SSD not using or formatted for SATA.

    If I enable SATA in the BIOS, the 2TB drive shows up in the BIOS, but the computer won’t boot to the 500gb boot drive. If I disable SATA, the 2TB drive disappears in the BIOS, but the computer will boot to the boot drive. Because I can’t see the 2TV drive when the PC is booted, I don’t know what data, if any, still resides on it.

    My boot SSD seems fine, and windows runs fine. I don’t care about the data on the 2TB data SSD, I have good data backup and I can recover the drive; all I really want is for both SSDs to appear in the BIOS, the computer booting into Win10, and both drives showing up in Win10 file explorer able to be written to. I also have a good backup (2 days old) of the boot disk if I have to recover it.

    Thanks for any ideas, and I apologize for messing up the whole thing – sad thing is I don’t even know what I did wrong!

    releib

     

    Viewing 11 reply threads
    Author
    Replies
    • #2555756

      SATA is not a format that can be lost or erased. It is a hardware interface between the PC and the drive.

      It sounds like what is happening is that when the SATA drive is enabled and working, the PC is trying to boot from it, but it is not bootable (so it fails). Have you gone into the UEFI (“BIOS” as it is often called) and made sure that the boot device is first in the boot priority?

      Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
      XPG Xenia 15, i7-9750H/16GB & GTX1660ti, KDE Neon
      Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11 for maintenance)

    • #2555772

      Ascaris, thanks for your response.

      When SATA is disabled, Storage Information shows 1 drive, the 512gb boot disk; the Boot Priority shows Windows Boot Manager (M2._1 Samsung SSD 970 Pro 512 GB first and under that M.2_1 Samsung SSD 970 Pro 512 GB. The 2TB drive doesn’t show anywhere. This is the configuration that does boot up to Win10.

      When SATA is enabled, Storage Information shows both drives, but the Boot Priority only shows Windows Boot Manager (M.2_1 Samsung SSD 970 Pro 512 GB. It doesn’t boot.

      I did add M.2_1 Samsung SSD 970 Pro 512 GB under the Windows Boot Manager, but it didn’t boot although it looked the same as the Boot Priority that does boot.

      Appreciate any more ideas or questions. Thanks again.

      rdleib

    • #2555778

      When you say it fails to boot, what exactly does it do? Are there any error messages?

       

      Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
      XPG Xenia 15, i7-9750H/16GB & GTX1660ti, KDE Neon
      Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11 for maintenance)

    • #2555780

      Rdlieb,

      When I first purchased a Samsung 960 EVO NVME drive for my 2017 vintage Dell XPS 8920 I could not boot from the drive. It was over 6 months until Dell provided a BIOS update that allowed booting from the 960. You may want to check with your Motherboard maker or OEM to see if BIOS updates are available.

      May the Forces of good computing be with you!

      RG

      PowerShell & VBA Rule!
      Computer Specs

    • #2555786

      Ascaris, see attached. I’ve never seen it before, it wants to reboot but of course ends up at the same error message. You’ll note it says “Inaccessible Boot Device”. I haven’t tried to go to windows for fixes as I believe the problem isn’t a windows problem.

       

    • #2555789

      RetiredGeek, thanks for your response. I’ve been booting from my 970 for years, no issues. Booting from it now. It’s the 2TB 860 that I can’t get to, and it’s not a boot disk, never has been. Any other thoughts or ideas would be appreciated. Thanks.

    • #2555793

      Grab your phone and take some pics of your BIOs/UEFI screens and post them to this thread. Might help.

    • #2555800

      See attached, Ascaris

      First one shows the 512gb in storage info, boot priority. SATA is disabled. This boots

      Second one shows the CSM boot options same as above, SATA disabled, boots

      Third shows SATA Disabled

      Fourth shows both the drives in Storage Information once SATA is enabled, but only the windows boot manager entry in Boot Priority, this doesn’t boot.

      Nothing else has been changed in the BIOS, just enabling or disabling SATA.

      Appreciate any thoughs or ideas, thanks for your help.

      rdleib

    • #2555805

      Okay… narrowing it down a bit.

      It boots fine from the 970 (NVMe) when that is the only drive attached. If the 860 is added, booting (from the 970) does not get into Windows, and now we are seeing an inaccessible boot device message.

      I wonder if there is some setting in the UEFI, like where you can change the SATA mode from AHCI to RAID/Intel RST, that is messing things up here. I have no experience with this personally, so it is a kind of shot in the dark, but I have heard of this setting causing Windows to fail to boot. If it is set to the wrong setting, when the drive is in, it fails to boot, but when you remove the SATA SSD, the setting is irrelevant, as there are no SATA devices.

      You could try switching the SATA mode… whatever setting it is on now, try the other one (RAID/RST or AHCI).

      Windows is apparently really fussy about things like that. I keep reading about how people have to reinstall Windows to change the AHCI or RST mode, and there have been a few other seemingly innocuous settings changes that also trigger the need for reinstallation, according to what I have read.

      It could be that a Windows in-place repair install could fix it… but before that, I would recommend trying the Macrium Reflect rescue/restore USB drive’s “Fix Windows boot issues” option. I used that back in my Windows days, and it was able to fix a lot of Windows issues that the Windows boot repair function would not.

      If you do not have one, just download and install the free version of Macrium Reflect (while it is still available) and use that to create a rescue/restore USB drive. Boot from that, then hopefully it can repair your issue.

       

      Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
      XPG Xenia 15, i7-9750H/16GB & GTX1660ti, KDE Neon
      Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11 for maintenance)

      1 user thanked author for this post.
    • #2555818

      Ascaris,

      I owe you big time, if you ever make it to the Tampa Bay area and can stand the thought of having dinner¬† with an old man, you’ll be my guest!

      You last message mentioned AHCI, which I remembered seeing as a setting, so I went back into the BIOS and changed the SATA setting from Intel RST to AHCI – rebooted, and there everything was – didn’t even lose any data! I would have never believed it.

      Thanks so much, now I can get on with my life! I’ll thank you officially if I can figure out how to do that!

      Bob

    • #2555825

      Ascaris – couldn’t find out how to thank you officially, older I get harder things become. I had a Timex Sinclair as my first computer – went the IBM PCjr route which wasn’t the best choice in retrospect. You have my eternal gratitude.

      Bob

      • #2555904

        Glad I could help!

        I’m not a spring chicken myself… I also started with a Timex-Sinclair (T/S 1000) in the early 1980s, where I taught myself to program in BASIC. I discovered that I could “break” into the program flow of one of the simple games that came on cassette tapes with a certain keypress, and it all flowed from there.

        The Timex had all of the commands listed on the membrane keyboard, which made them very discoverable. With the Timex, one did not type the commands into the BASIC interpreter as with a Commodore or Apple II.

        Initially for each line, the cursor would be an inverted “K”, if I recall, for keyword. One could enter numbers (line numbers for a BASIC program) and they would appear as entered, but the letter keys all had keywords (BASIC commands) printed above the key. In “K” mode, when one would press the key with keyword “RUN” above it, which was probably the R key, the word “RUN” would appear on the command line. After a keyword was entered, the cursor would turn to an inverted L, for letter mode, where individual letters would be entered instead of keywords, and one could enter the arguments to the keyword (command) that had been entered.

        This system (probably done for making the most of the 2KB RAM the unit came with) made all the available commands easily available for experimentation from the unit itself, without needing any prior knowledge or reference to find out what to type in. Simply pressing any letter key would result in the command appearing, and it was not hard to figure out that the command that appeared on-screen was the same as the one printed above the key. For an inquisitive youngster who knew nothing about BASIC syntax, it was a perfect system to lure me in to experimenting with the commands and to begin to piece it all together.

        I started by making minor modifications to Timex’s games to see what it would do, using the manual to look up BASIC statements I would see in the program listing to see what they do, and from there moved to making my own programs…

        That was my gateway into the world of computing, and I haven’t been the same ever since. I moved from the Timex to the Commodore 64, then the Commodore 128, then my first PC (first owned and the first one I ever built), which was in 1990. That was when I first used Windows (3.0), which I would continue to use in subsequent releases until 2015-6.

        Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
        XPG Xenia 15, i7-9750H/16GB & GTX1660ti, KDE Neon
        Acer Swift Go 14, i5-1335U/16GB, KDE Neon (and Win 11 for maintenance)

        2 users thanked author for this post.
    • #2555992

      You are much more computer literate than I am, I was a systems analyst for many years, but on the functional, or logical, side of things, designing the logic for business processes that someone else turned into computer programs – or in many cases implemented as physical processes, like the flow of material into and out of warehouses. But I did have the Timex Sinclair, which I would have kept it now, with the big 4k memory unit and the cassette tape storage, tv “monitor”! Thanks again, Ascaris.

       

    Viewing 11 reply threads
    Reply To: Sata and Non-Sata SSD in a PC isn’t good it seems…Help!

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: