News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Stuck at a Grub Rescue prompt

    Posted on MrJimPhelps Comment on the AskWoody Lounge

    Home Forums AskWoody support Non-Windows operating systems Linux – all distros Stuck at a Grub Rescue prompt

    This topic contains 5 replies, has 4 voices, and was last updated by  LHiggins 3 weeks, 4 days ago.

    • Author
      Posts
    • #1971464 Reply

      MrJimPhelps
      AskWoody_MVP

      The past few days have been very stressful for me – somehow my computer got stuck at a “Grub Rescue” prompt whenever I would reboot.

      I tried running the Grub Rescue commands to find my Linux partition, setting it to Root, running “insmod normal” and “normal”, but that didn’t work, because apparently there was no Grub folder. (I couldn’t find it.)

      I tried booting to Linux Live, mounting my hard drive Linux partition as the active one, then running “grub-install”, but that didn’t work. But this step made some progress – I now rebooted to a “Grub” prompt rather than a “Grub Rescue” prompt.

      I even tried copying the Grub folder (and all subfolders) from the Linux Live DVD to my hard drive, but that didn’t work.

      I found all of the above suggestions by searching the web. I don’t remember the specific locations, except that one of them was a Youtube video.

      What finally fixed it was a procedure I found at https://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/.

      Basically, I ran a few commands from a terminal window, then a command called “boot-repair”. Once boot-repair finished running, I removed the Linux Live DVD and rebooted.

      Here’s what HowToGeek says about Boot Repair: “Boot Repair is a graphical tool that can repair GRUB2 with a single click. This is the ideal solution to boot problems for most users.”

      It worked for me, and it will probably work for you if you ever get stuck at a grub or grub rescue prompt.

      Here are the steps to follow, as outlined in the HowToGeek article:

      1. Boot to Linux Live, either with a DVD or a flash drive.

      2. Make sure you have a good internet connection.

      3. Open a Terminal window and run the following commands to install and launch Boot Repair:

      sudo apt-add-repository ppa:yannubuntu/boot-repair

      sudo apt-get update

      sudo apt-get install -y boot-repair

      boot-repair

      4. Follow all on-screen instructions in Boot Repair; choose “Recommended Repair” when asked.

      Once Boot Repair finished, I removed the Linux Live DVD and rebooted. The Grub boot menu appeared for a few seconds, and then I came to the login screen for Linux Mint.

      Problem solved!

      Group "L" (Linux Mint)
      with Windows 8.1 running in a VM
      2 users thanked author for this post.
    • #1971771 Reply

      mn–
      AskWoody Lounger

      BTW – computers with either buggy UEFI firmware or dead CMOS battery (or both) may end up at a Grub Rescue prompt on their own too.

      Say, one of those models that by default looks for Windows by name… specifics vary but at least one of these models will boot up just fine after exiting the Grub Rescue interface and then picking the UEFI-mode internal disk out of the firmware menu it drops to.

    • #1972784 Reply

      Paul T
      AskWoody MVP

      A partition restore would have done the same thing only faster.

      cheers, Paul

    • #1984254 Reply

      LHiggins
      AskWoody Plus

      Hello! I am replying to this thread even though it is a couple of weeks old. I have run into a GRUB repair problem and in my search came across this thread. I started a post about it, GRUB boot issue and Macrium Backup but thought I’d also post here.

      After reading through this post and thinking a bit more, I think the issue for me is that the boot loader on my Windows 7 laptop has been somehow compromised during the attempt to install Linux Mint on an external SSD. When I initially tried to boot into that SSD drive after the Mint install, I got the GRUB repair message, but I think that was because the GRUB in Windows wasn’t working. I can access Windows using my Mint install on my thumb drive – there I get a choice, but I think that is because the GRUB on the thumb drive is working. Before, if I wasn’t booting into the thumb drive, it would go right to Windows – now I can only access Windows through that USB thumb drive’s GRUB menu.

      I know this is the Linux forum, but I was wondering if the process of repairing that you used would also be able to repair my Windows GRUB as well, since I think that is where the problem lies. No idea why it would have gotten changed when I was dealing with my YUMI drive and installing Mint on the SSD.

      Anyway – took a chance posting here to see if this process might repair the Windows GRUB as well.

      Thanks!

      • #1984511 Reply

        Paul T
        AskWoody MVP

        Lily, we are dealing with it in your original thread. Easier than moving it across multiple threads.

        cheers, Paul

        1 user thanked author for this post.
        • #1984576 Reply

          LHiggins
          AskWoody Plus

          Thanks Paul! Much appreciated. I’ve posted over there!

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Stuck at a Grub Rescue prompt

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.