• Stuck in a repair loop

    Home » Forums » AskWoody support » Windows » Windows 10 » Windows 10 version 22H2 » Stuck in a repair loop


    My wife has a pretty old laptop – a Dell Latitude E5510. I don’t know how old it is, but it has a 9-pin serial port on it, which makes it pretty old.

    A while back I installed Windows 10 on it. Since doing that, it has worked just fine until now – this morning it was stuck in a repair loop.

    I tried restarting in Safe Mode with Networking and in basic Safe Mode. It wouldn’t restart in either. I finally got it to restart in Safe Mode with Command Prompt, and I was able to do a directory listing on the hard drive, which told me that the hard drive was not the problem.

    I suspected that a rogue Windows update was the culprit; so I chose “Troubleshoot” then “Uninstall update” from the start screen. I wasn’t able to uninstall either the most recent feature update or the most recent quality update. (Don’t you love those “clear as mud” names for the updates!)

    I figured I would need to reinstall Windows, so I installed the drive in my other computer and booted it up, to copy the data off of the drive. I thought it would be treated as the 2nd drive, but it actually was the primary drive – it booted to that drive. It showed the Windows update screen with the spinning wheel for a couple of minutes, then let me log into Windows. I could tell I was on my wife’s drive, because of what I saw on the drive. So I figured the drive was now ok – Windows had somehow fixed whatever the problem was.

    I then installed the drive back in my wife’s laptop and fired up the laptop. But I was once again stuck in the repair loop! On a lark, I tried once again to uninstall the most recent feature and quality updates. It failed immediately on the feature update, but it ran for a good while before failing on the quality update. I then restarted the computer, and I was able to successfully log into Windows 10!

    My gut tells me that there was a hardware update that caused Windows to hang (it is, after all, a very old laptop). So I ran Group Policy Editor and told it not to install device updates, just to make sure this doesn’t happen again.

    So far, so good….

    Group "L" (Linux Mint)
    with Windows 8.1 running in a VM
    2 users thanked author for this post.
    Viewing 1 reply thread
    • #2603851

      Christmas present time?  As yes, serial port means it’s old 🙂

      Thank you for sharing your solution!

      Susan Bradley Patch Lady/Prudent patcher

      1 user thanked author for this post.
    • #2607180

      Was it KB5032189? We seem to be having repair loop issues across various models, and O365 disconnects. Removing that patch seems to stablilze.

    Viewing 1 reply thread
    Reply To: Stuck in a repair loop

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: