News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Suddenly cannot set 3rd party apps as default in 1803

    Posted on zero2dash Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 Suddenly cannot set 3rd party apps as default in 1803

    This topic contains 6 replies, has 5 voices, and was last updated by  Tiny 3 months, 2 weeks ago.

    • Author
    • #220931 Reply

      AskWoody Lounger

      @ Work under 1803 17134.286, I noticed today that Edge is set as my primary browser instead of Chrome or Firefox.
      When I try to change this, there are no options. Edge or “Look for app”, but “Look for app” finds no apps.

      I’ve tried rebooting, resetting to MS defaults and then changing default. I’ve also tried going to Control Panel > Default Programs > Set Your Default Program, but in 1803 this pulls up Settings, not the old CPL screen like 1709 does.

      Any other suggestions? This is not enforced by GPO on our domain. I’m expecting that a Windows Update did this, because previously I did have Chrome set as the default.

    • #220936 Reply

      Da Boss

      Have you tried disabling Edge from starting up in GP? Perhaps this is taking precedence over other browsers? Not sure..

      Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Microsoft Edge
      On Windows 10 1803, the configuration listing states:
      ‘Prevent Microsoft Edge from starting and loading the Start and New Tab page at Windows startup and each time Microsoft Edge is closed’
      click on the radio button labeled as Enabled.
      And in the configuration drop-down menu, select ‘Prevent tab pre-loading’
      click on OK. Reboot the computer for the changes to take an effect then try setting default browser.

      ********** Win7 x64/x86 | Win8.1 x64 | Linux Hybrids x64 **********

    • #220953 Reply

      AskWoody Lounger

      Ended up reinstalling the browsers, and now both show up as options to set as default.
      Very weird that they disappeared in the first place though I’m not putting it past MS.

      1 user thanked author for this post.
    • #220968 Reply

      Da Boss

      Very odd glitch in the favor of MS, glad you got it sorted 😉

      ********** Win7 x64/x86 | Win8.1 x64 | Linux Hybrids x64 **********

      1 user thanked author for this post.
    • #1732253 Reply

      Mark L Olson
      AskWoody Plus

      This is still a problem in 1809, May 2019. I’ve tried multiple different ways to set my preferred default apps with no success.

      In searching for help, I’ve come across an app “Stop Resetting My Apps” — does anyone have experience with it?

    • #1864276 Reply


      I researched “Stop Resetting My Apps” and found no warnings against it, so I have given it a try.  It half-works.

      It seems to (so far anyway) successfully prevent Windows from resetting my image viewer and browser to their products, but it *doesn’t* prevent Windows from detaching my preferred viewer!  So I still lose the preferred file associations, but at least I don’t have Edge popping up and annoying me.

      Another shortcoming is that PDFs are not among the file types it protects.

      Still, I’m fining it to be better than nothing.

    • #1866075 Reply

      AskWoody Lounger

      I often find that it is much easier to right click on file.  Then select “open with” another app.  Then simply pick the program you want open that type of file with and check the always use this program box.

      Where am I? What am I doing in this hand basket?

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Suddenly cannot set 3rd party apps as default in 1803

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.