• Text editor for PDF’s

    Home » Forums » AskWoody support » Linux for the Home user » Linux Mint » Text editor for PDF’s


    Previously used OO Draw for filling in PDF format forms, etc.  Master PDF Editor (free) is somewhat awkward.  Anyone using Scribus?

    1 user thanked author for this post.
    Viewing 21 reply threads
    • #2481473

      Sorry, no.
      Using Foxit pdf free version, and Libre Office mostly here

      * _ the metaverse is poisonous _ *
      1 user thanked author for this post.
    • #2481474

      I’ve used this in a pinch. Here’s a write up on it.


      One upside is you’ve probably got it installed already.

      2 users thanked author for this post.
    • #2481570

      This is a common problem with PDF software. Any PDF app that does it all costs a lot. Each of the different PDF software makers offers some form of limited free functions of their app to get you to buy the expensive one. The trick is finding a PDF maker that offers the function you want in their free app. Results is getting one app to fill in forms, another app to extract text, another app to extract images, etc.

      If you have Word, it can do a lot of these functions. If not then consider the free PDF tools from PlotSoft. They have many free PDF tools where each tool performs a specific function like merging or filling in forms.

      One Warning: This is free software, so every time you close the app after using it will pop up a box asking you to upgrade to the paid version. Even if you close the box it causes your browser to open to their web page to buy the paid version. So each close needs a box closed followed by closing your browser (Alt + F4). Considering the number of times I use the app, it is a small hassle and a better alternative than buying an app.

      This link to download the PDFill app:

      PDFill Free PDF Editor Basic

      Be sure to check out the other free tools.

      HTH, Dana:))

      1 user thanked author for this post.
    • #2481590

      If it’s about filling in forms only, you could try Foxit Reader. I’m not sure, but I think you can fill in forms with just about every free PDF reader?

      1 user thanked author for this post.
    • #2481594

      Web search yielded this information:


      Carpe Diem {with backup and coffee}
      offline▸ Win10Pro 2004.19041.572 x64 i3-3220 RAM8GB HDD Firefox83.0b3 WindowsDefender
      offline▸ Acer TravelMate P215-52 RAM8GB Win11Pro 22H2.22621.1265 x64 i5-10210U SSD Firefox106.0 MicrosoftDefender
      online▸ Win11Pro 22H2.22621.1413 x64 i5-9400 RAM16GB HDD Firefox112.0b3 MicrosoftDefender
      1 user thanked author for this post.
      • #2483746

        Been using LO Draw, but advised elsewhere this is not a good idea.  Not sure why.  Searching PDF editors- 5 times = 5 different lists- just as happy to stick with Draw unless the sky falls or suchlike.

        • #2483757

          Consult Oldergeeks , they know!

          * _ the metaverse is poisonous _ *
          1 user thanked author for this post.
        • #2483844

          I’m curious where you found using LO Draw was not a good idea. Seems to me that you have it, it works, and you updated it a few months ago.

          1 user thanked author for this post.
          • #2483905

            A couple of years or so ago, might have been on the Mint forum, a user warned me that Draw processed a pdf as a picture and might disrupt the elements of a form being filled out.  Never had that happen, but went to Master PDF Editor as a precaution.  That app was kinda clunky the few times I used it.  No idea if the warning re Draw is valid or not.

            And yes, Draw gets updated via Update Mgr.

            1 user thanked author for this post.
            • #2499591

              @slowpoke47, I know I’m very late to this party, but in case you’re still interested, you may have a way to vastly expand the range of PDF editing choices for your Linux Mint system.

              WINE is an application that simulates the Windows environment within Linux, allowing the use of many (though not all) Windows programs in Linux. If you do not have WINE installed on your machine, I recommend that you consider it. As far as I know, it’s available from the repositories for all flavors of Linux.

              Having WINE and a related application, Q4Wine, already installed on my Kubuntu machine, today I decided to try installing PDF software made for Windows. I settled on Foxit PDF Editor Pro, which I’ve had good experiences with in Windows. So I went to Foxit’s downloads page and selected the trial version, then downloaded the setup .EXE file. (Depending on your requirements, you might prefer to download the free Foxit Reader.)

              Once it was downloaded, I right-clicked on the filename and then selected the “Open With” option in the resulting menu. This gave me (among other things) a choice of running the setup file in Q4Wine or with the Wine Windows Program Loader; they both seem to accomplish the same thing via slightly different UIs.

              After selecting Wine Windows Program Loader, a window opened up asking where to install the program. (Not to worry, they offer default locations and these are sensible.) Next, the Foxit installer launched and took me through the various options of what components to install.

              Once this was done, the installation began and soon it was done, announcing that “Foxit PDF Editor has been successfully installed”. Clicking on “Start now” launched the actual program, preceded by an option of whether to Buy Now and whether to select “PDF Editor” or “PDF Editor Pro”, which has more enterprise-oriented features. So far, everything appears to be working to perfection.

              The process will no doubt be similar for any Windows PDF program that you choose to install in WINE; this is only an example. For years, I hesitated to use WINE, as I found the installation process to be convoluted and confusing. But clearly the developers of WINE have upped their game in this regard, and today I found the installation process to be fairly simple and straightforward. The Windows programs that have been installed in WINE show up in the application launcher in cascading menus under Wine.

              I hope that you, or at least a future reader, will find this rundown to be useful.


              2 users thanked author for this post.
            • #2499676

              A big thanks for this post- never truly resolved this issue but kept it simmering on the back burner.  Currently time-challenged due to pressing (non-computer) list of to-do’s but will absolutely pursue your suggestion shortly.  much appreciated.

              1 user thanked author for this post.
            • #2503389

              I’ve just installed Notepad++ in a manner very similar to what @Cybertooth described. Instead of Q4Wine, I have Playonlinux installed. The only difference seems to be what happened in Cybertooth’s paragraph 4. When I right clicked on the Notepad++ setup executable file, I did not get any choices like he did. So I installed from the terminal and everything went well. I did get an error message that I didn’t understand but which seems totally innocuous.

              FYI the terminal commands I used were:

              $ cd Downloads/
              $ wine npp.8.4.7.Installer.exe

              npp.8.4.7.Installer.exe is the 32 bit installer file that I downloaded to my Downloads folder. 8.4.7 is the version number and could well be different by the time anyone reads this.

              2 users thanked author for this post.
    • #2500792

      It turns out that Dedoimedo posted a quick guide to installing the Windows version of Foxit Reader on Linux by using WINE. He actually posted his piece the day before I replied to this topic, otherwise I was going to wisecrack that maybe he read AskWoody and decided to report on the procedure himself.  🙂


      1 user thanked author for this post.
      • #2500874

        Searched WINE in Synaptic the other day, got a dozen or so hits, and this latest info is likely going to be most helpful.  As mentioned above, busy putting out (non-computer) fires as well as chasing an oddball FF display issue that all need more or less immediate attention first.  Might be back looking for some wisdom with that FF issue, but some house semi-emergencies come first.  Once the dust settles, back to cyber projects.

        1 user thanked author for this post.
    • #2503340

      Out of circulation for (I hope) a few days, health issue.  Back to this as soon as possible.

    • #2511700

      Attempting to rejoin the world and get back to this.  Installed okular from synaptic, seemed less likely to trip me up than going the WINE route.  Now trying to figure out how to manipulate this program.

    • #2511745

      Welcome back!

      I have Okular installed on my Kubuntu Linux machine. I’ve used it a few times to view image (.PNG) files. Just launched it to see what it might be able to do with PDFs.

      In terms of text manipulation, I don’t see any way to edit text in Okular. All you can do in it with regard to text is to select text, find text, print out the document, or export the PDF’s contents to a plain text file. I tried selecting a couple of words of text and then typing over them, but nothing happened.

      Looking at the Okular Handbook (from clicking on the Help menu at the top), the program is described as “a KDE universal document viewer”. That does seem to capture the essence of it: it’s a viewer, not an editor, and there really isn’t very much that one can do with it.

      Hope this helps.

      1 user thanked author for this post.
      • #2511768

        A user on the Mint forum suggested it.  Looked at it briefly once installed and I didn’t spot an edit option either.  But the Mint user posted several s/shots, not resembling my screen.  About to investigate…

        UPDATE:  Installation was CLI, <sudo apt install okular>  s/shot shows 3 of 8 modules installed.  Would you add the other 5?


    • #2511962

      In spite of the tease re ghosted “show forms” item mentioned previously, looks like Okular is a non-starter.  About to wipe it via Synaptic.

      Every PDF app I have tried on Linux has failed on form-filling. I get tax or bank PDFs that have XFA or AcroForms in them, and I have to go to Windows to fill them out.

      We no longer have Windows on any machine, abandoned when MS threw W7 under the bus.

      This whole issue is frustrating because in the past, I have filled in PDF’s using Libre Office Draw without drama.  OS then was Mate 19.2.  Now, new computer, Mate 20.3, multiple L-O updates later, Draw returns an error message “wrong file version” when attempting to open a PDF.  Also tried Master PDF a while back, turned out to be unworkable.

      The installed (default) version of L-O is  According to the L-O site, a newer version, 7.4, is available.  https://www.libreoffice.org/                       Might be worth updating to see if that solves the issue.  Synaptic shows 405(!) items for “Libre Office” search, only a few here and there are installed, see examples here:


      How can this be so hard?🤨



    • #2512055

      This whole issue is frustrating because in the past, I have filled in PDF’s using Libre Office Draw without drama.

      Yeah, it sounds like the Windows world isn’t the only one that’s affected by progressive loss of features/functionality.

      It might indeed be worth a try updating your LibreOffice to see if the desired functionality has returned. Otherwise, we can revisit the idea of installing a Windows PDF editor in Linux by using WINE. I know you’ve been reluctant to go that route, but WINE isn’t that difficult to use anymore.

      1 user thanked author for this post.
      • #2512063

        L-O update probably worth trying.  As noted, 400+ modules listed in Synaptic with search for “Libre Office” but only a handful installed.  Should I uninstall the few that are installed before going ahead with the L-O update?

        • #2512120

          Somebody correct me if I’m wrong, but I believe that you can install the latest version of Libre Office without needing to install patches for the version that’s currently installed.

          Regarding those 400+ modules that Synaptic is showing, if your screenshot is any indication, then the bulk of them are dictionaries for languages that you’ll never have any need for.

          The bottom line: I wouldn’t bother to install those 400+ modules, nor would I bother to uninstall those few that you already have. I would simply move up to LO version 7.4. I anticipate that the LO updater will pick up on the modules you have installed and bring those up to date as well, but that remains to be seen.

          Good luck!

          1 user thanked author for this post.
    • #2512366

      Several attempts at this, no joy.  Simple enough to download the LO 7.4 tarball, and extract, either via right click or terminal.

      Managed to get extracted folder recognized by terminal, but unable to proceed.  Conflicting/incomplete info on web search.  Some advise searching for dependencies, others not.  Recently installed hplip tarball using this:    How to install hplip on Ubuntu – Edoardo Vignati  and tried substituting the LO program name for hplip, didn’t work.  My local library has not explained sufficiently just what to do next.  Most commands I tried returned “no such file or directory”  or “command not found.”  GDEBi Package Installer tells me “not a deb file” on both the downloaded and extracted files.  Reluctantly, once again, raising the white flag of surrender.

    • #2512427

      You might have better luck with installing LO 7.4 if you try doing it via Mint’s package manager rather than manually.

      My preference for sure but LO 7.4 not in Pkg Mgr.  This whole operation is above my pay grade.  Installed version is, nothing newer available.  Used LO Draw in the old machine to edit PDF’s but attempting to open a PDF in the current Draw installation returns error messages.


      Also looked for a path to update LO from within the app, nothing found.

      Another thing to remember is ‘Snap’ and ‘Flatpak’ packages may also have different versions from the LM repo’s.

      On the LO site, only one choice for Mint debian 64 bit, Snap and Flatpak listed separately.

      Is there a means to introduce LO 7.4 to Synaptic and then install?

      1 user thanked author for this post.
    • #2512467

      Just made an interesting discovery- the specific PDF I need to edit would not open, as detailed above.  But other PDF’s open using the installed version of LO Draw w/o issue and are editable.  There must be some X factor with the problem doc that prevents me from opening it as with the others.


      2 users thanked author for this post.
      • #2512501

        So then I would scrap what I say below, at least for now. Try to download the pdf again; maybe it got corrupted. Or perhaps whoever created the pdf in the first place did something wrong. Does the pdf file name actually end in “.pdf”?

        1 user thanked author for this post.
        • #2512630

          Yes, it’s .pdf and has the pdf icon.  Here’s my thought- the email to which the pdf was attached has an ALL-CAP BOLDED  paragraph announcing that the sender (our accountant) is using a new encryption service this year.  Likely some aspect of that “feature” interferes with editing the doc.

          I’ve spent a chunk of my life on this, and those Woody members who have contributed have spent time and effort as well.  My grateful thanks for the help!

          The discovery mentioned above that the doc, not the app, is the culprit leads me to abandon this effort and use the installed LO Draw to operate on other pdf’s if/when needed.  I plan to slice/dice/copy/paste the needed info from this problem doc into something I can work with.

          Once again my cyber education advances by going astray.

          3 users thanked author for this post.
          • #2512707

            “Once again my cyber education advances by going astray.”

            That’s usually the way it works!

            I would think your accountant could/would do a better job of providing user friendly documents that don’t sacrifice security.

            3 users thanked author for this post.
    • #2512477

      Since your version of LO has worked before I would go to Synaptic package manager and try ‘Fix Broken Packages’. Then if there’s no joy ‘Uninstall’ followed by an ‘Install’, or alternatively, a ‘Reinstall’. IIRC you’ve done these things before, although maybe not for LO. It’s worth a shot since maybe something got corrupted somewhere along the way.

      Also IIRC you installed on your old computer the version you now have, maybe a year or so ago. There’s an AskWoody Topic that I think you started where you, me, and probably a few others worked through downloading and installing the version you now have (we did it on your old computer, but I think it was the same version you now have on your new computer). There were some pretty specific instructions on the LO wiki (there’s a link to them on the LO site) that we got to work without too much trouble.

      1 user thanked author for this post.
    • #2512581

      Also looked for a path to update LO from within the app, nothing found.

      How odd. LO updates do show up regularly in Discover for Kubuntu Linux.

      I found this discussion from 2019 that jibes with what you’ve seen with regard to LO updates on Mint. I still don’t understand why updates would be offered automatically for Kubuntu but not for Mint.

      2 users thanked author for this post.
      • #2512631

        IIRC occasional updates for LO are offered on Mint.  But they are tweaks within the installed version (6.x) and not the newer 7.4.

        As I chased this phantom across the web a common result was contradictory and just plain unworkable info.  The pre-computer days had a (sarcastic) observation- “I read it in the tabloids, so it must be true.”  Substitute “online” for “tabloids”  and draw your own conclusion 🙄.

        2 users thanked author for this post.
    • #2512602

      Perhaps this will shed a glimmer of light on things.

      Mint 20.n is based on Ubuntu 20.04. If you scroll about 1/3 down this page:

      you’ll see that LO 6.4.7 is associated with Ubuntu 20.04 and that LO 7.3.6 is associated with Ubuntu 22.04, which in turn is the Ubuntu version that Mint 21.n is based on.

      When I search Software Manager on my Mint 20.3 machine for Libre Office I get a bunch of entries all of which are for LO 6.4.7.

      When I search Synaptic Package Manager for Libre Office, I get a lot of entries, almost all of which are for LO 6.4.7. But when I look carefully, there are a few packages for LO 7.3.7. In particular there is a package “libreoffice-nogui” which is a “metapackage; no gui”.

      Unfortunately I don’t know what a metapackage is nor what the consequences of “no gui” are.

      If I have time I might play with it tomorrow (or perhaps the next couple of days) on one of my test machines. In the meantime perhaps one of our Linux experts can shed some light on things.

      2 users thanked author for this post.
    • #2512632

      Unfortunately I don’t know what a metapackage is nor what the consequences of “no gui” are.

      Me neither.  Maybe that’s too far into coding-speak for mere users.  And perhaps “no gui” means you issue commands to your computer using thought waves.

      1 user thanked author for this post.
    • #2512719

      “Once again my cyber education advances by going astray.” That’s usually the way it works!

      Perhaps my consolation is that I at least learned some little nugget from this, hopefully to go on to bigger and better mistakes.


    • #2512725

      Hopefully this won’t be too far off topic, but here’s a link that offers a decent description of metapackages


      It seems that we’ve used metapackages to install/update kernels. When I update a kernel I get a list of dependencies and am then asked if I want to proceed. I think it’s actually a kernel metapackage that “gathers” every thing needed for a successful kernel installation.

      So I’m guessing the LO metapackage “gathers” everything needed to install LO; you only need to select one package in Synaptic Package Manager – the metapackage – instead of selecting multiple packages. I’ll try to verify this on a test machine, time allowing.

      Not sure about the gui yet.

      1 user thanked author for this post.
      • #2513024

        I tried installing the 7.3.7 metapackage, no gui package from within Synaptics Package Manager. Long story short, nothing I did worked. Many error messages ranging from need to fix broken packages, can’t fix broken packages, dependencies not satisfied, package xxx can’t be installed so package yyy will be installed instead, etc., etc., etc.

        Probably not a great setback since I found somewhere that the no-gui package is primarily used for scripting.

        I haven’t tried installing 7.3.7 – or 7.4 – directly from the LO website, and I probably won’t. The LO website says the preferred method is to install from a package manager

        So it appears that at least for installing from a package manager, Mint 20.x is locked in to LO 6.n.m (or perhaps lower), and that Mint 21.n is locked in to LO 7.n.m (or perhaps lower).

        1 user thanked author for this post.
        • #2513037

          Thanks for your efforts.  Having determined that the problem lay with the doc and not LO, that’s my excuse (in case I needed one) to compose our own doc locally with the pertinent info on it.  Yesterday my wife reminded me that we had similar misery trying to use last year’s form, and when she called the office back then, the partner said that 90% of their clients ignore it.  Sounds like a plan.

          A footnote:  LO itself is not without warts- just finished up a tax-related spreadsheet in Calc, in spite of some insistent wayward behavior by the program.  Could have done it with crayons in half the time.

          2 users thanked author for this post.
          • #2513048

            I’d be tempted to submit the crayon version!

            Seems to me that a lot of software exists with the main intent of pushing work downstream. In other words let’s make the customer do more of the work we (the vendor) used to do and still charge the same – or more – amount of money. Might increase the profits and productivity of the vendors, but it does just the opposite for the “proletariat”. It’s a zero sum game and the people at the bottom of the hill pay the price.

            3 users thanked author for this post.
            • #2513055

              Bearing in mind that Libre Office is free (as in, not purchased) software, increasing profits wouldn’t come into play in this case. However, it does suggest a lack of concern for the user on the part of the developers.

              Wouldn’t surprise me to see complaints to them meeting with the response, “if you don’t like it the way it works, then write your own software!” (I have actually been told that. <rolling eyes>)


              2 users thanked author for this post.
            • #2513059

              I should have been more precise in my statement. It’s really the accountant who seems to have a lack of concern for the user. While I understand the desire for encryption, it seems that there are likely better and more end-user friendly ways to ensure security than by throwing a pdf form at a customer apparently with a lack of guidance as to how to handle it.

              I actually applaud open source software, which is one reason I try to do as much with Linux as I can. Libre Office would not fall into the category I described above: “…a lot of software exists with the main intent of pushing work downstream”, but I think most for-fee software does fall into that category.

              2 users thanked author for this post.
    • #2512729

      Here’s my thought- the email to which the pdf was attached has an ALL-CAP BOLDED paragraph announcing that the sender (our accountant) is using a new encryption service this year.


      For me, this raises a BIG RED FLAG.  🛑🚫⛔🚩  Why? Because of the use of all caps to create a sense of urgency. That is one of the tactics of phishing-type of emails.

      If you haven’t done so already, PLEASE call your accountant (DON’T send an email on your own and DON’T reply to the one you received) or stop by to see your accountant to verify that the email you received is indeed legit. Call them at a number that you’ve used before. DO NOT call any number that might be listed in the email you received. If you plan to stop by, print out the email and bring a copy of it with you.

      Sometimes, establishments can have their systems inappropriately accessed, and the way they unfortunately find out is when one of their customers calls them or stops by to see them asking…”Hey, I just got this email (or this type of automated phone call) from you. Is this legit, or should I ignore it because it’s fake?”

      Especially important if the form you’re trying to modify is soliciting ANY type of personal information.

      If it turns out the email is legit, no harm, no foul. BUT, if it’s not legit, then by asking the question of them, you will have done yourself AND the rest of your accountant’s clients a BIG favor by helping them potentially avoid unwanted disclosure of potentially very sensitive information.

      • This reply was modified 2 months, 3 weeks ago by Bob99.
      1 user thanked author for this post.
    • #2513200

      Bearing in mind that Libre Office is free (as in, not purchased) software, increasing profits wouldn’t come into play in this case. However, it does suggest a lack of concern for the user on the part of the developers.

      I fully concur.  It seems that the cyber world is the only venue where people just assume a product should be free, no thought to the creative effort behind a program.  If a developer offers a less elaborate free version of a full-fledged app, we the users should appreciate it and not throw stones.

      Personally speaking I jump through hoops to avoid being a burden upon said developers.  My occasional use of office software doesn’t warrant buying an office suite.  But note that the LO Calc manual is 500+ pages and does not react usefully to searches.

      2 users thanked author for this post.
    Viewing 21 reply threads
    Reply To: Text editor for PDF’s

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: