• The Device Has Either Stopped Responding or Has Been Disconnected

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » The Device Has Either Stopped Responding or Has Been Disconnected

    • This topic has 62 replies, 11 voices, and was last updated 3 weeks ago by Jim.

    Greetings!  I have a experienced a new error message – and I was wondering if anyone else has experienced this as well.

    Recently – Upon unplugging my Android phone from the PC .. I get an error message “The Device has either stopped responding or has been disconnected” (see photo attached).

    This has happened recently – on a few different days – after I have transferred documents or images from my cellphone to the PC.

    And it’s not just one error message popup – if I click the “OK” or the “X” in top right corner to close the message – about another 19 of these images are remaining that I have to click shut.

    I have found the only way to stop the messages is to restart the PC.

    Does anyone know what causes this error message?  From where in the operating system is it coming?

    I did a hardware scan using the Dell SupportAssist – everything seems to be fine.  I checked device manager and I see that the Android’s USB’s Universal Serial Bus Controller doesn’t have a yellow triangle – I checked for the latest update for the device driver – it’s current.

    I ran a  – sfc/scannow – in command prompt – no integrity violations

    I have checked the cable I use to connect the phone to the PC – swapped it out and it’s not the cable.  I tried plugging in the phone into a different USB slot … it’s not the USB slot I usually use.

    I was wondering what could be the problem with my PC?

    Viewing 33 reply threads
    • #2385758

      I’m wondering if you’re ending your phone-to-PC transfer in an orderly fashion.

      Before unplugging the USB cable, are you going to the Android USB Preferences setting on your phone to select No data transfer, thereby telling your PC that the transfer is done?


      1 user thanked author for this post.
    • #2385788

      It’s my guess that the phone is mounted as another drive, in the same way as is done with a Flash Drive or CD/DVD drive.
      Close any app on the phone used for the data transfer.
      You should have an icon in the PC’s tray to “Safely remove device,” or open File Explorer, right click on the drive letter that represents the phone, and select “Eject.”

      1 user thanked author for this post.
      • #2385889

        I looked to see if the PC still felt it had a connection to the phone – I checked to see if there is a “safely remove hardware Icon” presented – there is none.  I copied and pasted the files.  I didn’t use an app.  I tried using Bluetooth last night to transfer some documents – no issue using Bluetooth.

        • #2385891

          The drive won’t show up unless the phone is connected.
          If you copy/pasted, you did so from somewhere – a drive letter in File Explorer.
          There should be a USB icon in the right hand taskbar system tray when the phone is connected – it may be under the hidden “^”
          You disconnect the phone the same way you disconnect a USB drive by clicking on that icon and choosing “Eject.”
          In File Explorer, right click on the drive letter that represents the phone (the one you copied from, not C:), and select “Eject.”

          • #2390033

            Your post prompted me to think about what could be running or how can the phone still be attached and then I tried different copy and paste motions and then when I copy and pasted to OneDrive – is when I received the error message.

          • #2413070

            I agree that there should be an option to “eject” an Android phone from the computer.  However, Windows 10 does not seem to offer that.  I read and followed all of the recommendations here.  I also cannot find a drive letter associated with the device.

            I am using a Samsung Galaxy S21 Ultra 5G, connected to the computer via USB type C.  It works just fine while connected.  Files transfer in either direction.  I just get this constant and irritating error message whenever I disconnect my phone from the computer.

            Any more ideas?

        • #2386034

          My Samsung Galaxy 4 phone does not cause Windows to show a “Safe to remove hardware” icon for it when it is connected to my computer.

    • #2385961

      Hi Linda2019,

      What type of USB cable are you using to connect to your Android phone to your PC? Is your computer a desktop or tower or laptop computer? What type of USB port are you plugging your phone into the computer — USB2 or USB3? Are you plugging your Android phone into a front panel on a desktop or tower computer?

      I am asking the above questions because many desktop and tower computers, especially if custom built, can have issues for front panel USB2 and USB3 connections. The issue is that radio frequency (RF) leakage from not fully shielded USB2 ports can leak into and interfere with not fully shielded USB3 ports on the front panel connections on desktop and tower computer cases. This issue is very rarely seen on laptop computers.

      Thus, a description of your computer would be helpful.

      Best regards,


      • This reply was modified 2 years, 1 month ago by GoneToPlaid. Reason: edited for a spelling typo
    • #2385970

      Further thoughts and input:

      1. I tried to reproduce Linda’s problem by unplugging 4 different Android devices with USB data transfer active from my W10 laptop. No errors.
      2. A Google search of Galaxy Grand Prime reveals a 2014 smartphone.  Could there be a failing micro-USB connection on the phone?
      3. GTP’s questions are interesting. Also, is anything new on the USB side, such as a hub?
      4. Regarding PKCano’s remarks, Android devices show up in File Explorer by device name (e.g. Pixel 3a) similar to computers listed under Network. They don’t show up in the USB icon on the taskbar and Properties for the device offers no Eject option.
      5. Bluetooth for transfers sounds like a better solution with no USB cable handling.
      6. Be on the lookout for phone charging problems if the USB connection is failing.




      1 user thanked author for this post.
      • #2387323

        Thanks for the input.  The phone is due to be replaced before the end of the year.  I received a message from my carrier that my phone will not be able to migrate over to the new 4G LTE HD Voice system.  Something to definitely think about.

        I have been doing Bluetooth and workaround with the USB cables – tried a bunch.. including the original that came with the phone .. the only way I don’t get the error message , while using the cable, is to only copy and paste to the PC .. and not to OneDrive.  The files are fully copied over, no “processing’ messages in icon tray .. but it still may be syncing.

    • #2386046

      Hi Linda2019,

      If you haven’t had issues in the past when connecting your phone to your computer to transfer photos, then I suggest replacing the USB cable which you are using with your phone. I previously mentioned the possibility of interference between a USB2 port and a nearby USB3 port if the ports on your computer are not properly shielded. Fortunately, only USB3 ports can be affected by this issue. Try connecting your phone to a USB2 port on your computer and see if your phone no longer disconnects from the computer. It will take longer to transfer photos from your phone to your computer when the phone is connected to a USB2 port, but at least the connection should be totally stable and not suddenly disconnect.

      I still use my old Samsung Galaxy S4. To transfer photos, I always connect it to a USB2 port on my computer since the front USB3 ports on my computer regularly drop connections due to interference from the nearby USB2 ports. In other words, the front USB3 ports on my computer basically are not usable due to interference.

      Best regards,



      1 user thanked author for this post.
    • #2386133

      Fire up MS Process Explorer.
      Drag the “target” icon over the message.
      What does PE say is the process? (highlighted)

      cheers, Paul

      • #2390030

        What is the “target” icon?  I haven’t tried this yet.

      • #2405630

        Take another look at this entry: #2386133

        The target icon is in the tool bar on the right end, just to thr right of the binoculars.

        Do as he said and drag that icon over error the message and let it go.  It will highlight the problrm process.  You can then right click and decide what to do with it.  I terminatedd mine with no ill affects (as of yet).

        Very simple!

        Thank you Paul T!

    • #2386305

      I started getting this same error with my iPhone after updating the Phone app (which I don’t even use, but it runs in the background) from the Microsoft Store (could be coincidental).

      I never saw the message before. Now it pops up at random, always two message boxes at a time, even if the iPhone has not been plugged in for days. I’ve done some Google searches, and I’ve see some other recent mentions of this problem elsewhere, but no solution.

      It first appeared shortly after an update to the Phone app, and the iPhone was not plugged into the USB, and had not been plugged into the USB for weeks.

      • #2399452

        I have this issue as well, it just started a few days ago, iPhone 11 updated to iOS 15 to Windows 10 with the latest built. I’m using an Apple cable that came with the phone.

        Never had this issue in many years using iPhone/Windows combination to transfer my photos from my phones to my laptops.

        2 weird looking warnings pop up after the phone is disconnected (as it they were fake warnings, nothing subtle about them) and you have to close them by clicking the “x” in the warnings, and then they pop up again several days later, even if the phone has not been reconnected since. I put my laptop to sleep at night so i have not restarted it. There is no “click on this before disconnecting” icon, as there is usually with a flashdrive-type of device. But traditionally, I never got that icon for the iPhone(s) anyway.

        • #2403610

          FYI, the problem fixed after another update to the “Your Phone” app for me, so I’m pretty confident that in my case, a buggy interim update was the culprit.

    • #2386379

      I started getting this same error with my iPhone after updating the Phone app (which I don’t even use, but it runs in the background) from the Microsoft Store (could be coincidental).

      What Microsoft iPhone app and for what purpose ?

    • #2386388

      What Microsoft iPhone app and for what purpose ?

      How did we get from Linda’s Android phone to an iPhone?  As someone observed on another thread, “apples and oranges”.

      Dell E5570 Latitude, Intel Core i5 6440@2.60 GHz, 8.00 GB - Win 10 Pro

      • #2386833

        The same problem is occurring with both devices; they are both phones that connect to the PC via the USB. I thought it would be useful to indicate that the problem is not unique to android phones.

    • #2386402
      2 users thanked author for this post.
    • #2386407

      This is a sideways slant on the issue based on a Windows 98 issue, but as Microsoft have been rearranging their printing a lot in recent weeks.. might be worth a shot.. no matter what device/phone/gadget  you plug in..

      You don’t have a MFC (scan and print using SD card) printer do you? (the one I had was an Epson, but I doubt that matters.)

      The problem was the result of a file system on another unrelated device being attached which the “media insertion” detection part of the driver for the printer already installed couldn’t correctly resolve, and thus the printer driver was causing the message, as that became unresponsive when the problem device was connected.. (as it was expecting the “drive” to be a SD card (FAT32 I guess) in a card reader, not an ancient no brand MP3 player which for some reason was FAT formatted by its software and caused the problem when plugged in.)

      Perhaps unplug any other devices, reboot (so their drivers don’t start) and see if the problem goes away? The “10 times” could simply be the result of the number of times that the failing service supporting the driver is set to try restarting.

      1 user thanked author for this post.
    • #2386579

      Update from  my post 2385970 above:

      Today I copied some photos from my wife’s Moto G7. On turning off Data transfer mode, I got the error message. I then tried my Pixel 3a and browsed some files, turned off data transfer and got the error message. In each case a single error message.

      The day after my earlier tests, the 2021-08 cumulative update KB5005033 installed on my system (Win 10 Home X64 21H1).

      Regards, Phil


      1 user thanked author for this post.
      • #2386583

        It seems like the CU is the cause of the issue.

        • #2387322

          I was hoping that .. it wasn’t due to updates.  My problems started 2 weeks after I updated Windows in early August.  I did have a couple of  DELL updates about a week after the Windows Updates.  The error messages started after the DELL updates.  I wouldn’t even know where to start with fixing this type of problem.

    • #2387320

      Well, I have sort of narrowed down the problem .. the error message pops up when I copy and paste to OneDrive.  Even though the file is copied over and the icon next to the folder is a solid green check mark .. no processing of changes messages from icon tray … some how it must still be syncing.

      I have copied and pasted only to the PC and unplugged the phone from the PC … no error messages.  The error messages happen when I copy the file to OneDrive or OneDrive in addition to the PC.

      Workaround – I will copy just to the Documents folder and then separately copy it from there to the OneDrive Folder.

      But, it would be nice to be rid of the problem

    • #2389631

      I am having the same problem on my Dell laptop. The error message keeps coming up despite not having my android phone connected for days. I get 10 or more error boxes randomly appearing while using my computer. I wonder if it’s a Dell update problem. When I disconnect my phone from my laptop, there never has been an icon in the ‘safely remove hardware’ spot for it, which I use for other devices, such as SD cards, external hard drive etc. I  hope Dell produces a fix soon, if that is the problem. I have a small USB C port, which I need converters for.

    • #2390303

      I also encounter this problem whenever I disconnect my android phone or my Nikon digital compact camera. It’s very annoying to say the least.

    • #2390378


      Since you’ve isolated the problem as being related to OneDrive, you may want to read Fred Langa’s series on the ins and outs of OneDrive configuration and use in the AskWoody newsletter from earlier this year (assuming you haven’t already,  of course). He goes rather in-depth and you may find the answer in there.

      1 user thanked author for this post.
    • #2393210

      The problem isn’t specific to Dell PCs. I have a home built desktop computer. And NO you can’t “eject” a smart phone from File Explorer. Reboot has been my only solution so far. Definitely a new problem not seen before 2 months ago.

      • #2397834

        Same here – only a problem in the last few months – after the August updates – the only advice that works is to:

        1. use Bluetooth to transfer files
        2. if using a cable – copy and paste into an existing folder in your PC – do not sync to the cloud – put it in your folder  and then , later copy it to your cloud files
        3. a new item – I used to be able to open the files on the phone and print from them and not have the strange disconnect message – but now I do – so now .. to work around that I have to copy the file to an existing folder to look at the photo or document

        It might be solved correcting something in the registry – but I have done sfc /scannow, ckdsk, etc – nothing *appears* to be an error in the registry…but I bet something is off.

        My inability to burn DVDs happened after an update as well – did all of the protocol like scanning for errors, and in examining the registry the NoCDBurning value was 0 –  not 1 – so I still should have been able to burn a DVD.  Dell Tech Support was useless – paid all that money for nothing.  I find a Dell article about that topic and followed the instructions in the article to delete those keys within the registry and now I can burn DVDs.  So… there was no real error – 0 is a valid value – … but something just wasn’t right.  I bet its something similar plaguing our phones relationship with our computers.  We just need to find an article or tutorial that actually addresses it.

    • #2395453

      It’s definitely not specific to OneDrive or Dell – I have had the issue for a couple of weeks now with two Windows 10 Pro computers; my laptop at work, and my PC at home.

      The device is a Huawei P20 Pro – this has not received any updates in recent months that might cause it. I’ve also cleaned the contacts of the USB C connector, and there are no issues while connected (data transfer is fine, USB C headphone adapters work fine).

      It occurs with USB2.0, USB3.0, 3.2g1 and 3.2g2 (A & C). I’ve used at least six different cables.

      Neither computer has OneDrive installed, nor are they Dells (home PC is a personally-built gaming PC built around  a Ryzen 5800x/Asus Prime X570 Pro, work laptop is an HP).

      Both run Windows 10 Pro (home 21H1, work 2004).

      Home updates frequently. Work last updated 14/09/21 (Updates are paused until we find it convenient to update). Latest update was KB5005565.


      Prior to this, I could simply unplug my phone with only the disconnected sound playing – no issues whatsoever.

      Now, however, I will get 1-10 popups when disconnecting (there’s no option to eject the device anywhere) after accessing the device (even browsing files in explorer is enough, file transfer is not required to trigger it).


      Restarting the PC, or using Task manager to restart Windows Explorer, will temporarily stop the issue.

      • #2395912

        As an addition to this – I had an update through the Microsoft Store yesterday for the Your Phone app (home PC, and I believe the app was dated 12/10). Immediately after it downloaded and installed, I received the device not responding/disconnected error but have yet to receive it again.

        I checked for updates on MS Store on the work laptop, and Your Phone was last updated 12/10 – I haven’t seen the issue occur today.

    • #2398241

      I’m having this same problem after transferring some files via USB from a Galaxy S10 to a Windows 10 PC. I’ve had this phone for a while, but the problem only started in the last several months. I get one popup window for every time the phone has been disconnected since my last reboot, so if I don’t fully reboot for a while, the popups can stack up (a dozen at a time!). The popups always appear all at once.

      Thanks to Paul T for his post on August 27, 2021 suggesting that we (install and) fire up Process Explorer to identify the culprit. (The “target” icon is the cross-hair thing on the right, and it works like a champ.) Turns out the culprit is Microsoft Edge, which Microsoft DOES keep reinstalling on my machine, over my objections. Simple solution to this problem may be to uninstall Microsoft Edge.


    • #2398251

      Before you think you are going to get rid of Edge, read this #2372696, the section about removing it and especially the 9/14/2021 “Update.”.

      If you use the method  linked to tomsguide above, the next time you use Windows Update, the update will fail with an error code 0x800f0922.

      You can no longer remove Edge – it will reinstall with every monthly update. You CAN use the Edge Deflector App to ease the pain.

    • #2399817

      I removed Edge using the guide linked above but I’m still getting the same issue every time I connect my Samsung Note 20. I just built my PC so I was wondering if there was something wrong with my particular computer but after seeing how many people have the same issue I don’t know what to think.

      It’s very annoying because every time I want to transfer and photos or videos from my phone to my computer, the Photos app on my computer says the file is either “corrupted to incompatible.”

      I was contemplating whether I should update to Windows 11 to see if that somehow fixes it.

    • #2399957

      I have had this problem for a few months with both a Home built PC running Win10 Pro with the error mentioning my Android Phone

      and a Work Computer (Surface Book 2) with Win10 Pro with the error mentioning my work phone (an Apple Iphone)

      I do not have Onedrive installed on either pc.

      I have and use MS Edge and it is required because of my work.

      I tried to uninstall the Your Phone app but it is not allowed through the add/remove.


    • #2400645

      It happened after the last Windows update. It is an issue with the Shell Infrastructure Host. That is what is causing the errors. Microsoft currently has no fix. I saw this fix by a user on Reddit.


      Edit: Hey u/PureSilverFox the issue stopped for me after reinstalling “HID-compliant consumer device” in Device Manger. Right click on those devices (I had two), Properties, Update Driver, Browse Computer, Let me pick from a list, the select HID-compliant consumer control device. I am not sure if this a fix but you might try it. At least I couldn’t reproduce the issue since then.

    • #2400650

      This Windows fix worked for me.

      Settings – Bluetooth and Other Devices

      Removed the HID-Keyboard. I also removed my phone as a device. Unplugged my phone. Plugged it back up. Let it go through setting up the device. Fixed. I plugged it up and unplugged it several times. I think the issue was with the HID keyboard thing.

    • #2407321

      I am suddenly having the same problem: I unplug my phone and instantly 42 messages “The device…ETC”… I have transferred files (Audio, Doc, video, images)  the same way for years. I am doing nothing different. I transfer both to and from the phone to computer. I have several external drives on multiple hubs (I know your not advised to do so, but for what I’m doing, Ive never had any problems). My computer has never shown my phone listed anywhere in the “disconnect drive” list in the task bar though it shows the other external drives. The phone (android) shows up in explorer under in the “my PC” folder, with all of the other drives, and that’s where I’ve always accessed it. When I am done transferring files, seeing no “click to eject phone” or “click to disconnect” of any type ANY where, I just unplug the phone and off I go. I have changed nothing, except I DID update windows very recently… So I’m wondering if its something to do with that. Has anyone figured this out yet?

      • #2407346

        I first saw this following the Windows 2021-08 cumulative update. Since I don’t transfer files from the phone frequently, I now test it after each month’s updates. It still occurs following the 2021-12 update.

        On the first occurrence, I saw just one message after each disconnect of 2 different phones. The following day, random repetitions began to appear, some of which appeared on a different machine in my home network that had not had any phone transfer activity!  A restart of my machine calmed the weirdness, but any USB phone transfer will now generate one or a flurry of these messages, so I make a point of restarting after each phone transfer.

        Regards, Phil

    • #2413093

      My Samsung Galaxy 4 phone does not cause Windows to show a “Safe to remove hardware” icon for it when it is connected to my computer.

      I think that when connection your Android to Windows you get 2 options :
      Connect a phone, connect as USB storage.
      When connecting as USB storage you should have the option to ‘remove hardware’.


      1 user thanked author for this post.
      • #2422984

        I don’t see the option to “Press Stop on your Android phone to end the storage session before disconnecting the cable”.  Do you see it on your phone?

    • #2419012

      Any solid solution to the original stated problem by “Linda” dating back to August 24, 2021?

      Same problem here, Windows 10 PC, and a Samsung 21 phone.

      Upon disconnecting the Samsung from the PC, about 20 messages pop up stating “This device has either stopped responding or has been disconnected”

      In my case, not limited to when disconnecting to “OneDrive” like Linda’s experience.

      And NO, it is not a (“switch your cable thing”), or find the (“disconnect the device safely thing option”, one is not provided).

      Any solid fix will be greatly appreciated.



      • #2422981

        Well – I have a new Android phone – a Samsung A32 5G and I did not experience any problems at first.  Then one day – the issue came back again.  I have tried to run the DISM RestoreHealth when that took place and it did correct the registry.  Not sure if it is a recurring theme – hasn’t happened again since but .. if it does I will update this post.

    • #2419027

      UPDATED previous post.

      Well, for my situation, I followed the info provided by:

      DOKK3N on November 9, 2021 post:_ _ _where the suggestion was to remove the “HID Keyboard Device”.

      So I went into my PC’s device manager, then scrolled to “Keyboards”, then found “HID Keyboard Device”, right clicked that and “uninstall”.

      Then rebooted my PC, and the issued now seems to have vanished, problem solved for me.

      Upon research, when I rebooted, my PC reinstalled the “HID Keyboard Device”, but apparently updated it somehow or in some way to where now there is no problem or conflict and the original issued described by “Linda” at he origin of this post that I also experienced is no longer present.

      Thank you  DOKK3N

      Much appreciated.



      1 user thanked author for this post.
      • #2435409

        Rebooting “fixes”, so whatever changes you’re making before the reboot, don’t confuse correlation with causation.  But the issue will return the next connect/disconnect. Wish I knew the answer, but the grasping at USB cables, OneDrive, Dell, and the like is nearly comical.

      • #2585471

        Same issue as all were having…


        Uninstalled HID Keyboard Device as recommended…


        So far have not seen error message!





    • #2419250

      Experiencing the same issue. Multiple popups saying The device is either stopped responding or has been disconnected messages when unplugging my android device.

      • #2422983

        Have you tried to run a sfc /scannow or a DISM RestoreHealth command?  That’s the direction I am taking – that there is a registry problem – not necessarily a phone problem.

        Reason being … I have a new Android and at first I had no problems unplugging the device but it did happen again.  So I tried running a RestoreHealth command and it did fix something in the registry.  But not sure if it’s a direct correlation to the problem.

    • #2428193

      THIS IS DEFINITELY A ONEDRIVE ISSUE, NOT A USB ISSUE. I am getting it on a new phone I have never connected to my laptop via USB but am syncing files across both devices with Onedrive.

      • #2443579

        I disagree, as I, and at least one other post I saw above, said they experienced this same thing when NOT using OneDrive.

    • #2429311

      I am having the same issue with my pc and iphone.

    • #2443578

      I am having the same issue with these popup errors after I transfer files from my iPhone X to my HP computer’s C: drive (so this  does NOT appear to be a OneDrive problem nor a Dell problem as had been hypothesized earlier in the thread).  I usually get about 3-5 popups, and if I do nothing, they just sit there on the screen, but if I try to close the windows, I will eventually get a few more.

      My phone does appear as a drive in Windows Explorer.  I do not get the icon in my hidden task view icon list to allow me to “safely remove hardware”.  I made a desktop shortcut for this function, and when I execute it, my phone doesn’t appear on the list.  I am not given an option what to do when I connect the phone because it probably just does whatever I told it to do the first time so it remembers the device and just opens it as a drive.

      One thing I tried the last time was to close all copies of Windows Explorer I have open at the time I did the transfer, since I normally have several of those windows open all the time.  When I did this, I didn’t get the popup error messages. But this was a very small sample size of one try, so maybe I can try this a few more times with both methods: leaving several windows explorers open, and closing them all, and see if this really solves the problem.

    • #2537708

      My Samsung Galaxy S22 did the same thing, multiple messages “The device has either stopped…”. The solution for me was to go to USB settings on the device, select “Transferring files” for transferring files, then select “Charging phone only” before disconnecting it.

    • #2552173

      I am having the same problem with my Galaxy 21s and my new Nikon Z9 camera after I unplug the cable. I only started getting these warnings in the past 4 to 6 months.

      1 user thanked author for this post.
    Viewing 33 reply threads
    Reply To: The Device Has Either Stopped Responding or Has Been Disconnected

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: