• TLS error when running Thunderbird daily accessing outlook.office365.com server

    Home » Forums » AskWoody support » Productivity software by function » Non-MS Apps/programs » TLS error when running Thunderbird daily accessing outlook.office365.com server

    Author
    Topic
    #2419434

    Since Jan 13th, I have been unable to download emails to Thunderbird Daily v95 or v97, or to automatically update Thunderbird due to a TLS error as shown in screenshot below:

    I recently let Windows Update install the Jan 11th Feature update to Windows 10 21H2 and the Jan 11th Cumulative update for 21H2 and this error started just after that.  I had also installed the Redistributable for VS2015-2022, but this wasn’t the issue as I subsequently uninstalled it and the error remains.

    I am running Windows 10 21H2 64-bit on a desktop system.

    Thanks in advance for any suggestions!

    David

     

    Thunderbird-TLS-error

    • This topic was modified 4 months, 1 week ago by b. Reason: Reduced screenshot to just error message to obscure email address
    • This topic was modified 4 months, 1 week ago by b.
    Viewing 9 reply threads
    Author
    Replies
    • #2419440

      You need to check the Microsoft/Office 365 settings to see which TLS level is required. Microsoft is phasing out TLS versions older than 1.2.

      --Joe

    • #2419444

      I haven’t been able to find any settings in http://www.outlook.com or Thunderbird having to do with the TLS version number.   I’ve submitted this bug to bugzilla.mozilla.com to see if they have any suggestions.

      Thanks for your help!

      David

    • #2419454

      On your system, you can check the TLS settings using the old Internet Settings in Control Panel. Open Control Panel, type internet into the search box. Click On Internet Properties. Click on the Advanced tab. Scroll down to the TLS settings.

      If your Office 365 account is a personal account I’m not familiar with the admin settings available, If it is a business account contact your Office administrator.

      --Joe

    • #2419460

      I’ve looked at the TLS settings in the config editor in TB, and here’s what I have…

      Thunderbird-TLS-settings

      • This reply was modified 4 months, 1 week ago by b. Reason: Cropped out email addresses from screenshot
      • This reply was modified 4 months, 1 week ago by b.
    • #2419465

      I checked in Internet Options > Advanced in Control Panel and checked “Use TLS 1.3 (experimental)”, which was unchecked and “Use SSL 3.0”, which was also unchecked.  I then rebooted by system and tried TB again, with the same result.

    • #2419554

      That looks like an issue with the University of Waterloo server, not outlook. Check the settings for that account.

      cheers, Paul

    • #2419565

      Are other students/staff experiencing the same problem?
      ask around..you never know it could be affecting lots of people.

      Meanwhile, try reducing the following Thunderbird config flag:
      security.tls.version.fallback-limit to 3 (instead of 4)
      Then try your email after restarting thunderbird.

      If it still does not work, set the above config flag back to 4

      Then I would phone the university IT dept to assist.

      "-rw-rw-rw-" extreme computing
    • #2419591

      I doubt that the University of Waterloo server is at fault since the issue also happens with my personal hotmail and gmail accounts as well.  I can also log into the outlook.com website and use my hotmail and uwaterloo accounts with no difficulty.  Also, the university is no longer using its own servers for email but relying entirely on outlook.office365.com for its email service.

      I also changed the suggested config file key setting, but it made no difference.

    • #2419592

      The University has gone completely to outlook… TB is no longer accepted.  Since I’m retired, I set my system up the way I want it.  I like TB much better than outlook.  <grin>

    • #2421327

      Issue has been resolved. I uninstalled all Windows Updates from Jan 11 onward (2022-01 Feature update to Windows 10 21H2 and 2022-01 Quality Update to Windows 10 21H2), and also uninstalled Daily. I then reinstalled Daily from Jan 11 and let it update, and let Windows Update bring that up to date. Everything is working properly now. Not sure what the issue was, but it is now solved.

      • #2445842

        I was getting the same error and found it was because the clock on my computer was wrong.  I updated the time and everything worked.

        • #2445844

          If the clock is wrong again, you should check/replace the CMOS battery on the motherboard. Nickle-size round battery.

    Viewing 9 reply threads
    Reply To: TLS error when running Thunderbird daily accessing outlook.office365.com server

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.