• Touchpad no longer working

    Home » Forums » AskWoody support » PC hardware » PC hardware-General Questions » Touchpad no longer working


    I hope this is the right place for this question. I have an older Toshiba laptop with a touchpad (alps pointing device is the driver name). I’ve had it docked for a few months and been using an external mouse. Now I want to take it on the road and the touchpad doesn’t work. Zero response from touchpad or buttons. The driver is up to date (so I’ve been informed by Windows) and installed and working OK. Looking at Device Manager it says the driver is connected to a PS2 port. Huh? There’s no PS2 port on this laptop. There’s no sign of the driver in my startup programs so I’m guessing a Windows update has done this. I have no idea which one. (Win 10, 21H2).

    Any ideas?

    Viewing 3 reply threads
    • #2530187

      Windows 11 Pro version 22H2 build 22621.1483 + Microsoft 365 + Edge

    • #2530196

      The Device Manager is right. The PS/2 port is an internal port. There is no physical connector… the touchpad is wired directly to the chip (southbridge, most likely). This was usually how touchpads were set up on older laptops prior to the Microsoft “Precision” touchpad specification (which uses the I2C bus). If there are any modern laptops that do not have precision touchpads, they would also be PS/2 devices.

      Some precision touchpads can also be set to use legacy PS/2 mode, either in the UEFI/”BIOS” or in the OS).

      Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
      XPG Xenia 15, i7-9750H/16GB & GTX1660ti, OpenSUSE Tumbleweed

      1 user thanked author for this post.
    • #2530232

      Using Device Manager, I uninstalled the touchpad driver. Then rebooted. Then, again using Device Manager, I installed the touchpad device driver. I was given the option of 2 drivers, one about 3 versions newer than the original. So I installed that, rebooted and … yep. It worked. If an update downloaded a new driver because an old one was incompatible with the updated version of Win10, why the @#%& didn’t it install it?

      Anyhow … problem solved.

      • #2530239

        That’s great! Thanks for letting us know how it went. I’ll mark the topic as resolved!

        Dell XPS 13/9310, i5-1135G7/16GB, KDE Neon
        XPG Xenia 15, i7-9750H/16GB & GTX1660ti, OpenSUSE Tumbleweed

    • #2530253

      If an update downloaded a new driver

      In Windows Pro block drivers updates using GPEdit.
      In Windows Home block drivers updates using RegEdit


    Viewing 3 reply threads
    Reply To: Touchpad no longer working

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: