News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Triple Boot Disaster

    Home Forums AskWoody support Windows Windows 7 Questions: Windows 7 Triple Boot Disaster

    This topic contains 26 replies, has 6 voices, and was last updated by  anonymous 3 days, 16 hours ago.

    • Author
      Posts
    • #1921178 Reply

      anonymous

      I scoured the forums for any help on botched triple boot attempts, but came up empty. If there is an existing forum, please direct me to it. Otherwise, here goes.

      A couple of months ago, I got the bright idea of adding Zorin 15 to my dual boot machine which already had Win7 x64 and Win10 x32 working in harmony. Win7 is on one internal hard drive and Win10 is on the other internal hard drive. I created a new partition on the Win10 drive and successfully installed Zorin 15. However, when I rebooted my rig, Win7 had been renamed in the boot menu to “Microsoft Windows” and Zorin would not load. So I monkeyed around with grub. When I still couldn’t get Zorin to load, I uninstalled it and wiped the newly created partition.

      Now, Win10 will not load and cannot fix itself to be able to load or fix the boot menu. Although wiped, Zorin still appears on the boot menu and the Win10 drive has two partitions with the same drive letter. One was the wiped Zorin partition which I reformatted in Win7. The other is a storage partition for seldom used files. Also, the “hidden” grub garbage partition is at the head of the Win10 drive.

      To top all that off, my only working OS of the three, [Win7]’s drive clicks and freezes all functions of the computer, including the Win7 countdown clock. This freeze and clicking seems to be caused when I am downloading or move files around. The spasm ends anywhere from 5-20 minutes later without a BSOD or reboot. I have ran chkdsk /r, sfc /scannow, and sfcfix. Checkdisk finds data in bad sectors but seems unable to move the data. My guess is there are system files located in those bad sectors which are causing the clicking and freezing. Scannow finds corrupt system files, but cannot fix them and neither can scanfix. I have no installation dvd and cannot get an iso or anything because the product key on my refurbished computer is useless and MS doesn’t recognize it.

      I would appreciate any help in, first and foremost, being able to boot into Win10 because I don’t know how much longer 7 will limp along until it collapses. Secondly, I would like to fix Win7.

    • #1921371 Reply

      BobbyB
      AskWoody Lounger

      Hmm tricky one this little “pickle” you find yourself in.
      I’ll deal with the clicking HDD 1st as a matter of priority a “clicking” HDD is indicative of imminent failure so better to get all your data off there as soon as possible. Indeed back up all that you hold dear if possible from all your drives as a matter of course.
      The 1st avenue would be to try and run the BCDEDIT and BOOTREC cmds to either remake you Boot record or fix it, assuming you can boot from a system disk and or a USB stick;
      You can Boot from your WINRE or WINPE media or Setup image when you get to your first Window either hit SHIFT-F10 or in the next Window invoke the repair Windows and follow whichever path you choose albeit Auto Repair or X:prompt
      To remove Zorin from the boot menu use the bcdedit /delete {ENTRYGUID} /cleanup just enter the values indicated in the parentheses as illustrated below:
      BCDEDIT-remove
      Then run the BOOTREC cmd’s after the BCDEDIT cmd’s assuming the Zorin entry is there to be removed: there’s a guide here:
      https://www.lifewire.com/how-to-rebuild-the-bcd-in-windows-2624508
      I hit this a little bit back test driving Ubuntu when I was done with it, it had managed to write its self in to the Boot Record and I couldn’t remove it. Seems with an (U)EFI Machine it writes its self in to the NVRAM and is tricky to get out, the Solution was Draconian, back up and wipe the lot and Clean reinstall either from new or restore from a Macrium image.

      There’s some drastic Solutions there for you to try, just hold off for now or a while until some one else comes up with a better or easier solution but if you can, do backup in the meantime as a matter of course.

      Attachments:
      2 users thanked author for this post.
      • #1921676 Reply

        BobbyB
        AskWoody Lounger

        PS I did find this web page from HTG’s this may explain it better than I can:
        https://www.howtogeek.com/howto/17903/remove-ubuntu-or-xp-from-the-windows-7-boot-menu/ (note the same CMD’s work either from a CMD prompt inside Windows as well as booting from USB/ISO recovery environment “RE” ) and as Zorin is allegedly a descendant of Ubuntu, from what I read it may help.
        There’s another thought which maybe simpler than all that WINRE, WINPE cmd prompt work, and that is to clean reinstall over the Top of your Win10 install and or Win7. Install the OS as you want to choose on the drive of your choice, maybe skipping the “Ticking Drive” in the meantime and then pluck your files from WINDOWS OLD folder on the applicable drive, again risky but simpler. If you have easy access to the drives i.e. Desktop box disconnect the Cable or remove from Slot of the drive you don’t want to work with and do whichever course of action to whatever drive you choose. Note if its a laptop they do not take kindly to constant Assembly/disassembly or running in such a state for any length of time owing to their portable nature and cramped enclosure, come to think of it Desktops aren’t much better in that respect but they are more forgiving and an easier work around with a loose bad connections.
        Hope this helps a little bit. 🙂

      • #1922590 Reply

        anonymous

        BobbyB,

        Thanks for your response. The physical drive Win7 is on is partitioned so the only thing on the boot partition is the OS and installed programs. I am assuming I need to restart my PC in Safe Mode with Command Prompt to use the BCDEDIT and BOOTREC cmds? Can I do this without booting from a system disk and or a USB stick? All I have is a “repair” disc. I have no installation dvd and cannot get an iso or anything because the product key on my refurbished computer is useless and MS doesn’t recognize it.

    • #1921416 Reply

      anonymous

      Don’t know if this will help any but if you launch “msconfig” with Admin rights and go to the “boot” tab, you might be able to remove Zorin 15 from the MBR. This will not resolve other issues but it might recover access to Win 10?

      • #1921615 Reply

        Ascaris
        AskWoody_MVP

        MSconfig won’t be able to see the Zorin stuff, and I am not sure the BCDEDIT command will either.  Linux uses its own bootloader, while the MS options are all looking at the configuration of the MS bootloader.  When you start a multi-boot Linux PC, it uses the Linux bootloader to start GRUB, and if you then select Windows, it chain loads the Windows bootloader, hopefully starting Windows normally.

        If it is a UEFI PC, I would go into the setup and make sure that Windows boot manager is selected as the first boot option, not “Zorin” or “Ubuntu” or anything other than Windows.  The UEFI partition on the boot device can contain several bootloaders, unlike a MBR setup, and if the Linux one is selected, it will keep loading GRUB.

        If that does not work, I’d suggest using a Macrium Reflect rescue disc/USB drive to fix it.  It has a “repair Windows boot issue” function that exceeds the capability of the Windows boot issue fixer in the Windows installer or WinRE.

        But, as BobbyB said, you have a dying hard drive to worry about first. The click of death is an unmistakable sign that the drive’s hours are numbered.  Anything on that drive that is not also somewhere else is in immediate danger.  Whether this has anything to do with why Zorin failed, I do not know.  I’ve not tried Zorin itself, but it’s an Ubuntu descendant, and I have used Mint and KDE Neon, which are themselves both Ubuntu descendants.  Whatever it is, I am sure we could get it working (though that isn’t what you asked for, I know!), but for now, save your data.

        It’s a little late now, but before trying any major surgery like setting up multiple booting, always be sure to have a backup first.  It’s a really good idea even when not setting up things like that, as a hard drive (for example) could begin to fail at any time.  Sometimes it gives warning, sometimes not!  My last hard drive failure had no warning at all, from a perfectly functioning drive that looked perfectly healthy in SMART (which I had just checked hours before the failure) to a deader-than-a-doornail drive that wouldn’t do anything.

        Group "L" (KDE Neon User Edition 5.16.5).

        1 user thanked author for this post.
        • #1925196 Reply

          anonymous

          Ascaris,

          Thank you. Unfortunately, yesterday lightning struck my house. The only damage apparent was the Ethernet port on my desktop computer! Since the port is hard-wired to the motherboard, I was shocked it wasn’t fried as well. Also noticed the power strip outlet where my computer was plugged in is fried. I guess it did it’s job the best it could. So I have no internet access on my main computer. Going to Best Buy today to get some kind of wireless connection.

          • #1926015 Reply

            GoneToPlaid
            AskWoody Plus

            Well over a decade ago, a direct lightning strike took out the ethernet port on a desktop computer’s motherboard. The port wasn’t entirely dead. Instead, it was throwing tons of interrupts every second. I had to disable the port in BIOS, and then I had to boot into Safe Mode and uninstall and delete its drivers.

            • #1930565 Reply

              anonymous

              @gonetoplaid: Mine must be totally dead because the the lights are out above the port and diagnostics say the cable is unplugged. Not having any interrupts either.

              Ended up getting, at my son’s suggestion, an Ethernet to USB adapter. Who knew? Works great and didn’t have to sacrifice LAN speed to go wireless.

              Getting back to the triple boot disaster:

              @ascaris, when the computer boots up, “Microsoft Windows” i.e. Windows 7 is the first option, then Windows 10, Zorin, and System Restore. Apparently Windows 10 had created no restore points prior to the disaster.

              @bobbyb, I tried to download Win7x64 Pro and Win10x64 1903 from TechBench, both returned “File is not available for download.” I already have downloaded from HeiDoc, but the site seems static now so what can I do with the iso without a product key?

              Anyway, I don’t need to reinstall Windows 7 and I don’t want to reinstall Windows 10, just need help getting it to load. I have already tried “bootrec /rebuildbcd” and all System Recovery Options, nothing allows a boot into Windows 10. I have also gone through the Windows 10 repair options with no solution.

              I was able to follow the HowToGeek linked article to remove the “Neosoft Zorin” entry from the boot menu, thanks!

              I wish I could upload screenshots here, but don’t see how to. I’m almost to the point of buying another “refurbished” Windows 7 or 10 machine off eBay for $100.

            • #1932311 Reply

              Ascaris
              AskWoody_MVP

              when the computer boots up, “Microsoft Windows” i.e. Windows 7 is the first option, then Windows 10, Zorin, and System Restore. Apparently Windows 10 had created no restore points prior to the disaster.

              Is this the GRUB menu or some other kind of menu, like a boot override menu from the UEFI or a Windows boot menu?  Normally you have to press a key to get the UEFI to give you a menu, but the Windows menus I have seen have been blissfully unaware of Linux, though I haven’t done much with Windows 10.

              If the menu you see is GRUB (it will say GRUB at the top), you’re still using the Linux bootloader, and you would need to get to the UEFI settings and select the Windows one instead.  If it is the Windows one, you’re on the right track, and the Macrium rescue USB should still work… the “fix Windows boot issues” option in Reflect has become my go-to for Windows.  It’s simple and it “just works” much better than the Windows installer boot repair function, which really makes me wonder… why is Macrium better at restoring Microsoft Windows boot function than Microsoft?

               

              Group "L" (KDE Neon User Edition 5.16.5).

            • #1941990 Reply

              anonymous

              @ascaris

              When my rig boots up, I see “Windows Boot Manager” at the top. Even though the Macrap rescue dvd failed, my options are now 1) Microsft Windows -used to say Windows 7, 2) Windows 10 -which is inaccessible, and 3) & 4) Macrap Recovery.

            • #1932605 Reply

              GoneToPlaid
              AskWoody Plus

              It is good to hear that the network interface on the motherboard got totally cooked. That is better than a partially cooked network interface which can create the issues which I described.

              Please register here at AskWoody. It is quick and painless, and all of us would love to have you here as a forum member.

    • #1931980 Reply

      Paul T
      AskWoody MVP

      You have such a mess that it may be better to junk the lot and load W10 – after making a backup to an external USB disk/memory stick.

      Search the web for “windows media creation tool”. Go to the MS site and download a W10 ISO. Burn to USB, boot and re-install from scratch.

      cheers, Paul

      • #1932611 Reply

        BobbyB
        AskWoody Lounger

        Yeah my thoughts exactly @Paul_T, well if memory serves me right the “Ticking” Drive is on the 2nd Drive with the Win10 install, Wipe the C:\ (Shift-F10 at setup) X:\ DISKPART, LIST DISK, SEL DISK 0, CLEAN should do the trick then any data my be accessible after adding the 2nd Drive after install by adding the 2nd Drive via BCD. BCDBOOT D:\WINDOWS normally does the trick where D:\ is the 2nd Drive.
        This may well be a quicker solution than typing “hours” of BOOTREC Cmds to no avail. As the machine is fired up and assuming its connected then if the Drive’s on the way out as I suspect the longer its running the closer to failure it may well be and the data unrecoverable.

        • #1941982 Reply

          anonymous

          @bobbyb

          The ticking drive is partition C: on Disk 1 where my Windows 7 installation resides. Disk 1 consists of partitions C, D, F, and X. All are storage drives except C. Disk 0 consists of partitions G, H I, J, K, L, L- yes there’s two, and M – inaccessible Windows 10 installation.

          • #1942252 Reply

            Ascaris
            AskWoody_MVP

            When you add another drive to an existing Windows installation and put Windows on that new drive, it uses the same bootloader from the existing Windows installation and adds the option to boot from that point.  It’s very possible that whatever is wrong with the hardware on the system is what’s causing all of this grief.  Zorin didn’t work, Macrium won’t work, the network interface doesn’t work, the hard drive is failing…

            Can you test the Macrium rescue media on another PC and see if it boots?  It would be nice to know whether the issue was with the writing of the rescue media or while trying to boot it.

            Macrium may have an .iso version of the rescue media on their site.  That may work better.

            Good luck!

            Group "L" (KDE Neon User Edition 5.16.5).

            • #1948522 Reply

              anonymous

              @ascaris,

              Before I installed Zorin, Windows 7 and Windows 10 both booted up.

              Zorin installed but after restart, I could not boot into it so I uninstalled it.

              After that Windows 10 would no longer boot up either, so I was left with my rickety Windows 7.

              The network interface doesn’t work because it was struck by lightning.

              The Macrium ISO I burnt to DVD, failed to run on Windows 7 due to some winpeshl.ini nonsense. Also, the DVD was ignored when I tried to run it on my Windows 10 laptop and on an old Vista laptop.

              I believe my system files are corrupt, because every repair disk, back up, Macrium DVD etc. I’ve created from my current state of Windows 7 do nothing.

              I also believe the problem of booting into Windows 10 lies with Windows Boot Manager.

               

              @anonymous friend

              At this point, I’m will to try Super Grub2. Thanks for the suggestion.

               

              @PaulT

              If I had a Windows 10 install disk/usb I would have tried that first. Same with if I had a Windows 7 install disk/usb. If Super Grub2 fails, I will disconnect the drive where Windows 7 resides and try to boot anyway. Thanks for the suggestion.

    • #1932606 Reply

      GoneToPlaid
      AskWoody Plus

      I totally agree with Ascaris about trying the Macrium rescue menu to repair bootloader issues. I don’t know and I don’t care how it works. It just works. It saved my butt after I put Windows 7 into self-signed driver test mode in order to try an unsigned low level driver which I had hacked. The driver wasn’t the issue. It turns out that Microsoft no longer allows Windows 7 to be put into self-signed driver test mode. If you do that, then UEFI automatically gets broken.

    • #1941449 Reply

      anonymous

      @ALL,

      Well, I downloaded, installed, and ran Macrium…..totally ineffectual. It allowed me to create a “rescue” dvd, but it fails to load upon booting with message “A winpeshl.ini file is present, but no commands were successfully launched. This could be caused by incorrect formatting or an invalid executable name. Please consult the documentation for more information.”

      So I’m back to square one.

      • #1941559 Reply

        geekdom
        AskWoody Plus

        Are you able to copy your user files (profile) to an external drive?

        At this point, retrieve your important data.

        Group G{ot backup} TestBeta
        Win7Pro · x64 · SP1 · i3-3220 · RAM 8GB · Firefox: uBlock Origin - NoScript · HDD · Canon Printer · Microsoft Security Essentials · Windows: Backup - System Image - Rescue Disk - Firewall
        • #1941975 Reply

          anonymous

          @geekdom

          Thank you, but backup/copy attempts of user profile were ineffectual.  Error code 0x800700002. Thought this was because my system recovery drive had an * instead of a drive letter so I assigned it drive letter “B.” I only discovered that was an issue after extensive googling revealed that other Win7 x64 users had same problem making backups. Still getting same error. Apparently, Windows can’t find the files because they reside in the bad sectors of C: drive?

          Backstory on recovery drive, for the past 6 months it won’t fully defragment, stays at 3% and it’s almost full. Also when trying to back up, drive makes horrible grinding noise. Now this system recovery partition is on the drive – Disk 0, with the Windows 10 partition. The drive with my Windows 7 partition apparently has no recovery partition!

          The folders I see on the B partition are: Boot, Recovery, restore, and SVI. Files are: $WINRE_BACKUP_PARTITION, bootmgr, BOOTNXT, BOOTSECT.BAK, and RestoreLog.txt. The restore folder file restore.wim is taking up 2.36GB out of the 3.14GB partition.

          Another curious thing happened after the failed/removed? Zorin fiasco. Disk 0 was somehow changed to a Dynamic Disk thus making disk partition operations very limited.

          @anonymous friend

          Thank you, but I really don’t think grub will help as there is no longer any Linux on my computer.

    • #1941676 Reply

      anonymous

      Hello friend.

      Agree with others on need to backup data on failing drive, and assume that’s why you’re trying to boot Win10.

      So, that being said, if still trying to boot into Win10, maybe try Super Grub2 Disk?

      Super Grub2 Disk

      It’s basically a live bootloader (i.e., NOT an OS). As nothing else has worked so far, it might be worth a shot…

      Hope this helps.

      • #1942046 Reply

        anonymous

        @anonymous friend
        Thank you, but I really don’t think grub will help as there is no longer any Linux on my computer.

        Super Grub2 Disk is name of project, yes, but again,
        it’s basically a live bootloader – it is NOT a Linux-only tool.

        I obviously don’t know if it will work in your case, but if disk & Win10 partition are still ok, then it might be worth trying…

        Hope this clarification helps. And hope you’re able to find a solution that works for you.

    • #1942857 Reply

      Paul T
      AskWoody MVP

      Backstory on recovery drive, for the past 6 months it won’t fully defragment, stays at 3% and it’s almost full. Also when trying to back up, drive makes horrible grinding noise.

      You seem to have some serious hardware problems and need to replace that drive ASAP.
      I’d take the noisy disk out and try to boot with just the W10 disk installed, but you will need a W10 install USB/DVD ready in case you need to fix the boot.

      cheers, Paul

    • #1957988 Reply

      anonymous

      RE: Super Grub2

      Okay, so I ran SG2. Windows 10 is not listed under operating systems so scrolled down to the Chainload section and selected hd1,msdos3 which is where Windows 10 is. Hit enter and this was returned:

      “BOOTMGR is missing” Press Ctrl+Alt+Del to restart

      So what can I do now?

       

      • #1958107 Reply

        anonymous

        Not clear if you have done anything to address what seems to be a failing/failed drive. This has been mentioned by a few advisors above. But I haven’t seen you answer that directly.
        SuperGrub2 will find boot sectors located on working drives available to the system. If the Win10 boot sector is bad, or resides on a disk that cannot be seen, it will not be listed. Advise you install a new drive, complete with Win10 image from Microsoft, then pursue recovering data from the failed drive as a separate exercise.

        1 user thanked author for this post.

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Triple Boot Disaster

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.