• Two New Issues with attached and Network Drives

    Home » Forums » AskWoody support » Windows » Windows 10 » Windows 10-other » Two New Issues with attached and Network Drives

    Author
    Topic
    #2455036

    Hard to find the right place for this question. Feel free to move it if you like.

    Two relatively new issues.

    I have two attached portable drives and a NAS mapped.

    When I boot, the NAS is found. But at random after hours or days, the path is no longer found. When I try to remap it says it is already connected to the path I specifcy, do I wish to continue? I do, enter credentials and it remaps and works again. Usually until next reboot. So it is not not finding it at boot, but losing it??

    With BOTH attached portable drives I go to a folder filled for example with tunes. it opens, then one by one top down erases the listings but keeps the icon. When all are blank it repopulates like normal. The next time I open the folder they are all there. ONLY happens with folders set as MUSIC and only if viewing as DETAILS!!

    AGHHHH- just figured it out as I am typing this and testing:

    I changed the folder type from General Items to Music so when I open it reads, erases and repaints and changes the columns. Maybe this will help someone else.

    BUT…why does my NAS lose the mapping – and I did not mention before, but from the desktop shortcut to it? I have not tried from this PC when I get the error and will next time. And, even if lost, for example, my backup program will still write to it.

     

     

    Viewing 40 reply threads
    Author
    Replies
    • #2455040

      I have 2 Seagate NAS drives (single drive, personal Cloud type attached by Ethernet). Both have static IP addresses assigned to them. Both are mapped to my personal share on the drive by their SSID and a given drive letter, and set to reconnect on login: (\\Backup1\pkcano) (M:) and (\\Backup2\pkcano) (N:)

      After login, in Explorer, below the icon for each drive, there is a green dot. But after a while, the dot on the second drive turns red. It has gone to sleep. If I click once on the drive icon in Explorer, it wakes the drive and the dot again turns green. But while it is red the drive is reported offline. If I watch Explorer, when I run my backup program, the backup doesn’t start immediately because it takes a short time for the backup program to wake the drive and for it to spin up. The backup on the drive that does not sleep begins immediately.

      The Seagate drives come with Seagate Dashboard software that allows logging directly into the NAS. Whether the drive sleeps or not and the time of delay are settings in the NAS.

      Perhaps you can look at the settings in your NAS drives and see it this applies in your case.

    • #2455050

      Thanks PK.

      Mine has a static IP as well. Mine is attached by Ethernet as well.Mine is mapped by SSID and also needs the share wihich is c on the NAS. Mine \Nasboxc. Credentials are saved.

      I have never noticed before, but in My PC the NAS has a green bar below it. Not a dot. I have never seen it turn red, but will watch next time the shortcut reports it maissing the path or path not found.

      I do not recall a setting to have this sleep. Interface is nbrowser based. I shall look for a setting. But I cn say this never happened when this NAS was connected to my Windows 7 computer.

      1dot

       

       

       

      • #2455056

        Maybe check/turn off “sleep to save resources” on your PC’s Ethernet/WiFi cards also (?)

      • #2455135

        rebop,

        The green bar in the picture is actually a cable depiction indicating a network connection.

        May the Forces of good computing be with you!

        RG

        PowerShell & VBA Rule!
        Computer Specs

        • #2455145

          Hmm, so then what is the green dot PK referred to?

        • #2455191

          Same thing, just a different icon. green = GO, red = NO GO
          Green = connected, red = not (for whatever reason, disconnected, sleep, etc)
          Sorry, thought that was obvious from my explanation.

      • #2455226

        I have never noticed before, but in My PC the NAS has a green bar below it. Not a dot. I have never seen it turn red, but will watch next time the shortcut reports it maissing the path or path not found.

        The green part doesn’t turn red if it’s disconnected, instead there’ll be a big red X over it like this.

        NAS-Disconneccted

    • #2455062

      Checked NAS and no sleep or spindown checked.

      Ethernet adapter allow to save power unchecked.

      I changed DNS servers on the NAS. Corrected the time zone since i moved. Will see when it happens again.

    • #2455070

      The NAS should use your local router as DNS. Then it can see other devices on the network by name. (Ideally it should not have a DNS at all – it doesn’t need internet access.)

      Instead of worrying about the mapping, use shortcuts to connect to the NAS.

      cheers, Paul

    • #2455071

      Don’t know if it’s true for drives from other manufacturers or would even apply to your NAS, but WD drives are infamous for having a “built-in” sleep function that can not be disabled by any external S/W; including Windows power management!

      I just happen to own such a drive (a My Passport) and regularly have it go to sleep when it’s plugged in even with the “Allow the computer to turn off this device to save power” option under Power Management disabled.

    • #2455081

      I AM using a shortcut Paul. But it is to a share on a mapped network drive. How else could a shortcut be? And the NAS is accessible remotely with software I have so I belive it DOES need DNS. I havd comcast in there as that is where I used to be and changed to the Goggle DNS servers.

      And alejr, you might be right. This is populated with 2 WD Red’s.

      Wating on the next incident to look at things a little more.

    • #2455144

      Use the direct path, e.g. \\nas_name\nas_share\path

      Remote access to the NAS does not require the NAS has a DNS set. Access is from the remote machine to the NAS.
      I hope you use MFA to access the NAS. There are plenty of reports of ransomware on NAS.

      cheers, Paul

      • #2455169

        Not understanding, Paul.

        I have the \\name\share\what are you referring to as path here???

        • #2455245

          Does that shortcut allow you to connect without supplying credentials?

          cheers, Paul

        • #2455262

          No, I have to have saved credentials. Or enter them.

        • #2455281

          “Saved credentials”?
          You have the drive mapped at boot and it works, yes?
          Sometime later the map is missing. At this point can you use the full path to connect?

          When the map is missing, enter this in a Command Prompt and tell us everything you get in response: net use

          cheers, Paul

        • #2455283

          “saved credentials” Remember box checked when mapping, hence saved credentials.

          And forgive me, I STILL do not know what you mean by “full path”. As far as I am concerned, \\Nasbox\c  IS the full path. What else could it be?

          So when it stops finding the drive from the shortcut., I remap the drive. It says it is already connected to – but I cannot open from the shortcut icon. I have not tried to open from explorer, and I should. But it has also not failed in 2 days or so. Will be the next thing I try.

          But I need to know what you mean by full path and enter that where?

          Good idea on net use. Will try before clicking in explorer next failure. Hmmm. maybe not:

          Just ran it and it reported:

          C:\WINDOWS\system32>net use
          New connections will be remembered.

          There are no entries in the list.

          And the NAS IS connected. Why would that be?

           

           

        • #2455288

          Look in Explorer and see if the connection indicator is green or red.
          If it’s red, click once (left) and see if it turns green.

    • #2455289

      Its green.

       

      • #2455293

        Can you access it?
        Can you copy anything to it?
        Did the net use command wake it up? Let it sit for a while and see it it turns red.

    • #2455294

      Totally. As I implied, it is there. Perfectly. DOes not show in net use. But opens from shortcut or explorer.

    • #2455435

      When you map a drive you tell your machine to use a local drive letter as an alias for a remote device.

      If you type the drive letter in Explorer (e.g. F:) can you connect?
      If you type the remote device in Explorer (e.g. \\nas\share)) can you connect?
      “Connect” means without having to authenticate.

      cheers, Paul

      p.s. what does “net use” show after a reboot?

    • #2455461

      I open Exploreer to This PC. The drive (i:) appears in the left column under ALL the drives I show including C:, etc.

      On the right, it appears under network locations. Both open fine.

      Typed i: in the path box left of search and it brought up the drive. Never typed in there before. Had no reason to.

      When I type \\nas\share, same thing. Opens instantly.

      Also odd that once I started this topic, the drive has not been lost by the shortcut. I am sure it will. Its just teasing me.

      Tried net use again, nothing. Same as yesterday. Have not rebooted in a day or two. Will try net use again when I do.

      Thanks.

       

    • #2455468

      Rebooted. Drive is there from shortcut, etc.

      Net Use the same – empty. Here is my thought on that.

      I am on a wireless network wher eI am attached t nothing but Internet access. The NAS is attched to the computer via ethernet cable and a fixed IP address. So likely neet use is not seeing that network? Network Connections lists it as Ethernet / Unknown Network.

    • #2455476

      OK, hour or so after boot and working s expected the drive shortcut failed:

      1-net

      Net Use the same. Nothing:

      Green bar in Explorer My PC!! Both in drives on left and network icon on right. About to click that:

      Single click nothing. Double click opens!!!

      And NOW, also opens from the desktop shortcut!

      How odd is all this?

       

       

    • #2455480

      Not very odd. Windows is reporting that it cannot find a DNS entry for “nasbox”.
      It’s because you have a direct ethernet cable instead of having the nas on the router.

      The easiest solution may be to use the IP address of the nas instead of its name in the map command. e.g. \\192.168.1.201\c

      cheers, Paul

      • #2455487

        Thanks. But then, why does it work most of the time? I could understand if never.

        I checked to see if I can make it private. There are no settings for public or private for this ethernet connection like there is for WiFI. Just not there in settings. Another clue?

         

    • #2455481

      Something interesting. This Ethernet “network” is listed as Public and Network Discovery is NOT checked. Can I make it private and should discovery be checked?

       

      Next, the shortcut that breaks is to “i:” I just made another shortcut to “\\nas\share”. Maybe its the shortcut? If so, why does it work “most of the time”?

       

    • #2455488

      Windows isn’t happy with your “strange” setup. I’m not surprised you have issues.

      cheers, Paul

    • #2455489

      And what makes this strange? Seems not strange to connect a NAS via ethernet direct. So what have I done “strange” and how to normalize it?

    • #2455490

      More oddities 🙂

      I now have three shortcuts on my desktop:

      1. to “i:”
      2. to \\nas\share
      3. to ip address

      All three have different views of the same data. Most concerning is that I spent a few hours changing ALL music folder (second level down – not top leverl so could not select “and all folders below” from General Items to Music. 1. Shows this properly. 2. Shows as general items. And 3. shows only top level shared folders, no root files from the NAS. When I drill down, general items.

      I find that odd.

    • #2455498

      So now a bit more confused. I KNOW I do not like the views from mapping by IP or \nasshare. Only from the drive letter. That works as expected / desired everywhere but that shortcut disonnects periodically.  I may have to live with that, though I hate to and always drive these things until they really work.

      Would changing to PRIVATE in Group Policy (my only option other than regedit) for the NAS help?

      I then would get these options:

      2-net

       

       

    • #2455574

      Unusual, but happened again today. This time NO link worked and I had to remap the drive to get it working again.

      Would love ideas. If it were on reboot that it failed, I would have a path toward things to try. But its at seemingly random.

    • #2455601

      Yes, direct connect via ethernet is strange in the network world.

      The ethernet network should be set to private. Do not use Group Policy to do this, set it in the network properties.

      The shortcuts should all open Explorer and you can change the view from there.

      cheers, Paul

    • #2455668

      It is NOT in network properties. I wish it were. The only way I can find is group policy.

      This is Ethernet:

      3net

      This is Wifi

      4net

      Any other place if not GP?

      Yes, all the shortcuts open in explorer. but changing from General to music means changing EACH and EVERY folder below the top levels I wish to show as General. Too much work. Hours. One shortcut to “i” retains these views.The other two do not. Surprised me. Not worth the effort to change.

      I wonder if I added a batch file to startup would help?

      “net use i:\nasboxc /delete
      net use i: \nasboxc /persistent:yes /savecred”

      And, no issues since remapping. That might be what happens/ Reboot – loses it some time later – remap – sticks until reboot. Not sure. But I THINK that is the pattern.

      Not showing under net use baffles me.

       

    • #2455701

      The more I think about this, I find I’m confused. Please confirm this:

      The NAS is connected directly to the PC by Ethernet (not to the Router by Ethernet). Static IP
      The two portable drives are connected by USB (?) to the PC.
      The PC is connected to the Router by WiFi. DHCP? Static?

      I am going to make some guesses here:

      In this case scenario, the NAS has no Internet connection except through the PC (since it is not connected directly to the Router). Therefore, it seems to me to be a SHARED Network connection. Since you can’t have two devices on a network with the same IP address, if a single network card (WiFi) is being used, it will act as a router, create a different set of IP addresses for each device, and manage the routing while the network facing IP will be that of the network Router. Another possibility is that the Ethernet card n the PC is handling the SHARED Network connection, in which case there may be a similar occruance.

      Example:
      + My Router’s IP is 192.168.1.1
      + My printer is connected to my Router be WiFi at 192.168.1.200 (static)
      + On the network side my Mac is connected to the Router at 192.168.1.104
      + I have a Win10 VM on a Mac. The IP address on the VM is 10.211.55.3 with a default gateway at 10.211.55.1. The Shared connection has basically created a different network with a router DHCP server at 10.211.55.1 and its connection on the network side at 192.168.1.104.

      If I log in the Router, it shows only the connection at 192.168.1.104 and not both SSIDs (Win10 and Mac). So the SHARED Network connection (WiFi card) is doing the routing for the two devices.

      In Control Panel\Network and Sharing Center (not Settings) Click on Change adapter settings.
      Right click on each of the active network cards, choose “Status” then “Details.”
      This may give you an idea about the network connections.
      Then log in your Router and see what devices are connected where.

    • #2455715

      Jeeez. I just wrote a long reply and it was blocked and now gone. Unsafe to poost my reply by something tracking your wpordpress.

       

       

       

    • #2455717

      That was one of the attachments.

      Here is the other. Basically, all you ays is correct including me being confused as well.

      NAS has no access to the Internet. Two cards, wifi for internet oin a router that is not mine and I cannot log into.

      Ethernete for direct connect to NAS only.

      2 USB 3.0 drives direct to docking station.

      Wish I had that post!

       

    • #2455719

      Fast answers. Cannot recreate it all.

      YES, NAS is static IP. WiFi is DHCP. All 192.168. but different sub nets.

      So, everythijng works, just the shortcut to NAS loses its connection from time to time and says it is mapped but must be remapped to work.

      AND, net use shows nothing.

    • #2455760

      Use the IP to map, not the name. #2455480

      cheers, Paul

      • #2455796

        For some reason that did not work previously, but it did just now.

        It does not have the folder views I want, so will wait to see if it loses itself over the next few days. Wish I did not have to redo those.

        And still nothing in net use.

        Thanks.

    • #2455863

      OK, it finally failed again with :

      1-net-1

      Happened right after waking from sleep which may and may not be coincidence. Computer had been up 4 or 5 hours.

      No access to the \servershare from any icon or netwrok drive in exploere. BUT the map to IP address DID work? Why?

      Tried to shortuct to servershare and after maybe 5 or 6 tries and failures, it connected wothout remapping.

      So, still odd…

    • #2456614

      That error shows you are not mapping via the IP.
      Delete all maps and redo using the IP.

      cheers, Paul

    • #2456638

      Well, why intermittent and why does it come back after trying 4-6 times?

      I remapped the primary link (i) to the ip and all things that sync there like backups wprking fine. I then maopped (z) to the server\share to monitor when it stops again.

      I find it odd that these display different folder views. Would never have expected that. Will wait until all settled to set as I prefer.

    • #2456738

      OK, since we are so far down this rabbit hoe, need to update.

      Rebooted. And hour or two later the mapped to server\share had the error message. The shortcut mapped to the IP worked fine.

      I closed and clicked the shortcut to the server\share shortcut 10 times and on the 10th it opened just fine. So it really IS there, but somehow does not open until repeated tries. From experience I will guess it will remain working until sometime after the next reboot.

    • #2456741

      @rebop2020, just FYI…

      While my NAS my setup isn’t “exactly” like yours (my NAS device is connected to my router and not my PC) I was experiencing the same symptoms as you (i.e. the NAS drive would “regularly” become unavailable after a reboot and I’d have to “re-enabled” the connection by clicking on it multiple times.)

      In fact, I got so frustrated with having to do that, I added a batch file to my startup to unmap/remap it after every reboot exactly like you thought of doing…

      I wonder if I added a batch file to startup would help?

      “net use i:\nasboxc /delete
      net use i: \nasboxc /persistent:yes /savecred”

      That didn’t help!

      What finally solved it for me was exactly what Paul T has suggested numerous times.

      I replaced all the mappings to the NAS that were using \\ServerName\SharedName with the actual IP address for the ServerName (i.e. \\192.168.3.#\SharedName) and it’s never “disconnected” after a reboot since.

      Like Paul T pointed out, I think what was causing my problem, and most likely yours, is the DNS lookup step required to make the connection if you use the ServerName in the mapped path. Using the IP address instead completely bypasses that!

      BTW, the reason you’re seeing “different” folder views for each mapping is because Windows Explorer treats each mapping as if it were a “different” device with it’s own separate folder view… even if they all point to the same physical device.

      1 user thanked author for this post.
    • #2456742

      Its the direction I am going. However as you may notice, I like to understand all I can when things like this happen.

      Interesting on the folder view. Do you know where those are stored? I wonder if I can cut and paste my preferred to the new mapping.

    • #2456748

      Interesting on the folder view. Do you know where those are stored? I wonder if I can cut and paste my preferred to the new mapping.

      The folder views are stored in

      HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags

      The Desktop views are stored in

      HKCU\Software\Microsoft\Windows\Shell\Bags

      Unfortunately, the actual values used to determine how a particular folder/Desktop appears are all hex code and it’s not obvious which values actually control what function of the view itself and, I can tell you from personal experience, you DO NOT want to experiment with trying to change things just to see what effect it has.

      I did that and totally screwed up Explorer being able to even display anything in the temporary folder I’d set up just so I could “try things out“!

      That convinced me that area in the registry is best left as is and to always use Explorer’s “built-in options” for setting individual folder/Desktop views.

    • #2456751

      Its the direction I am going. However as you may notice, I like to understand all I can when things like this happen.

      Ok, so here’s the difference between using a Name and an IP Address (applies both locally and over the internet.)

      When you use a Name (for either a local network or internet connection), your PC has to make a call to a DNS server (either the local Windows DNS cache or the DNS server configured in your network adapter) to convert that Name into the IP address your PC hardware needs to actually “make” the connection.

      What’s most likely happening when you try to connect to a “local” network asset using it’s Name and the connection fails, is the local DNS cache on your PC has “forgotten” the Name so it can’t provide the IP address needed to connect to it.

      This can happen for a whole host of reasons but the one that’s important for this discussion is Windows clears it’s DNS cache at every reboot and it can take up to 5 mins to fully refresh it.

      That explains why, if you keep trying to connect, it eventually works.

      If you use an IP address instead of a Name to make the connection, Windows no longer has to initiate a DNS lookup because it already has the IP address needed for the hardware to make the connection.

      Think of it like a phone number.

      If you don’t know the number, you need to look it up to find what digits are needed to dial it.

      If you already know the number, you can dial it immediately without needing to look it up first.

    • #2456752

      Thanks @alejr, but no –

      The nemed drive is ALWAYS there at reboot. Always. I loses the shortcut connection hours after that.

      While DNS makes some sense, not the flush at reboot.

       

    • #2456772

      Windows also clears/refreshes its DNS cache every 86,400 secs (24 hrs) even while it’s up and running and again, a possible 5 min wait while it refreshes things.

      Another factor that “could” effect your network connection is the TTL (Time To Live) value assigned to the specific DNS entry for your NAS’s “Name“. The shorter it is, the quicker it’ll expire from the cache.

      Attempting to connect after it’s expired would also trigger a wait while it gets refreshed.

      You can use the following “powershell” command to display the TTL for your NAS (remember, the value is secs.)

      Resolve-DnsName -Name nasbox

      Just FYI, mine was set to 1200 sec (20 min) but I didn’t go into my router and change it since the new setting would apply to everything that’s connected to the router and not just my NAS (didn’t want to risk messing up some other device’s connection to the router, especially my VoIP phone device.)

      I “assume” yours would be assigned by the NAS box itself and have no idea how (or even if) you could increase it if it’s too short?

    • #2456775

      Thanks.

      TTL=120

      So, I never had this issue when I had the NAS attached to my router via Ethernet. And I recall someone above said I do not need DNS on my NAS. But the manual says I do if I have  a static IP set. So, I have the DNS set to the Google pair of DNS servers. BUt, have not enytered Domain. Could that be the issue and if so what domain to enter?

      1net

      • #2456781

        WOW, that’s awfully short (it’s expiring every 2 min) and could easily be part of your problem!

        Also remember, the whole point of a DNS server is to convert a Name into an IP Address.

        If your NAS is only being used via a “local” network where none of the other devices are assigned Names (in your case, the single PC it’s connected to), it doesn’t really need them.

        BTW, those particular DNS’s would never actually be used because the NAS will never try to connect to a site out on the web, it can only connect to your PC (i.e. it would never need to have the Name google.com converted into an IP address.)

        The DNS option in a NAS is typically only used in business networks where they have their own local DNS server, assign each PC it’s own unique Name, the NAS is connected to a router, and they need to share it between some but not all of their PCs.

    • #2456782

      All of the devices on the network have names. And when I was connected to my router I mapped the shortcut to \\server\share. Now I seem to be working just fine mapped to the fixed IP, but since this came up again I wonder if the DNS and DOmain settings are not what was causing the map to \\server\share to fail?

      I wonder if the computer ethernet fixed IP should not be the DNS set in the NAS such as 198.162.0.1.

    • #2456787

      That’d probably be OK.

      The DNS for my PC’s ethernet card is the router’s IP address 192.168.3.1 while the router itself has it’s own set of static DNS addresses for connecting out to the internet.

      Static DNS 1: 166.102.165.32
      Static DNS 2: 208.67.222.222
      Static DNS 3: 129.250.35.251

      I use those particular addresses because they’re the fastest ones from my location that do not redirect my browser to a search page if they can’t connect to a site.

      I like to “know” whether a site’s down or not if I try to reach it (i.e. 404 Not Found) not get redirected to a list of search results containing the site name!

    • #2456829

      But the manual says I do if I have  a static IP set. So, I have the DNS set to the Google pair of DNS servers

      Manual DNS when you have a manual IP is correct for network devices, BUT you have a device that is effectively a local device because it is direct connected to your PC. You do not need a DNS setting for that device.

      More importantly, you should not connect your NAS to the internet (unless you know exactly what you are doing). Having a DNS setting in your on a NAS is only required for internet connection.

      TL;DR A NAS does not need a DNS set because it does not browse the internet.

      cheers, Paul

    Viewing 40 reply threads
    Reply To: Two New Issues with attached and Network Drives

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: