News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Choose Password for New Keyring in Opera/Mint

    Posted on LHiggins Comment on the AskWoody Lounge

    Home Forums AskWoody support Non-Windows operating systems Linux – all distros Choose Password for New Keyring in Opera/Mint

    Topic Resolution: Resolved
    • This topic has 27 replies, 7 voices, and was last updated 11 months ago.
    Viewing 7 reply threads
    • Author
      Posts
      • #999183 Reply
        LHiggins
        AskWoody Plus

        *ETA – I think I solved this – sorry for the post. I did just click continue and it set the password to blank and that seems to have done the trick. Thanks!

        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

        I am running Mint 19.1 from a full install on a USB thumb drive. I downloaded Opera browser and each time I open it, I get a message saying “Choose password for new keyring” – “An application wants to create a new keyring called ‘Default Keyring’. Choose the password you want to use for it”.

        I cancel that and Opera starts, but I was hoping that there was a way to get rid of the message. It isn’t asking for the password to Mint, I don’t believe, and I didn’t set any type of password when I installed Opera. And I don’t understand the request to create a default keyring.

        I thought it might be because Firefox was set as the default browser, but even when I made Opera the default, I still get that message.

        It looks something like the image below, but has two fields – one for the password and one to confirm the password. (Couldn’t get a screenshot of the actual box).

        Maybe leaving it blank and confirming it will do it but I wasn’t sure and didn’t want to create any issues.

        Thanks for any ideas on how to get rid of this. Not a huge deal and Opera runs fine once I cancel the message, but since Firefox doesn’t do that, I was hoping there was a way to disable it.

        ETA – some corrections to the wording of the message.

        Screenshot-from-2019-04-26-14-45-49

        • This topic was modified 8 months, 4 weeks ago by Kirsty.
        • This topic was modified 8 months, 4 weeks ago by Kirsty.
        Attachments:
        1 user thanked author for this post.
      • #1001897 Reply
        DrBonzo
        AskWoody Plus

        I’ve got a laptop running Ubuntu 16.04 LTS and Opera from the hard drive. I get a similar message from Opera when I open it. I hit cancel 3 times (with a new identical pop-up window each time), after which Opera apparently gives up and opens and runs fine. It all takes about a second so I’ve never bothered to fix/change it. I believe if you enter your Ubuntu password for authentication that Opera will then automatically enter passwords to various sites automatically (assuming you’ve told Opera to store passwords). I don’t use that feature of Opera, so I don’t personally care.

        Nice to see another Opera user out there. 🙂

        1 user thanked author for this post.
        • #1005816 Reply
          LHiggins
          AskWoody Plus

          I did the same thing – just canceling it several times and it did work. I finally got tired of that and clicked continue and it seems that set it to have a blank password – hasn’t asked me for anything again. I think there was a warning that my passwords would not be “encrypted” or would be visible to other users. Since it is only me, I didn’t give that much thought.

          We’ll see what happens – but I love Opera and really wanted it to work. One strange thing though – I have it running when I use Windows on this laptop. When I downloaded it to what I thought was the USB drive, since this is a full install on USB, when I logged back into Windows, it was also updated to a newer version. Made me wonder where Opera really “lives” – but changes I’ve made in Windows/Opera are not changed in Linux/Opera and vice versa.

          Thanks for the input – we’ll see what happens and if it asks for passwords again.

          • #1006106 Reply
            JohnW
            AskWoody Plus

            It’s probably safe to assume that a copy of Opera only “lives” on the OS it was installed on.

            So you would have two unique instances of Opera, one on Windows, and another on Linux.

            The version on Windows was compiled to execute only on Windows, and the same goes for Linux.

            It is probably only a coincidence that your Windows version was updated. Automatic updates?

      • #1002399 Reply
        JohnW
        AskWoody Plus

        I have seen that behavior with Chrome browsers on Ubuntu and Mint, but not with Firefox.

        Opera has been Chromium based since 2013, so it must use the same tech.

        It seems to have something to do with using automatic login in Linux.

        How to disable keyring in Ubuntu, elementary OS, and Linux Mint

         

        1 user thanked author for this post.
        • #1005905 Reply
          LHiggins
          AskWoody Plus

          Thanks for the link! I agree that it seems to have something to do with the auto log in – but for now, just continuing and not putting in a password for Opera seems to be working. We’ll see for how long – hopefully it won’t reappear.

          Since this is all run from the full install on USB – it isn’t “forever” and once I get to the point that I am comfortable with Mint – I’m probably going to either dual boot this laptop with Mint/Win 7 – or possibly find a refurbished laptop and make it Mint only. So far I haven’t been “missing” much of what I use in Windows that I haven’t been able to find a way to use in Mint.

          Thanks!!

          LH

      • #1002769 Reply
        OscarCP
        AskWoody Plus

        I hope you have really resolved the problem. In case this is not quite so, here is a suggestion as to its probable cause:

        It looks to me like you probably have got, for whatever reason, Linux configured to browse or to connect by VPN to a secure Web site (e.g., some government one), but with the details to be provided by you through the browser. If so, the “keyring” is a PIN number assigned to you by such an organization. I take it that you are using the PC purely for personal use and in no way to telecommute or to check your mail at such a secure site. I really have no idea of how you can correct this. I hope that, at least, my suggestion here as what might be the trouble will help someone else to come up with a practical, and one would hope also painless, solution. Good luck!

        Windows 7 Professional, SP1, x64 Group W (ex B) & macOS + Linux (Mint)

        1 user thanked author for this post.
      • #1006022 Reply
        LHiggins
        AskWoody Plus

        I hope you have really resolved the problem.

        Thanks – I think I have, at least for the moment.

        I appreciate your ideas, but I don’t use a VPN or have any type of PIN. I think this was just a way for Opera to “protect” the saved passwords I have stored in it – but since I just “continued” without setting up a master password for Opera, it seems to work. Just warned me that my saved passwords would not be secure for other users – of which there aren’t any!

        Good luck!

        Thanks – and thanks, too, for the possible solutions! Much appreciated!!

        • #1007397 Reply
          OscarCP
          AskWoody Plus

          Sorry, I did not mean to write that you have VPN access or a PIN, but that the software you are using somehow is already set up, when installed, or has become set up, for whatever reason and without you knowing or having anything to do with it, to expect you to provide a keyring, or PIN. So it is a software problem — you already knew that, of course — but there has to be something more especific about it, for example, what I have explained already.

          However, you seem to have found one way around it, so I am glad for that, and probably you’ll not have to bother with this again.

          But if you did have to…

          Windows 7 Professional, SP1, x64 Group W (ex B) & macOS + Linux (Mint)

          1 user thanked author for this post.
          • #1035269 Reply
            LHiggins
            AskWoody Plus

            Thanks for the additional info. This really is just something that is associated with Opera I think. I haven’t seen it happen with anything else – yet! I saved my password to log in to Mint and it asks for it when it wants to “do” something before allowing access. I never had a password to log in to Opera on any of my other computers. So I think it is exactly what JohnW’s link above says – it is a way for Mint to secure certain passwords. I haven’t tested Chrome yet – but if it is something related to a Chromium-based browser, then it might pop up again.

            In any case – I haven’t stored many passwords on Opera and not entering any password, but just clicking continue seems to be a way around that pop up.

            Thanks again!

            • #1035706 Reply
              JohnW
              AskWoody Plus

              I have a Linux Mint VM setup with automatic login.

              When I open up Chrome, I get the keyring prompt. If I enter my Mint password, the prompt accepts it and goes away. Only seems to be required once per session.

              1 user thanked author for this post.
      • #1008833 Reply
        PKCano
        Da Boss

        I have never used Opera, nor have I supported it. So this is based on the other browsers I have used.

        In the browser’s settings you can choose to have it save (remember so you don’t have to, auto-ill) logins and passwords, form history, connection information, etc. It is often the default if you don’t turn it off.

        You can make a choice to enter a password (or master password), so this information is at least password protected, maybe even encrypted. If you do not enter a password, well, it’s not protected and anyone can access it.

        It would be doubly important to have your login and password protected if you were connecting to a secure site, using a VPM to access a secure site, etc. You surely wouldn’t want the information accessible to any one having access to your computer.

        So the password is not just about having a VPN set up. It is about securing whatever stored information you choose in the settings to save (remember so you don’t have to, auto-fill).

        1 user thanked author for this post.
        • #1035435 Reply
          LHiggins
          AskWoody Plus

          Hi PKCano – nice to see you!

          Thanks for the info on securing passwords, etc. I am pretty careful, but I guess that this does beg one question. This kind of security layer never comes into play in Windows. I have used IF, Firefox, Chrome and Opera on various Windows computers – all with options to save and store passwords (some of which I don’t allow to be saved!) – and have never had any type of warning or offer to create a master password or a password key like this one. Maybe it is just a Linux/Mint thing? And it didn’t ask to create one for Firefox in Mint – which is also set to save certain passwords.

          I guess I’ll do a little more digging around and see what else I can find about it. JohnW’s article above is the closest I’ve seen to what was happening, and how to work around it!

          Thanks for the reply!

          • #1035763 Reply
            JohnW
            AskWoody Plus

            The more secure solution would probably be to just enter your Mint password, rather than to try to defeat the feature with a blank password.

            Or not use Mint with automatic login, which is causing this prompt. If you enter a password at Mint startup, then you should not see a prompt for the keyring from certain apps that are looking for it.

            1 user thanked author for this post.
            • #1036906 Reply
              JohnW
              AskWoody Plus

              OK, I added Opera to my Linux Mint VM to check this out.

              If I enter my Mint password at the keyring prompt for either Chrome or Opera, then any subsequent browser window (either one) that I open does not prompt me for the keyring again for the rest of my Mint session.

              To test the automatic login theory, try logging out of your Mint user session (not shutting down), and then enter your userid and password to log back in when prompted at the desktop. You will have something like 10 seconds to do this before you are automatically logged back in. But this manual login will simulate what you see when Mint is not set for automatic login.

              If you manually login to your Mint user session, you will not be prompted for the keyring when you launch one of these browsers, because you used your password to gain access to the user session.

              But on the other side of the coin, if you allow Mint to automatically log you back in you will get the keyring prompt when you launch Opera or Chrome.

              3 users thanked author for this post.
              • #1038393 Reply
                OscarCP
                AskWoody Plus

                JohnW: Thanks for your informative comment.

                Now, to be clear in my own mind about this:

                Is it because I always log in to a new Linux Mint or macOS session with user name and password, that I do not have encountered this “keyring” issue, so far? (FireFox and Chrome are the two browsers I have installed and running on both macOS and Linux Mint.)

                Windows 7 Professional, SP1, x64 Group W (ex B) & macOS + Linux (Mint)

                2 users thanked author for this post.
              • #1038676 Reply
                JohnW
                AskWoody Plus

                I cannot speak for the Mac, as I have not tested that, but YES for Linux Mint.

                I have run Mint in both configurations, automatic login, and not automatic.  I only see the keyring prompt when I am automatically logged in to the user session without entering a password.

                And I have never encountered this keyring prompt with Firefox, regardless of my login credentials having been entered or not. Only with Chromium based browsers, such as Chrome and Opera. So this must only be related to the security architecture internal to Chromium, and how it relates to the user session.

                2 users thanked author for this post.
              • #1044273 Reply
                LHiggins
                AskWoody Plus

                Hi John! Thanks for doing this test for me!

                OK – so I think I understand it now – it is a Mint feature that happens when you use the automatic log in – which is what I’ve been doing, and then open Opera. I guess just bypassing setting up the default keyring is OK, at least for now. It is interesting that when you don’t set up the password and just click cancel, Opera will start anyway. I didn’t ever try seeing if it would save a password under those circumstances. It might have again asked for that keyring since one wasn’t set up.

                But clicking continue, which in effect sets up a blank password has gotten rid of that box. And while this does have some security issues – when I am using Windows – all of my browsers are set to save passwords, and none need any type of security password – so that is equally insecure it seems. Since I am the only user, there shouldn’t be an issue – and I don’t save sensitive passwords like banking etc. anyway, so no worries there. I will keep an eye on it and see if I notice any other behaviors with Opera.

                Thanks for investigating it for me – much appreciated!

          • #1035905 Reply
            DrBonzo
            AskWoody Plus

            For what it’s worth Opera running on an iMAC High Sierra behaves similarly to your observed Mint behavior. Perhaps that’s not too surprising since the MAC OS is, I believe, based on Linux. But as you say Opera does not behave this way on Windows 7 (or Vista for that matter)

            1 user thanked author for this post.
            • #1037154 Reply
              JohnW
              AskWoody Plus

              Well technically, Mac is a legit UNIX system now. Linux is only a UNIX-like system. So there are a lot of similarities and compatible technologies, but Mac was not based on Linux.

              1 user thanked author for this post.
              • #1038130 Reply
                OscarCP
                AskWoody Plus

                My understanding is that the original version of macOS (then called “OS X”) was derived from NextSTEP, the  OS developed at Seteve Jobs’ own computer company started when he left Apple to stay subsequently away for some years:

                “The heritage of what would become macOS had originated at NeXT, a company founded by Steve Jobs following his departure from Apple in 1985. There, the Unix-like NeXTSTEP operating system was developed, and then launched in 1989. The kernel of NeXTSTEP is based upon the Mach kernel, which was originally developed at Carnegie Mellon University, with additional kernel layers and low-level user space code derived from parts of BSD. Its graphical user interface was built on top of an object-oriented GUI toolkit using the Objective-C programming language.”

                More about this here:

                https://en.wikipedia.org/wiki/MacOS

                 

                 

                Windows 7 Professional, SP1, x64 Group W (ex B) & macOS + Linux (Mint)

                2 users thanked author for this post.
              • #1039481 Reply
                JohnW
                AskWoody Plus

                There is certainly a long and storied history of the Mac OS development as you have pointed out.

                But just to oversimplify things, I was only referring to the present OS X, and stating that Mac was currently an official UNIX system, and most definitely not based on Linux.

                This article and the associated diagrams traces the evolutionary roots of UNIX and Unix-like systems.

                https://en.wikipedia.org/wiki/Unix-like

                And this article lists OS X as a currently registered UNIX system. It first became registered with Mac OS X 10.5 “Leopard”, when run on Macs with an Intel processor.

                https://en.wikipedia.org/wiki/Single_UNIX_Specification

                 

                 

                1 user thanked author for this post.
      • #1861632 Reply
        MrJimPhelps
        AskWoody_MVP

        I went from Linux Mint 19.1 to 18.2 and the incessant Keyring password prompt went away. Apparently this is something with newer versions of Mint. I use Opera with this version of Mint, but I have never gotten the Keyring password prompt since downgrading from Mint 19.1 to 18.2.

        Group "L" (Linux Mint)
        with Windows 8.1 running in a VM
        • #1861705 Reply
          JohnW
          AskWoody Plus

          As I had posted here 2 months ago, my conclusion that I confirmed through testing was this:

          “I have run Mint in both configurations, automatic login, and not automatic. I only see the keyring prompt when I am automatically logged in to the user session without entering a password.”

          • #1862296 Reply
            MrJimPhelps
            AskWoody_MVP

            When I went to Mint 19.1, I did not set up automatic login; I set it so I would always need to enter my password when logging into Mint. In that scenario I was getting the incessant Keyring password prompts whenever I would run Opera.

            I believe there is some new feature out there that Mint and Opera are both employing that is triggering the Keyring password prompts.

            I don’t need the “latest and greatest”, I need something that just works. So I’m staying with Mint 18.2 for now.

            Group "L" (Linux Mint)
            with Windows 8.1 running in a VM
            • #1862350 Reply
              JohnW
              AskWoody Plus

              I get the keyring prompt from both Opera and Chrome on Mint 18.3, where I installed Mint with auto login enabled.

              I don’t get the keyring prompt on Mint 19.1, where I installed Mint to require a login each time.

              I can confirm this login behavior using Mint 18.3, by logging out (not shutting down), and then logging back in to the user session. Mint will then prompt me for the user password. Once I have done this there are no more prompts for the keyring password from either Opera or Chrome.

              I read somewhere that this is a security feature coded into Chromium based browsers, such as Opera and Chrome.

              I have no explanation for the behavior that you experienced with Mint 19.1.

      • #1861697 Reply
        Berton
        AskWoody_MVP

        I’ve never gotten the Keyring issue with Linux Mint 19.1 on my Desktop or 2 Notebooks.

        Before you wonder "Am I doing things right," ask "Am I doing the right things?"
        • #1861706 Reply
          JohnW
          AskWoody Plus
          Please see my reply above to Jim that I was typing as you posted this…
    Viewing 7 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Choose Password for New Keyring in Opera/Mint

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.