• Update error message

    Home » Forums » AskWoody support » Linux for the Home user » Linux Mint » Update error message

    Author
    Topic
    #2447329

    Running Mint Mate 19.2.  Couple of days ago attempts to install updates began generating this pop-up:

    Update-error-message

    Entering quoted command produces this:

    terminal-output
    This is above my pay grade.  Suggestions?

    Linux Mint Mate 19.2

    Viewing 8 reply threads
    Author
    Replies
    • #2447335

      I think a space is required after --configure and before -a

      I’m no expert, but if I understand correctly, it seems to think there is a package that hasn’t been configured, and it needs that to happen before it can proceed.

      Linux Mint 20.3 (Cinnamon) | Windows 10 Home 21H1
      1 user thanked author for this post.
    • #2447369

      I don’t recall ever seeing this error.

      I’ll make a guess that it has something to do with the HP fax software you installed a few days ago. When you look at the list of updates in Update Manager do you see any that you can identify as related to the HP software?

      If you go here:

      https://ubuntu.com/security/notices

      you can probably see which security updates are in the list in your Update Manager; these would not be related to HP software. Try installing just the ones you can identify as not being HP software and see if that works. If it does, then proceed to one other update or updates that you might be pretty sure aren’t HP-related and try to install those. Doing this sort of thing might at least allow you to figure out what the offending update/package is.

      I’ve used this sort of method before when I got a message saying updates couldn’t be installed (unfortunately that was all my message said, it didn’t offer any command line suggestions). In my experience if there’s one update in a batch of updates that is “unliked”, none of the updates will install, but I can at least get the other updates installed and figure out which is the offending update by doing something similar to above.

      For me, the culprit has always been a 3rd party program and I think that the trouble – again for me – is that the update download site wasn’t working. Sometimes trying again in a few minutes worked, sometimes trying the next day worked.

      One other thing you might look at: In Update Manager go to Edit, then Software Sources. Look for Additional Repositories and see if there’s anything related to HP software. If there is, see if there’s a checked box under the Enabled Column. That should allow you to get HP updates. Unfortunately, I don’t know what to do right now if you don’t see the checked box or if you don’t see any HP software. Also, I’m running Mint 20.3 Cinnamon now so what I see may not jibe exactly with what you see.

      1 user thanked author for this post.
      • #2447412

        Nothing in the history at all related to HP, although during the driver update earlier this month the option to get HP updates was offered and I accepted.  No HP updates offered since that upgrade.  Here’s the recent history:

        Update-history

        In Update Manager, no 3rd party updates are enabled.

        This error first appeared a couple of days ago, when trying to install the only update offered at that time, cannot copy/paste but it is tiff (Tag Image File Format- old v.4.0.9-5ubuntu0.4 new v. 4.0.9-5ubuntu0.5

        FOLLOWUP- Today that update was offered along with 5 additional updates.  Just now installed the other 5 in the usual manner, no drama.  But the system still offers that tiff update.

        Linux Mint Mate 19.2

    • #2447452

      So it apparently doesn’t like TIFF for some reason. I still have 1 computer that runs 19.2 and TIFF updated normally just a few minutes ago. I didn’t try to install any other updates along with it. I was hoping it wouldn’t install which would indicate a problem with the update and that would then be fixed in the near future.

      1 user thanked author for this post.
      • #2447481

        Looks like I have two choices- ignore that update or attempt to install it via CLI, which presumably bring me back to that terminal output posted above.

        Linux Mint Mate 19.2

        1 user thanked author for this post.
      • #2447525

        In Update Manager when I select the tiff update and then click the packages tab, it says I have the libtiff5 package installed. When I open the Synaptic Package Manager and search for libtiff5 I see that it’s installed. When I select it and go to Edit, there’s an option to Fix Broken Packages. That might do the trick for you. Disclaimer: I’ve never done this so I don’t know if it will work. I’d probably do a bit of internet searching before I tried it, although I don’t see how it could hurt anything. If it works, great and if it doesn’t, you’re no worse off. Back in the Update Manager when I look at the Changelog it says the urgency is ‘medium’

        1 user thanked author for this post.
        • #2447644

          Here’s what I see in the lower pane of Update Mgr when selecting the TIFF update- notice the word ‘failure’

          tiff-changelog
          In Synaptic, searching as you did, this displays

          libtiff5
          Clicking Edit>fix broken packages adds a yellow star to the green checkboxes on the left that indicate ‘package installed.’  Note the message at the bottom of the s/shot re ‘0 packages broken.’  That showed the same before I used the ‘fix broken pkgs’ option.

          Linux Mint Mate 19.2

          1 user thanked author for this post.
        • #2447755

          The word ‘failure’ in the context above means that in the old version of the tiff package there was a “malloc failure” which is being fixed with the new patch (update); it’s not telling you about why your attempted update didn’t work (unfortunately).

          1 user thanked author for this post.
        • #2447760

          The tip from anonymous below about inserting a -s would be worth trying.

          The only other thing I’ve got is this: in synaptic package manager select libtiff5, then go to the Package menu and choose “Mark for Reinstallation”, the click Apply.

          If that doesn’t work try “Mark for Removal”, then Apply. Then select libtiff5 again and the “Mark for Installation”.

          Hopefully one of these methods will get the newest version of tiff installed – a roundabout way of updating without using Update Manager.

          I can try this on my 19.2 machine and get back to you with the results, but probably won’t get to it until tonight at the earliest. My tiff update went in without problem but I can still test out the method.

          1 user thanked author for this post.
        • #2447873

          I ran the “Mark for Reinstallation” as described above. After clicking “Apply” you get a summary of what’s about to be done. Then click “OK” and you get a window just like you normally get in Update Manager when an update is being installed. Remember, my libtiff5 update went in without problems, but what I’ve just described seems to work, although it doesn’t seem that it will install the very latest version, which is the one you’re having trouble installing. But maybe a fresh reinstallation will somehow allow you to install the newest update. Might be worth a try.

          Then I tried the “Mark for Removal” as described above. I got nothing but errors and couldn’t do anything. I got a window that listed a LOT of other packages that needed to be marked for removal. When I clicked “OK” to allow this removal I got a message at the screen bottom that said I now had 3 broken packages,5 packages to install/upgrade, 328 packages to remove, and 1539 MB would be freed. Clicking “Apply” said I needed to fix broken packages first, but when I clicked “Fix Broken Packages” I got an error message saying they couldn’t be fixed.

    • #2447508

      ? says:

      Commit Log for Mon May 16 08:26:16 2022
      Upgraded the following packages:
      libtiff5 (4.1.0+git191117-2ubuntu0.20.04.2) to 4.1.0+git191117-2ubuntu0.20.04.3

      what happens if you “sudo apt install (your tiff package)” in the terminal? it usually prints out the status after you execute the command and any errors with resolution(s).

      2 users thanked author for this post.
      • #2447648

        I’d consider trying this if I felt I could recover should that be needed.

        Linux Mint Mate 19.2

        1 user thanked author for this post.
        • #2447652

          ? says:

          ok, sounds good about “recover.” just type the command and insert a -s. gives a what -if-i do-this simulation…

          3 users thanked author for this post.
        • #2447880

          I ran “sudo apt install libtiff5” and “sudo apt install libtiff5 -s” and both returned essentially the same thing, that my libtiff5 was already the newest version (which on my computer it is).

          I think this will either work and get the newest version of libtiff5 installed for you or you’ll get an error message, but I don’t think you’ll end up in an unrecoverable situation, although I can’t guarantee that.

          1 user thanked author for this post.
        • #2447918

          Haven’t been fully at ease using CLI due to limited forays into that arena.  But just ran the command you suggest and looks like it was a no-drama event, terminal shows update installed.

          Synaptic also shows new tiff version installed.  I was interested to check there because, over a week ago, I updated the entire HP printer driver package via CLI, and Synaptic still shows the old version as installed, even though the updated version is confirmed in the printer GUI, no question that the updated version has superseded the old one.

          Followup- Update Mgr from the tray icon still offers the tiff update just installed.  After deselecting it and installing the other update offered (Opera) the Mgr still offers that tiff update even after refreshing.

           

          Linux Mint Mate 19.2

          1 user thanked author for this post.
    • #2447768

      ? says:

      you could run “sudo apt update” in your terminal. and you could run “sudo apt list –upgradable” if the results show no updates, then you are good to go.

      like so:

      https://linuxtect.com/list-upgradeable-packages-with-apt-in-ubuntu/

      you can also copy your terminal commands and results and post them here if you like…

      2 users thanked author for this post.
      • #2447881

        Ran these 2 also and got back that Opera was upgradable, which it was.

        I did need to use two hyphens instead of just one in front of ‘upgradable’. In other words
        “sudo apt list –upgradable”

        Well, I don’t know if anything I’ve done tonight helps, but the commands seem pretty straightforward and don’t seem like they will get you in trouble. Can’t guarantee anything, though.

        1 user thanked author for this post.
    • #2447932

      ? says:

      dude, you get some funky gremlins sometimes. maybe try Synaptic Package Manager>Preferences>Files>Temporary Files> then tick “Delete downloaded packages after installation,” then “Delete Cached Package Files,” and then Apply/ok? since you  seem toprefer to do your work in a GUI. CMD/Terminal has always been my friend, so i do:

      sudo du -sh /var/cache/apt
      sudo du -sh /var/cache/apt/archives
      sudo apt clean

      as part of regular apt maintainence. enjoy…

      2 users thanked author for this post.
      • #2447989

        Yes, I’m more fluent in GUI.  But gradually getting conversant with CLI.

        I don’t really care if Synaptic is up to date- that HP driver update, AFAIK, is 100% functional, which was the goal there.

        The HP update I ran using CLI and mostly I just watched- supplied input when asked.  Took quite a while, but for me that was a baby step forward.

        Linux Mint Mate 19.2

    • #2448152

      I don’t know how much you want to pursue this but when I searched “sudo dpkg –configure -a” I got this (as well as a bunch of other stuff)

      https://fedingo.com/how-to-fix-dpkg-was-interrupted-you-must-manually-run-sudo/

      It offers some solutions to the issue you’re having. It’s all command line stuff, but most of the commands seem similar to those you’ve already used.

      On the other hand it seems that you got an indication a few posts up that the latest libtiff5 package actually did get installed. There’s a similar thing that happens on 2 Win 8.1 computers I deal with. I update the virus definitions in Windows Defender (what used to be Microsoft Security Essentials in Win 7) and it tells me that the update was successful. Windows Update should also tell me that, but very often there’s no mention of the update I have just installed – no indication of success or failure, absolutely no mention at all. That raises the question of which to believe, Windows Update from which I would conclude that the update never was even attempted or Windows Defender which said the update was successful. I’ve taken to believing the update was successful.

      If it was me I’d probably try some of the things in the above link if I felt comfortable with the commands (at the moment I don’t and would want to make sure I knew what each was going to do before I proceeded), and if none of the suggestions worked, I’d probably assume libtiff5 was updated.

    • #2448239

      Putting out fires elsewhere.  I’ll be back…

      Linux Mint Mate 19.2

      • #2448668

        Sometimes if things are not working properly it’s easier just to revert to an earlier system snapshot via timeshift and back to a time before applying the failed update and start again from there. There are times when that mlocate daily background task is running during a system update and a lock on any file can create problems for the update process. And mlocate does not check in advance to see if the update process is running so it runs and locks some file while doing its database updating task and that can cause issues there.

         

        I have old laptops that rarely get utilized so only get pulled out once a week to apply the Mint 20.3 updates for the week and that daily mlocate task invariably will start up and some interval after the laptops are booted up, So that’s causing issues sometimes there with updates and file locks. But I always have a recent system snapshot made to revert back there if some issue becomes intractable to repair and that will restore the system  to an earlier state before the latest updates are applied. So sometime I have that and have to reapply any update that came after that snapshot was made and that failed update re-installed that way along with any other updates that can after that system snapshot.

        1 user thanked author for this post.
    • #2452847

      Just now back to this error message and prepared for an ordeal.  Several other updates successfully installed since the tiff error displayed.  First move was to try the tiff update alone (remember, the definition of insanity is repeating the same behavior while expecting a different outcome).

      The tiff update installed without incident, end of story.  Conclusion: the computer has driven me to insanity…

      Thanks to all who posted to this thread!

      Linux Mint Mate 19.2

      1 user thanked author for this post.
    Viewing 8 reply threads
    Reply To: Update error message

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: