News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Update Orchestrator Service disabled and greyed out

    Posted on Bundaburra Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 10 Windows 10 version 1903 – May 2019 Update Update Orchestrator Service disabled and greyed out

    This topic contains 14 replies, has 4 voices, and was last updated by  Rick Corbett 1 month, 3 weeks ago.

    • Author
      Posts
    • #1847127 Reply

      Bundaburra
      AskWoody Plus

      I had the above problem in W10 1809, meaning that Windows Update would not work.  So I upgraded to 1903 in the hope that this would fix it, and for a time all was OK.  The Update Orchestrator Service was running, and Windows Update was working correctly.  But now I find that the service is once again disabled, and all its attributes are greyed out so it cannot be started.  This remains the case even after a system restart.  Without this service running, Windows Update will not work, so how can I recover the situation?

    • #1847710 Reply

      Rick Corbett
      AskWoody_MVP

      The Update Orchestrator Service is supposed to be set to Automatic (Delayed Start). More recently has taken to protecting the service so it cannot be changed in the Services management snap-in (services.msc) even if logged in as a member of the ‘Administrators’ group. Whilst in 1809 you would get an error if you attempted to change the service’s properties, in 1903 it’s greyed out completely so you can’t even attempt to fiddle with it:

      update_orchestrator_1903

      So, it being greyed out is now normal for 1903. However, if it’s also disabled then something has changed the service’s Start and DelayedAutoStart  properties… and to check you need to use the Registry Editor:

      update_orchestrator_1903_default_registry

      This is quite safe. All you are doing at this point is checking 2 values.

      1. In the Cortana search box type regedit then, when it’s found, choose Run as administrator in the *right*-hand pane. (In this respect 1903 is much improved, IMO).

      2. When the Registry Editor opens, navigate in the *left*-hand pane to the following key and click on it to select it:

      HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesUsoSvc

      3. In the *right*-hand pane, check the values for the DelayedAutoStart and Start entries. From your description in the OP it sounds like the Start entry has been set from 2 to 4, i.e. ‘disabled’.

      Post back with the values for DelayedAutoStart and Start (and Type, just in case).

      PS – Have you used any third-party utility (O&O ShutUp10, Windows Update Blocker, etc.) to ‘control’ Windows Update, either in 1903 or 1809?

      Hope this helps…

      Attachments:
      2 users thanked author for this post.
    • #1847949 Reply

      Rick Corbett
      AskWoody_MVP

      Unfortunately the forum software has removed the backslashes from the registry key path in my previous post. I’ll try again:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UsoSvc
      1 user thanked author for this post.
    • #1848219 Reply

      Rick Corbett
      AskWoody_MVP

      @bundaburra – I’ve just spotted a post of yours recommending Windows Update Blocker. If you are using this then it could be the reason why the Update Orchestrator Service is disabled.

      Hope this helps…

    • #1848230 Reply

      Rick Corbett
      AskWoody_MVP

      In my first post in this topic I wrote “The Update Orchestrator Service is supposed to be set to Automatic (Delayed Start).” I should have made it clear that I was referring to Windows 10 1903.

      The service Start value changed to 2 (Automatic) from Win 10 1803. Prior to 1803 (i.e. 1709 and earlier) the Start value was 3 (Manual).

      A useful resource is Service Defaults, although the Win 10 section hasn’t yet been updated to include 1903.

      Hope this helps…

      1 user thanked author for this post.
    • #1848462 Reply

      Bundaburra
      AskWoody Plus

      Thanks Rick,

      I have discontinued using the Windows Update Blocker, and have reset the ShutUp10 settings to “recommended”.  This seems to have made a difference, because following a Restart I can once again run Windows Update.  The actual Windows Update service (wuauserv) shows as  ‘”Running, Automatic (Trigger Start”.  The status of the UsoSvc service now shows as “Running, Disabled”, which does not look right but at least it’s working.   The registry values for UsoSvc, as mentioned above, are now Delayed AutoStart (1), Start (4), and Type (32).  If I try to change the Start value, it says “Cannot edit Start.  Error writing the value’s new contents.”  Thanks again for your help, but where to from here?

      • #1848488 Reply

        Rick Corbett
        AskWoody_MVP

        Here’s the safest way:

        1. In the *left*-hand navigation pane of the Registry Editor (remember to use Run as administrator), *right*-click on UsoSvc and choose Export.

        2. Export the settings to the Windows desktop as something like usosvc.reg. This will be your failsafe.

        3. Copy and paste the usosvc.reg file to the desktop then *right*-click on the usosvc-Copy.reg file and choose Edit.

        4. Delete *all* the settings *except* for the registry key path and the Start entry. (See the screenshot below.)

        5. Change the DWORD value of the Start entry from 4 to 2 so it looks like this:

        usosvc_reg

        6. Save the changes then *right*-click on the amended copy and choose Merge. Accept the changes and that should be it.

        When you’re happy the change to the Start value has been made successfully then you can delete both REG files from the Windows desktop. I’ve just made the exact same changes in 1903 at my end as a test.

        Hope this helps…..

        Attachments:
    • #1849235 Reply

      Bundaburra
      AskWoody Plus

      I have done as suggested, and it seems to have worked.  Following the restart, I tried Windows Update and it was OK.  Looking in the Services list, I now see:

      Update Orchestrator:  Running, Automatic (Delayed Start)

      Windows Update:  Running, Automatic (Trigger Start).

      In the registry entry for UsoSvc, the Start field is now 2.

      Does that all seem correct?  Anyway, it is working now, thanks again

       

    • #1849237 Reply

      Rick Corbett
      AskWoody_MVP

      In the registry entry for UsoSvc, the Start field is now 2.

      @bundaburra – Thanks for posting back.

      That’s good about UsoSvc. 2 is the correct value for UsoSvc‘s Start entry in the registry, so it looks like you fixed it.

      “Update Orchestrator: Running, Automatic (Delayed Start)” is also correct.

      According to what I see on my own Windows 10 1903, Windows Update (wuaserv) should be set to a Startup Type of Manual (Trigger Start)… which is different from yours.

      Do you want to continue and fix this service as well? Yours is OK but will run ‘always on’, i.e. more frequently than required, instead of ‘as needed’ – as per the default ‘trigger condition(s)’.

      Hope this helps…

    • #1853614 Reply

      Bundaburra
      AskWoody Plus

      Yes, I would like to fix the Windows Update service as well.  But it’s not really running as “always on”.  This morning I have not used Windows Update, and the service shows as Automatic (Trigger Start), but not running.  I suspect what happens is if I run Windows Update, the service will start running, but will not stop when I quit Windows Update and will continue to run until the next restart.   If the attribute is Manual rather than Automatic, this would not happen?

      • #1854253 Reply

        Rick Corbett
        AskWoody_MVP

        ‘Trigger Start’ was introduced by Microsoft to try to prune the amount of ‘always on’ services.

        If you want to investigate (or manipulate) the actual ‘triggers’ themselves, try using the freeware, portable Service Trigger Editor.

        Hope this helps…

      • #1854296 Reply

        Rick Corbett
        AskWoody_MVP

        Hopefully there’s a reason why your services are not working ‘as per default’. (If not, then registry corruption, particularly of the HKLM…services keys, would be a possible suspect.

        Have you edited the services manually (using the MMC snap-in services.msc [using Run as administrator]) or used a third-party utility (like O&O ShutUp10, Windows Update Blocker or a multifunctional ‘tweaker’)?

    • #1853970 Reply

      Paul T
      AskWoody MVP

      I suspect what happens is if I run Windows Update, the service will start running

      Some services never stop, some run for a short time, some are stopped by something else. Why don’t you keep an eye on WU for a day or two and let us know if it runs continuously?

      cheers, Paul

    • #1877242 Reply

      anonymous

      What about the… opposite desire?
      How can the whole Update mechanism (WinUpdate, Orchestrator, Update Medic…) be disabled?

      • #1877576 Reply

        Rick Corbett
        AskWoody_MVP

        How can the whole Update mechanism (WinUpdate, Orchestrator, Update Medic…) be disabled?

        The easiest way I know is to use something like Sordum’s Windows Update Blocker.

        Takes seconds to download and implement… and can be disabled again within seconds (but, in my experience of v1.2, very occasionally requires a restart of Windows for the re-enablement of Windows Update to take 100% effect so Settings > Update & Security doesn’t just hang. This may be sorted with the very recent release of v1.3 but I personally don’t know.)

        Just be aware of the side effects of Windows Update Blocker… it’s a broadsword – not a scalpel, and this is an important distinction. For example, it also blocks anti-malware definition updates to Windows Defender.

        It includes a mechanism to defeat the recent ‘remediation’ fixes implemented to stop people doing what MS don’t want, i.e. manually disabling various Windows Update services.

        The longer manual way is to disable each of the Windows Update and download services (and the scheduled tasks which fire them)… and the more recent (and ever-evolving) ‘remediation’ and ‘medic’ services that watch for your shenanigans and attempt to undo them.

        There’s ways round this (all involving elevated permissions, some involving masquerading as ‘System’ or ‘Trusted Installer’) but – by and large –  it’s becoming too time-consuming to keep fighting against MS’ will… hence why I now dabble with alternatives like Linux and macOS. 🙂

        Hope this helps…

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Update Orchestrator Service disabled and greyed out

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.