News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Upgrading Firefox crashes all tabs

    Tagged: 

    Viewing 8 reply threads
    • Author
      Posts
      • #2088258 Reply
        nag2
        AskWoody Plus

        Trying to upgrade to the latest ESR firefox from version 60.9.0 ESR in Win10 and no matter what version I switch to all the tabs begin to open then crash.  I have the latest Nvidia drivers (9600GT card) and “set browser.tabs.remote.autostart” to false.  Also tried resetting allowed apps in Windows firewall to block firefox then installed update and reset to allow firefox.  Also, I added a new profile as default and other things I can’t remember doing as I spent all afternoon on this and nothing fixes the tabs crashing so I’m stuck with this very outdated version and I’m fresh out of possible solutions.  Any ideas?

      • #2088398 Reply
        Alex5723
        AskWoody Plus

        Trying to upgrade to the latest ESR firefox from version 60.9.0 ESR in Win10

        Why not use the latest Mozilla Firefox ESR, Portable Edition 68.4.2 ?

        https://portableapps.com/apps/internet/firefox-portable-esr

      • #2088965 Reply
        nag2
        AskWoody Plus

        Alex:

        I tried the portable version (68.4.2 ESR) on a thumb drive and I get the same result.  All tabs crash and no internet access.

      • #2088966 Reply
        geekdom
        AskWoody Plus

        Beta versions are here in all flavors:
        https://www.mozilla.org/en-US/firefox/73.0beta/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew

        Consider trying the MSI version.

        G{ot backup} TestBeta
        offline▸ Win7Pro SP1 x64 InUse
        online▸ Win10Pro 1909.18363.752 x64 i5-9400 RAM8GB HDD Firefox75.0b10 Windows{Image/Defender/Firewall}
        • This reply was modified 2 months ago by geekdom.
      • #2089112 Reply
        Microfix
        Da Boss

        question, did you use the same profile for your thumb drive portable version from the previous installed version?

        If not:
        You may have an issue whereby your profile is corrupt and still resident.
        Suggest backing up your bookmarks, then disconnect from the internet and remove the thumb drive with the portable version on it. Then look for any previous mozilla stuff (from your uninstalled version) in file explorer usually within the following folders:

        Program files or Program Files (x86)
        Program Data (hidden by default, need to show hidden files in explorer ribbon to see it)
        User Profile/your name/appdata/ (check 3 folders local, local low and roaming and delete the mozilla folders)

        In doing this, your old extensions, if any, will be obliterated which also rules them out of troubleshooting these can be re-installed on your portable version once plugged in again.
        Don’t import any bookmarks yet!
        Then try online access, once you have established an online connection, then import your backed up bookmarks.
        let us know how you get on..

        Win7 Pro x86/x64 | Win8.1 Pro x64 | Linux Hybrids x86/x64 |
        • #2100345 Reply
          nag2
          AskWoody Plus

          Microfix: I’ve given up on this.  I uninstalled everything Mozilla I could find (Program files86, Users/Local/Roaming/Public/Mine), cleared the registry, shutdown the computer, cleared the ram, rebooted, fresh install.  There were no more tidbits of Firefox left on my machine and still I get the same crashed tabs.  Can’t find the problem so Firefox is history.  I’ll use Chrome, Opera, Epic or even Brave.  But I’m not willing to waste anymore time on Firefox.  Too bad because that has been my favorite browser for many many years.  I’m willing to admit defeat.

      • #2100355 Reply
        anonymous
        Guest

        If you can run Firefox long enough to get into the URL address about:config panel, or use Firefox safe mode to get there, crashes may be from webrender.  Find gfx.<wbr />webrender.<wbr />all and set it to false, then restart.

        If you can’t get Firefox stable enough to allow that change, instead set the environment variables and restart the computer MOZ_WEBRENDER=0
        MOZ_ACCELERATED=0

        These two links explain two ways to do that https://www.onmsft.com/how-to/how-to-set-an-environment-variable-in-windows-10 or https://superuser.com/questions/79612/setting-and-getting-windows-environment-variables-from-the-command-prompt/79614

      • #2110271 Reply
        nag2
        AskWoody Plus

        anonymous: OK, couldn’t do it in Firefox as those keys weren’t there.  However, I did add the environment variables you suggest to no effect.  I still get the crashes after reboot.  I have really moved on to Opera now as everything so far has been a bust with Firefox.  I haven’t tried it but I’ll bet I could re-install the old ESR version I had and it would work again but it’s so out of date that some sites won’t allow me access to use them.

      • #2110275 Reply
        anonymous
        Guest

        I got some extra characters in there,  the setting to set false was gfx.webrender.all

        If you enable crash reporting and submit crashes to the mozilla crash reporting service, and then several minutes later click on them in about:crashes, sometimes they will be classified to show what caused the crash.  This may only be immediately helpful if it shows a conflict with other installed software.

        If you decide to try again later, I agree with the above that trying a portable version may be the quickest way to do it with a known good profile.  So, when 73 is released try its portable, or the portable of 68 or 60.  There is a Firefox portable beta of 73 there now.  Even though they are portable, I think they may have updates turned on.  There is a registry key that can be set to block that, maybe the Firefox portable support forum can explain.

      • #2110292 Reply
        nag2
        AskWoody Plus

        Anonymous: OK, I tried the setting in About:config and it was already set to false so that’s not it.  Also, checked crashes and none were sent even though I had options set to sent reports.  Never had this much trouble with any browser ever.

    Viewing 8 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Upgrading Firefox crashes all tabs

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.

    Cancel