News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • USB Flash (Thumb) Drives not opening in Explorer

    Home Forums AskWoody support PC hardware USB Flash (Thumb) Drives not opening in Explorer

    Viewing 5 reply threads
    • Author
      Posts
      • #2313151 Reply
        Mike
        AskWoody Plus

        OS:  Windows x64 1903-2004

        Question:  On all versions of Windows, why is it that some, but not all, of my USB Thumb Flash drives don’t “auto open” with Explorer….when they used to.  I can’t figure out this behavior.

        Thanks

      • #2313154 Reply
        PKCano
        Da Boss

        Check Settings App\Devices\Autoplay

      • #2313224 Reply
        Mike
        AskWoody Plus

        Thanks.  That’s the first thing I thought of.  Working fine for some drives but not for others.  Makes no sense…….unless each thumb drive has some sort of ID or name based.  Yet they all Autoplayed at one point.  Can’t think of anything I’ve done, other than look at files and eject them when finished.  No corruption either.

        Autoplay

        Attachments:
      • #2313247 Reply
        bratkinson
        AskWoody Plus

        Try reinstalling your USB device drivers.

        I had a problem where my most-used USB 3 thumb drive (on my key ring) wasn’t being recognized by Windows when inserted in any of the USB 3 ports – no beep or other sounds shortly after insertion and not showing up in the list of all drives (‘my computer’, in days gone by).  Interestingly, it worked just fine in the USB 2 ports also on the front of my home-built computer.  I tried a couple of things before finally resorting to the CD that came with my motherboard and reinstalled those ‘old’ drivers.  Everything has worked fine ever since.

        I’m guessing that a Windows update decided to ‘update’ my device driver(s) and made a mess of things.  In my best Gomer Pyle imitation: “Surprise, surprise, surprise!”

      • #2313553 Reply
        firstmerk
        AskWoody Plus

        USB….UNIVERSAL SB….is not. Those things are a lot more finicky than people think. Myriad of driver/chipsets, hoards of different quality of USB drives, multiple kinds.
        I have a USB 3 port (Intel chipset) that gets ‘tired’ and slows down after awhile. Unplugging and re-inserting do not help. Rebooting does help, for awhile. With long term use it gets tired again. I am using stock Win10 drivers. Maybe that’s a mistake.

        Anyone know of a USB chipset that is actually reliable?

        • This reply was modified 1 week, 5 days ago by firstmerk.
      • #2313562 Reply
        CADesertRat
        AskWoody Plus

        Have you tried this:

        You could try the following (unplug the USB Flash drives first):
        Open an elevated Command Prompt (Start/Search, type “cmd” [no quotes]).
        At the top of the list of results right-click “cmd” (cmd.exe) then left-click “Run as Administrator”.
        At the prompt type “SET DEVMGR_SHOW_NONPRESENT_DEVICES=1” (no quotes) then press Enter.
        Then type “START DEVMGMT.MSC” then press Enter. (no quotes)
        A “Device Manager” window should open; click on View/Show hidden devices

        Any greyed-out (disconnected) devices listed under “Disk Drives” and “Universal Serial Bus controllers” that you recognize as your USB Flash drives should be removed (right-click/Uninstall).
        Any greyed-out (disconnected) devices listed under “Unknown Devices” should be safe to remove.

        Once you have removed any problem devices you should restart Windows; once Windows has loaded fully plug in one of your Flash drives – Windows should now detect and install it normally.

        Don't take yourself so seriously, no one else does 🙂
        4 Win 10 Pro at 1909 (3 Desktops, 1 Laptop).

        1 user thanked author for this post.
    Viewing 5 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: USB Flash (Thumb) Drives not opening in Explorer

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.