News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • USB Logitec Problem

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 USB Logitec Problem

    Viewing 2 reply threads
    • Author
      Posts
      • #2279682 Reply
        pjamme
        AskWoody Lounger

        I bought a new wireless keyboard and mouse set because the old unit was flaky.

        This one is too!  Took me forever to find an annoying fix, if I unplug the USB key and plug it back in the mouse and keyboard work again.  Sometimes it is one or the other, and sometimes just keyboard not entering letters or mouse hanging.  The only fix I found on the Internet is to start Task Manage and the ESC.  That doesn’t always work.

        Originally I thought I had a bad batch of batteries and kept changing them out, not much help there either.  I have tried changing the USB port with no success.

        Is there a fix for this or do I need to buy another brand?

        Winver

        Attachments:
      • #2279685 Reply
        Elly
        AskWoody MVP

        For anything that uses an USB connection, the first thing I do is go to device manager, universal serial bus controllers, right click, select properties, and on the power management tab deselect ‘allow the computer to turn this device off to save power’. I don’t have anything plugged into a USB that I want turned off while using the computer, so I’ve done that for all of my USB connections.

        I don’t have the documentation on when this ‘feature’ was implemented in W10, but it played havoc with my keyboard, mouse, USB WIFI adapter, and an attached external hard drive… and I spent hours trying to solve each individual problem. Save yourself some time, and fix this first! You might even find that your old keyboard and mouse work just fine!

        Non-techy Win 10 Pro and Linux Mint experimenter

        1 user thanked author for this post.
      • #2279753 Reply
        Rick Corbett
        AskWoody_MVP

        With USB keyboards and mice, these symptoms are usually indicative of either power management or interference issues.

        Power Management: Elly has already covered this in her reply. The USB Host Controllers have 1 or more onboard Root Hubs per controller. Disable power saving on the USB Root Hubs.

        usb_power

        Also, make sure you amend Windows’ Advanced Power Options:

        1. Click Start > Settings > System > Power & sleep.

        2. In the *right*-hand pane, click on Additional power settings.

        3. Click on the link for Change plan settings for whichever power plan option you are using.

        4. Click on the link for Change advanced power settings.

        5. Scroll down to USB settings and click on the + sign to expand the view then the next + sign to expand the selective suspend settings.

        6. Click on the link for Enable to change it to a dropdown and select Disabled:

        usb_power_suspend

        7. Click on the Apply then OK buttons to close the dialog then close any remaining power dialogs.

        Interference: Make sure you don’t have a cordless phone anywhere close. Older models operate on the same frequency as wireless Bluetooth. The same goes for baby monitors, garage door openers and microwaves. Don’t forget your router… it has at least one but probably 2 radios in it, one of which operates at the same 2.4GHz radio frequency.

        Note that there’s also reports that USB 3 ports interfere with keyboard/mouse dongles… so use a USB 2 port for the Logitech combi-dongle, not a (blue) USB 3 port.

        Hope this helps…

        Attachments:
        1 user thanked author for this post.
    Viewing 2 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: USB Logitec Problem

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.