• USB stick failure


    I have a 64Gb Toshiba memory stick which suddenly started reporting itself as 1Gb, and this occurs in seperate pc’s running both W10 and W7. Is there any way I can get it back to 64Gb?


    Viewing 4 reply threads
    • #349513

      Go to Administrative Tools\Computer Management\Disk Management.
      See what partitions appear on the Flash Drive.
      It may be that it is corrupt/unusable.
      If it shows the 64GB, you can possibly format it.

      1 user thanked author for this post.
    • #349538

      I have just had a 3 month old SanDisk 128GB Uktra Flair disk fail.  It just stopped working.  I tried it on another 4 machines (Win 7, 8.1 and 10) and none recognised it when plugged in, so I could not even try formatting it.

      It was a little surprising as I have never had a memory stick fail, even after a 60C wash cycle…..

      The store replaced it immediately.  But it contained my recently curated music folders which meant that about a third of the corrected files had not been backed up.  Ouch.  Lesson learned.

      • #349579

        Unfortunately, a Windows system not recognising a storage device, at least in Explorer or even the graphical partition tool, doesn’t mean much.

        Easiest case, it “merely” has the partition table corrupted. In that case it might even be fixable with the appropriate commands to DISKPART.EXE … though I would recommend a proper data recovery tool instead.

        Though, yes, I *have* had memory sticks fail.

        There’s even a SATA SSD model out there that initially shipped with buggy firmware, leading to it sometimes starting to believe itself to have a maximum capacity of… what was it, 2 Mbytes? Not sure anymore. Couldn’t install the fixed firmware after it got to that state, either.

    • #349580

      I’ve been wondering – can a Trim program be used on a flash drive?  Trim is used on SSD’s and they are the same kind of memory right.  It’s just a thought, and if it’s good for SSD’s it could maybe save problems with flash drives.

      Being 20 something in the 70's was much more fun than being 70 something in the 20's.
      • #349608

        Depends on the flash drive.

        Would expect to only find this on very high-end ones – such as for example Kingston DataTraveler Workspace, which Kingston indeed does advertise as having that capability.

        There are others too but can’t recall product names offhand.

    • #350100

      Thankfully I had no important info on the drive, so I tried PKCano’s suggestion and looked at it in Disk Management.
      It had a 1Gb partition and the rest showed unformatted space. I deleted the !Gb partition and formatted the total space left after this operation. This produced a partition of 58Gb, in other words it had discarded part of its capacity. I’ve since tried various disc operations on it and all seem to work OK, so I’ll use it for miscellaneous tasks, while keeping an eye on it for misbehaviour.
      I’m just assuming the lost capacity is somehow damaged.
      Thanks for all the advice.


    • #350172

      Yes, it seems the drive is not well, which caused the corruption in the first place. Personally I’d replace it – murphy’s law says it will fail when you need it.

      cheers, Paul

      1 user thanked author for this post.
    Viewing 4 reply threads
    Reply To: USB stick failure

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: