News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • V2004 Says: “No connection to the internet” when it is actually working

    Home Forums AskWoody support Windows Windows 10 Windows 10 version 2004 – May 2020 Update V2004 Says: “No connection to the internet” when it is actually working

    Topic Resolution: Resolved

    Tagged: 

    Viewing 9 reply threads
    • Author
      Posts
      • #2269595 Reply
        RayG
        AskWoody Plus

        Windows 10 2004 seems to have an issue deciding if it is connected to the internet. The System Tray Icon shows the “World” type icon and it keeps insisting that its not connected. From the fact that I have posted this you will realise that its actually working.

        Does anyone know how to fix the issue. Resetting the network has no effect and turning proxy setups on/off etc has no effect and I see a lot of wpad.home errors in my DNS server logs. The DNS server on the system is unbound using DoT and DNSSEC. I had no issues whatsoever with V1909 and the only change is the 2004 update which sneaked itself in this morning when I wasn’t looking via windows update.

        Thanks for any pointers

      • #2269601 Reply
        BATcher
        AskWoody_MVP

        I had this happen on a whole bunch of PCs on V1903…

        To ‘solve’ the problem, the following procedure was found to work, for no obvious reason.

        1. In Network and Sharing Centre, click on Change adapter settings
        2. Right click on the Ethernet adapter, and choose Properties
        3. At the top, choose Configure
        4. Select the Advanced tab
        5. Select IPv4 Checksum Offload, which will probably be set to “Rx & Tx Enabled”
        6. Change this value to Disabled, and click OK
          After a few seconds, the ‘world’ icon in the system tray should change to the normal ‘rectangular’ icon.
        7. Now change the IPv4 Checksum Offload setting back to “Rx & Tx Enabled” and click OK.
          Having waited a few seconds, there should be no change to the system tray icon.
        8. Things should now have returned to normal!

        BATcher

        Ascetics go without, mystics go within.

        1 user thanked author for this post.
      • #2269623 Reply
        cyberSAR
        AskWoody Plus

        I’ve had this issue with multiple machines over the last couple years but never with mine… until I upgraded to 2004. Tried all of the fixes, rebooting router, reset  and new drivers and nothing seemed to work. Then all of a sudden yesterday it was fine.. until I rebooted!

        • #2269625 Reply
          PKCano
          Da Boss

          I think MS has had a problem with that off and on since the pciclearstalecache days. I run into it here and there, not just on Win10, but Win7/8.1 too.

          • #2269633 Reply
            cyberSAR
            AskWoody Plus

            Have never seen it myself until 10, although I’ve read numerous reports from 7 on. The other weird thing I notice with 10 is if a machine connects via wireless to the router, the LAN connection name will sometimes be changed from “Network” to the name of the wireless network SSID. Can be aggravating! Windows 10  definitely prefers wireless over wired connections it seems.

            1 user thanked author for this post.
      • #2270407 Reply
        RayG
        AskWoody Plus

        @batcher

        I tried your suggestions but the WiFi adapter does not have those options. What I did find however was the when the Windows Sandbox is installed it runs a Hyper-V virtual adapter which does have those options. However changing them made no difference. I then uninstalled the Sandbox rebooted and that made no difference either. I reset the network, still no joy. I then uninstalled and removed the drivers when prompted all the items in device manager under the network branch and rebooted. It was then working as it should. Windows then decided it wanted to update the WiFi Adapter Driver – and then it looks like the install fails (each time) and when that happens things go wrong. It seems it is a Microsoft Driver Issue See this link:

        https://answers.microsoft.com/en-us/surface/forum/all/marvell-avastar-related-wireless-connectivity/5ee2de4e-8a2f-4fb5-9b76-adbfbd33397c?page=3

        The driver installed at the moment is:

        V15.68.17018.116

        looks like it will be a while before it gets fixed – not sure how long it will work for time will tell.

        Thanks all for your suggestions.

        • This reply was modified 4 months, 3 weeks ago by RayG.
      • #2271470 Reply
        anonymous
        Guest

        Hi,  I too ran into this problem on one of my laptops while testing 2004. I tried many many things and eventually –   This is what I did to fix the issue for me (and it so far worked).

        Note that I have Fast Startup disabled so your mileage may vary if this is enabled for you.

        Regedit > Computer > HKLM > System > CurrentConmtrolSet > Services > NLASvc > Parameters > Internet

        Change the value of EnableActiveProbing from DWORD 0 to DWORD 1

        Reboot
        Voila

        2 users thanked author for this post.
        • #2271499 Reply
          doriel
          AskWoody Lounger

          I think this workaround refers to msftconnecttest.com poping-window on the start of Windows system. But it could work somehow to fix @RayG ‘s issue, if this probing defines system try icon status and if it is disabled in his registry.

           

          Also you can try type

          nslookup

          into elevated cmd, you will see what DNS are you using

          then type

          exit

          and flush cache by command

          ipconfig /flushdns

          Then restart your PC

          Dell Latitude E6530, Intel Core i5 @ 2.6 GHz, 4GB RAM, W10 1809 Enterprise

          HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

          • This reply was modified 4 months, 3 weeks ago by doriel. Reason: tip
          1 user thanked author for this post.
      • #2271520 Reply
        RayG
        AskWoody Plus

        @anonymous

        Regedit > Computer > HKLM > System > CurrentConmtrolSet > Services > NLASvc > Parameters > Internet

        Change the value of EnableActiveProbing from DWORD 0 to DWORD 1[\quote]

        I will try this to see what happens.

        @doriel

        I am using unbound as a local DNS server which is started as soon as the interface gets an IP address and it is also using DoT + DNSSEC which is also working correctly.

        nslookup http://www.microsoft.com
        Server: localhost
        Address: ::1

        Non-authoritative answer:
        Name: e13678.dspb.akamaiedge.net
        Addresses: 2a02:26f0:4000:2b5::356e
        2a02:26f0:4000:2b2::356e
        2a02:26f0:4000:28d::356e
        2.19.61.200
        Aliases: http://www.microsoft.com
        http://www.microsoft.com-c-3.edgekey.net
        http://www.microsoft.com-c-3.edgekey.net.globalredir.akadns.net[\code]

        Apologies if I have the formatting codes incorrect

      • #2271720 Reply
        Paul T
        AskWoody MVP

        The NSLOOKUP command won’t do anything – it’s just informational – but IPCONFIG /FLUSHDNS might. Try that before the registry change.

        cheers, Paul

      • #2271756 Reply
        RayG
        AskWoody Plus

        All – thanks for your suggestions.

        Nothing suggested has worked, it’s strange as sometimes it appears to work and then 10 minutes later its gone again.

        Latest updates did/do nothing. The system is still useable its just got one or two annoying issues at this time but they can all be worked around. I even tried using the Media Tool to reinstall windows (keeping apps/files and settings) and that again made no difference. The windows .old folder had also gone, I read that some times when that is automatically removed by windows things are resolved, again that made no difference.

        Look like a waiting game…

      • #2287388 Reply
        RayG
        AskWoody Plus

        Since the Windows 10 V2004 update has been out and about, every time I have upgraded a system I have had issues with the networking. Windows thought that it was not connected to the internet. The little system tray icon always showed the  little world icon (as I call it) to say no internet access. I could never get it to show the little TV screen icon to say networking was up and running and the internet was fully accessible.

        I was made aware of this issue:
        https://www.bleepingcomputer.com/news/microsoft/windows-10-hosts-file-blocking-telemetry-is-now-flagged-as-a-risk/
        where blocking MS telemetry IP addresses (DNS Names) via the hosts file would cause Windows Defender to complain that the hosts file had been “infected” and would return it to defaults depending on how you answered Defenders prompt. This apparently has been the case sine the end of July.

        This got me thinking and I have now upgraded my desktop to V2004 again and low and behold – networking issues.

        I use Macrium Reflect as backup software and that allows me to take a backup and then convert that into a VM. I did this and then played with the Unbound configuration.

        What I found was:

        Any reference to 127.0.0.x or ::1 for DNS entries in the Adapter configuration causes the networking to fail to detect internet access is available. I don’t know if this is intentional on MS’s behalf or a bug – time will perhaps tell.

        That said, if I changed the Adapter configuration so that it pointed to the IPV4 and IPV6 address the IPCONFIG /ALL

        IPv6 Address. . . . . . . . . . . : :x:x:x:x(Preferred)
        IPv4 Address. . . . . . . . . . . : x.x.x.x(Preferred)

        For the DNS server entries then the networking worked correctly if I also set the “interface:” and “access_control” definitions in the unbound configuration file to the same addresses

        interface: :x:x:x:x
        interface: x.x.x.x

        &

        access_control: :x:x:x:x allow_snoop
        access_control: x.x.x.x allow_snoop

        I also commented out the references to 127.0.0.0/8 and ::1

        Today I upgraded two systems and having removed my local DNS server from the adapter configuration – no 127.0.0.1 or ::1 for the DNS server entries (those were overriding the DHCP defined entries from the router)

        So now I am happy I have solved the issue and I hope anyone else who is having such issue will find this useful.

         

      • #2287393 Reply
        RayG
        AskWoody Plus

        Thanks for the information, not sure if it’s the same issue though, The network ONLY works properly i.e. probing works IF and only IF 127.0.0.1 and/or ::1 are not in the adapter DNS entries. If I run my DNS server on any other IP Address then things work OK without any other changes.

        So in my case I don’t think its to do with the probing issue.

    Viewing 9 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: V2004 Says: “No connection to the internet” when it is actually working

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.