News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • vMWARE 12 (and newer) – Incompatible with Windows 10 1903?

    Posted on petesmst Comment on the AskWoody Lounge

    Home Forums AskWoody support Questions: Browsers and desktop software vMWARE 12 (and newer) – Incompatible with Windows 10 1903?

    This topic contains 8 replies, has 3 voices, and was last updated by  anonymous 1 day, 5 hours ago.

    • Author
      Posts
    • #1849871 Reply

      petesmst
      AskWoody Plus

      Since upgrading to Windows 10 (Version 1903) I am unable to access Windows 10 Insider from within my VMware V12.5.9 virtual machine.  Initially, Windows Insider opens and I am able to log in, and then about 3-5 minutes later Windows 10 Insider freezes, and about 30 seconds later  the parts of VMware dedicated to the open virtual machine also freeze.  This results in an inability to pause, suspend, shut down or restart the guest OS (Windows Insider).  The only way to resolve the issue is to reboot the (Host) desktop PC.

      Occasionally, VMware produces an error window indicating that “VMware workstation and Device/Credential Guard are not compatible …” and provides a link for further information.  The link suggests that this can be resolved by preventing Hyper-V from running (however, in my case, hyper-V is not enabled).

      I have been testing Windows using the Insider program from within VMware for several years, and would like to continue doing so.  I might mention that the incompatibility issue referred to is present in the latest version of VMware (V15) according to reports elsewhere on the Web.

      Any suggestions?

      My Setup: Custom built: 4.00GHz Intel Core i7-6700K CPU; MSI Z170A Gaming Carbon Mobo (Military Class V); Win 10 Pro (64 bit)-(UEFI-booted); 16GB RAM; 500GB SAMSUNG 960 EVO M.2 NVME SSD; 512GB SAMSUNG 850 PRO SSD; Seagate 2TB Barracuda SATA6G HDD; 2 X GeForceGTX 1070 8GB Graphics Card (SLI); Office 2016 Prof (32-bit); Condusiv SSDKeeper Professional; Acronis TI 2019 Premium, Norton Internet Security, VMWare Workstation12 Pro). WD My Book 3 1TB USB External Backup Drive). Dell S2417DG G-Sync UHD Monitor.

    • #1849974 Reply

      cyberSAR
      AskWoody Plus

      I’m running vmware 15.1 –  Guest 1903, build 18362.1 and just updated to 18362.175

      My host is 1903 18362.145. I just fired up the vm (haven’t run it in some time) and had youtube videos running for about 20 minutes. Haven’t had any issues yet.

    • #1850010 Reply

      anonymous

      Windows components which use hyper-v prevent virtualbox guests from starting in 1903.  The new sandbox feature, in particular, uses hyper-v, and hyper-v components remain active even after you’ve turned the sandbox off again.  I suspect that this problem would affect vmware as well.

      I did the following to get virtualbox guests working.  YMMV, but it’s worth a shot with vmware if you don’t find a better idea.

      First, in the Turn Windows features on or off panel, turn off everything which uses hyper-v, including the hyper-v feature, the new windows sandbox, and everything with “guard” in the name.  If you find anything to turn off, you’ll probably have to reboot. Then, in an elevated cmd window, type:

      bcdedit /set hypervisorlaunchtype off

      Then reboot (again) and try your vmware tests.  If you want to turn hyper-v stuff back on, you can use:

      bcdedit /set hypervisorlaunchtype Auto

      It’s possible that turning the hyper-v hypervisor stuff off with the bcdedit command is sufficient by itself (i.e. you don’t have to turn components off) but I haven’t gotten around to trying that.

      If you’ve never had a hyper-v-related component turned on, then never mind 🙂  But please let us know what you find.

      1 user thanked author for this post.
    • #1861049 Reply

      petesmst
      AskWoody Plus

      @anonymous:  Many thanks (Sorry for late response, but I did not get an email notification of your reply, despite checking “Notify me …”

      I’ll try what you suggest, but note that this is a major issue reported within VMware circles (incompatibility with Windows 1903).  It is reported that Microsoft and VMware are working together to find a solution; and that it will (eventually) be corrected via a patch.

      My Setup: Custom built: 4.00GHz Intel Core i7-6700K CPU; MSI Z170A Gaming Carbon Mobo (Military Class V); Win 10 Pro (64 bit)-(UEFI-booted); 16GB RAM; 500GB SAMSUNG 960 EVO M.2 NVME SSD; 512GB SAMSUNG 850 PRO SSD; Seagate 2TB Barracuda SATA6G HDD; 2 X GeForceGTX 1070 8GB Graphics Card (SLI); Office 2016 Prof (32-bit); Condusiv SSDKeeper Professional; Acronis TI 2019 Premium, Norton Internet Security, VMWare Workstation12 Pro). WD My Book 3 1TB USB External Backup Drive). Dell S2417DG G-Sync UHD Monitor.

    • #1861053 Reply

      petesmst
      AskWoody Plus

      @cybersar  Thanks.  Initially I was also able to run my Windows 1903 (Insider) VM quite normally within my host Windows 1903.  Two or three days later, all started out OK, and then about three minutes into use, the VM froze.  Now, VMware simply refuses to fire up any VM and posts the error window “VMware workstation and Device/Credential Guard are not compatible …”  The same issue is being reported by users of VMware 15.1

       

      I will try the solution suggested by @anonymous in the previous post #1850010 and will report back.

      My Setup: Custom built: 4.00GHz Intel Core i7-6700K CPU; MSI Z170A Gaming Carbon Mobo (Military Class V); Win 10 Pro (64 bit)-(UEFI-booted); 16GB RAM; 500GB SAMSUNG 960 EVO M.2 NVME SSD; 512GB SAMSUNG 850 PRO SSD; Seagate 2TB Barracuda SATA6G HDD; 2 X GeForceGTX 1070 8GB Graphics Card (SLI); Office 2016 Prof (32-bit); Condusiv SSDKeeper Professional; Acronis TI 2019 Premium, Norton Internet Security, VMWare Workstation12 Pro). WD My Book 3 1TB USB External Backup Drive). Dell S2417DG G-Sync UHD Monitor.

    • #1861126 Reply

      petesmst
      AskWoody Plus

      @anonymous: I tried using only

      bcdedit /set hypervisorlaunchtype off

      It worked! Many thanks.

      Windows 10 Insider Preview 18922.1000 (rs_prerelease) is currently downloading into the OS in the VM.

      My Setup: Custom built: 4.00GHz Intel Core i7-6700K CPU; MSI Z170A Gaming Carbon Mobo (Military Class V); Win 10 Pro (64 bit)-(UEFI-booted); 16GB RAM; 500GB SAMSUNG 960 EVO M.2 NVME SSD; 512GB SAMSUNG 850 PRO SSD; Seagate 2TB Barracuda SATA6G HDD; 2 X GeForceGTX 1070 8GB Graphics Card (SLI); Office 2016 Prof (32-bit); Condusiv SSDKeeper Professional; Acronis TI 2019 Premium, Norton Internet Security, VMWare Workstation12 Pro). WD My Book 3 1TB USB External Backup Drive). Dell S2417DG G-Sync UHD Monitor.

      • This reply was modified 3 weeks, 4 days ago by
         petesmst.
      • #1861289 Reply

        anonymous

        Great!  Thanks for letting us know.  The Windows Hypervisor Platform feature is supposed to provide an api allowing virtualization software like vmware and virtualbox to run in a hyper-v environment.  That doesn’t work (for me) with virtualbox 6.0.8 but it’s possible it might work with recent releases of vmware (if you’re in an experimental mood).

        There is also a Virtual Machine Platform feature in 1903 and (I think) 1809.  I’m darned if I can find any documentation for it though.

        MS appears to be using hyper-v technology for more and more (containers, security, the new sandbox, wsl2, who knows what else) so lots of vmware and virtualbox users will be running into this.

    • #1873839 Reply

      anonymous

      I have two batch files I use to switch turn off or on hypervisorlaunchtype.

      When my 1903 upgrade failed I wondered if this could be it. Thank you for confirming!!

      P.S.
      I have VMware Workstation and VirtualBox both on my machine and to get either to work requires bcdedit /set hypervisorlaunchtype off .

      If I want to play with Win10 Hyper-V I have to set it back to auto.

    • #1878338 Reply

      anonymous

      i have tried following and work great (from anonymous)

      First, in the Turn Windows features on or off panel, turn off everything which uses hyper-v, including the hyper-v feature, the new windows sandbox, and everything with “guard” in the name.  If you find anything to turn off, you’ll probably have to reboot. Then, in an elevated cmd window, type:

      bcdedit /set hypervisorlaunchtype off

      great thanks

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: vMWARE 12 (and newer) – Incompatible with Windows 10 1903?

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.